Está en la página 1de 18

UNIVERSIDAD DE EL SALVADOR FACULTAD DE INGENIERA Y ARQUITECTURA ESCUELA DE INGENIERA ELCTRICA INTRODUCCIN A LA INFORMTICA

Tarea 01 algoritmos

Profesores: Ing. Carlos Osmn Pocasangre Instructor: Augusto Mejia Integrantes. Apellidos Barrera Jimenez Leones Rosa Lobato Leiva Rodriguez Martines Nombres Noe edgardo Edwin Osmaro Carlos Alonso Daniel Adonnis No de carnet BJ14001 (lab02) LR13003 (lab02) LL13001 (lab05) RN13041 (Lab02)

Ciudad Universitaria, abril de 2014


1

INTRODUCCIN En el presente trabajo se muestra una serie de ejercicios resueltos, en los cuales se ponen en prctica los conocimientos adquiridos a lo largo de la unidad 1. Lo que permite obtener una mayor agilidad a la hora de resolver problemas y familiarizarse con los algoritmos de una manera ms prctica.

OBJETIVO GENERAL Poner en prctica los conocimientos adquiridos sobre los algoritmos.

OBJETIVOS ESPECFICOS Disear algoritmos narrados y grficos. Aplicar en los algoritmos los bucles Si, Hacer, Para y Hacer mientras. Aplicar los diferentes operadores bolanos AND, OR, XOR, NOT.

DESARROLLO 1) Se tiene 3 nmeros reales (a, b y c) y se desea saber cul es el mayor. Hacer un algoritmo narrado para resolver este problema

I.
E a, b, c

Anlisis de Problema

S < > < > < >

1. 2. 3. 4. 5. Sino 6.

Inicio Leer a leer b leer c Si a>b a AND a>c Entonces Mostrar "el nmero mayor ingresado es: a Si b>a AND B>c Entonces Mostrar "el nmero mayor ingresado es: b Sino

7.

Si c>a and c>b Entonces Mostrar "el nmero mayor ingresado es:" c Sino Mostrar "los nmeros ingresados son iguales" FinSi FinSi FinSi

8.

Fin

2). Desarrollar un diagrama NS que calcule e Angulo menor entre las agujas del reloj (minutero y horaria), el dato de entrada ser la hora. I. Anlisis del problema
E Hora (H, M) Limites 0<H<=12

S Angulo (A) menor entre la minutero y horaria

II.

Diseo de solucin

3). Implementar un algoritmo narrado y de flujo que calcule la mxima cantidad de billetes de 100, 50, 25, 5 y 1. I. anlisis del problema
Cifra (C) E Limite Nueros Enteros

N de 100 N de 50 N de 25 N de 5 N de 1

I.

Diseo de Solucin Algoritmo narrado

1. Inicio

Leer C bill=100 conta=0; Mientras C >= bill Hacer C= C-bill; conta= conta+1; 5. FinMientras 6. Mostrar conta,"($100)"; 7. conta=0; 8. bill<50; 9. Mientras C >= bill Hacer C=C-bill; conta<conta+1 10. FinMientras 11. Mostrar conta,"($50)" 12. conta=0; 13. bill=25; 14. Mientras C >= bill Hacer C=C-bill; Conta=conta+1 15. FinMientras 16. Mostrar conta,"($25)" 17. conta=0; 18. bill=10; 19. Mientras C >= bill Hacer C=C-bill; conta<conta+1 20. FinMientras 21. Mostrar conta,"($10)" Conta=0 Bill=5 22. Mientras n >= bill Hacer C=C-bill; Conta=conta+1; 31. FinMientras 32. Mostrar conta,"($5)"; 33. conta=0 34. bill=1 35. Mientras n >= bill Hacer C=C-bill; Conta=conta+1; 36. FinMientras 37. Mostrar conta,"($1)"; 38. FinProceso

1. 2. 3. 4.

>

""

>

""

>

""

>

""

>

""

Los ngulos se pueden representar en grados, minutos y segundo, por ejemplo 140245. Hacer un diagrama de flujo que pueda sumar dos ngulos en este formato

Implementar un diagrama de flujo que ordene N cantidades de datos


9

10

6) Implementar un diagrama de flujo de la siguiente serie:

I)

Analisis del problema ? II) Diseo de solucin

<

11

7) Disear un diagrama de cajas para la siguiente serie:

III)

Diseo de solucin

<

/ 3

12

8) Disear un algoritmo de flujo que calcule un numero combinatorio para:

13

9) Crear el diagrama de flujo para encontrar el MCD (Mximo Comn Divisor) de dos

nmeros enteros.

14

10) Hacer una corrida manual del siguiente diagrama de flujo se deber realizar por lo menos 10 iteraciones para x=0.45

Mientras >

Mientras [

<

15

iteraciones

Valor de x

Valor de suma

Valor de k

Valor del segundo mientras 2.2222 3.6579 10.8384 38.2308 146.8401 593.2935 2479.0995 10610.1380 46231.5383 204271.9041 912678.7017

1 2 3 4 5 6 7 8 9 10

0.45 0.45 0.45 0.45 0.45 0.45 0.45 0.45 0.45 0.45 0.45

2.2222 5.8802 16.7186 54.9495 201.9877 795.0833 3274.1828 13884.3209 60115.8592 264387.7634 1177066.76

2 3 4 5 6 7 8 9 10 11 12

NOTA IMPORTANTE
El el valor para x propuesto queda anidado en el bucle mientras para poder realizar laas iteraciones cabamos la condicin por lo tanto obtuvimos los siguientes resultados Datos:

16

17

CONCLUSIONES. El correcto manejo y conocimiento de los algoritmos proporcionan una herramienta muy potente para resolver problemas e introducirlos al ordenador. En el presente trabajo se ha aprendido a optimizar el uso de los bucles y diagramas de caja, lo cual es de mucha importancia para poder solucionar problemas que presente un alto grado de dificultad.

BIBLIOGRAFIA http://es.wikipedia.org/wiki/Diagrama_de_flujo http://html.rincondelvago.com/algoritmos-y-diagramas-de-flujo.html http://pseint.sourceforge.net/

18