Está en la página 1de 26

Home

Diagramas de Flujo y Algoritmos


C o le c c i n d e e j e r ci c i o s r e s ue l t o s d e al g o r it mo s b s i co s u sa n d o d i a g ra ma s d e f l u j o c o n c d i g o f u e n t e e n J a v a , V B, C # , P h yto n , C y C ++ .

Mostrando entradas con la etiqueta PSeInt. Mostrar todas las entradas


v ie rne s , 2 6 de ab ril de 2 01 3

Realizar un diagrama de flujo para escribir los 100 primeros pares


Realizar un diagrama de flujo de un programa que permita escribir en pantalla los 100 primeros nmeros pares.

Buscar en este blog


Buscar

364

Qu son los diagramas de flujo? FreeDFD Dibujar y Simular Diagramas de Flujo

Pseudocdigo Proceso CienPrimerosPares Escribir "Los 100 primeros pares son"; num <- 0; Mientras num < 200 Hacer Escribir num; num <- num +2; FinMientras FinProceso
Pub lic ado po r G e o rge Tac uri e n 01 :03 1 c o m e ntario s Enlac e s a e s ta e ntrada Etiq ue tas : diagram a de fluj o , pro gram ac io n e s truc turada, PS e I nt, ps e udo c o digo

Labels
algoritmo (569) C (118) C# (95) C++ (112) codigo fuente (616) DFD (95) diagrama de flujo (116) diagrama de flujo de datos (95) diagrama flujo (92) ejercicios resueltos (665) funciones (1) Java (104)

m i rc o le s , 1 7 de ab ril de 2 01 3

Volumen de un Prisma - Diagrama de Flujo


Realizar el algoritmo y diagrama de flujo para calcular el volumen de un prisma recto. Diagrama de flujo:

problema conversion (44) programacion estructurada (547) programacion modular (21) PSeInt (13) pseudocodigo (12) python (96) Recursividad (11) varios (1) Visual Basic (96)

Blog Archive
2013 (686) abril (3) Realizar un diagrama de flujo para escribir los 10... Volumen de un Prisma Diagrama de Flujo Porcentaje numeros pares e impares - Diagrama de F... marzo (18) febrero (121) enero (544) 2012 (52)

El volumen de un prisma recto es el producto del rea de una de las bases por la distancia entre ellas (altura) Pseudocdigo Proceso volumenPrisma Escribir "VOLUMEN DE UN PRISMA RECTO"; Escribir "Ingresar el area de la base";

Leer abase; Escribir "Ingresar la altura"; Leer altura; volumen <- abase*altura; Escribir "El volumen del prisma es: ", volumen; FinProceso

Nos visitan
Live Traffic Feed

Pub lic ado po r G e o rge Tac uri e n 2 3 :4 6 0 c o m e ntario s Etiq ue tas : diagram a de fluj o , PS e I nt, ps e udo c o digo

Enlac e s a e s ta e ntrada

m i rc o le s , 2 7 de m arz o de 2 01 3

Permetro de un triangulo - Diagrama de Flujo


Ejercicio: Realizar el diagrama de flujo para hallar el permetro de un triangulo, el valor de los lados del triangulo se debe ingresar por teclado.

A visitor from Bucaramanga, Santander viewed "Diagramas de Flujo y Algoritmos: PSeInt" 0 secs ago A visitor from Cabo San Lucas, Baja California Sur viewed "Convertir de grados Celsius a grados Fahrenheit y viceversa Diagrama de Flujo ~ Diagramas de Flujo y Algoritmos" 32 secs ago A visitor from Quertaro, Queretaro de Arteaga viewed "Ingrese un nmero y convierta a binario Cdigo Fuente en C++ ~ Diagramas de Flujo y Algoritmos" 52 secs ago A visitor from Bogot, Distrito Especial left "Determinar el mayor de tres nmeros Diagrama de Flujo ~ Diagramas de Flujo y Algoritmos" via 1.bp.blogspot.com 1 min ago A visitor from Panama City, Panama viewed "Determinar si un nmero es primo Codigo Fuente en Visual Basic ~ Diagramas de Flujo y Algoritmos" 2 mins ago A visitor from Barcelona, Cataluna

A visitor from Barcelona, Cataluna viewed "Programa para comprobar la Conjetura de Collatz cdigo en C ~ Diagramas de Flujo y Algoritmos 3 mins ago A visitor from Bogot, Distrito Especial viewed "Determinar el mayor de tres nmeros Diagrama de Flujo ~ Diagramas de Flujo y Algoritmos" 3 mins ago A visitor from Mexico, Distrito Federal viewed "Diagrama de Flujo

Pseudocdigo
Proceso PerimetroTriangulo Escribir "PERIMETRO DE UN TRIANGULO"; Escribir "Ingresar los lados: "; Escribir "Lado 1: "; Leer L1;

Escribir "Lado 2: "; Leer L2; Escribir "Lado 3: "; Leer L3; perimetro <- L1+L2+L3; Escribir "Perimetro = ",perimetro; FinProceso

Pub lic ado po r G e o rge Tac uri e n 1 4 :1 6 3 c o m e ntario s Etiq ue tas : diagram a de fluj o , PS e I nt, ps e udo c o digo

Enlac e s a e s ta e ntrada

do m ingo , 2 4 de m arz o de 2 01 3

Suma y promedio de 10 nmeros - Diagrama de Flujo


Realizar un diagrama de flujo de un programa que permita la carga de 10 valores por teclado y muestre la suma de los valores ingresados y su promedio.

Pseudocdigo
Proceso SumaNumeros suma<-0; // se pide que se ingrese los numeros Para i<-1 Hasta cant Con Paso 10 Hacer Escribir "Ingrese el numero ",i; Leer numero; suma <- suma + numero; FinPara Escribir "La suma es: ",suma; Escribir "El promedio es: ", suma/10; FinProceso

Pub lic ado po r G e o rge Tac uri e n 07 :5 0 1 c o m e ntario s Etiq ue tas : diagram a de fluj o , PS e I nt, ps e udo c o digo

Enlac e s a e s ta e ntrada

m i rc o le s , 2 0 de m arz o de 2 01 3

Suma de nmeros pares en un rango - Diagrama de Flujo


Elaborar el diagrama de flujo de un programa que realice la suma de los nmeros pares en un rango dado, los nmeros inferior y superior del rango deben ser ingresados por teclado.

Pseudocodigo
Proceso SumaNumerosPares Escribir "SUMA DE NUMEROS PARES EN UN RANGO"; Escribir "Ingrese numero inferior: "; Leer inferior; Escribir "Ingrese numero superior: "; Leer superior; suma <- 0; Mientras inferior < superior Hacer //averiguamos si el numero es par Si inferior%2=0 Entonces suma <- suma + inferior; FinSi inferior <- inferior + 1;

FinMientras Escribir "La suma de numeros pares es: ", suma; FinProceso

Pub lic ado po r G e o rge Tac uri e n 2 3 :5 5 0 c o m e ntario s Etiq ue tas : diagram a de fluj o , PS e I nt, ps e udo c o digo

Enlac e s a e s ta e ntrada

lune s , 1 8 de m arz o de 2 01 3

Media de las notas de un estudiante - Diagrama de Flujo Cdigo en C++


Cuatro enteros entre 0 y 100 representan las puntuaciones de un estudiante de un curso de informtica. Escribir un programa para encontrar la media de estas puntuaciones y visualizar una tabla de notas de acuerdo al siguiente cuadro: MEDIA 90-100 80-89 70-79 60-69 PUNTUACION A B C D

Realizar anlisis Realizar diagrama de flujo de datos Elaborar el programa en C++

Diagrama de Flujo

Pseudocdigo
Proceso MediaNotas //cantidad de notas n <- 4;

nota <- 0; // se declara un arreglo de n elementos Dimension notas[n]; //se llena las notas en el arreglo Para i<-0 Hasta n-1 Con Paso 1 Hacer Escribir "Ingrese nota ",i+1; Leer notas[i]; //comprobamos que la nota ingresada sea correcta Si notas[i]>= 0 Y notas[i]<=100 Entonces Escribir "Nota OK"; Sino Escribir "Nota incorrecta "; i <- i-1; FinSi FinPara //se calcula la media Para i<-0 Hasta n-1 Con Paso 1 Hacer nota <- nota + notas[i]; FinPara nota <- nota/n; //imprimimos el resultado Escribir "MEDIA PUNTUACION"; //se busca equivalencia en la tabla Si nota>=60 Y nota<=69 Entonces Escribir nota," FinSi Si nota>=70 Y nota<=79 Entonces Escribir nota," FinSi Si nota>=80 Y nota<=89 Entonces Escribir nota," B"; C"; D";

FinSi Si nota>=90 Y nota<=100 Entonces Escribir nota," FinSi FinProceso A";

Cdigo Fuente en C++


view plain print ?

0 1 . 0 2 . 0 3 . 0 4 . 0 5 . 0 6 . 0 7 . 0 8 . 0 9 . 1 0 . 1 1 . 1 2 . 1 3 . 1 4 . 1 5 . 1 6 . 1 7 . 1 8 . 1 9 . 2 0 . 2 1 . 2 2 . 2 3 . 2 4 . 2 5 . 2 6 . 2 7 . 2 8 . 2 9 . 3 0 . 3 1 . 3 2 .

# i n c l u d e < i o s t r e a m > u s i n gn a m e s p a c es t d ; i n tm a i n ( ){ f l o a ti ; f l o a tn ; f l o a tn o t a ; f l o a tn o t a s ; n = 4 ; n o t a = 0 ; f o r( i = 0 ; i < = n 1 ; i + + ){ c o u t < < " I n g r e s en o t a" < < i + 1 < < e n d l ; c i n > > n o t a s [ i ] ; i f( n o t a s [ i ] > = 0 & & n o t a s [ i ] < = 1 0 0 ){ c o u t < < " N o t aO K " < < e n d l ; }e l s e{ c o u t < < " N o t ai n c o r r e c t a" < < e n d l ; i = i 1 ; } } f o r( i = 0 ; i < = n 1 ; i + + ){ n o t a = n o t a + n o t a s [ i ] ; } n o t a = n o t a / n ; c o u t < < " M E D I A P U N T U A C I O N " < < e n d l ; i f( n o t a > = 6 0 & & n o t a < = 6 9 ){ c o u t < < n o t a < < " D " < < e n d l ; } i f( n o t a > = 7 0 & & n o t a < = 7 9 ){ c o u t < < n o t a < < " C " < < e n d l ;

3 3 . 3 4 . 3 5 . 3 6 . 3 7 . 3 8 . 3 9 . 4 0 . 4 1 . 4 2 . 4 3 .

} i f( n o t a > = 8 0 & & n o t a < = 8 9 ){ c o u t < < n o t a < < " B " < < e n d l ; } i f( n o t a > = 9 0 & & n o t a < = 1 0 0 ){ c o u t < < n o t a < < " A " < < e n d l ; } r e t u r n0 ; }

Pub lic ado po r G e o rge Tac uri e n 09 :4 8 0 c o m e ntario s Enlac e s a e s ta e ntrada Etiq ue tas : C + + , c o digo fue nte , diagram a de fluj o , PS e I nt, ps e udo c o digo

Suma de los 10 primeros pares - Diagrama de Flujo


Realizar el diagrama de flujo de un programa para calcular la suma de los 10 primeros nmeros pares.

En pseudocodigo: Proceso SumaPares num <- 0; sum <- 0; Mientras num < 11 Hacer Si num%2 = 0 Entonces sum <- sum + num; FinSi num <- num + 1; FinMientras Escribir "La suma de los 10 primeros pares es: ",sum; FinProceso

Pub lic ado po r G e o rge Tac uri e n 09 :1 1 1 c o m e ntario s Enlac e s a e s ta e ntrada Etiq ue tas : diagram a de fluj o , pro gram ac io n e s truc turada, PS e I nt, ps e udo c o digo

v ie rne s , 8 de m arz o de 2 01 3

Elevar un numero a una potencia - Diagrama de Flujo


Realizar el diagrama de flujo de un programa que permita elevar un numero entero ingresado por teclado, a una potencia dada.

PSEUDOCDIGO Proceso ElevarPotencia Escribir "Ingrese un numero: "; Leer num; Escribir "Ingrese la potencia: "; Leer pot; rpta <- num; Mientras pot>1 Hacer rpta <- rpta * num; pot <- pot - 1; FinMientras Escribir "El resultado es: ", rpta ; FinProceso
Pub lic ado po r G e o rge Tac uri e n 1 9 :09 Etiq ue tas : diagram a de fluj o , PS e I nt 1 c o m e ntario s Enlac e s a e s ta e ntrada

Nmeros divisibles por tres - Diagrama de Flujo


Realizar el pseudocodigo y el diagrama de flujo para indicar si un numero ingresado es divisible por tres.

Proceso NumerosDivisibles Escribir "Ingrese un numero: "; Leer num; Si (num % 3) = 0 Entonces Escribir "El numero SI es divisible por tres"; Sino Escribir "El numero NO es divisible por tres"; FinSi FinProceso

Pub lic ado po r G e o rge Tac uri e n 1 8:1 6 Etiq ue tas : diagram a de fluj o , PS e I nt

0 c o m e ntario s

Enlac e s a e s ta e ntrada

do m ingo , 3 de m arz o de 2 01 3

Algoritmo que muestra los nmeros pares entre 1 y 100 Pseudocdigo Diagrama de Flujo
Desarrollar el pseudocodigo y diagrama de flujo de un algoritmo que muestre los nmeros pares que hay entre 1 y 100.

Pseudocdigo Proceso NumerosPares Escribir "Los numeros pares entre 1 y 100: "; num <-1; Mientras num <= 100 Hacer Si num%2 = 0 Entonces Escribir num; FinSi num <- num + 1; FinMientras FinProceso

Pub lic ado po r G e o rge Tac uri e n 1 2 :3 1 0 c o m e ntario s Enlac e s a e s ta e ntrada Etiq ue tas : diagram a de fluj o , e j e rc ic io s re s ue lto s , PS e I nt, ps e udo c o digo

Imprimir 10 primeros nmeros en orden inverso Pseudocodigo y Diagrama Flujo


Realizar el pseudocodigo y diagrama de flujo de un programa que imprima en pantalla los 10 primeros nmeros en orden inverso.

Pseudocdigo Proceso NumerosOrdenInverso Escribir "Los 10 primeros numeros en orden inverso:"; cont <- 10; Mientras cont > 0 Hacer Escribir cont; cont <- cont -1 ; FinMientras FinProceso

Pub lic ado po r G e o rge Tac uri e n 1 2 :01 0 c o m e ntario s Etiq ue tas : diagram a de fluj o , PS e I nt, ps e udo c o digo

Enlac e s a e s ta e ntrada

m i rc o le s , 2 7 de fe b re ro de 2 01 3

Programa que apartir de una temperatura en grados Celcius determina si hace fro o calor - Diagrama de flujo
Desarrollar el pseudocodigo y diagrama de flujo de un programa que lea una temperatura en grados Centgrados y que imprima si hace fro o calor segn el siguiente esquema: el clima es muy fro (temperatura menor a 0C), es fro (temperatura entre 0 y 9 C), es templado (temperatura entre 10 y 19C), es clido (temperatura entre 20 - 26C) y muy caliente (temperatura mayor a 26C).

PSEUDOCDIGO Proceso TemperaturaAmbiente Escribir "Ingrese una temperatura"; Leer temp; Si (temp < 0) Entonces Escribir "El clima es muy frio"; Sino Si (temp < 10) Entonces Escribir "El clima es frio"; Sino Si (temp < 20) Entonces Escribir "El clima es templado"; Sino Si (temp < 27) Entonces Escribir "El clima es calido"; Sino Escribir "El clima es muy caliente"; FinSi FinSi FinSi

FinSi FinProceso

Pub lic ado po r G e o rge Tac uri e n 1 7 :2 3 0 c o m e ntario s Etiq ue tas : diagram a de fluj o , PS e I nt, ps e udo c o digo

Enlac e s a e s ta e ntrada

m arte s , 2 6 de fe b re ro de 2 01 3

Imprimir 8 primeros mltiplos de un numero - Diagrama de Flujo y Pseudocdigo


Realizar el pseudocdigo y el diagrama de flujo de un programa que imprima los 8 primeros mltiplos de un numero ingresado por el usuario.

PSEUDOCDIGO Proceso MultiplosNumero Escribir "Ingrese un numero: "; Leer num; Escribir "Los 8 primeros multiplos de ", num, " son: "; Para i<-1 Hasta 8 Con Paso 1 Hacer Escribir num*i; FinPara FinProceso

Pub lic ado po r G e o rge Tac uri e n 1 8:2 3 0 c o m e ntario s Enlac e s a e s ta e ntrada Etiq ue tas : diagram a de fluj o , e j e rc ic io s re s ue lto s , PS e I nt, ps e udo c o digo

Pgina principal

Entradas antiguas

( c ) 2 009 Diagr am as de Fl uj o y Algo ritm o s . B lo gge r Te m plate s c re ate d b y De luxe T e m pla te s . n e t. W p b y w pth e m e s fr e e