Está en la página 1de 7

1.

realizar el algoritmo de un programa que permita hallar el volumen de un cilindro Inicio Entero: Altura, Radio,Volumen; Leer Altura; Leer Radio; Volumen= (3.1416)*(Radio)*(Radio)*(Altura); Escrbir: El volumen del cilindro es: (Volumen); Fin 2. realizar el algoritmo que permita convertir la temperatura en grados kelvin a grados Celsius Inicio Entero: Temperatura_K, Celsus; Leer: Temperatura_K; Celsius=Temperatura_K -273.16; Escribir= La temperatura en Celsius es: (Celsius); Fin 3. realizar el algoritmo de un programa que permita hallar el rea de un circulo Inicio Entero: Radio, Area; Leer: Radio; Area= (3.1416)*(Radio)(Radio); Escribir= El area del circulo es: (Radio); Fin 5. A un trabajador le pagan segun sus horas y una tarifa de pago por horas. si la cantidad de horas trabajadas es mayor a 40 horas. La tarifa se incrementa en un 50% para las horas extras. calcular el salario del trabajador dadas las horas trabajadas y la tarifa. Inicio Entero: Horas, Tarifa, tarifa2, pago; Leer: Horas; Leer: Tarifa; Si Horas>= 40 entonces; Tarifa2= Tarifa- Tarifa*0.50; Pago= horas*tarifa2; Si no; Pago= horas* Tarifa Fin Si

Escribir: Pago Fin

6. A un trabajador le descuentan de su sueldo el 10% si su sueldo es menor o igual a 1000. por encima de 1000 y hasta 2000 el 5% del adicional, y por encima de 2000 el 3% del adicional. calcular el descuento y sueldo neto que recibe el trabajador dado su sueldo. Inicio Entero: sueldo, sueldot; Si sueldo>= 3000 entonces; Sueldot= sueldo-sueldo*0.03; Si no; Si sueldo <=1000 entonces; Sueldot=sueldo-sueldo*(0.10); Si no Sueldot= sueldo-sueldo*0.05; Fin si Fin si Escribir: sueldot Fin

7. Dado un monto calcular el descuento considerando que por encima de 100 el descuento es el 10% y por debajo de 100 el descuento es el 2%. Inicio Entero: monto, total; Leer: monto; Si monto >= 100 entonces; Total= monto monto*0.10 Si no Total= monto monto * 0.02 Fin si Escribir: total Fin 8. Dado un tiempo en segundos, calcular los segundos restantes que le correspondan para convertirse exactamente en minutos. Inicio Entero: seg, min; Leer: seg; Min= 60-seg

Escribir: Min Fin 9. Dado un tiempo en minutos, calcular los dias, horas y minutos que le corresponden. Inicio Entero: t, dia, x, min, hr; Leer: t; Dia= t /1440; X= t mod 1440; Hr= x/60; Min= x mod 60; Escribir: dia, min, hr Fin 10. Calcular mediante un algoritmo repetitivo la suma de los 20 primeros nmeros naturales. Inicio Entero: n, suma, i; Leer: n; Suma: 0 i= 20; Mientras i > n hacer; Suma= suma +i; i= i+1; Fin mientras Escribir: suma Fin

11. Dado las tres notas de un estudiante calcular: a) Cuantas notas tiene desaprobados. b) Cuantos aprobados. Inicio Entero: n, cont, contrep, numa, numr, nota, contap; Numa=0; Numr= 0; Mientras cont <=3 hacer; Leer: nota; Si nota <59 entonces; Contrep= numrep+1; Si no

Contap= contap +1; Fin mientras Escribir: Aprobados (contap), Reprobados (contrep); Fin 12. Dado las tres notas de un estudiante calcular: a) El promedio de notas. b) El promedio de notas aprobadas y desaprobadas. Inicio Entero: cant, cantrep, numapro, sumarep, sumap, suma, promap, promrep; Leer: cant; Cantrep=0; Numapro=0; Sumarep= 0; Sumap=0; N=3; Suma= 0; Mientras que cont <=n; Leer: nota Si nota <59 entonces Cantrep= cantrep+1; Sumarep= sumarep +1; Sino Numapro= numapro +1; Sumap= sumap+1 Fin si Suma= suma + nota Cant= cant + 1; Fin mientras Promap= sumap /numpro; Promrep = sumarep/cantrep; Prom= suma/ n; Escriba : cantep, numapro, prom, promap, promrep; Fin 13. Dado un numero determinar la suma de sus dgitos Inicio Entero: Num, resta, suma, nu; Leer: Num; Suma= 0; Mientras que num >0 hacer; Resta= num (num/10) *10 Suma= suma + resta nu= num/10;

Escribir: La suma de digitos s: Suma; Fin mientras Fin

14. Se trata de escribir el algoritmo que permita emitir la factura correspondiente a una compra de un articulo determinado, del que se adquieren una o varias unidades. Inicio Entero: precio, numart; Leer: precio; Leer: numart; Total= precio *numart; Escribir: Total, numart; Fin 15. Realizar un algoritmo que permita pedir 50 nmeros naturales y determine cuantos son pares Inicio Entero: par, x,n; Leer: x; Par=0; Para x=1 hasta 50 hacer; Si n mod 2=0 Par = par + 1 Si no; Leer: x; Fin si fin para Escribir: impar Fin 16. Realizar un algoritmo que permita pedir 50 nmeros naturales y determine cuantos son impares,. Inicio Entero: impar, x, n; Leer: x; Impar=0; Para x=1 hasta 50 hacer; Leer: n; Si n mod 2=0 Leer: n; Si no;

Impar= impar + 1; Fin si fin para Escribir: impar Fin

17. Desarrollar un algoritmo para calcular el factorial de un nmero.

Inicio Entero: f, x, n; F=1; X=1; Leer: n Para x=1 hasta n; F= f *x Fin para Escribir f Fin 18. "SAGA FALABELLA" se encuentra de aniversario y ha programado una serie de ofertas con la finalidad de brindar facilidades a sus clientes y al a vez de incrementar sus ventas. Estas ofertas se basan especficamente en un porcentaje de descuento sobre el total de compra el cual varia de acuerdo al monto a. Por un monto mayor o igual a $500 se har un descuento del 30% b. Por un monto menor de $500 pero mayor o igual a 200 se har un descuento del 20% c. Por un monto menor de $200 pero mayor o igual a 100 se har un descuento del 10% d. Considere 100 personas Inicio Entero: monto, n, total, Leer: monto; Leer: n; Mientras n <= 100 hacer Si monto >= 500; Total = monto monto *0.30; Si no Si monto <100; Total = monto; Si no Si monto<500; Total= monto- monto *0.20;

Sino Total = monto- monto* 0.10; Fin si Fin si Fin si Fin mientras Escribir: total Fin

19. Hacer un programa en el que ingresados dos nmeros se debe calcular la suma, diferencia, producto y divisin Inicio Entero: a, b, s, r,m,d; Leer: a Si a= 0 entonces Escribir Fin; Si no Leer: b; S=a+b; R=a-b; M= a*b; D= a/b; Escribir: s, r, m, d; Fin si Fin

20. Hacer un programa que imprima y el cubo de un numero; el programa debe estar confeccionado de tal manera que el proceso a efectuarse sea repetitivo.

Inicio Entero: n, x, num, cubo; Leer: x; N=1; Para n=1 hasta X hacer; Leer: num; Cubo= num*num*num; Escribir: cubo Fin para Fin