Está en la página 1de 7

FUNCIONES LGICAS DESEMPEO: Conoce y aplica las funciones lgicas de Microsoft Office Excel 2007.

DEFINICIN: Las funciones lgicas se utilizan en diferentes campos del saber humano para obtener un resultado exacto a travs de la comparacin entre 2 o ms proposiciones LAS FUNCIONES SON: Y Devuelve VERDADERO si todos sus argumentos son verdaderos FALSO Devuelve el valor lgico FALSO SI Especifica un texto lgico para ejecutar NO Invierte la lgica de sus argumentos O Devuelve VERDADERO si algn argumento es VERDADERO VERDADERO Devuelve el valor lgico VERDADERO Funcin Y: Devuelve VERDADERO si todos los argumentos son VERDADERO; devuelve FALSO si uno o ms argumentos son FALSO. Sintaxis Y(valor_lgico1;valor_lgico2; ...) Valor_lgico1, Valor_lgico2, ... VERDADERO o FALSO. son entre 1 y 30 condiciones que se desea comprobar y que pueden ser

Ejemplo 1 El ejemplo puede resultar ms fcil de entender si lo copia en una hoja de clculo en blanco. 1 2 3 4 A B Frmula Descripcin (Resultado) =Y(VERDADERO;VERDADERO) Todos los argumentos son VERDADERO (VERDADERO) =Y(VERDADERO;FALSO) =Y(2+2=4;2+3=5) Un argumento es FALSO (FALSO) Todos los argumentos se evalan (VERDADERO) como VERDADERO

Ejemplo 2 El ejemplo puede resultar ms fcil de entender si lo copia en una hoja de clculo en blanco 1 2 3 A Datos 50 104 Frmula =Y(1<A2;A2<100) =SI(Y(1<A3; A3<100); A3; "El valor queda fuera del rango.") Descripcin (Resultado) Porque 50 es un nmero entre 1 y 100 (VERDADERO) Muestra el segundo nmero de la expresin anterior si se trata de un nmero entre 1 y 100; en caso contrario, muestra un mensaje (El valor

queda fuera del rango.) =SI(Y(1<A2; A2<100); A2; "El Muestra el primer nmero de la expresin anterior, si est comprendido valor queda fuera del rango.") entre 1 y 100; en caso contrario, muestra un mensaje (50)

Funcin FALSO: Devuelve el valor lgico FALSO. Sintaxis FALSO( ) Funcin SI: Utilice SI para realizar pruebas condicionales en valores y frmulas. Sintaxis SI(prueba_lgica;valor_si_verdadero;valor_si_falso) Prueba_lgica es cualquier valor o expresin que pueda evaluarse como VERDADERO o FALSO. Por ejemplo, A10=100 es una expresin lgica; si el valor de la celda A10 es igual a 100, la expresin se evala como VERDADERO. De lo contrario, la expresin se evala como FALSO. Este argumento puede utilizar cualquier operador de comparacin. Valor_si_verdadero es el valor que se devuelve si el argumento prueba_lgica es VERDADERO. Por ejemplo, si este argumento es la cadena de texto "Dentro de presupuesto" y el argumento prueba_lgica se evala como VERDADERO, la funcin SI muestra el texto "Dentro de presupuesto". Si el argumento prueba_lgica es VERDADERO y el argumento valor_si_verdadero est en blanco, este argumento devuelve 0 (cero). Para mostrar la palabra VERDADERO, utilice el valor lgico VERDADERO para este argumento. Valor_si_verdadero puede ser otra frmula. Valor_si_falso es el valor que se devuelve si el argumento prueba_lgica es FALSO. Por ejemplo, si este argumento es la cadena de texto "Presupuesto excedido" y el argumento prueba_lgica se evala como FALSO, la funcin SI muestra el texto "Presupuesto excedido". Si el argumento prueba_lgica es FALSO y se omite valor_si_falso, (es decir, despus de valor_si_verdadero no hay ninguna coma), se devuelve el valor lgico FALSO. Si prueba_lgica es FALSO y valor_si_falso est en blanco (es decir, despus de valor_si_verdadero hay una coma seguida por el parntesis de cierre), se devuelve el valor 0 (cero). Valor_si_falso puede ser otra frmula. Observaciones
Es posible anidar hasta siete funciones SI como argumentos valor_si_verdadero y valor_si_falso para construir pruebas ms elaboradas. Vea el ltimo de los ejemplos siguientes. Cuando los argumentos valor_si_verdadero y valor_si_falso se evalan, la funcin SI devuelve el valor devuelto por la ejecucin de las instrucciones. Si uno de los argumentos de la funcin SI es una matriz, cada elemento de la matriz se evaluar cuando se ejecute la instruccin SI.

Microsoft Excel proporciona funciones adicionales que pueden utilizarse para analizar los datos basndose en una condicin. Por ejemplo, para contar el nmero de veces que aparece una cadena de texto o un nmero dentro de un rango de celdas, utilice la funcin de hoja de clculo CONTAR.SI. Para calcular una suma basndose en una cadena de texto o un nmero dentro de un rango, utilice la funcin SUMAR.SI. Obtenga informacin sobre calcular un valor basado en una condicin.

Ejemplo 1 El ejemplo puede resultar ms fcil de entender si lo copia en una hoja de clculo en blanco. 1 2 A Datos 50 Frmula Descripcin (Resultado) =SI(A2<=100;"Dentro de Si el nmero anterior es menor o igual que 100, la frmula presupuesto";"Presupuesto excedido") muestra "Dentro de presupuesto". De lo contrario, la funcin mostrar "Presupuesto excedido" (Dentro de presupuesto) =SI(A2=100;SUMA(B5:B15);"") Si el nmero anterior es 100, se calcula el rango B5:B15. En caso contrario, se devuelve texto vaco ("") ()

Ejemplo 2 El ejemplo puede resultar ms fcil de entender si lo copia en una hoja de clculo en blanco. 1 2 3 4 A Gastos reales 1500 500 500 Frmula =SI(A2>B2;"Presupuesto excedido";"Aceptar") =SI(A3>B3;"Presupuesto excedido";"Aceptar") Ejemplo 3 El ejemplo puede resultar ms fcil de entender si lo copia en una hoja de clculo en blanco. 1 2 3 4 A Puntuacin 45 90 78 Frmula Descripcin (Resultado) =SI(A2>89,"A",SI(A2>79;"B";SI(A2>69;"C";SI(A2>59;"D";"F")))) Asigna una puntuacin de una letra al primer resultado (F) =SI(A3>89;"A";SI(A3>79;"B";SI(A3>69;"C";SI(A3>59;"D";"F")))) Asigna una puntuacin de una letra al segundo resultado (A) =SI(A4>89;"A";SI(A4>79;"B";SI(A4>69;"C";SI(A4>59;"D";"F")))) Asigna una puntuacin de una letra al B Gastos previstos 900 900 925 Descripcin (Resultado) Comprueba si la primera fila sobrepasa el presupuesto (Presupuesto excedido) Comprueba si la segunda fila sobrepasa el presupuesto (Aceptar)

tercer resultado (C) En el ejemplo anterior, la segunda instruccin SI representa tambin el argumento valor_si_falso de la primera instruccin SI. De manera similar, la tercera instruccin SI es el argumento valor_si_falso de la segunda instruccin SI. Por ejemplo, si el primer argumento prueba_lgica (Promedio>89) es VERDADERO, se devuelve el valor "A". Si el primer argumento prueba_lgica es FALSO, se evala la segunda instruccin SI y as sucesivamente. Las letras de puntuacin se asignan a nmeros utilizando la siguiente clave. SI LA PUNTUACIN ES Mayor que 89 De 80 a 89 De 70 a 79 De 60 a 69 Menor que 60 Funcin NO: Invierte el valor lgico del argumento. Use NO cuando desee asegurarse de que un valor no sea igual a otro valor especfico. Sintaxis NO(valor_lgico) Valor_lgico Observacin Si valor_lgico es FALSO, NO devuelve VERDADERO; si valor_lgico es VERDADERO, NO devuelve FALSO. Ejemplo El ejemplo puede resultar ms fcil de entender si lo copia en una hoja de clculo en blanco. 1 2 3 A Frmula =NO(FALSO) =NO(1+1=2) B Descripcin (Resultado) Invierte FALSO (VERDADERO) Invierte una ecuacin que se evala como VERDADERO (FALSO) es un valor o expresin que puede evaluarse como VERDADERO o FALSO. LA FUNCIN DEVUELVE A B C D F

Funcin O: Devolver VERDADERO si alguno de los argumentos es VERDADERO; devolver FALSO si todos los argumentos son FALSO.

Sintaxis O(valor_lgico1;valor_lgico2; ...) Valor_lgico1;valor_lgico2,... VERDADERO o FALSO. son entre 1 y 30 condiciones que desea comprobar y que pueden ser

Ejemplo El ejemplo puede resultar ms fcil de entender si lo copia en una hoja de clculo en blanco.

1 2 3 4

A Frmula =O(VERDADERO) =O(1+1=1;2+2=5)

B Descripcin (Resultado) Un argumento es VERDADERO (VERDADERO) Todos los argumentos se evalan como FALSO (FALSO).

=O(VERDADERO;FALSO;VERDADERO) Al menos un argumento es VERDADERO (VERDADERO).

Funcin VERDADERO: Devuelve el valor lgico VERDADERO. Sintaxis VERDADERO( ) Observacin El valor VERDADERO puede introducirse directamente en las celdas y frmulas sin necesidad de usar esta funcin. La funcin VERDADERO se proporciona principalmente por su compatibilidad con otros programas para hojas de clculo.

TABLA DE AMORTIZACION DE PRESTAMOS MONTO INTERES PLAZO CUOTA CALC. CUOTA TOTAL SALDO PERIODO 1 2 3 4 5 6 7 8 9 10 11 12 INICIAL 12.450.000,00 12.239.747,68 12.023.888,63 11.802.273,35 11.574.748,32 11.341.155,95 11.101.334,46 10.855.117,73 10.602.335,22 10.342.811,84 10.076.367,83 9.802.818,66 Bs 12.450.000,00 32,00% 36 Bs 542.252,32 Bs 557.252,32 SALDO FINAL 12.239.747,68 12.023.888,63 11.802.273,35 11.574.748,32 11.341.155,95 11.101.334,46 10.855.117,73 10.602.335,22 10.342.811,84 10.076.367,83 9.802.818,66 9.521.974,84 CUOTA MENSUAL 557.252,32 557.252,32 557.252,32 557.252,32 557.252,32 557.252,32 557.252,32 557.252,32 557.252,32 557.252,32 557.252,32 557.252,32 TOTAL A PAGAR INTERES MENSUAL 332.000,00 326.393,27 320.637,03 314.727,29 308.659,96 302.430,83 296.035,59 289.469,81 282.728,94 275.808,32 268.703,14 261.408,50 Bs 20.061.083,46 AMORTIZACION MENSUAL 210.252,32 215.859,05 221.615,29 227.525,03 233.592,36 239.821,49 246.216,73 252.782,51 259.523,38 266.444,00 273.549,18 280.843,82 INTERES ACUMULADO 332.000,00 658.393,27 979.030,30 1.293.757,59 1.602.417,55 1.904.848,37 2.200.883,96 2.490.353,76 2.773.082,70 3.048.891,02 3.317.594,16 3.579.002,66 AMORTIZACION ACUMULADA 210.252,32 426.111,37 647.726,65 875.251,68 1.108.844,05 1.348.665,54 1.594.882,27 1.847.664,78 2.107.188,16 2.373.632,17 2.647.181,34 2.928.025,16 COBRANZA Bs 15.000,00

: : PASOS A SEGUIR 1.- Situarse en la celda indicada e ingresar: En A1: TABLA DE AMORTIZACION DE PRESTAMOS En B3: MONTO En B4: INTERES En B5: PLAZO En B6: CUOTA CALC. En B7: CUOTA TOTAL En E3: COBRANZA En E7: TOTAL A PAGAR En C3: En C4: En C5: En C6: En F3: En C7: En F7: 12450000 32% 36 MONTO DE LA CUOTA CALCULADA =PAGO(C4/12;C5;-C3) PAGO(TASA;PERIODOS; VALOR ACTUAL;[VALOR FINAL];[TIPO]) 15000 =C6+F3 (CUOTA TOTAL = CUOTA CALCULADA + GASTOS DE COBRANZA) =C7*C5 (TOTAL A PAGAR POR EL PRESTAMO = CUOTA TOTAL * PLAZO DEL PRESTAMO)

Se ingresan los encabezados que tendrn las diferentes columnas En A10: PERIODO En D9: CUOTA En F10: MENSUAL En B9: SALDO En D10: MENSUAL En G9: INTERES En B10: INICIAL En E9: INTERES En G10: ACUMULADO En C9: SALDO En E10: MENSUAL En H9: AMORTIZACION En C10: FINAL En F9: AMORTIZACIN En H10: ACUMULADA 2.- Colocar en la columna A, a partir de la fila 12, los nmeros de perodo que van desde el 1 hasta el 72 (Esta tabla debe servir para cualquier plazo desde 1 mes hasta 72 meses, con las cuotas pagndose al final del mes, es decir, se aplicar el clculo de las cuotas post pagables). INGRESO DE LAS FORMULAS PARA EL PRIMER PERIODO 3.- Hacer el saldo inicial del primer perodo igual al monto del prstamo. Situarse en la celda B12 y escribir =C3 4.- En la celda C12 escribir la frmula para calcular el saldo al final del primer perodo. (VA es el Valor Actual o presente de una serie de pagos iguales: VA(TASA ; PERIODOS ; MONTO PAGOS)) =VA(C4/12;(C5-1);-C6) (C14/12 valor que corresponde a la tasa mensual) Con esta frmula se est calculando el valor que tienen al final del primer perodo las restantes (PLAZO-1) cuotas que faltan por cancelar. 5.- En la celda D12 ingresar la frmula para el clculo de la cuota mensual ( CUOTA MENSUAL = MONTO DE LA CUOTA ) =C7 6.- En la celda E12 ingresar la frmula para el clculo del inters pagado en el primer perodo ( INTERES MENSUAL = CUOTA MENSUAL - AMORTIZACIN MENSUAL - GASTOS COBRANZA )

=D12-(B12-C12)-F3 7.- En la celda F12 escribir la frmula para el clculo de la amortizacin en el primer perodo ( AMORTIZACIN PERIODO = SALDO INICIAL DEL PERIODO - SALDO FINAL DEL PERIODO) =B12-C12 8.- En la celda G12 escribir la frmula para el clculo del inters acumulado en el primer perodo =E12 9.- En la celda H12 escribir la frmula para el clculo de la amortizacin acumulada en el primer perodo =F12 INGRESO DE LAS FORMULAS PARA LOS RESTANTES PERIODOS Como esta hoja debe servir para cualquier nmero de perodos entre 1 y 72, se debe controlar que solamente se realicen clculos para los perodos menores o iguales al plazo del prstamo. =SI( perodo<=plazo ; asigne ; no asigne ) 10.- En la celda B13 ingresar la frmula para el clculo del saldo inicial del segundo perodo ( SALDO INICIAL = SALDO FINAL PERIODO ANTERIOR ) =SI(A13<=C$5;C12;NOD( )) ( Observe la utilizacin de la funcin SI. SI(Expresin Lgica ; cuando sea VERDADERO asigne ; cuando sea FALSO asigne NOD( )) NOD( ) = Funcin que devuelve el valor de error #N/A, que significa "no hay ningn valor disponible" 11.- En la celda C13 escribir la frmula para el clculo del saldo final del segundo perodo =SI(A13<=C$5;VA(C$4/12;(C$5-A13);-C$6);NOD( )) 12.- En la celda D13 escribir la frmula para el clculo de la cuota mensual =SI(A13<=C$5;C$7;NOD( )) 13.- En la celda E13 ingresar la frmula para el clculo del inters pagado en el segundo perodo =SI(A13<=C$5;(D13-(B13-C13)-F$3);NOD( )) 14.- En la celda F13 ingresar la frmula para el clculo de la amortizacin mensual en el segundo perodo =SI(A13<=C$5;(B13-C13);NOD( )) 15.- En la celda G13 ingresar la frmula para el clculo del inters acumulado al final del segundo perodo ( INTERS ACUMULADO = INTERS DEL PERODO + INTERS ACUMULADO HASTA PERODO ANTERIOR ) =SI(A13<=C$5;(E13+G12);NOD( )) 16.- En la celda H13 ingresar la frmula para el clculo de la amortizacin acumulada al final del segundo perodo. ( AMORTIZACIN ACUMULADA = AMORTIZAC PERODO + AMORTIZAC ACUMULADA HASTA PERODO ANTERIOR ) =SI(A13<=C$5; ;NOD( )) 17.- Las frmulas para el clculo de los valores correspondientes a los restantes perodos ( 3 a 72 ) son semejantes a las ingresadas para el segundo perodo; por lo tanto, estas frmulas pueden y deben ser copiadas a los dems perodos, de ah la necesidad de utilizar referencias absolutas de celdas en algunas de las frmulas. 18.- Colocar el ancho adecuado y el formato indicado a cada una de las columnas.