Está en la página 1de 6

1

Explica la sintaxis de la primitiva CREABOTON

Solución:

La sintaxis es la siguiente. CREABOTON “vent “nombre [texto] x y alto ancho [acción] Vent es la ventana que contiene al botón. Nombre es el nombre que queremos darle al botón. X e y son las coordenadas con respecto a la esquina superior izquierda de la ventana. Ancho y alto son las dimensiones de botón y acción es lo que queremos que suceda al pulsar el botón.

2 Escribe correctamente la primitiva de LOGO que te permita:

a) Poner color en el área gráfica.

b) Llevar la tortuga al centro.

c) Desactivar el trazo del lápiz gráfico.

d) Hacer visible la tortuga.

Solución:

a) PonColorLápiz o PonCL.

b) Centro.

c) DubeLápiz o SL.

d) MuestraTortuga o MT.

3 ¿Para qué sirve la ventana de textos en MSWLogo?

Solución:

Para que la aplicación MSWLogo se comunique con nosotros mostrando las instrucciones de escritura y los mensajes de error.

4 ¿Para qué sirve la ventana de trabajo en MSWLogo?

Solución:

Para escribir las instrucciones o Primitivas de los programas. Es el canal de comunicación para darle órdenes a la tortuga, y para recibir los mensajes de error.

5 Indica que diferencia existe entre la primitiva LIMPIA y la primitiva BORRAPANTALLA

Solución:

Ambas borran toda la ventana de gráficos, pero en el caso de la primitiva LIMPIA, la tortuga permanece en la situación en la que se encontraba, mientras que en el caso de la primitiva BORRAPANTALLA, la tortuga reinicia su posición, es decir se sitúa como al inicio del programa.

6 Explica la sintaxis de la primitiva CREAVENTANA

1

Solución:

La sintaxis es creaventana “vent1 “nombre [texto] x y ancho alto [acción]

Vent1 será el nombre de la ventana que contendrá a la que estamos creando. Nombre será el nombre que queramos darle esta ventana. Texto es lo que queremos que aparezca escrito en la ventana. X e y son las coordenadas respecto de la esquina superior izquierda de la ventana de gráficos. Ancho y alto son las dimensiones de la ventana y acción será lo que queremos que suceda cuando se cree la ventana.

7 ¿Qué es la tortuga en la aplicación MSWLogo y dónde se sitúa?

Solución:

Es un pequeño trángulo que inicialmente está en el puntote coordenadas (0,0), que es el centro de la ventan, y que se mueve por la pantalla si se lo indicamos mediante las órdenes que le vamos dando.

8 Sabiendo que los ángulos interiores de un hexágono miden 60 º, escribe el programa en lenguaje LOGO que sirva para dibujar un hexágono de 70 mm de lado.

Solución:

Repite 6 [GiraDerecha 60 Avanza 70]

9 Indica qué figura se dibujaría en la pantalla si indicamos las siguientes instrucciones:

GD 30 AV 50 GD 120 AV 50 GI 120 AV 50 GD 120 AV 50 GI 120 AV 50

Solución:

Se dibuja una línea en zig zag como la de la siguiente figura:

dibuja una línea en zig zag como la de la siguiente figura: 10 Si con la

10 Si con la siguiente instrucción: REPITE 360[AV 1 GD 1], se realiza una circunferencia, ¿Cómo harías otra más grande?

Solución:

Aumentando el número de puntos que se avanza cada vez. Por ejemplo: REPITE 360[AV 2 GD 1],

11 Indica las instrucciones en lenguaje LOGO necesarias para que se dibuje un cuadrado de 10 cm. de lado.

2

Solución:

AV 100

GD 90

AV100

GD 90

AV100

GD 90

AV100

GD 90

12 Escribe las órdenes que se han de dar a MSWLogo para crear, sobre la ventana de gráficos, una ventana como la siguiente:

la ventana de gráficos, una ventana como la siguiente: La ventana comenzará en la posición 50

La ventana comenzará en la posición 50 50 y el tamaño será de 60 mm por 60 mm.

Solución:

creaventana "principal "bienvenido [hola] 50 50 60 60[]

13 Si con la siguiente instrucción: REPITE 3 [AV 20 GD 360/3], se realiza un triángulo, y con la instrucción:

REPITE 5 [AV 20 GD 360/5] se realiza un pentágono, ¿Cómo harías una circunferencia?

Solución:

REPITE 360[AV 1 GD 360/360]

14 Dibuja el gráfico resultante del siguiente programa:

gd 90

av 70

gd 120

av 70

gd 120

av 70

3

Solución:

Se dibuja un triángulo equilátero de 70 mm. de lado:

Se dibuja un triángulo equilátero de 70 mm. de lado: 15 Indica qué figura se realizará

15 Indica qué figura se realizará en MSWLOGO con la siguiente instrucción:

REPITE 3 [AV 20 GD 360/3]

Solución:

Se realizará un triángulo equilátero.

16 Realiza un cuadrado de 60 mm de lado y de grosor de línea 6, utilizando la primitiva REPITE

Solución:

PONGROSOR [0 6] REPITE 4 [AV 60 GD 90]

REPITE Solución: PONGROSOR [0 6] REPITE 4 [AV 60 GD 90] 17 Si con la siguiente

17 Si con la siguiente instrucción: REPITE 3 [AV 20 GD 360/3], se realiza un triángulo, ¿Cómo harías un pentágono regular?

Solución:

REPITE 5 [AV 20 GD 360/5]

4

18

Escribe un programa que te dibuje la siguiente figura con un grosor 3:

50 50 50 50 Solución:
50
50
50
50
Solución:

Pongrosor 3 Repite 2 [gd 90 av 100 Gi 90 av 50 gi 90 av 50 gd 90 av 50 gd 90 av 100 gd 90 av 100 gd 180]

O También:

Pongrosor 3 gd 90 av 100 Gi 90 av 50 gi 90 av 50 gd 90 av 50 gd 90 av 100 gd 90 av 100 gd 180 gd 90 av 100 Gi 90 av 50 gi 90 av 50 gd 90 av 50 gd 90 av 100 gd 90 av 100 gd 180

19 ¿Qué se dibujará en el área de gráficos si seleccionamos las siguientes instrucciones y hacemos clic en el botón “ejecutar”? Avanza 10 GiraIzquierda 180 Retrocede 20 GiraIzquierda 180 Avanza 30

Solución:

Se dibujará una línea vertical de 60 mm. de longitud.

20 Indica las instrucciones a seguir para obtener una ventana en la ventana de gráficos llamada “mover tortuga” con las siguientes características:

Las coordenadas de la ventana serán 100 100 Las dimensiones de la ventana serán 80 80 Tendrá un botón en el que ponga avanza, que servirá para que la tortuga avance 20 mm sin dibujar nada Tendrá otro botón en el que ponga retrocede, que servirá para que la tortuga retroceda 20 mm.

Solución:

creaventana "principal "movertortuga [] 100 100 80 80[] creaboton "movertortuga "avanza [avanza] 10 10 60 20 [ sl av 20] creaboton "movertortuga "retrocede [retrocede] 10 30 60 20 [sl re 20]

21 ¿En qué consiste la fase de codificación de un programa?

5

Solución:

Es la fase en la que, una vez definido el funcionamiento del programa, éste se debe codificar mediante un lenguaje de programación apropiado. Para ello se utilizan los editores de programas y otras herramientas que detectan errores y convierten el programa a lenguaje máquina.

6