Está en la página 1de 3

Funcin Y En este artculo se describen la sintaxis de la frmula y el uso de la funcin Y de Microsoft Office Excel.

Devuelve VERDADERO si todos los argumentos se evalan como VERDADERO; devuelve FALSO si uno o ms argumentos se evalan como FALSO. Un uso comn de la funcin Y es expandir la utilidad de otras funciones que realizan pruebas lgicas. Por ejemplo, la funcin SI realiza una prueba lgica y, luego, devuelve un valor si la prueba se evala como VERDADERO y otro valor si la prueba se evala como FALSO. Con la funcin Y como argumento prueba_lgica de la funcin SI, puede probar varias condiciones diferentes en lugar de slo una. Sintaxis Y(valor_lgico1; [valor_lgico2]; ...) La sintaxis de la funcin Y tiene los siguientes argumentos:

valor_lgico1 Obligatorio. La primera condicin que desea probar se puede evaluar como VERDADERO o FALSO. valor_lgico2, ... Opcional. Las condiciones adicionales que desea probar se pueden evaluar como VERDADERO o FALSO, hasta un mximo de 255 condiciones.

Funcin O Devolver VERDADERO si alguno de los argumentos es VERDADERO; devolver FALSO si todos los argumentos son FALSO. Sintaxis O(valor_lgico1;valor_lgico2; ...) Valor_lgico1, Valor_lgico2, ... son de 1 a 255 condiciones que se desea comprobar y que pueden tener el resultado de VERDADERO o FALSO. Ejemplo El ejemplo ser ms fcil de entender si lo copia a una hoja de clculo en blanco. A 1 Frmula B Descripcin (resultado)

2 3 4

=O(VERDADERO) =O(1+1=1;2+2=5) =O(VERDADERO;FALSO;VERDADERO)

Un argumento es VERDADERO (VERDADERO) Todos los argumentos se evalan como FALSO (FALSO). Al menos un argumento es VERDADERO (VERDADERO).

Funcin NO Invierte el valor lgico del argumento. Use NO cuando desee asegurarse de que un valor no sea igual a otro valor especfico. Sintaxis NO(valor_lgico) Valor_lgico Observacin Si valor_lgico es FALSO, NO devuelve VERDADERO; si valor_lgico es VERDADERO, NO devuelve FALSO. Ejemplo El ejemplo ser ms fcil de entender si lo copia a una hoja de clculo en blanco. es un valor o expresin que puede evaluarse como VERDADERO o FALSO.

A 1 2 3 =NO(1+1=2) Funcin SI Frmula =NO(FALSO)

B Descripcin (resultado) Invierte FALSO (VERDADERO) Invierte una ecuacin que se evala como VERDADERO (FALSO)

Devuelve un valor si la condicin especificada es VERDADERO y otro valor si dicho argumento es FALSO. Utilice SI para realizar pruebas condicionales en valores y frmulas.

Sintaxis SI(prueba_lgica;valor_si_verdadero;valor_si_falso) Prueba_lgica es cualquier valor o expresin que pueda evaluarse como VERDADERO o FALSO. Por ejemplo, A10=100 es una expresin lgica; si el valor de la celda A10 es igual a 100, la expresin se evala como VERDADERO. De lo contrario, se evaluar como FALSO. Este argumento puede utilizar cualquier operador de comparacin. Ejemplo 1 Es ms sencillo comprender el ejemplo si se copia en una hoja de clculo en blanco.

A 1 2 Datos 50 Frmula =SI(A2<=100;"Dentro de presupuesto";"Presupuesto excedido") Descripcin (resultado) Si el nmero anterior es igual o menor que 100, la frmula muestra "Dentro de presupuesto". De lo contrario, la funcin mostrar "Presupuesto excedido" (Dentro de presupuesto) Si el nmero anterior es 100, se calcula el rango B5:B15. En caso contrario, se devuelve texto vaco ("") ()

=SI(A2=100;SUMA(B5:B15);"")