Está en la página 1de 5

TRABAJO PRCTICO 8 - PLANILLA DE CALCULOS

FUNCIONES CONDICIONALES
En este ejercicio se trabaja con: Nombrar rangos. Funcin condicional simple =Si(...). Funcin =Contar.Si() Funcion =Sumar.Si(...). Abrir el libro de Excel nombrado como TP8-PlanillaCalculos.xlsx de la carpeta correspondiente. Dicho libro contiene la siguiente informacin:

1.

Calcular la columna Descuento, teniendo en cuenta que el modelo Sandalia tendr un descuento sobre el precio unitario del 10%, mientas que para el resto de los modelos el descuento ser del 5%. Utilizar para este calculo la funcin condicional simple =SI(). Como se usa la Funcin condicional simple SI(): Excel tiene la posibilidad de incluir condicionales en las formulas. Esto significa que permite elegir entre dos acciones en funcin de que una condicin sea verdadera o falsa. Su sintaxis es: =SI(condicin; valor_si_condicin_es_V; valor_si_condicin_es_F) Por ejemplo:

TRABAJO PRCTICO 8 - PLANILLA DE CALCULOS

2.

Insertar una columna entre Descuento y Total rotulada como Importe del IVA y calcularla para cada venta efectuada. Se debe considerar el porcentaje de IVA definido en la parte superior de la planilla y que este porcentaje debe ser calculado en base al importe total de la venta, que requiere de clculos intermedios para ser obtenido. La columna Total debe mostrar el resultado de aplicarle al precio, el descuento e IVA correspondientes para todas las unidades vendidas. Al final de esta columna totalizar. Nombrar la Hoja1 como Ventas. Al final de la planilla de ventas, en una columna rotulada como Puntos, se deben mostrar los puntos generados por vendedor en cada venta realizada. Para esto se debe tener en cuenta que las ventas que superan las 2 unidades, generan 2 puntos; mientras que aquellas que no superan esta cantidad generan slo 1 punto. Utilizar para este calculo la funcin condicional simple =SI(). En una nueva hoja nombrada como Vendedores calcular cuntas ventas (registros en la tabla) ha realizado cada vendedor, cunto ha recaudado en Total cada uno de ellos y totalizar. Utilizar para el primer clculo la funcin =Contar.Si() y para el segundo clculo la funcin =Sumar.Si(). Tener en cuenta que puedes utilizar celdas ubicadas en otras hojas para realizar los clculos, solo debes hacer click primero en la hoja y luego en la/s celda/s (Por ejemplo: Ventas!A4:A20 hace referencia al rango desde A4 hasta A20 de la hoja Ventas). Ver la tabla de ejemplo que se muestra a continuacin, esta es la que debe obtenerse realizando los clculos correspondientes.

3.

4. 5.

6.

Cmo se usa la funcin CONTAR.SI La funcin CONTAR.SI cuenta el nmero de celdas dentro de un rango que cumplen un solo criterio especificado por el usuario. Por ejemplo, puede contar todas las celdas que comienzan con cierta letra, o bien todas las celdas que contienen un nmero mayor o menor que un nmero especificado por el usuario. Por ejemplo, suponga que tiene una hoja de clculo que contiene una lista de tareas en la columna A y el primer nombre de la persona asignada a cada tarea en la columna B. Puede usar la funcin CONTAR.SI para contar cuntas veces aparece

TRABAJO PRCTICO 8 - PLANILLA DE CALCULOS el nombre de una persona en la columna B y, de esa forma, determinar cuntas tareas tiene asignadas. Por ejemplo: =CONTAR.SI(B2:B25,"Nancy") Su sintaxis es: =CONTAR.SI(rango; criterio) Donde: rango: una o ms celdas que se van a contar, incluidos nmeros o nombres, matrices o referencias que contengan nmeros. Los valores en blanco y los de texto no se tienen en cuenta. Criterios: nmero, expresin, referencia de celda o cadena de texto que determina las celdas que se van a contar. Por ejemplo, los criterios pueden expresarse como 32, ">32", B4, "manzanas" o "32". En los criterios se puede utilizar los caracteres comodn signo de interrogacin (?) y asterisco (*) . El signo de interrogacin corresponde a un solo carcter cualquiera y el asterisco equivale a cualquier secuencia de caracteres. Si desea buscar un signo de interrogacin o un asterisco reales, escriba una tilde (~) delante del carcter que desea buscar. Los criterios no distinguen entre maysculas y minsculas; por ejemplo, la cadena "manzanas" y la cadena "MANZANAS" corresponden a las mismas celdas. Por ejemplo:
A 1 2 3 4 5 6 Datos manzanas naranjas melocotones manzanas Frmula =CONTAR.SI(A2:A5;"manzanas") B Datos 32 54 75 86 Descripcin Nmero de celdas con manzanas en las celdas A2 a A5. Nmero de celdas con melocotones en las celdas A2 a A5. Nmero de celdas con naranjas y manzanas en las celdas A2 a A5. Nmero de celdas con un valor superior a 55 en las celdas B2 a B5. Nmero de celdas con un valor no igual a 75 en las celdas B2 a B5. Nmero de celdas con un Resultado 2 C

=CONTAR.SI(A2:A5;A4)

=CONTAR.SI(A2:A5;A3)+CONTAR.SI(A2:A5;A2)

10

=CONTAR.SI(B2:B5;">55")

11 =CONTAR.SI(B2:B5;"<>"&B4)

12

=CONTAR.SI(B2:B5;">=32")-

TRABAJO PRCTICO 8 - PLANILLA DE CALCULOS


CONTAR.SI(B2:B5;">85") valor superior o igual a 32 e inferior o igual a 85 en las celdas B2 a A5.

Como se usa la Funcin SUMAR.SI(): Esta funcin suma las celdas en el rango que coinciden con el argumento criterio. Sintaxis Su sintaxis es: =SUMAR.SI(rango; criterio; rango_suma) Rango: es el rango de celdas que se desea evaluar segn los criterios especificados. Las celdas de cada rango deben ser nmeros, o bien nombres, matrices o referencias que contengan nmeros. Los valores en blanco y los de texto no se tienen en cuenta. Criterio: es el criterio en forma de nmero, expresin o texto, que determina las celdas que se van a sumar. Por ejemplo, los criterios pueden expresarse como 32, "32" ">32" o "manzanas". rango_suma: son las celdas reales que se deben sumar si las correspondientes celdas incluidas en el rango cumplen los criterios. Si se omite el argumento rango_suma, las celdas del rango se evaluarn segn los criterios y se sumarn si cumplen los criterios. Por Ejemplo:

TRABAJO PRCTICO 8 - PLANILLA DE CALCULOS 7. En la planilla generada en la hoja Vendedores, en una columna rotulada como Puntos, se deben mostrar los puntos totales obtenidos por las ventas efectuadas por cada vendedor. Utilizar para el clculo la funcin =Sumar.Si(). Al final de esta misma planilla, en una columna rotulada como Premio, se debe calcular un premio especial para los vendedores que hayan acumulado ms de 10 puntos. El valor del premio ser del 5% sobre el total vendido por cada uno. En una nueva hoja nombrada como Productos calcular cuntas unidades se vendieron por modelo, cunto se recaud para cada uno de ellos y totalizar. Utilizar para el clculo la funcin =Sumar.Si().

8.

9.

10. Luego de aplicar los formatos de celda que crea conveniente, guardar el libro actual con el nombre TP8+ApellidoAlumno.xlsx.