Está en la página 1de 12

CAMPUS CUITLAHUAC

PROF. JESUS CAYETANO REDES IV


Presentation_ID
2002, Cisco Systems, Inc. All rights reserved.

Configuracin de NAT y PAT


Traduccin esttica: entre una ip local interna y una global

router(config)# ip nat inside source static local-ip global-ip !!! para desactivar ...# no ip nat inside source static

Configuracion de una interfaz como interna y externa


Seleccionamos la interfaz router(config)# interface type-number !!!por ejemplo ...# interface fa0

Marcamos la interfaz como conectada al interior router(config-if)# ip nat inside Marcamos la interfaz como conectada al exterior router(config-if)# ip nat outside

ejemplo
router(config)# ip nat inside source static 10.1.1.2 192.168.1.2 !!! host interno 10.1.1.2, ext 192.168.1.2

!!! interface interna la fastethernet 0


router(config)# interface f0/0 router(config-if)# ip address 199.16.1.1 255.255.255.0

router(config-if)# ip nat inside router(config-if)# no shutdown router(config-if)# exit

!!! interface externa la serial 0 router(config)# interface serial0 router(config-if)# ip address 192.168.1.1 255.255.255.0 router(config-if)# ip nat outside router(config-if)# no shutdown

Traduccin dinmica: Usa las listas de acceso. La lista de acceso debe


permitir slo aquellas direcciones que se deben traducir Recordar que existe un "denegar todo" implcito al final de una lista de acceso Recomendacin de Cisco: Cisco no recomienda configurar listas de acceso con el comando permit any si los comandos NAT se refieren a esas listas. El uso de permit any puede hacer que NAT consuma demasiados recursos de los routers, lo que puede provocar problemas en la red. 1) Defina un conjunto de direcciones globales para asignarse segn sea necesario. Router(config)#ip nat pool name start-ip end-ip {netmask 2) Definir una lista de acceso estndar que permita las direcciones que se deban traducir. Router(config)# access-list access-list-number permit source [source-wildcard] 3) Establezca la traduccin dinmica de origen , especificando la lista de acceso Router(config)# ip nat inside source list access-list-number pool name

4)Especificar la interfaz interna Router(config)# interface type-number

5) Marcar la interfaz como conectada al interior


Router(config-if)# ip nat inside 6) Especificar la interfaz externa Router(config)# interface type-number Router(config-if)# ip nat outside

Definir el conjunto de direcciones IP pblicas utilizables router(config)#ip nat pool public-access 199.99.9.40 199.99.9.62 netmask 255.255.255.192 Definir una lista de acceso que coincida con las direcciones IP privadas internas router(config)#access-list 1 permit 10.10.10.0 0.0.0.255 Definir la traduccin NAT de la lista interna al conjunto externo router(config)#ip nat inside source list 1 pool public-access

PAT Sobrecarga: La sobrecarga se puede configurar de dos formas , segn las ips pblicas Si solo existe una ip pblica: Se crea la ACL o lista de acceso y se sobrecarga el interfaz con la ip pblica Router(config)# access-list access-list-number permit source [sourcewildcard] Router(config)# ip nat inside source list access-list-number interface typenumber overload router(config)# access-list 1 permit 10.0.0.0 0.0.255.255

router(config)# ip nat inside source list 1 interface serial 0/0 overload


Si existe ms de una ip pblica Se crea la ACL, se define el pool , y se sobrecarga el interfaz Router(config)# access-list access-list-number permit source [sourcewildcard] router(config)#ip nat pool name ipPrimera ipFinal {netmask netmask|prefixlength prefix-length} Router(config)# ip nat inside source list access-list-number pool number overload

internas

externa

Para definir el conjunto de direcciones pblicas router(config)#ip nat pool public-access 199.99.9.32 199.99.9.35 netmask 255.255.255.252 Definir una lista de acceso que coincida con las direcciones IP privadas internas router(config)#access-list 1 permit 10.10.10.0 0.0.0.255 Definir la traduccin NAT de la lista interna al conjunto externo router(config)#ip nat inside source list 1 pool public-access overload

Verificacin de la configuracin PAT. -Tras un periodo de inactividad , por defecto las traducciones de direcciones dinmicas se eliminan de la tabla de traduccin de NAT ( 24 horas ) -Si el puerto de traduccin no est configurado, las entradas de traduccin se borran despus de 24 horas -Configurar Temporizadores de NAT: router(config)# ip nat translation timeout nsegundos .

-Para borrar las entradas antes de que venza el temporizador: !!! borra todas las entradas
router# clear ip nat traslation * !!!elimina una entrada simple de traduccin dinmica router# clear ip nat traslation inside global-ip local-ip

-!!!Para ver las traducciones activas


router#show ip nat traslations !!!Para ver estadisticas router#show ip nat statics

-Otra alternativa, es utilizar el comando show run y buscar los comandos de NAT, de lista de acceso, de interfaz, o de conjunto con los valores requeridos.

Configuracin de DHCP
DHCP se habilita por defecto en las versiones de IOS que as lo admitan para desactivar el servicio: no service dhcp

para activar el servicio: service dhcp


!!!Crear un conjunto IP DHCP y le damos nombre router(config)# ip dhcp pool pool-name !!!definimos el rango de direcciones para alquilar router(dhcp-config)# network network-number [mask | / prefix-length] !!!En el modo de configuracion global podemos definir ips a excluir router(config)# ip dhcp excluded-address low-address [high-address] router(dhcp-config)# lease { days [hours] [minutes] infinite} !!! duracion alquiler , por defecto 1 dia

Ejemplo: router(config)# ip dhcp pool subnet12

router(dhcp-config)# network 172.16.12.0 255.255.255.0


router(dhcp-config)# default-router 172.16.12.254 router(dhcp-config)# dns-server 172.16.1.2 router(dhcp-config)# netbios-name-server 172.16.1.3 router(dhcp-config)# domain-name undominio.com

router(config)# ip dhcp excluded-address 172.16.1.1 172.16.1.10


router(config)# ip dhcp excluded-address 172.16.1.254

Verificacin de la operacin DHCP !!! Muestra lista de todos los enlaces que cre el servicio DHCP router# show ip dhcp binding

!!! Para verificar que el router recibe y envia los mensajes


router# show ip dhcp server statistics

!!! Para diagnosticar las fallas en el funcionamiento del servidor DHCP router# debug ip dhcp server events