Está en la página 1de 58

Anhanguera Educacional Faculdade de Sorocaba

ATPS: Construo de Algoritmos

Lucas Fernandes Frana - 4211666970 Lucas Maciel de Macedo - 4203790279

Prof Edna Dias Mateus

Sorocaba 2012

LUCAS FERNANDES FRANA LUCAS MACIEL DE MACEDO

Construo de Algoritmos

Trabalho acadmico apresentado ao Curso de Tecnologia em Anlise e Desenvolvimento de Sistemas para a obteno de nota para o 2 semestre.

Sorocaba 2012

Resumo

ATPS de Construo de Algoritmos, que constituem nos primeiros passos do uso de linguagem C.

Contedo
Relatrio do Sistema 01 .......................................................................................................................... 4 Primeiro Desafio: ................................................................................................................................ 4 1.1 Dados de Entrada: ..................................................................................................................... 4 1.2 Resultados Alcanados .............................................................................................................. 5 Relatrio do Sistema 02 .......................................................................................................................... 5 Conversor de Moedas: Apresentao em Pseudocdigo ..................................................................... 5 Converso das 10 moedas para as 10 moedas. ................................................................................ 5 Etapa 3................................................................................................................................................... 44 3.1 Novos dados a serem incorporados no algoritmo ................................................................ 44

3.2 Processamento necessrio para encontrar o valor mdio, o menor e o maior valor da cotao dentro de um ms: .............................................................................................................. 45 3.3 Pseudocdigo do algoritmo alterado .................................................................................... 46

Etapa 4................................................................................................................................................... 48 4.1 Pseudocdigo do algoritmo que foi alterado para atender o solicitado no Passo 2. ........... 48

Algoritmo cotao2 ....................................................................................................................... 48 4.2 Estudos desenvolvidos .......................................................................................................... 56

Relatrio do Sistema 01

O problema proposto nos pede para elaborar um algoritmo que resolva o problema de uma empresa. Ela precisa de um programa que faa a converso de moedas. De dlar para reais, de reais para dlar, euro e dlar americano. O primeiro passo identificar os dados de entrada do problema, os processamentos necessrios para encontrar o que pedido e os dados de sada. Usando essas informaes, deveremos elaborar o algoritmo em descrio narrativa, em pseudocdigo e em fluxograma. Primeiro Desafio:

1.1 Dados de Entrada: Moeda a qual possumos que o dlar. Moeda a qual desejamos fazer a converso, que o real. O clculo necessrio para a converso. Como o problema nos deu a cotao do dlar, sendo o real mais valorizado (R$ 1,00 US$1,94). Processamento: Considerar o Valor de Venda da Moeda; A moeda Real dever ser a referncia, ou seja, R$1,00 igual a xxx dlares;

Dados de Sada: Ser impresso na tela o valor calculado da moeda desejada.

Os processamentos se definem pela frmula de: a) Reais*2.03 = dlares b) Dlares/2.03 = reais c) Reais*2.61 = euros 4

d) Reais*1.95 =Dlares Canadenses. Os dados de sada do problema, sero conforme a escolha do usurio. Ou ser em dlar, ou euros, ou dlar canadense ou ento em reais.

1.2 Resultados Alcanados Com o usufruto de vrias alternativas de solues de problemas, foi possvel cria um arquivo executvel capaz de converter o real em algumas outras moedas. Com isso, foi alcanado o objetivo de gerar um executvel capaz de efetuar a converso do real para a moeda escolhida pelo cliente.

Relatrio do Sistema 02

Conversor de Moedas: Apresentao em Pseudocdigo Converso das 10 moedas para as 10 moedas.

Inicio; real: moeda_real, valor_dolar, dolar, valor_dolarcnd, dolar_cnd, valor_euro, euro, real_euro, real_dolar, real_dolarcnd valor_dolaraus, dolar_aus real_dolaraus, rand, valor_rand, real_rand, rupiaindiana valor_rupia, real_rupia, yuan, valor_yuan real_yuan, iene, valor_iene, real_iene, pesoarg, valor_pesoarg, real_pesoarg; inteiro: escolha1, escolha2; valor_dolar = 1.94; valor_dolarcnd = 1.80;

valor_euro = 2.16; ; valor_dolaraus = 2.22 valor_rand = 0.23; valor_rupia = 0.03; valor_yuan = 0.34; valor_iene = 0.02; valor_pesoarg = 0.44; real_euro = 2.16; real_dolar = 1.94; real_dolarcnd = 1.80; real_dolaraus = 2.22; real_rand = 0.22; real_rupia = 0.03; real_yuan = 0.34; real_iene = 0.02; real_pesoarg = 0.44;

Algoritmo Cotao Inicio; escreva ("***Programa que converte moedas***"); escreva ("Deseja Converter qual moeda ?");

escreva ("Pressione: 1 - Real, 2 - Dolar, 3 - Dolar Canadense, 4 Euro, 5 Dolar Australiano, 6 - Rand, 7 - Rupia Indiana, 8 Yuan, 9 Iene, 10 Peso Argentino"); leia(escolha1); se (escolha1==1)ento; escreva ("Voce escolheu converter Real!!"); escreva ("Deseja Converter a moeda Real para qual moeda ?"); escreva ("1 - Dolar, 2 - Dolar Canadense, 3 Euro, 4 Dolar Australiano, 5- Rand, 6 Rupia Indiana, 7 Yuan, 8- Iene, 9 Peso Argentino: "); leia (escolha2); se (escolha2==1) ento; escreva("Voce decidiu converter da moeda Real para Dolar !"); escreva("Insira o valor em Reais: "); leia(moeda_real); dolar = moeda_real * valor_dolar; escreva ("Esse valor em Reais equivalem a Dlares.",dolar); fim se; fim se; se (escolha2==2)ento; escreva("Voce decidiu converter da moeda Real para Dolar Canadense"); escreva("Insira o valor em Reais: "); leia(moeda_real); dolar_cnd = moeda_real * valor_dolarcnd;

escreva ("Esse valor em Reais equivalem a Dlares Canadense.",dolar_cnd);

fim se; se (escolha2==3)ento; escreva("Voce decidiu converter da moeda Real para Euro !"); escreva("Insira o valor em Reais: "); leia(moeda_real); euro = moeda_real * valor_euro; escreva ("Esse valor em Reais equivalem a Euros",euro);

fim se; se (escolha2==4)ento; escreva("Voce decidiu converter da moeda Real para Dolar Australiano!"); escreva("Insira o valor em Reais: "); leia(moeda_real); dolar_aus = moeda_real * valor_dolaraus; escreva ("Esse valor em Reais equivalem a Dlares Australianos", dolar_aus);

fim se; se (escolha2==5)ento; escreva("Voce decidiu converter da moeda Real para Rand !"); escreva("Insira o valor em Reais: "); 8

leia(moeda_real); rand = moeda_real /valor_rand; escreva ("Esse valor em Reais equivalem a Rand", rand);

fim se; se (escolha2==6)ento; escreva("Voce decidiu converter da moeda Real para Rupia Indiana !"); escreva("Insira o valor em Reais: "); leia(moeda_real); rupiaindiana = moeda_real / valor_rupia; escreva ("Esse valor em Reais equivalem a Rupias Indianas", rupia);

fim se; se (escolha2==7)ento; escreva("Voce decidiu converter da moeda Real para YUAN!"); escreva("Insira o valor em Reais: "); leia(moeda_real); yuan = moeda_real / valor_yuan; escreva ("Esse valor em Reais equivale a Yuan, yuan);

fim se; se (escolha2==8)ento; 9

escreva("Voce decidiu converter da moeda Real para Iene !"); escreva("Insira o valor em Reais: "); leia(moeda_real); iene = moeda_real /valor_iene; escreva ("Esse valor em Reais equivalem a Ienes",iene);

fim se; se (escolha2==9)ento; escreva("Voce decidiu converter da moeda Real para Peso Argentino !"); escreva("Insira o valor em Reais: "); leia(moeda_real); pesoarg = moeda_real / valor_pesoarg; escreva ("Esse valor em Reais equivalem a Pesos Argentinos", pesoarg);

fim se; fim se; seno se(escolha1==2) ento; escreva("Voc escolheu converter em Dolar !!!"); escreva("Deseja converter a moeda Dolar para qual moeda ?"); escreva("Pressione: 2 - Dolar Canadense, 3 - Euro, 4 Real, 5 Dolar Australiano, 6 Rand, 7 - Rupia Indiana, 8 Yuan, 9 Iene, 10 Peso Argentino"); leia(escolha2); 10

se (escolha2==1) ento escreva(Opo invalida! Escolha outra.); fim se; se (escolha2==2) ento; escreva("Voce decidiu converter da moeda Dolar para Dolar Canadense !"); escreva("Insira o valor em Dlares: "); leia(dolar); dolar_cnd = dolar / valor_dolarcnd; escreva("Esse valor em Dlares equivalem a Dlares Canadense.",dolar_cnd);

fim se; se (escolha2==3) ento; escreva("Voce decidiu converter da moeda Dolar para Euro"); escreva("Insira o valor em Dlares: "); leia(dolar); euro = dolar * valor_euro; escreva("Esse valor em Dlares equivalem a Euros.",euro);

fim

se;

se (escolha2==4) ento; 11

escreva("Voc decidiu converter da moeda Dolar para a moeda Real."); escreva("Insira o valor em Dlares: "); leia(dolar); moeda_real = dolar * real_dolar; escreva("Esse valor em Dlares equivalem a Reais.",moeda_real);

fim se; se (escolha2==5)ento; escreva("Voce decidiu converter da moeda Dolar para Dolar Australiano!"); escreva("Insira o valor em Dlares: "); leia(dolar); dolar_aus = dolar * valor_dolaraus; escreva ("Esse valor em Dlares equivalem a Dlares Australianos", dolar_aus);

fim se; se (escolha2==6)ento; escreva("Voce decidiu converter da moeda Dolar para Rand !"); escreva("Insira o valor em Dlares: "); leia(dolar); rand = dolar/valor_rand; escreva ("Esse valor em Dlares equivalem a Rand", rand);

12

fim se; se (escolha2==7)ento; escreva("Voce decidiu converter da moeda Dolar para Rupia Indiana !"); escreva("Insira o valor em Dlares: "); leia(dolar); rupiaindiana = dolar /valor_rupia; escreva ("Esse valor em Dlares equivalem a Rupias Indianas", rupia);

fim se; se (escolha2==8)ento; escreva("Voce decidiu converter da moeda Dolar para YUAN!"); escreva("Insira o valor em Dlares: "); leia(dolar); yuan = dolar /valor_yuan; escreva ("Esse valor em Dlares equivale a Yuan, yuan);

fim se; se (escolha2==9)ento; escreva("Voce decidiu converter da moeda Dlar para Iene !"); escreva("Insira o valor em Dlares: "); leia(dolar); iene = dolar /valor_iene; 13

escreva ("Esse valor em Dlares equivalem a Ienes",iene);

fim se; se (escolha2==10)ento; escreva("Voce decidiu converter da moeda Dlar para Peso Argentino !"); escreva("Insira o valor em Dlares: "); leia(dolar); pesoarg = dolar /valor_pesoarg; escreva ("Esse valor em Dlares equivalem a Pesos Argentinos", pesoarg);

fim se;

fim se; seno se (escolha1==3) ento; escreva("Voce escolheu converter Dolar Canadense!!!"); escreva("Deseja Converter a moeda Dolar Canadense para qual moeda ?"); escreva("Pressione: 1 - Dolar, 3 Euro, 4 Real, 5 Dolar Australiano, 6 - Rand, 7 Rupia Indiana, 8 Yuan, 9 Iene, 10 Peso Argentino"); leia(escolha2); se(escolha2==1) ento;

escreva("Voce decidiu converter da moeda Dolar Canadense para a moeda Dolar"); 14

escreva("Insira o valor em Dlares Canadenses: "); leia(dolar_cnd); dolar = dolar_cnd/ valor_dolar; escreva("Esse valor em Dlares Canadenses equivalem a em Dlares.",dolar);

fim

se;

se(escolha2==3) ento;

escreva("Voce decidiu converter da moeda Dolar Canadense para a moeda Euro"); escreva("Insira o valor em Dlares Canadenses: "); leia(dolar_cnd); euro= dolar_cnd * valor_euro; escreva("Esse valor em Dlares Canadenses equivalem a Euros.",euro);

fim se; se(escolha2==4) ento;

escreva("Voce decidiu converter da moeda Dolar Canadense para a moeda Real."); escreva("Insira o valor em Dlares Canadenses: "); leia(dolar_cnd); moeda_real = dolar_cnd * real_dolarcnd;

15

escreva("Esse valor em Dolar Canadenses equivalem a em Reais.",moeda_real);

fim se; se (escolha2==5)ento; escreva("Voce Australiano!"); escreva("Insira o valor em Dlares Canadenses: "); leia(dolar_cnd); dolar_aus = dolar_cnd* valor_dolaraus; escreva ("Esse valor em Dlares Canadenses equivalem a Dlares Australianos", dolar_aus); decidiu converter da moeda Dolar Canadense para Dolar

fim se; se (escolha2==6)ento; escreva("Voce decidiu converter da moeda Dolar Canadense para Rand !"); escreva("Insira o valor em Dlares Canadenses: "); leia(dolar_cnd); rand = dolar_cnd/ valor_rand; escreva ("Esse valor em Dlares Canadenses equivalem a Rand", rand);

fim se; se (escolha2==7)ento;

16

escreva("Voce decidiu converter da moeda Dlares Canadenses para Rupia Indiana !"); escreva("Insira o valor em Dlares Canadenses: "); leia(dolar_cnd); rupiaindiana = dolar_cnd/valor_rupia; escreva ("Esse valor em Dlares Canadenses equivalem a Rupias Indianas", rupia);

fim se; se (escolha2==8)ento; escreva("Voce decidiu converter da moeda Dolar Canadense para YUAN!"); escreva("Insira o valor em Dlares Canadense: "); leia(dolar_cnd); yuan = dolar_cnd/valor_yuan; escreva ("Esse valor em Dlares Canadenses equivale a Yuan, yuan); fim se;

se (escolha2==9)ento; escreva("Voce decidiu converter da moeda Dolar Canadense para Iene !"); escreva("Insira o valor em Dlares Canadenses: "); leia(dolar_cnd); iene =dolar_cnd/ valor_iene; escreva ("Esse valor em Dlares Canadenses equivalem a Ienes",iene);

17

fim se; se (escolha2==10)ento; escreva("Voce decidiu converter da moeda Dolar Canadense para Peso Argentino !"); escreva("Insira o valor em Dlares Canadenses: "); leia(dolar_cnd); pesoarg = dolar_cnd/valor_pesoarg; escreva ("Esse valor em Dlares Canadenses equivalem a Pesos Argentinos", pesoarg);

fim se; fim se; seno se (escolha1==4) ento; escreva("Voce escolheu converter Euro !!!"); escreva("Deseja Converter a moeda Euro para qual moeda ?"); escreva("Pressione: 1 - Dolar, 2 - Dolar Canadense, 4 Real, 5 Dolar Australiano, 6 - Rand, 7 - Rupia Indiana, 8 Yuan, 9 Iene, 10 Peso Argentino"); leia(escolha2);

se(escolha2==1) ento;

escreva("Voce decidiu converter da moeda Euro para a moeda Dolar");

18

escreva("Insira o valor em Euro: "); leia(euro); dolar = euro / valor_dolar; escreva("Esse valor em Euros equivalem a em Dlares.",dolar);

fim

se;

se(escolha2==2) ento;

escreva("Voce decidiu converter da moeda Euro para a moeda Dolar Canadense"); escreva("Insira o valor em Euro: "); leia(euro); dolar_cnd = euro / valor_dolarcnd; escreva("Esse valor em Euros equivalem a em Dlares Canadense.",dolar_cnd);

fim se; se(escolha2==4) ento;

escreva("Voce decidiu converter da moeda Euro para a moeda Real."); escreva("Insira o valor em Euro: "); leia(euro); moeda_real = euro * real_euro;

19

escreva("Esse valor em Euros equivalem a em Reais.",moeda_real);

fim se; se (escolha2==5)ento; escreva("Voce decidiu converter da moeda Euro para Dolar Australiano!"); escreva("Insira o valor em Euros: "); leia(euro); dolar_aus = euro * valor_dolaraus; escreva ("Esse valor em Euros equivalem a Dlares Australianos", dolar_aus);

fim se; se (escolha2==6)ento; escreva("Voce decidiu converter da moeda Euro para Rand !"); escreva("Insira o valor em Euros: "); leia(euro); rand = euro/valor_rand; escreva ("Esse valor em Euros equivalem a Rand", rand);

fim se; se (escolha2==7)ento; escreva("Voce decidiu converter da moeda Euro para Rupia Indiana !"); escreva("Insira o valor em Euros: "); 20

leia(euro); rupiaindiana = euro / valor_rupia; escreva ("Esse valor em Euros equivalem a Rupias Indianas", rupia);

fim se; se (escolha2==8)ento; escreva("Voce decidiu converter da moeda Euro para YUAN!"); escreva("Insira o valor em Euros: "); leia(euro); yuan = euro / valor_yuan; escreva ("Esse valor em Euros equivale a Yuan, yuan);

fim se; se (escolha2==9)ento; escreva("Voce decidiu converter da moeda euro para Iene !"); escreva("Insira o valor em Euros: "); leia(euro); iene = euro/ valor_iene; escreva ("Esse valor em Euros equivalem a Ienes",iene);

fim se; se (escolha2==10)ento; 21

escreva("Voce decidiu converter da moeda Euro para Peso Argentino !"); escreva("Insira o valor em Euros: "); leia(euro); pesoarg = euro /valor_pesoarg; escreva ("Esse valor em Euros equivalem a Pesos Argentinos", pesoarg);

fim se; fim se; seno se (escolha1==5) ento; escreva("Voce escolheu converter Dlar Australiano!!!"); escreva("Deseja Converter a moeda Dolar Australiano para qual moeda ?"); escreva("Pressione: 1 - Dolar, 2 - Dolar Canadense, 4 Real, 6 - Rand, 7 - Rupia Indiana, 8 Yuan, 9 Iene, 10 Peso Argentino"); leia(escolha2);

se(escolha2==1) ento;

escreva("Voce decidiu converter da moeda Dlar Australiano para a moeda Dolar"); escreva("Insira o valor em Dlares Australianos: "); leia(dolar_aus); dolar = dolar_aus / valor_dolar; escreva("Esse valor em Dlares Australianos equivalem a em Dlares.",dolar); 22

fim

se;

se(escolha2==2) ento;

escreva("Voce decidiu converter da moeda Dolar Australiano para a moeda Dolar Canadense"); escreva("Insira o valor em Dlares Australianos: "); leia(dolar_aus); dolar_cnd = dolar_aus / valor_dolarcnd; escreva("Esse valor em Euros equivalem a em Dlares Canadense.",dolar_cnd);

fim se; se(escolha2==3) ento;

escreva("Voce decidiu converter da moeda Dolar Australiano para a moeda Euro."); escreva("Insira o valor em Dlares Australianos: "); leia(dolar_aus); euro = dolar_aus / valor_euro; escreva("Esse valor em Dlares Australianos equivalem a em Euros.",euro);

se(escolha2==4)

ento;

23

escreva("Voce decidiu converter da moeda Dolar Australiano para a moeda Real."); escreva("Insira o valor em Dlares Australianos: "); leia(dolar_aus); moeda_real = dolar_aus * real_dolaraus; escreva("Esse valor em Dlares Australianos equivalem a em Reais.",moeda_real);

fim se; se (escolha2==6)ento; escreva("Voce decidiu converter da moeda Dolar Australianos para Rand !"); escreva("Insira o valor em Dlares Australianos: "); leia(dolar_aus); rand = dolar_aus/ valor_rand; escreva ("Esse valor em Dlares Australianos equivalem a Rand", rand);

fim se; se (escolha2==7)ento; escreva("Voce decidiu converter da moeda Dolar Australiano para Rupia Indiana !"); escreva("Insira o valor em Dlares Australianos "); leia(dolar_aus); rupiaindiana = dolar_aus/ valor_rupia; escreva ("Esse valor em Dlares Australianos equivalem a Rupias Indianas", rupiaindiana); 24

fim se; se (escolha2==8)ento; escreva("Voce decidiu converter da moeda Dlares Australianos para YUAN!"); escreva("Insira o valor em Dlares Australianos: "); leia(dolar_aus); yuan = dolar_aus/ valor_yuan; escreva ("Esse valor em Dlares Australianos equivale a Yuan, yuan);

fim se; se (escolha2==9)ento; escreva("Voce decidiu converter da moeda Dolar Australianos para Iene !"); escreva("Insira o valor em Dlares Australianos: "); leia(dolar_aus); iene = dolar_aus/ valor_iene; escreva ("Esse valor em Dlares Australianos equivalem a Ienes",iene);

fim se; se (escolha2==10)ento; escreva("Voce decidiu converter da moeda Dolar Australiano para Peso Argentino !"); escreva("Insira o valor em Dlares Australianos: "); leia(dolar_aus); 25

pesoarg = dolar_aus/ valor_pesoarg; escreva ("Esse valor em Dlares Australianos equivalem a Pesos Argentinos", pesoarg);

fim se; fim seno se; seno se (escolha1==6) ento; escreva("Voce escolheu converter Rand!!!"); escreva("Deseja Converter a moeda Rand para qual moeda ?"); escreva("Pressione: 1 - Dolar, 2 - Dolar Canadense, 4 Real, 7 - Rupia Indiana, 8 Yuan, 9 Iene, 10 Peso Argentino"); leia(escolha2);

se(escolha2==1) ento;

escreva("Voce decidiu converter da moeda Rand para a moeda Dolar"); escreva("Insira o valor em Rand: "); leia(rand); dolar = rand* valor_dolar; escreva("Esse valor em Rand equivalem a em Dlares.",dolar);

fim

se;

26

se(escolha2==2) ento;

escreva("Voce decidiu converter da moeda Rand para a moeda Dolar Canadense"); escreva("Insira o valor em Rand: "); leia(rand); dolar_cnd = rand *valor_dolarcnd; escreva("Esse valor em rand equivalem a em Dlares Canadense.",dolar_cnd);

fim se; se(escolha2==4) ento;

escreva("Voce decidiu converter da moeda Rand para a moeda Real."); escreva("Insira o valor em Rand: "); leia(rand); moeda_real = rand * real_rand; escreva("Esse valor em Rand equivalem a em Reais.",moeda_real);

fim se; se(escolha2==5) ento;

escreva("Voce decidiu converter da moeda Rand para a moeda Dolar Australiano."); escreva("Insira o valor em Rand: ");

27

leia(rand); dolar_aus = rand * valor_dolaraus; escreva("Esse valor em Rand equivalem a em Dlares Australianos.",dolar_aus);

fim se;

se (escolha2==7)ento; escreva("Voce decidiu converter da moeda Rand para Rupia Indiana !"); escreva("Insira o valor em Rand: "); leia(rand); rupiaindiana = rand / valor_rupia; escreva ("Esse valor em Rand equivalem a Rupias Indianas", rupiaindiana);

fim se; se (escolha2==8)ento; escreva("Voce decidiu converter da moeda Rand para YUAN!"); escreva("Insira o valor em Rand: "); leia(rand); yuan = rand/ valor_yuan; escreva ("Esse valor em Rand equivale a Yuan, yuan);

fim se; 28

se (escolha2==9)ento; escreva("Voce decidiu converter da moeda RAND para Iene !"); escreva("Insira o valor em Rand: "); leia(rand); iene = rand/ valor_iene; escreva ("Esse valor em Rand equivalem a Ienes",iene);

fim se; se (escolha2==10)ento; escreva("Voce decidiu converter da moeda Rand para Peso Argentino !"); escreva("Insira o valor em Rand: "); leia(rand); pesoarg = rand* valor_pesoarg; escreva ("Esse valor em Rand equivalem a Pesos Argentinos", pesoarg);

fim se; fim seno se; seno se (escolha1==7) ento; escreva("Voce escolheu converter Rupia Indiana!!!"); escreva("Deseja Converter a moeda Rupia Indiana para qual moeda ?"); escreva("Pressione: 1 - Dolar, 2 - Dolar Canadense, 3- Euro 4 Real, 5 Dolar Australiano 6 - Rand , 8 Yuan, 9 Iene, 10 Peso Argentino"); 29

leia(escolha2);

se(escolha2==1) ento;

escreva("Voce decidiu converter da moeda Rupia para a moeda Dolar"); escreva("Insira o valor em Rupia: "); leia(rupiaindiana); dolar = rupiaindiana * valor_dolar; escreva("Esse valor em Rupia equivalem a em Dlares.",dolar);

fim

se;

se(escolha2==2) ento;

escreva("Voce decidiu converter da moeda Rupia para a moeda Dolar Canadense"); escreva("Insira o valor em Rupia: "); leia(rupiaindiana); dolar_cnd = rupiaindiana* valor_dolarcnd; escreva("Esse valor em Rupia equivalem a em Dlares Canadense.",dolar_cnd);

fim se;

30

se(escolha2==4)

ento;

escreva("Voce decidiu converter da moeda Rupia para a moeda Real."); escreva("Insira o valor em Rupia: "); leia(rupiaindiana); moeda_real = rupiaindiana * real_rupia; escreva("Esse valor em Rupia equivalem a em Reais.",moeda_real);

fim se; se (escolha2==5)ento; escreva("Voce decidiu converter da moeda Rupia para Dlar Australiano !"); escreva("Insira o valor em Rupia: "); leia(rupiaindiana); dolar_aus= rupiaindiana* valor_dolaraus; escreva ("Esse valor em Rupia equivalem a Dlares Australianos", dolar_aus);

se (escolha2==6)ento; escreva("Voce decidiu converter da moeda Rupia para Rand !"); escreva("Insira o valor em Rupia: "); leia(rupiaindiana); rand = rupiaindiana* valor_rand; escreva ("Esse valor em Rupia equivalem a Rand", rand); 31

fim se; se (escolha2==8)ento; escreva("Voce decidiu converter da moeda Rupia para YUAN!"); escreva("Insira o valor em Rupia: "); leia(rupiaindiana); yuan = rupiaindiana* valor_yuan; escreva ("Esse valor em Rupia equivale a Yuan, yuan);

fim se; se (escolha2==9)ento; escreva("Voce decidiu converter da moeda Rupia para Iene !"); escreva("Insira o valor em Rupia: "); leia(rupiaindiana); iene = rupiaindiana /valor_iene; escreva ("Esse valor em Rupia equivalem a Ienes",iene);

fim se; se (escolha2==10)ento; escreva("Voce decidiu converter da moeda Rupia para Peso Argentino !"); escreva("Insira o valor em Rupia: "); leia(rupiaindiana); 32

pesoarg = rupiaindiana* valor_pesoarg; escreva ("Esse valor em Rupiaindiana equivalem a Pesos Argentinos", pesoarg);

fim se; fim seno se; seno se (escolha1==8) ento; escreva("Voce escolheu converter Yuan!!!"); escreva("Deseja Converter a moeda Yuan para qual moeda ?"); escreva("Pressione: 1 - Dolar, 2 - Dolar Canadense, 3- Euro 4 Real, 5 Dolar Australiano 6 - Rand , 7 - Rupia, 9 Iene, 10 Peso Argentino"); leia(escolha2);

se(escolha2==1) ento;

escreva("Voce decidiu converter da moeda Yuan para a moeda Dolar"); escreva("Insira o valor em Yuan: "); leia(yuan); dolar =yuan * valor_dolar; escreva("Esse valor em Yuan equivalem a em Dlares.",dolar);

fim

se;

33

se(escolha2==2) ento;

escreva("Voce decidiu converter da moeda Yuan para a moeda Dolar Canadense"); escreva("Insira o valor em Yuan: "); leia(yuan); dolar_cnd = yuan* valor_dolarcnd; escreva("Esse valor em Yuan equivalem a em Dlares Canadense.",dolar_cnd);

fim se; se(escolha2==4) ento;

escreva("Voce decidiu converter da moeda yuan para a moeda Real."); escreva("Insira o valor em yuan "); leia(yuan); moeda_real = yuan * real_yuan; escreva("Esse valor em Yuan equivalem a em Reais.",moeda_real);

fim se; se (escolha2==5)ento; escreva("Voce decidiu converter da moeda Yuan para Dlar Australiano !"); escreva("Insira o valor em Yuan: "); leia(yuan); 34

dolar_aus= yuan* valor_dolaraus; escreva ("Esse valor em Yuan equivalem a Dlares Australianos", dolar_aus);

se (escolha2==6)ento; escreva("Voce decidiu converter da moeda Yuan para Rand !"); escreva("Insira o valor em Yuan: "); leia(yuan); rand = yuan/ valor_rand; escreva ("Esse valor em Yuan equivalem a Rand", rand);

fim se; se (escolha2==7)ento; escreva("Voce decidiu converter da moeda Yuan para Rupia!"); escreva("Insira o valor em Yuan: "); leia(yuan); rupiaindiana = yuan/ valor_rupia; escreva ("Esse valor em Yuan equivale a Rupia, rupiaindiana);

fim se;

se (escolha2==9)ento; 35

escreva("Voce decidiu converter da moeda Yuan para Iene !"); escreva("Insira o valor em Yuan: "); leia(yuan); iene = Yuan /valor_iene; escreva ("Esse valor em Yuan equivalem a Ienes",iene);

fim se; se (escolha2==10)ento; escreva("Voce decidiu converter da moeda Yuan para Peso Argentino !"); escreva("Insira o valor em Yuan: "); leia(yuan); pesoarg =yuan* valor_pesoarg; escreva ("Esse valor em Yuan equivalem a Pesos Argentinos", pesoarg);

fim se; fim seno se; seno se (escolha1==9) ento; escreva("Voce escolheu converter Iene!!!"); escreva("Deseja Converter a moeda Iene para qual moeda ?"); escreva("Pressione: 1 - Dolar, 2 - Dolar Canadense, 3- Euro 4 Real, 5 Dolar Australiano 6 - Rand , 7 - Rupia, 8- Yuan, 10 Peso Argentino"); leia(escolha2); 36

se(escolha2==1) ento;

escreva("Voce decidiu converter da moeda Iene para a moeda Dolar"); escreva("Insira o valor em Ienes: "); leia(iene); dolar =iene* valor_dolar; escreva("Esse valor em Ienes equivalem a em Dlares.",dolar);

fim

se;

se(escolha2==2) ento;

escreva("Voce decidiu converter da moeda Iene para a moeda Dolar Canadense"); escreva("Insira o valor em Ienes: "); leia(iene); dolar_cnd = iene* valor_dolarcnd; escreva("Esse valor em Iene equivalem a em Dlares Canadense.",dolar_cnd);

fim se; se(escolha2==4) ento;

37

escreva("Voce decidiu converter da moeda Iene para a moeda Real."); escreva("Insira o valor em Ienes "); leia(iene); moeda_real = iene * real_iene; escreva("Esse valor em Ienes equivalem a em Reais.",moeda_real);

fim se; se (escolha2==5)ento; escreva("Voce decidiu converter da moeda Ienes para Dlar Australiano !"); escreva("Insira o valor em Ienes: "); leia(iene); dolar_aus= iene* valor_dolaraus; escreva ("Esse valor em Ienes equivalem a Dlares Australianos", dolar_aus); fim se; se (escolha2==6)ento; escreva("Voce decidiu converter da moeda Iene para Rand !"); escreva("Insira o valor em Ienes: "); leia(iene); rand = iene* valor_rand; escreva ("Esse valor em Ienes equivalem a Rand", rand);

fim se; 38

se (escolha2==7)ento; escreva("Voce decidiu converter da moeda Iene para Rupia!"); escreva("Insira o valor em Ienes: "); leia(iene); rupiaindiana =iene* valor_rupia; escreva ("Esse valor em Ienes equivale a Rupia, rupiaindiana);

fim se; se (escolha2==8)ento; escreva("Voce decidiu converter da moeda Iene para Yuan!"); escreva("Insira o valor em Ienes: "); leia(iene); yuan =iene* valor_yuan; escreva ("Esse valor em Ienes equivale a Yuan, yuan);

fim se;

se (escolha2==10)ento; escreva("Voce decidiu converter da moeda Iene para Peso Argentino !"); escreva("Insira o valor em Ienes: "); 39

leia(iene); pesoarg =iene* valor_pesoarg; escreva ("Esse valor em Ienes equivalem a Pesos Argentinos", pesoarg);

fim se; fim seno se; seno se (escolha1==10) ento; escreva("Voce escolheu converter Peso Argentino!!!"); escreva("Deseja Converter a moeda Peso Argentino para qual moeda ?"); escreva("Pressione: 1 - Dolar, 2 - Dolar Canadense, 3- Euro 4 Real, 5 Dolar Australiano 6 - Rand , 7 - Rupia, 8- Yuan, 9 - Iene"); leia(escolha2);

se(escolha2==1) ento;

escreva("Voce decidiu converter da moeda Peso para a moeda Dolar"); escreva("Insira o valor em Pesos: "); leia(pesoarg); dolar =pesoarg* valor_dolar; escreva("Esse valor em Pesos Argentinos equivalem a em Dlares.",dolar);

40

fim

se;

se(escolha2==2) ento;

escreva("Voce decidiu converter da moeda Peso para a moeda Dolar Canadense"); escreva("Insira o valor em Pesos: "); leia(pesoarg); dolar_cnd = pesoarg*valor_dolarcnd; escreva("Esse valor em Pesos Argentinos equivalem a em Dlares

Canadense.",dolar_cnd);

fim se; se(escolha2==4) ento;

escreva("Voce decidiu converter da moeda Peso para a moeda Real."); escreva("Insira o valor em Pesos: "); leia(pesoarg); moeda_real = pesoarg * real_iene; escreva("Esse valor em Pesos Argentinos equivalem a em Reais.",moeda_real);

fim se; se (escolha2==5)ento; escreva("Voce decidiu converter da moeda Peso para Dlar Australiano !"); 41

escreva("Insira o valor em Pesos: "); leia(pesoarg); dolar_aus= pesoarg* valor_dolaraus; escreva ("Esse valor em Pesos Argentinos equivalem a Dlares Australianos", dolar_aus); fim se; se (escolha2==6)ento; escreva("Voce decidiu converter da moeda Peso para Rand !"); escreva("Insira o valor em Pesos: "); leia(pesoarg); rand = pesoarg/ valor_rand; escreva ("Esse valor em Pesos Argentinos equivalem a Rand", rand);

fim se; se (escolha2==7)ento; escreva("Voce decidiu converter da moeda Peso para Rupia!"); escreva("Insira o valor em Pesos: "); leia(pesoarg); rupiaindiana =pesoarg/valor_rupia; escreva ("Esse valor em Pesos Argentinos equivale a Rupia, rupiaindiana);

fim se; 42

se (escolha2==8)ento; escreva("Voce decidiu converter da moeda Peso para Yuan!"); escreva("Insira o valor em Pesos: "); leia(pesoarg); yuan =pesoarg* valor_yuan; escreva ("Esse valor em Pesos Argentinos equivale a Yuan, yuan);

fim se;

se (escolha2==9)ento; escreva("Voce decidiu converter da moeda Peso para Iene !"); escreva("Insira o valor em Pesos: "); leia(pesoarg); iene =pesoarg/valor_iene; escreva ("Esse valor em Pesos Argentinos equivalem a Ienes", iene);

fim se; fim seno se; Fim_Algoritmo;

43

Com o usufruto de vrias alternativas de solues de problemas, foi possvel criar um arquivo executvel capaz de converter o real em algumas outras moedas. Com isso, foi alcanado o objetivo de gerar um executvel capaz de efetuar a converso do real para a moeda escolhida pelo cliente. Usando os pseudocdigos iniciais, foram alterados praticamente 70% dos comandos, pois, a princpio, no era previsto a incluso de comandos / necessidades anormais. Portanto, inclumos variadas linhas de cdigos com o intuito de aprimorar o desempenho do sistema. Para facilitar a interao entre sistema e cliente, foram includas conversas didticas e dinmicas com os usurios. Tivemos uma intemprie perante a necessidade da incluso do percentual da variao entre os variados dlares onde, foi solucionado com uma boa leitura no PLT e, includo alguns comandos novos para resoluo de tal problema.

Etapa 3

3.1
Inicio;

Novos dados a serem incorporados no algoritmo

Tipo mat;matriz [1...10][1...30] de numrico;

Para i de 1 ate 10 faa Para j de 1 ate 30 faa Leia(mat1[ i , j ]); Fim para; Fim para;

44

Fim;

3.2 Processamento necessrio para encontrar o valor mdio, o menor e o maior valor da cotao dentro de um ms:
Inicio;

Soma 0; Para i de 1 ate 10 faa Para j de 1 ate 30 passo faa Leia (mat1[ i , j ]); Vet1 mat1 [ i , j ]; Soma soma + vet1; Fim para; Fim para;

Media soma/30; X vet1[1]; Para j de 1 ate 30 passo faa Se vet1 [ j ] > x X vet1[ j ]; Fim se; Fim para; Fim para;

Y mat1[1,1]; Para j de 1 ate 30 passo faa 45

Se vet1[ j ] < x Y vet1 [ j ]; Fim se Fim para Fim para; Fim;

3.3

Pseudocdigo do algoritmo alterado

Algoritmo Cotao Inicio; Tipo mat = matriz [1..10][1..30] de numrico; Tipo vet = vetor [1..30] de numrico;

Declare Mat1 : mat; Soma,media,i,j,x,y,: numrico; Vet1: vet;

Para i de 1 ate 10 faa Para j de 1 ate 30 faa Leia(mat1[ i , j ]); Fim para Fim para

Soma 0; 46

Para i de 1 ate 10 faa Para j de 1 ate 30 passo faa Leia (mat1[ i , j ]); Vet1 mat1 [ i , j ]; Soma soma + vet1; Fim para Fim para

Media soma/30;

X vet1[1]; Para j de 1 ate 30 passo faa Se vet1 [ j ] > x X vet1[ j ]; Fim se; Fim para; Fim para

Y mat1[1,1]; Para j de 1 ate 30 passo faa Se vet1[ j ] < x Y vet1 [ j ]; Fim se; Fim para; Fim para

47

Escreva (A media do mensal :,media); Escreva (A menor cotao do ms :, y); Escreva (A maior cotao do ms :,x);

Fim_algoritmo

Etapa 4
4.1 Pseudocdigo do algoritmo que foi alterado para atender o solicitado no Passo 2.
Algoritmo cotao2

Tipo mat = matriz [1..10][1..30] de numrico;

Declare Mat1 : mat; X1,X2,X3,X4: Numrico; media1, media2, media3, media4: Numrico; soma1, soma2, soma3, soma4: Numrico; I , j , op: Numrico;

Escreva ( escolha o perodo do ms para analise da media, maior e menos cotao );

Escreva ( 1 ao 10 dia ); Escreva ( 11 ao 20 dia ); Escreva ( 21 ao 30 dia ); 48

Escreva ( ms completo ); Escreva ( opo ); Leia (op)

Escolha (op)

Caso 1: Para I de 1 ate 10 Para J de 1 ate 10 soma1 soma1 + mat1[ I , J] fim para fim para Media1 soma1 / 10 Escreva ( 1 ao 10 dia = soma1); X1 mat1[1,1]; Para I de 1 ate 10 Para j de 1 ate 10 passo faa Se mat1 [ i , j ] < X1 X1 mat1[ i , j ]; fim se fim para fim para escreva ( Menor cotao = X1); Y1 mat1[1,1]; Para I de 1 ate 10 Para j de 1 ate 10 passo faa 49

Se mat1 [ i , j ] > Y1 Y1 mat1[ i , j ]; fim se fim para fim para escreva ( Maior cotao = Y1);

Caso 2: Para I de 1 ate 10 Para J de 11 ate 20 soma2 soma2 + mat1[ I , J] fim para fim para Media2 soma2 / 10 Escreva ( 11 ao 20 dia = soma2); X2 mat1[1,1]; Para I de 1 ate 10 Para j de 11 ate 20 passo faa Se mat1 [ i , j ] < X2 X2 mat1[ i , j ]; fim se fim para fim para escreva ( Menor cotao = X2); Y2 mat1[1,1]; Para I de 1 ate 10 50

Para j de 11 ate 20 passo faa Se mat1 [ i , j ] > Y2 Y2 mat1[ i , j ]; fim se fim para fim para escreva ( Maior cotao = Y2);

Caso 3: Para I de 1 ate 10 Para J de 21 ate 30 soma3 soma3 + mat1[ I , J] fim para fim para Media3 soma3 / 10 Escreva ( 21 ao 30 dia = soma3); X3 mat1[1,1]; Para I de 1 ate 10 Para j de 21 ate 30 passo faa Se mat1 [ i , j ] < X3 X3 mat1[ i , j ]; fim se fim para fim para escreva ( Menor cotao = X3); Y3 mat1[1,1]; 51

Para I de 1 ate 10 Para j de 21 ate 30 passo faa Se mat1 [ i , j ] > Y3 Y3 mat1[ i , j ]; fim se fim para fim para escreva ( Maior cotao = Y3);

Caso 4: Para I de 1 ate 10; Para J de 1 ate 30; soma4 soma4 + mat1[ I , J] fim para; fim para; Media4 soma4 / 10; Escreva ( Media Total = soma4); X4 mat1[1,1]; Para I de 1 ate 10; Para j de 1 ate 30 passo faa; Se mat1 [ i , j ] < X4 ento X4 mat1[ i , j ]; Fim se; Fim para; Fim para; 52

escreva ( Menor cotao = X4); Y4 mat1[1,1]; Para I de 1 ate 10 Para j de 1 ate 30 passo faa Se mat1 [ i , j ] > Y4; Y4 mat1[ i , j ]; Fim se; Fim para; Fim para; escreva ( Maior cotao = Y4);

Fim escolha;

Para I de 1 ate 10; Para J de 1 ate 10; soma1 soma1 + mat1[ I , J]; fim para; Para J de 11 ate 20; soma2 soma2 + mat1[ I , J]; fim para; Para J de 21 ate 30; soma3 soma3 + mat1[ I , J]; fim para; fim para ;

Media1 soma1 / 10; 53

Media2 soma2 / 10; Media3 soma3 / 10;

Para I de 1 ate 10; Para J de 1 ate 10; soma1 soma1 + mat1[ I , J]; fim para; Para J de 11 ate 20; soma2 soma2 + mat1[ I , J]; fim para; Para J de 21 ate 30; soma3 soma3 + mat1[ I , J]; fim para; fim para ;

Maior

X1 mat1[1,1]; Para I de 1 ate 10 Para j de 1 ate 10 passo faa Se mat1 [ i , j ] > x X1 mat1[ i , j ]; fim se fim para Para J de 11 ate 20 Se mat1 [ i , j ] > x 54

X2 mat1[ i , j ]; Fim se; Fim para; Para J de 21 ate 30; Se mat1 [ i , j ] > x; X3 mat1[ i , j ]; Fim se; Fim para; Fim para;

Menor

X1 mat1[1,1]; Para I de 1 ate 10; Para j de 1 ate 10 passo faa; Se mat1 [ i , j ] < x; X1 mat1[ i , j ]; Fim se; Fim para; Para J de 11 ate 20; Se mat1 [ i , j ] < x; X2 mat1[ i , j ]; Fim se; Fim para; Para J de 21 ate 30; 55

Se mat1 [ i , j ] < x; X3 mat1[ i , j ]; Fim se; Fim para; Fim para;;

4.2

Estudos desenvolvidos

No passo 1 incorporamos novos dados no algoritmo, como matrizes, interaes e novos dados para calcular a mdia, menor e maior valor da cotao. No passo 2 adicionamos os novos cdigos para calcular o perodo de 10 dias de cotao do ms, que o usurio pode escolher para calcular a mdia, menor e maior cotao ou escolher a opo 4 para calcular a cotao do ms inteiro.

56

Bibliografia PLT Lgica de Programao: Andr Luiz Villar Forbellone; Henri Frederico Eberspcher; 3 Edio. 57