Está en la página 1de 4

PRIMERA PRACTICA DE EXCEL AVANZADO

1ra Parte: Creacin del cuadro Movimientos de Almacn 1. Se va ha confeccionar el siguiente Cuadro de Movimientos de una Almacn de Vehculos, para lo cual siga los pasos que se indican mas adelante.

2.

En una hoja de calculo de Excel escriba solo los ttulos del cuadro Movimiento de Almacn y confeccione el cuadro de Tabla de Saldos Finales, tal como se muestra a continuacin:

3.

De nombre a los siguientes rangos de celda: LISTA TIPOS SALIDAS A3: E50 B4:B50 E4:E50 TABLA G3: L7 INGRESOS D4:D50

4. 5.

seleccione el rango A4: A5 y con el men Datos Validacin, permitir que solo se ingresen datos segn la lista ubicada en el rango G4: G7. En la celda B4 escriba la siguiente formula: =SI(ESBLANCO(A4),,BUSCARV(A4, tabla, 2,0))

y luego copiarla hasta el rango B5: B50. 6. 7. Seleccione el rango D4:E50 y valide el ingreso de datos para que solo permita ingresar cantidades enteras menores o iguales que 50. Llene los datos de las filas 4 a la fila 8.

2da Parte: Creacin de la Tabla de Saldos Finales y Grfico de Movimientos por Vehculo 8. Abrir el archivo : PRACTICA1 y Escriba las formulas en las siguientes Celdas: En I4 =BDMAX (LISTA, 3, G9: G10) En I5 = BDMAX (LISTA, 3, H9: H10) En I6 = BDMAX (LISTA, 3, I9:I10) En I7 = BDMAX (LISTA, 3, J9: J10) En J4 = SUMAR. SI( TIPOS,H4,INGRESOS) En K4 = SUMAR. SI (TIPOS,H4,SALIDAS). En L4 = J4 K4 Copie luego estas 3 ltimas formulas hacia abajo.

9. 10.

Confeccione luego el grfico tal como en la figura anterior Guarde el libro en disco dndole al archivo el nombre: Almacn de Vehculos

3ra Parte: Obtencin del Cuadro de Kardex 11. A partir de la celda G23 obtenga una copia de los ttulos correspondientes 12. Validar la celda G24 para que solo permita ingresar los datos segn la lista del rango G4: G7 13. En la celda H24 escribir la formula =SI(ESBLANCO(G24),,BUSCARV(G24, tabla,2,0) 14. En la celda L27 escribir la formula = SI(ESBLANCO (G27), , SUMA(J$27: J27) SUMA (K$27: K27) luego copiarla en el rango L28 : L50.

15.

Definir los siguientes nombres de rango CRIT G23: H24 EXTRAER

G26: K26

16.

Ingresar un cdigo en la celda G24 y luego con el men Datos Filtro Filtro avanzado, escribir lo siguiente en la ventana de dialogo:

17.

Haga clic en Aceptar y observe el resultado que deber ser igual al cuadro de la pgina 32 de esta separata practica.

4ta Parte: Obtencin del Grfico de Existencia en Almacn 18. A partir de los rangos seleccionados previamente en forma mltiple I26: I50 y L26: L50, crear el grfico del tipo Lneas segn como se muestra. 19. 20. Una vez creado el grfico, seleccionar con un clic la lnea graficada y luego con ayuda de su men contextual trazar una lnea de tendencia, tal como se observa en la figura adjunta. Seleccione el rango G23: H24 y con la herramienta cmara fotogrfica ubique la fotogrfica de este rango debajo del ttulo del grfico Existencia en Almacn, como se ve en la figura adjunta.

21.

Guarde nuevamente el archivo en disco.

5ta Parte: Creacin de un botn de macro para obtener el Kardex para el vehculo 22. Con ayuda de la grabadora de macros cree una macro cuyo nombre ser Kardex, para que realice las siguientes acciones: 23. 24. Llamar la men Datos Filtro Filtro Avanzado Marcar la opcin Copiar a otro lugar En los cuadros de texto correspondientes escribir los nombres LISTA, CRIT y EXTRAER Hacer clic en el botn Aceptar Usando Autoformas de las herramientas de dibujo, cree el botn Obtener Kardex y luego asignele la macro anterior Ahora para probar la macro, ingrese en la celda G24 un nuevo codigo, y luego haga clic sobre el botn de la macro. Observe como se obtiene el Kardex del vehculo ingresado, y tambin como se obtiene su grafica de lineas Existencia en Almacen. Guarde nuevamente el archivo en disco. Para ver el codigo generado por la macro pulse [Alt]+[F8] luego elija la macro KARDEX y haga clic en [Modificar]

25. 26.

También podría gustarte