Está en la página 1de 11

EXCEL TIPS Y CONSEJOS

Funciones lgicas: Y, O. Ejemplo SI anidado


NIVEL: INTERMEDIO Varias veces necesitamos comparar dos valores y tomar una decisin. A veces con que se cumpla una condicin es suficiente. A veces necesitamos que se cumplan las dos condiciones. Recordando las tablas de lgica del secundario , tenemos la comparacin con Y y con O. Ambas son intuitivas: Y implica que ambas condiciones se cumplan. O, que puede ser una u otra. A modo de de recordatorio, estas son las tablas:

FUNCIN Y(valor_lgico 1;valor_lgico_2) Esta funcin tiene solo dos argumentos (lgicos) y los compara. Solamente devuelve VERDADERO si ambas condiciones se cumplen. Ejemplos:

Y(2>1;3>2) devuelve VERDADERO Y(2<1;3>2) devuelve FALSO Y(2<1;3<2) devueve FALSO

FUNCIN O(valor_lgico 1;valor_lgico_2) Esta funcin tiene solo dos argumentos (lgicos) y los compara. Devuelve VERDADERO al menos una de las dos condiciones se cumple. Ejemplo2:

O(2>1;3>2) devuelve VERDADERO O(2<1;3>2) devuelve VERDADERO O(2<1;3<2) devueve FALSO

Vamos a ver un ejemplo prctico. Dada una lista de vendedores, queremos asignarle la comisin de ventas que le

corresponde segn dos criterios:


El nivel de ventas supera el objetivo. El precio promedio de las ventas supera cierto valor.

Si solo cumple uno de los objetivos, el vendedor tendr un 5% de comisin, mientras que si supera ambos, se llevar un 15%. Por el contrario, si no alcanza al menos uno, no se lleva comisin.

Redactado en palabras: SI las Ventas > Objetivo Y Precio> Objetivo, entonces corresponde 15%; de lo contrario, SI supera el objetivo de venta O el de precio, corresponde 5%. SI no cumple ninguno, entonces la comisin es 0%. Vemos que no solo tenemos las funciones Y y O, sino distintas comparaciones usando SI (para ver una descripcin de la funcin SI, ir ac). Sin embargo, vemos que tenemos varios SI que dependientes entre s. Esto se llaman SI anidados.

Recordemos la estructura de la funcin SI: SI(Prueba_logica;Valor_si_verdadero;Valor_si_falso) En la columna D, debemos ingresar las frmula que nos ayude a determinar la comisin

que corresponda. Para esto, vamos a armar la armar la frmula para la celda D7 siguiendo el esquema de arriba. Lo primero que debemos resolver es si se cumplen las DOS condiciones (el primer cuadro azul del diagrama)

Y(B7>$C$1;C7>$C$2) o B7: Ventas del vendedor AAAAA o $C$1: Objetivos de ventas (referencias fijas porque no cambiapara los distintos vendedores) o C7: Precio promedio vendedor. o $C$2: Objetivos de precio.

Ya tenemos la primera parte de la funcin: SI(se cumplen ambas condiciones; 15% de comisin(valor_si_verdadero); <Ac necesitamos armar la otra condicin del segundo cuadrado azul del diagrama) =SI(Y(B7>$C$1;C7>$C$2);$C$4;<Valor si falso>) [1] Ahora debemos armar la parte de la derecha del diagrama, cuando NO se cumplen ambas condiciones.

O(B7>$C$1;C7>$C$2)

Si la funcin da verdadero, corresponde el segundo nivel de comisin (que definimos en la celda C3). La nica forma en que la evaluacin da FALSO, es si ninguna de las condiciones se cumple. Por lo tanto, corresponde 0% de comisin. =SI(O(B7>$C$1;C7>$C$2);$C$3;0%) [2]

Al incluir esta ltima frmula en la frmula [1], tenemos para la celda D7: =SI(Y(B7>$C$1;C7>$C$2);$C$4;SI(O(B7>$C$1;C7>$C$2);$C$3;0%)) Vista as, es muy difcil de entender. Espero que al haberla armado por etapas, sea ms fcil de comprender.

Listas Desplegables (o Cuadros Combinados)


NIVEL: AVANZADO

Cuando armamos un reporte con mucha informacin, resulta muy til tener listas desplegables (o cuadros combiandos) como vemos en la pantalla. En este tutorial veremos la forma fcil de hacerlo en Excel 2007. SIN MACROS que requieren programacin as como un ejemplo el cual permita traer un valor asociado a la eleccin a la celda que necesitemos.

Primero, debemos asegurarnos que en Excel 2007 tenemos activado en el Men Superior la opcin Programador. Si no lo ves a la derecha del men Vista, mira el Truco para activarlo ac.

Haciendo click en el men Programador, encontraremos el botn de Insertar. Haciendo click sobre la flecha de abajo nos despliega los controles y podremos insertar el men desplegable (o cuadro combinado). Para hacer ms fcil la explicacin, vamos a seguir un ejemplo. Supongamos que tenemos en Excel como el de la figura de abajo donde queremos poder seleccionar un pas (a partir de una lista desplegable que tendremos en la celda B2) y nos devuelva el valor de las ventas en la celda B4.

Tenemos por otro lado en la columna F los nombres de los pases y en la columna G las ventas correspondientes a dicho pas. PASO 1: Insertar el control de lista desplegable Con esta tabla lista, vamos al men Programador, seleccionamos Insertar y luego Cuadro Combinado dentro de Controles de formulario (el encuadrado en rojo en la segunda figura de este tutorial). Al mover el mouse sobre el Excel, el cursor habr cambiado de una cruz gruesa, a una delgada, como un signo +. Esto nos permite dibujar el cuadro donde necesitemos. Por ejemplo, sobre la celda B2. Es imporante recordar que el cuadro est dibujado encima de la celda B2. No est dentro. Es decir, en B2 puede haber un valor o una frmula y el tener la lista desplegable sobre ella no la afectar. PASO 2: Indicarle al control dnde estn los datos de la lista

Formato de Control

Ahora necesitamos decirle al control dnde estn los valores que queremos que despliegue. Estos se encuentran en las celdas F2 a F7. La forma avanzada de hacer esto sera nombrar la regin como paises (ver truco sobre Nombres) Si acercamos la mano al cuadro combinado sobre B2, veremos que el cursor se transforma en una mano. Haciendo click derecho, despliega un men del cual debemos seleccionar Formato del control y nos abrir un nuevo men como el que se muestra en la figura (hacer click para agrandar). Al seleccionar la pestaa Control encontraremos dos campos que debemos configurar: - Rango de entrada - Vncular con la celda En rango de entrada, indicamos dnde se encuentran los valores que queremos de desplieguen en la lista. En nuestro archivo de trabajo, son los pases que se encuentran en la celdas F2:F7 por lo tanto ingresamos este rango. Alternativamente, si habas nombrado el rango como paises, solo hace falta escribir este nombre. Vncular con la celda: Realmente Excel no distingue cul es el contenido sele

ccionado (es decir si el pas es Argentina o Mxico). Solo sabe la ubicacin del elemento seleccionado. Es decir, si seleccionamos Brasil, Excel sabe que elegimos el elemento nmero 2. Si seleccionamos Colombia, para Excel es un 4. Para simplificar entender este punto, agregu el nmero de posicin en la columna E, al lado de cada nombre, para saber en qu posicin est cada uno. Esta numeracin no es necesaria para que el control funcione. Para el ejemplo, vamos a poner en este campo la celda D2 para que podamos verlo. En la prctica, lo ms til es ubicarlo debajo del control (es decir, en la celda B2), as no se ve. PASO 3 Asociar la seleccin del cuadro con el valor a devolver Ahora, debemos indicarle a Excel qu hacer con el valor que nos devuelve en la celda que vinculamos en el paso anterior. Es decir, cuando selecciono un pas, nos devuelva en la celda B4 el valor de las ventas que le corresponden. Para esto utilizaremos la funcin INDICE (hacer click para ver el tutorial de esta funcin)

matriz: G2:G7 (una sola columna) nmero de fila: D2 (valor de la posicin que devuelve la lista desplegable) nmero de columna: 1. Solo tenemos una columna.

La frmula de la celda B4 quedara: =INDICE(G2:G7;D2;1)

Sumas con condiciones (SUMAR.SI)


2 de November de 2009 | Autor: Excelman

NIVEL: INTERMEDIO
Descargar el archivo con este ejercicio ac. Muchas veces necesitamos realizar sumas, pero que estas estn restringidas a algn criterio. Ejemplo, que sume las ventas pero solo de cierto tipo de producto.

Como es usual, vamos a explicar esto con un ejemplo. Supongamos que tenemos las ventas de Peras y Manzanas y necesitamos saber cunto se vendi de cada producto. Es decir, realizar una suma pero con una condicin. En este caso, la funcin SUMAR.SI (SUMIF en ingls), nos ayuda a resolverlo. La funcin tiene los siguientes parmetros: SUMAR.SI(rango;criterio;[rango_suma]) Donde:

rango: contiene el rango de celdas a evaluar criterio: criterio o condicin a cumplir por las celdas que se van a sumar. rango_suma: son las celdas que se van a sumar. Si se omite, suma las celdas definidas en rango.

El criterio puede expresarse de varias formas.


Como un nmero: cuando necesitamos la suma de los valores que cumplen exactamente con esa condicin (ej. 100) Referencia a una celda: Cuando esa celda tiene el criterio (ej. Manzanas) u operacin lgica (ver punto siguiente). Operacin lgica: Cuando el criterio implica alguna operacin. Por ejemplo, Es mayor a .. o IMPORTANTE: El criterio debe estar encerrado entre comillas dobles. Ejemplo, si en este caso necesitramos sumar solamente las ventas mayores o iguales a 75, la frmula sera: SUMAR.SI(C2:C11; >=75)

En nuestro ejemplo necesitamos hacer dos sumas con condiciones: La primera es sumar las cantidades de Peras y las de Manzanas; mientras que en la segunda solamente queremos la suma de las ventas hechas despus de cierta fecha.

Caso 1. Separar Peras de Manzanas


En las celdas C13 necesitamos solamente la suma de las Peras. Por lo tanto tenemos:

rango: B2:B11 (donde se indica qu tipo de fruta es) criterio: Est indicado en la celda B13 rango_suma: C3:C11 donde se encuentran los datos de las cantidades a sumar.

Por lo tanto la frmula en C13 queda: =SUMAR.SI(B2:B11;B13;C2:C11) Equivalente en el caso de la suma para las Peras en C14: =SUMAR.SI(B2:B11;B14;C2:C11)

Caso 2 Sumar las ventas despus de determinada fecha


En este caso, la condicin ya no es tan simple ya que tenemos una condicin del tipo mayor a.. y no igual a, como en el caso anterior. En nuestro ejemplo, necesitamos sumar las ventas que se realizan desde el da que indicamos en B16. Por lo tanto, en el criterio debemos indicar tanto que es >= y lo debemos combiar con la fecha que indicamos en B16. Estas se combinan usando el smbolo de ampersand (&) que unifica las dos cadenas. Tenemos:

rango: A2:A11 (fechas) criterio: >= & B16 rango_suma: C3:C11 donde se encuentran los datos de las cantidades a sumar.

La frmula para C16 queda: =SUMAR.SI(A2:A11;>=&B16;C2:C11)

Funcin SUMAPRODUCTO y promedios ponderados


NIVEL: BSICO Descargar archivo de trabajo. En varias ocasiones, el calcular un promedio simple o aritmtico (es decir, dividir la suma de los nmeros entre la cantidad de elementos), no es representativa del comportamiento de la situacin que estamos analizando. Un ejemplo habitual de esta situacin es, por ejemplo, cuando tenemos cantidades vendidas y precios. Veamos un caso extremo: Tenemos 99 unidades de un producto vendidos a $1 y 1 unidad vendida a $9. La tarifa promedio, segn promedio simple, sera ($9 + $1) / 2 = $5. Pero la realidad es muy distinta.

99 unidades a $1 nos da $99 1 unidadad a $9 da $9 En total se vendieron 100 unidades por $108. El precio promedio por unidad es $108/100 = $1,08

El promedio simple de tarifa da $5. El promedio calculado por las ventas da $1,08. Vaya diferencia!! Por qu esta diferencia? Porque el promedio simple, el tradicional que conocemos, NO funciona cuando los valores a promediar (en nuestro caso, tarifas), tienen diferentes frecuencias (la tarifa de $1 se repite 99 veces mientras que la de $9 se repite una sola vez). En este tutorial, veremos cmo utilizar la funcin SUMAPRODUCTO de Excel a travs de este ejemplo para comprender mejor su funcionamiento.

Vamos a trabajar con el ejemplo de la derecha. En la columna B tenemos un detalle de la cantidad vendida de cada producto y en la C el precio. En la celda C9 vamos a calcular el promedio simple usando la funcin PROMEDIO: =PROMEDIO(C2:C6) El promedio ponderado, es decir, aquel en el cual a cada observacin se le da el peso (pondera) por la cantidad de veces que se repite, se calcula:

Esto es, la suma de la multiplicacin (producto) de cada cantidad (frecuencia) por el precio correspondiente, dividido por la suma de las cantidades.

SUMAPRODUCTO en Excel
Finalmente llegamos al punto donde utilizamos la funcin. La funcin SUMAPRODUCTO hace justamente las operaciones de la parte superior de la funcin mencionada: suma el producto (multiplicacin) de elementos de distintos rangos. La funcin tiene la siguiente estructura: SUMAPRODUCTO(rango1;rango2;) Es decir, permite realizar el clculo de varios rangos (no solo 2 como en nuestro ejemplo). Tambin es muy til para realizar clculos aplicando filtros o restricciones, pero esto lo dejar para otro tutorial. De esta forma, calcularemos nuestro promedio ponderado en la celda C10 utilizando la frmula: =SUMAPRODUCTO(B2:B6;C2:C6)/SUMA(B2:B6) Donde la funcin B2*C2+C3*C3+B4*C4+B5*C5+B6*C6. SUMAPRODUCTO calcular:

Nos ahorra tener que introducir todas estas multiplicaciones a mano, o contar con una columna adicional (en nuestro caso la celda de ventas contiene la multiplicacin de cada par cantidad-precio). La tarifa segn promedio simple nos dio $5. Segn promedio ponderado $2. Hagamos una simple comprobacin. Si queremos estimar cunto dinero se vendi, usaramos la aproximacin cantidad vendida x precio promedio. Utilizando el promedio lineal, nos da 178 unidades s $5 = $890 (!!!!!) Mientras si usamos el promedio ponderado, tendremos 178 unidades x $2 = $356 (que corresponde exactamente a las ventas realizadas)