Está en la página 1de 15

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.

p.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

Lab 1.9 Cu hnh MPLS VPN Layer 2 v nh tuyn EIGRP gia PE-CE
M hnh:

Customer A Site 1 EIGRP AS101


1.1.1.1/24

Customer A Site 2 EIGRP AS101


5.5.5.5/24

R1-CE
F0/0
.1 /24 68 . 15 192. 1

R5-CE
8.15 . 5/ 2 4

F0/0

VPN-A VPN-B

Loopback 0 F0/0 2.2.2.2/32 S1/3

S1/ 2 .3 24 .0 / 23 .

R3-P

S1/0 .3 19 2
.16

Loopback 0 4.4.4.4/32 F0/0

R2-PE
F0/1

8 2 2.16 19

8. 34. 0

.4
/2 S1/3 4

R4-PE
F0/1

68 .67

. 6/24

F0/1

Mng trc ca nh cung cp dch v MPLS

192 .1

R6-CE
6.6.6. 6/24

R7-CE
7.7.7.7/24

EIGRP AS201 Customer B Site 1

EIGRP AS202 Customer B Site 2

Hnh 1.9. M t

- Bi lab ny minh ha nh cung cp dch v cung cp cc kt ni cho cc khch hng qua mng trc MPLS. Bng cch s dng cng ngh MPLS VPN layer 2 m bo tnh ring t ca khch hng - Trong bi lab ny, ta s cu hnh cho ton m hnh bao gm pha khch hng v nh cung cp dch v. Trong :
Cu hnh Bc 1: Cu hnh c bn.

R1-CE v R5-CE l 2 router ca cng 1 khch hng A (Customer A). R6-CE v R7-CE l 2 router ca cng 1 khch hng B (Customer B).

t hostname cho router. t IP cho Router theo m hnh trong bi lab.

19 2.1 6

VPN-A VPN-B

6 8.67 19 2. 1 .7/24

F0/1

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

Bc 2: nh tuyn IP trong mng li trong nh cung cp dch v bng cch dng giao thc nh tuyn OSPF. Trn R2-PE:
R2-PE(config)#router ospf 1 R2-PE(config-router)# network 2.2.2.2 0.0.0.0 area 0 R2-PE(config-router)# network 192.168.23.0 0.0.0.255 area 0

Trn R3-P:
R3-P(config)#router ospf 1 R3-P(config-router)# network 192.168.34.0 0.0.0.255 area 0 R3-P(config-router)# network 192.168.23.0 0.0.0.255 area 0

Trn R4-PE:
R3-P(config)#router ospf 1 R3-P(config-router)# network 4.4.4.4 0.0.0.0 area 0 R3-P(config-router)# network 192.168.34.0 0.0.0.255 area 0

Kim tra bng nh tuyn trn R2-PE:


R2-PE#show ip route Gateway of last resort is not set

2.0.0.0/32 is subnetted, 1 subnets C 2.2.2.2 is directly connected, Loopback0 4.0.0.0/32 is subnetted, 1 subnets O C O 4.4.4.4 [110/129] via 192.168.23.3, 00:00:04, Serial1/3 192.168.23.0/24 is directly connected, Serial1/3 192.168.34.0/24 [110/128] via 192.168.23.3, 00:00:04, Serial1/3

Ping kim tra:


R2-PE#ping 4.4.4.4 source 2.2.2.2 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds: Packet sent with a source address of 2.2.2.2 !!!!!

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

Success rate is 100 percent (5/5), round-trip min/avg/max = 64/87/120 ms

Bc 3: Cu hnh MPLS trong mng li nh cung cp dch v.


R2-PE(config)# interface s1/3 R2-PE(config-if)#mpls lable protocol ldp R2-PE(config-if)#mpls ip R3-P(config)# interface s1/2 R3-P(config-if)#mpls lable protocol ldp R3-P(config-if)#mpls ip R3-P(config)# interface s1/0 R3-P(config-if)#mpls lable protocol ldp R3-P(config-if)#mpls ip R4-PE(config)# interface s1/3 R3-PE(config-if)#mpls lable protocol ldp R3-PE(config-if)#mpls ip

Kim tra vic MPLS c thit lp lng ging cha. Thc hin trn R3-P:
R3-P#show mpls ldp neighbor Peer LDP Ident: 2.2.2.2:0; Local LDP Ident 192.168.34.3:0 TCP connection: 2.2.2.2.646 - 192.168.34.3.20938 State: Oper; Msgs sent/rcvd: 10/10; Downstream Up time: 00:02:49 LDP discovery sources: Serial1/2, Src IP addr: 192.168.23.2 Addresses bound to peer LDP Ident: 192.168.23.2 2.2.2.2

Peer LDP Ident: 4.4.4.4:0; Local LDP Ident 192.168.34.3:0 TCP connection: 4.4.4.4.646 - 192.168.34.3.11532 State: Oper; Msgs sent/rcvd: 9/9; Downstream Up time: 00:02:13 LDP discovery sources: Serial1/0, Src IP addr: 192.168.34.4 Addresses bound to peer LDP Ident: 192.168.34.4 4.4.4.4

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

R3-P#

Xem bng forwarding-table trn R2-PE:


R2-PE#show mpls forwarding-table Local tag 16 17 Outgoing tag or VC 17 Pop tag Prefix or Tunnel Id 4.4.4.4/32 192.168.34.0/24 Bytes tag switched 0 0 Outgoing interface Se1/3 Se1/3 point2point point2point Next Hop

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

Bc 4: Cu hnh Port Transparent. Port transparent c cu hnh gia 2 router PE gm R2-PE v R4-PE to ra cc ng kt ni o ni gia cc khch hng. m bo rng 2 site cng 1 khch hng phi c cng s VC ID. Customer A:
R2-PE(config)#int f0/0 R2-PE(config-if)#no sh R2-PE(config-if)#xconnect 4.4.4.4 105 encapsulation mpls R2-PE(config-if-xconn)#end R4-PE(config)#int f0/0 R4-PE(config-if)#no sh R4-PE(config-if)#xconnect 2.2.2.2 105 encapsulation mpls R4-PE(config-if-xconn)#end

Customer B:
R2-PE(config)#int f0/1 R2-PE(config-if)#no sh R2-PE(config-if)#xconnect 4.4.4.4 607 encapsulation mpls R2-PE(config-if-xconn)#end R4-PE(config)#int f0/0 R4-PE(config-if)#no sh R4-PE(config-if)#xconnect 2.2.2.2 607 encapsulation mpls R4-PE(config-if-xconn)#end

Bc 5: Kim tra kt ni v cu hnh. Kim tra bng VC trn cc router PE:


R2-PE#show mpls l2transport vc

Local intf ------------Fa0/0 Fa0/1 R2-PE#

Local circuit

Dest address

VC ID

Status

-------------------------- --------------- ---------- ---------Ethernet Ethernet 4.4.4.4 4.4.4.4 105 607 UP UP

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org R4-PE#show mpls l2transport vc

Local intf ------------Fa0/0 Fa0/1 R4-PE#

Local circuit

Dest address

VC ID

Status

-------------------------- --------------- ---------- ---------Ethernet Ethernet 2.2.2.2 2.2.2.2 105 607 UP UP

Kim tra bng ARP ca cc router khch hng:


R1-CE#show ip arp Protocol Address Age(min) 9 Hardware Addr c200.00c0.0000 c204.00c0.0000 Type ARPA ARPA Interface FastEthernet0/0 FastEthernet0/0

Internet 192.168.15.1 Internet 192.168.15.5 R1-CE# R6-CE#show ip arp Protocol Address

Age(min) 4

Hardware Addr Type c205.00c0.0001 c206.00c0.0001 ARPA ARPA

Interface FastEthernet0/1 FastEthernet0/1

Internet 192.168.67.6 Internet 192.168.67.7 R6-CE#

Bc 6: Cu hnh nh tuyn EIGRP gia cc site khch hng. Customer A:


R1-CE(config)# router eigrp 101 R1-CE(config-router)# network 192.168.15.0 R1-CE(config-router)# network 1.0.0.0 R1-CE(config-router)# no auto-summary R5-CE(config)# router eigrp 101 R5-CE(config-router)# network 192.168.15.0 R5-CE(config-router)# network 5.0.0.0 R5-CE(config-router)# no auto-summary

Customer B:
R6-CE(config)# router eigrp 202 R6-CE(config-router)# network 192.168.67.0

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

R6-CE(config-router)# network 6.0.0.0 R6-CE(config-router)# no auto-summary R7-CE(config)# router eigrp 202 R7-CE(config-router)# network 192.168.67.0 R7-CE(config-router)# network 7.0.0.0 R7-CE(config-router)# no auto-summary

Kim tra lng ging EIGRP v bng nh tuyn:


R1-CE#show ip eigrp neighbors IP-EIGRP neighbors for process 1 IP-EIGRP neighbors for process 101 H Address Interface Hold (sec) 0 192.168.15.5 Fa0/0 11 00:10:52 Uptime SRTT (ms) 328 1968 RTO Q Seq

Cnt Num 0 9

R1-CE# R1-CE#show ip route Gateway of last resort is not set 1.0.0.0/24 is subnetted, 1 subnets C C 1.1.1.0 is directly connected, Loopback0 192.168.15.0/24 is directly connected, FastEthernet0/0 5.0.0.0/24 is subnetted, 1 subnets D R1-CE# R6-CE#show ip eigrp ne R6-CE#show ip eigrp neighbors IP-EIGRP neighbors for process 202 H Address Interface Hold Uptime (sec) 0 192.168.67.7 Fa0/1 13 00:06:27 SRTT (ms) 343 2058 RTO Q Seq 5.5.5.0 [90/409600] via 192.168.15.5, 00:11:09, FastEthernet0/0

Cnt Num 0 9

R6-CE# R6-CE#show ip route Gateway of last resort is not set

6.0.0.0/24 is subnetted, 1 subnets C 6.6.6.0 is directly connected, Loopback0

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org 7.0.0.0/24 is subnetted, 1 subnets D C 7.7.7.0 [90/409600] via 192.168.67.7, 00:06:49, FastEthernet0/1 192.168.67.0/24 is directly connected, FastEthernet0/1

R6-CE# Ping kim tra kt ni R1-CE#ping 5.5.5.5 source 1.1.1.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds: Packet sent with a source address of 1.1.1.1 !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 84/164/236 ms R1-CE# R6-CE#ping 7.7.7.7 source 6.6.6.6 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds: Packet sent with a source address of 6.6.6.6 !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 112/178/240 ms R6-CE#

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

Cu hnh y R1-CE
R1-CE#show running-config Building configuration...

Current configuration : 1504 bytes ! version 12.4 ! hostname R1-CE ip cef ! interface Loopback0 ip address 1.1.1.1 255.255.255.0 ! interface FastEthernet0/0 ip address 192.168.15.1 255.255.255.0 duplex auto speed auto ! router eigrp 101 network 1.0.0.0 network 192.168.15.0 no auto-summary ! end

R2-PE
R2-PE#show running-config Building configuration...

Current configuration : 1824 bytes !

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

version 12.4 ! hostname R2-PE ! ip cef ! interface Loopback0 ip address 2.2.2.2 255.255.255.255 ! interface FastEthernet0/0 no ip address duplex auto speed auto xconnect 4.4.4.4 105 encapsulation mpls ! interface FastEthernet0/1 no ip address duplex auto speed auto xconnect 4.4.4.4 607 encapsulation mpls ! interface Serial1/3 ip address 192.168.23.2 255.255.255.0 mpls label protocol ldp mpls ip serial restart-delay 0 ! router ospf 1 log-adjacency-changes network 2.2.2.2 0.0.0.0 area 0 network 192.168.23.0 0.0.0.255 area 0 !

10

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

end

R3-P
R3-P#show running-config Building configuration...

Current configuration : 1540 bytes ! version 12.4 ! hostname R3-P ! ip cef ! interface Serial1/0 ip address 192.168.34.3 255.255.255.0 mpls label protocol ldp mpls ip serial restart-delay 0 ! interface Serial1/2 ip address 192.168.23.3 255.255.255.0 mpls label protocol ldp mpls ip serial restart-delay 0 ! router ospf 1 log-adjacency-changes network 192.168.23.0 0.0.0.255 area 0 network 192.168.34.0 0.0.0.255 area 0 ! end

R4-PE

11

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

R4-PE#show running-config Building configuration...

Current configuration : 2011 bytes ! version 12.4 ! hostname R4-PE ! ip cef ! interface Loopback0 ip address 4.4.4.4 255.255.255.255 ! interface FastEthernet0/0 no ip address duplex auto speed auto xconnect 2.2.2.2 105 encapsulation mpls ! interface FastEthernet0/1 no ip address duplex auto speed auto xconnect 2.2.2.2 607 encapsulation mpls ! interface Serial1/3 ip address 192.168.34.4 255.255.255.0 mpls label protocol ldp mpls ip serial restart-delay 0 !

12

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

router ospf 1 log-adjacency-changes network 4.4.4.4 0.0.0.0 area 0 network 192.168.34.0 0.0.0.255 area 0 ! end

R5-CE
R5-CE#show running-config Building configuration...

Current configuration : 1504 bytes ! version 12.4 ! hostname R5-CE ! ip cef ! interface Loopback0 ip address 5.5.5.5 255.255.255.0 ! interface FastEthernet0/0 ip address 192.168.15.5 255.255.255.0 duplex auto speed auto ! router eigrp 101 network 5.0.0.0 network 192.168.15.0 no auto-summary ! end

13

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

R6-CE
R6-CE#show running-config Building configuration...

Current configuration : 1473 bytes ! version 12.4 ! hostname R6-CE ! ip cef ! interface Loopback0 ip address 6.6.6.6 255.255.255.0 ! interface FastEthernet0/1 ip address 192.168.67.6 255.255.255.0 duplex auto speed auto ! router eigrp 202 network 6.0.0.0 network 192.168.67.0 no auto-summary ! end

R7-CE
R7-CE#show running-config Building configuration...

Current configuration : 905 bytes !

14

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

version 12.4 ! hostname R7-CE ! ip cef ! interface Loopback0 ip address 7.7.7.7 255.255.255.0 ! interface FastEthernet0/1 ip address 192.168.67.7 255.255.255.0 duplex auto speed auto ! router eigrp 202 network 7.0.0.0 network 192.168.67.0 no auto-summary ! End

15