Está en la página 1de 20

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.

p.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

Lab 1.8 Cu hnh MPLS VPN Layer 3 v nh tuyn EIGRP gia PE-CE
M hnh

Customer A Site 1 EIGRP AS101


1.1.1.1/24

Customer A Site 2 EIGRP AS101


5.5.5.5/24

R1-CE
.1 F0/0

R5-CE
F0/0 .5
.0/2 4

VPN-A VPN-B

Loopback 0 F0/0 2.2.2.2/32 .2 S1/3 .2 F0/1

S1/2 .3
6 2. 1 .0 23 8. 4 /2

R3-P

S1/0 .3 19 2.

Loopback 0 4.4.4.4/32 F0/0 .4


8. 34

16

.4
.0/ 24 S1/3

R2-PE

19

R4-PE
.4 F0/1

.0/2 4

6 8 .2 6

1 9 2 .1

F0/1 .6

Mng trc ca nh cung cp dch v MPLS

R6-CE
6.6.6.6/24

7.7.7.7/24

EIGRP AS201 Customer B Site 1

EIGRP AS202 Customer B Site 2

Hnh 1.8.

1 9 2 .1

6 8 .4 5

1 92.1 68.1 2 .0/ 24 1 9 2 .1 6 8 .4 7

VPN-A VPN-B

.0 /2 4

.7 F0/1

R7-CE

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

M t

- Bi lab ny minh ha nh cung cp dch v cung cp cc kt ni cho cc khch hng qua mng trc MPLS. Bng cch s dng cng ngh MPLS VPN m bo tnh ring t ca khch hng. - Trong bi lab ny, ta s cu hnh cho ton m hnh bao gm pha khch hng v nh cung cp dch v. Trong : R1-CE v R5-CE l 2 router ca cng 1 khch hng A (Customer A). R6-CE v R7-CE l 2 router ca cng 1 khch hng B (Customer B).

Cu hnh Bc 1: Cu hnh c bn

t hostname cho router. t IP cho Router theo m hnh trong bi lab.

Bc 2: nh tuyn IP trong mng li ca nh cung cp dch v bng cch dng giao thc nh tuyn OSPF. Trn R2-PE:
R2-PE(config)#router ospf 1 R2-PE(config-router)# network 2.2.2.2 0.0.0.0 area 0 R2-PE(config-router)# network 192.168.23.0 0.0.0.255 area 0

Trn R3-P:
R3-P(config)#router ospf 1 R3-P(config-router)# network 192.168.34.0 0.0.0.255 area 0 R3-P(config-router)# network 192.168.23.0 0.0.0.255 area 0

Trn R4-PE:
R3-P(config)#router ospf 1 R3-P(config-router)# network 4.4.4.4 0.0.0.0 area 0 R3-P(config-router)# network 192.168.34.0 0.0.0.255 area 0

Kim tra bng nh tuyn trn R2-PE.


R2-PE#show ip route Gateway of last resort is not set

2.0.0.0/32 is subnetted, 1 subnets C 2.2.2.2 is directly connected, Loopback0

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

4.0.0.0/32 is subnetted, 1 subnets O C O 4.4.4.4 [110/129] via 192.168.23.3, 00:00:04, Serial1/3 192.168.23.0/24 is directly connected, Serial1/3 192.168.34.0/24 [110/128] via 192.168.23.3, 00:00:04, Serial1/3

Ping kim tra.


R2-PE#ping 4.4.4.4 source 2.2.2.2 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 4.4.4.4, timeout is 2 seconds: Packet sent with a source address of 2.2.2.2 !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 64/87/120 ms R2-PE#

Bc 3: Cu hnh MPLS trong mng li nh cung cp dch v


R2-PE(config)# interface s1/3 R2-PE(config-if)#mpls label protocol ldp R2-PE(config-if)#mpls ip R3-P(config)# interface s1/2 R3-P(config-if)#mpls label protocol ldp R3-P(config-if)#mpls ip R3-P(config)# interface s1/0 R3-P(config-if)#mpls label protocol ldp R3-P(config-if)#mpls ip R4-PE(config)# interface s1/3 R3-PE(config-if)#mpls label protocol ldp R3-PE(config-if)#mpls ip

Kim tra vic MPLS thit lp c lng ging cha. Thc hin trn R3-P.
R3-P#show mpls ldp neighbor Peer LDP Ident: 2.2.2.2:0; Local LDP Ident 192.168.34.3:0 TCP connection: 2.2.2.2.646 - 192.168.34.3.20938 State: Oper; Msgs sent/rcvd: 10/10; Downstream Up time: 00:02:49 LDP discovery sources:

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

Serial1/2, Src IP addr: 192.168.23.2 Addresses bound to peer LDP Ident: 192.168.23.2 2.2.2.2

Peer LDP Ident: 4.4.4.4:0; Local LDP Ident 192.168.34.3:0 TCP connection: 4.4.4.4.646 - 192.168.34.3.11532 State: Oper; Msgs sent/rcvd: 9/9; Downstream Up time: 00:02:13 LDP discovery sources: Serial1/0, Src IP addr: 192.168.34.4 Addresses bound to peer LDP Ident: 192.168.34.4 R3-P# 4.4.4.4

Xem bng forwarding-table trn R2-PE.


R2-PE#show mpls forwarding-table Local tag 16 17 Outgoing tag or VC 17 Pop tag Prefix or Tunnel Id 4.4.4.4/32 192.168.34.0/24 Bytes tag switched 0 0 Outgoing interface Se1/3 Se1/3 point2point point2point Next Hop

Bc 4: To bng VRF tng ng cho tng khch hng trn cc router PE Customer A:
R2-PE(config)#ip vrf A R2-PE(config-vrf)#rd 15:15 R2-PE(config-vrf)#route-target export 1:1 R2-PE(config-vrf)#route-target import 5:5 R4-PE(config)#ip vrf A R4-PE(config-vrf)#rd 15:15 R4-PE(config-vrf)#route-target export 5:5 R4-PE(config-vrf)#route-target import 1:1

Customer B
R2-PE(config)#ip vrf B R2-PE(config-vrf)#rd 67:67

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

R2-PE(config-vrf)#route-target export 6:6 R2-PE(config-vrf)#route-target import 7:7 R4-PE(config)#ip vrf B R4-PE(config-vrf)#rd 67:67 R4-PE(config-vrf)#route-target export 7:7 R4-PE(config-vrf)#route-target import 6:6

Kim tra bng VRF c to trn R2-PE:


R2-PE#show ip vrf Name A B R2-PE# Default RD 15:15 67:67 Interfaces

Bc 5: Kt hp (associate) bng VRF vi cc interface ca tng khch hng. Customer A:


R2-PE(config)# interface f0/0 R2-PE(config-if)#ip vrf forwarding A R2-PE(config-if)#ip address 192.168.12.2 255.255.255.0 R4-PE(config)# interface f0/0 R4-PE(config-if)#ip vrf forwarding A R4-PE(config-if)#ip address 192.168.45.4 255.255.255.0

Customer B:
R2-PE(config)# interface f0/1 R2-PE(config-if)#ip vrf forwarding B R2-PE(config-if)#ip address 192.168.26.2 255.255.255.0 R4-PE(config)# interface f0/1 R4-PE(config-if)#ip vrf forwarding B R4-PE(config-if)#ip address 192.168.47.4 255.255.255.0

Kim tra bng nh tuyn VRF v ping:


R2-PE#show ip route vrf A Routing Table: A Gateway of last resort is not set

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org C 192.168.12.0/24 is directly connected, FastEthernet0/0

R2-PE# R2-PE#show ip route vrf B Routing Table: B Gateway of last resort is not set C 192.168.26.0/24 is directly connected, FastEthernet0/1

R2-PE# R2-PE#ping vrf A 192.168.12.1 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.12.1, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 24/63/124 ms R2-PE#ping vrf B 192.168.26.6 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 192.168.26.6, timeout is 2 seconds: !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 28/63/112 ms R2-PE#

Bc 6: nh tuyn gia PE v CE. Bng cch s dng giao thc nh tuyn EIGRP Cu hnh trn cc router PE pha nh cung cp dch v:
R2-PE(config)#router eigrp 1 R2-PE(config-router)#address-family ipv4 vrf A R2-PE(config-router-af)#network 192.168.12.0 R2-PE(config-router-af)#redistribute bgp 24 metric 1000 100 255 1 1500 R2-PE(config-router-af)#autonomous-system 101 R2-PE(config-router-af)#no auto-summary R2-PE(config-router-af)#exit R2-PE(config-router)#address-family ipv4 vrf B R2-PE(config-router-af)#network 192.168.26.0 R2-PE(config-router-af)#redistribute bgp 24 metric 1000 100 255 1 1500 R2-PE(config-router-af)#autonomous-system 202 R2-PE(config-router-af)#no auto-summary R2-PE(config-router-af)#end

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

R4-PE(config)#router eigrp 1 R4-PE(config-router)#address-family ipv4 vrf A R4-PE(config-router-af)#network 192.168.45.0 R4-PE(config-router-af)#redistribute bgp 24 metric 1000 100 255 1 1500 R4-PE(config-router-af)#autonomous-system 101 R4-PE(config-router-af)#no auto-summary R4-PE(config-router-af)#exit R4-PE(config-router)#address-family ipv4 vrf B R4-PE(config-router-af)#network 192.168.47.0 R4-PE(config-router-af)#redistribute bgp 24 metric 1000 100 255 1 1500 R4-PE(config-router-af)#autonomous-system 202 R4-PE(config-router-af)#no auto-summary R4-PE(config-router-af)#end

Cu hnh nh tuyn EIGRP pha khch hng:


R1-CE(config)#router eigrp 101 R1-CE(config-router)#network 192.168.12.0 R1-CE(config-router)#network 1.0.0.0 R1-CE(config-router)#no auto-summary R5-CE(config)#router eigrp 101 R5-CE(config-router)#network 192.168.45.0 R5-CE(config-router)#network 5.0.0.0 R5-CE(config-router)#no auto-summary R6-CE(config)#router eigrp 202 R6-CE(config-router)#network 192.168.26.0 R6-CE(config-router)#network 6.0.0.0 R6-CE(config-router)#no auto-summary R7-CE(config)#router eigrp 202 R7-CE(config-router)#network 192.168.47.0 R7-CE(config-router)#network 7.0.0.0 R7-CE(config-router)#no auto-summary

Kim tra s thit lp quan h lng ging trn router R2-PE.


R2-PE#show ip eigrp vrf A neighbors

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org IP-EIGRP neighbors for process 101 H Address Interface Hold (sec) 0 192.168.12.1 Fa0/0 13 Uptime SRTT (ms) 00:07:02 209 1881 RTO Q Seq

Cnt Num 0 4

R2-PE#show ip eigrp vrf B neighbors IP-EIGRP neighbors for process 202 H Address Interface Hold (sec) 0 192.168.26.6 Fa0/1 10 00:05:44 Uptime SRTT (ms) 214 1926 RTO Q Cnt 0 Seq Num 5

R2-PE#

Bc 7: nh tuyn PE-PE bng cch s dng giao thc nh tuyn MP-BGP. Thit lp lng ging MP-BGP gia R2-PE v R4-PE:
R2-PE(config)#router bgp 24 R2-PE(config-router)#neighbor 4.4.4.4 remote-as 24 R2-PE(config-router)#neighbor 4.4.4.4 update-source loopback 0 R4-PE(config)#router bgp 24 R4-PE(config-router)#neighbor 2.2.2.2 remote-as 24 R4-PE(config-router)#neighbor 2.2.2.2 update-source loopback 0

Cu hnh VPNv4 address family:


R2-PE(config)#router bgp 24 R2-PE(config-router)#address-family vpnv4 R2-PE(config-router-af)#neighbor 4.4.4.4 activate R4-PE(config)#router bgp 24 R4-PE(config-router)#address-family vpnv4 R4-PE(config-router-af)#neighbor 2.2.2.2 activate

Kim tra thit lp lng ging:


R2-PE# show ip bgp summary BGP router identifier 2.2.2.2, local AS number 24 BGP table version is 1, main routing table version 1

Neighbor 4.4.4.4

V 4

AS MsgRcvd MsgSent 24 5 5

TblVer 1

InQ OutQ Up/Down 0 0 00:01:06

State/PfxRcd 0

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org R2-PE#

Cu hnh IPv4 address family:


R2-PE(config)#router bgp 24 R2-PE(config-router)#address-family ipv4 vrf A R2-PE(config-router-af)#redistribute eigrp 101 R2-PE(config-router-af)#exit R2-PE(config-router)#address-family ipv4 vrf B R2-PE(config-router-af)#redistribute eigrp 202 R2-PE(config-router-af)#end R2-PE# R4-PE(config)#router bgp 24 R4-PE(config-router)#address-family ipv4 vrf A R4-PE(config-router-af)#redistribute eigrp 101 R4-PE(config-router-af)#exit R4-PE(config-router)#address-family ipv4 vrf B R4-PE(config-router-af)#redistribute eigrp 202 R4-PE(config-router-af)#end R4-PE#

Kim tra bng nh tuyn ca cc router khch hng v thc hin ping kim tra: Trn R1-CE customer A:
R1-CE#show ip route Gateway of last resort is not set C 192.168.12.0/24 is directly connected, FastEthernet0/0 1.0.0.0/24 is subnetted, 1 subnets C D 1.1.1.0 is directly connected, Loopback0 192.168.45.0/24 [90/307200] via 192.168.12.2, 00:02:34, FastEthernet0/0 5.0.0.0/24 is subnetted, 1 subnets D R1-CE# R1-CE#ping 5.5.5.5 source 1.1.1.1 5.5.5.0 [90/435200] via 192.168.12.2, 00:02:34, FastEthernet0/0

Type escape sequence to abort.

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

Sending 5, 100-byte ICMP Echos to 5.5.5.5, timeout is 2 seconds: Packet sent with a source address of 1.1.1.1 !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 168/215/356 ms R1-CE#

Trn R6-CE customer B:


R6-CE#show ip route Gateway of last resort is not set D 192.168.47.0/24 [90/307200] via 192.168.26.2, 00:03:34, FastEthernet0/1 6.0.0.0/24 is subnetted, 1 subnets C C 6.6.6.0 is directly connected, Loopback0 192.168.26.0/24 is directly connected, FastEthernet0/1 7.0.0.0/24 is subnetted, 1 subnets D 7.7.7.0 [90/435200] via 192.168.26.2, 00:03:34, FastEthernet0/1

R6-CE# R6-CE#ping 7.7.7.7 source 6.6.6.6 Type escape sequence to abort. Sending 5, 100-byte ICMP Echos to 7.7.7.7, timeout is 2 seconds: Packet sent with a source address of 6.6.6.6 !!!!! Success rate is 100 percent (5/5), round-trip min/avg/max = 124/222/288 ms R6-CE#

Cu hnh y Trn R1-CE


R1-CE#show running-config Building configuration...

Current configuration : 1504 bytes ! version 12.4 hostname R1-CE !

10

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

ip cef ! interface Loopback0 ip address 1.1.1.1 255.255.255.0 ! interface FastEthernet0/0 ip address 192.168.12.1 255.255.255.0 duplex auto speed auto ! router eigrp 101 network 1.0.0.0 network 192.168.12.0 no auto-summary ! End

Trn R2-PE
R2-PE#show running-config Building configuration... Current configuration : 2580 bytes ! version 12.4 hostname R2-PE ! ip cef ! ip vrf A rd 15:15 route-target export 1:1 route-target import 5:5 ! ip vrf B

11

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

rd 67:67 route-target export 6:6 route-target import 7:7 ! interface Loopback0 ip address 2.2.2.2 255.255.255.255 ! interface FastEthernet0/0 ip vrf forwarding A ip address 192.168.12.2 255.255.255.0 duplex auto speed auto ! interface FastEthernet0/1 ip vrf forwarding B ip address 192.168.26.2 255.255.255.0 duplex auto speed auto ! interface Serial1/3 ip address 192.168.23.2 255.255.255.0 mpls label protocol ldp mpls ip serial restart-delay 0 ! router eigrp 1 auto-summary ! address-family ipv4 vrf B redistribute bgp 24 metric 1000 100 255 1 1500 network 192.168.26.0 no auto-summary

12

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

autonomous-system 202 exit-address-family ! address-family ipv4 vrf A redistribute bgp 24 metric 1000 100 255 1 1500 network 192.168.12.0 no auto-summary autonomous-system 101 exit-address-family ! router ospf 1 log-adjacency-changes network 2.2.2.2 0.0.0.0 area 0 network 192.168.23.0 0.0.0.255 area 0 ! router bgp 24 no synchronization bgp log-neighbor-changes neighbor 4.4.4.4 remote-as 24 neighbor 4.4.4.4 update-source Loopback0 no auto-summary ! address-family vpnv4 neighbor 4.4.4.4 activate neighbor 4.4.4.4 send-community extended exit-address-family ! address-family ipv4 vrf B redistribute eigrp 202 no synchronization exit-address-family !

13

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

address-family ipv4 vrf A redistribute eigrp 101 no synchronization exit-address-family ! End

Trn R3-P
R3-P#show running-config Building configuration... Current configuration : 1540 bytes ! version 12.4 ! hostname R3-P ! ip cef ! interface Serial1/0 ip address 192.168.34.3 255.255.255.0 mpls label protocol ldp mpls ip serial restart-delay 0 ! interface Serial1/2 ip address 192.168.23.3 255.255.255.0 mpls label protocol ldp mpls ip serial restart-delay 0 ! router ospf 1 log-adjacency-changes network 192.168.23.0 0.0.0.255 area 0

14

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

network 192.168.34.0 0.0.0.255 area 0 ! end

Trn R4-PE
R4-PE#show running-config Building configuration...

Current configuration : 2580 bytes ! version 12.4 hostname R4-PE ! ip cef ! ip vrf A rd 15:15 route-target export 5:5 route-target import 1:1 ! ip vrf B rd 67:67 route-target export 7:7 route-target import 6:6 ! interface Loopback0 ip address 4.4.4.4 255.255.255.255 ! interface FastEthernet0/0 ip vrf forwarding A ip address 192.168.45.4 255.255.255.0 duplex auto speed auto

15

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

! interface FastEthernet0/1 ip vrf forwarding B ip address 192.168.47.4 255.255.255.0 duplex auto speed auto ! interface Serial1/3 ip address 192.168.34.4 255.255.255.0 mpls label protocol ldp mpls ip serial restart-delay 0 router eigrp 1 auto-summary ! address-family ipv4 vrf B redistribute bgp 24 metric 1000 100 255 1 1500 network 192.168.47.0 no auto-summary autonomous-system 202 exit-address-family ! address-family ipv4 vrf A redistribute bgp 24 metric 1000 100 255 1 1500 network 192.168.45.0 no auto-summary autonomous-system 101 exit-address-family ! router ospf 1 log-adjacency-changes network 4.4.4.4 0.0.0.0 area 0

16

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

network 192.168.34.0 0.0.0.255 area 0 ! router bgp 24 no synchronization bgp log-neighbor-changes neighbor 2.2.2.2 remote-as 24 neighbor 2.2.2.2 update-source Loopback0 no auto-summary ! address-family vpnv4 neighbor 2.2.2.2 activate neighbor 2.2.2.2 send-community extended exit-address-family ! address-family ipv4 vrf B redistribute eigrp 202 no synchronization exit-address-family ! address-family ipv4 vrf A redistribute eigrp 101 no synchronization exit-address-family ! end

Trn R5-CE
R5-CE#show running-config Building configuration...

Current configuration : 1504 bytes ! version 12.4

17

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

hostname R5-CE ! ip cef ! interface Loopback0 ip address 5.5.5.5 255.255.255.0 ! interface FastEthernet0/0 ip address 192.168.45.5 255.255.255.0 duplex auto speed auto ! router eigrp 1 auto-summary ! router eigrp 101 network 5.0.0.0 network 192.168.45.0 no auto-summary ! end

Trn R6-CE
R6-CE#show running-config Building configuration...

Current configuration : 1473 bytes ! version 12.4 hostname R6-CE ! ip cef interface Loopback0

18

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

ip address 6.6.6.6 255.255.255.0 ! interface FastEthernet0/1 ip address 192.168.26.6 255.255.255.0 duplex auto speed auto router eigrp 202 network 6.0.0.0 network 192.168.26.0 no auto-summary ! End

Trn R7-CE
R7-CE#show running-config Building configuration...

Current configuration : 905 bytes ! version 12.4 hostname R7-CE ! ip cef ! interface Loopback0 ip address 7.7.7.7 255.255.255.0 ! interface FastEthernet0/1 ip address 192.168.47.7 255.255.255.0 duplex auto speed auto ! router eigrp 202

19

CNG TY TNHH T V N & D CH V CHUYN VI T 149/1D Ung Vn Khim, phng 25, qun Bnh Thnh, Tp.HCM T: (08) 35124257 (7 lines) Fax: (08) 35124314 Website: http://vnpro.vn Support forum: http://vnpro.org Live Chat: http://www.vnpro.vn/support WifiPro : http://wimaxpro.org

network 7.0.0.0 network 192.168.47.0 no auto-summary ! End

20