Mirar el desarrollo de los ejercicios algunos ejercicios le faltan algunos respuestas 1 Hacer un algoritmo que lea los nombres

y edades de dos personas e imprima cual de ellas tiene más edad. Inicio Nombre1=0, nombre2=0, edad=1, edad2=0 leer nombre1,edad1 leer nombre2 ,edad2 comparar edad1 con edad2: Si edad1 > edad2 entonces imprimir ( nombre1, ” es mayor “) si edad2 > edad1 entonces imprimir ( nombre2, ” es mayor”) Si edad1 = edad2 entonces imprimir (”Edades iguales”) fin si fin si fin si Fin Realice un algoritmo tal que dado como dato la calificación de un alumno en un examen, escriba “reprobado" en caso de que dicha nota sea menor a 3 de lo contrario “aprobado” Inicio Nota=0 Leea ”digite la nota del examen” Lea nota If nota <= 3.0 entonces Imprimir ”reprobado” Sino Imprimir ”aprobado” Fin si Fin si fin 3. Leer dos números y ver en la pantalla si están en orden crecientes o decrecientes

2

Inicio A=0,b=0 Leer “digite los números” lea a, b si a < b entonces imprimir “ orden creciente” sino imprimir “orden decreciente” Fin_si Fin 4. Realizar un algoritmo que lea tres números por teclado y nos indique cual de ellos es el mayor

Fin si. Sino imprimir “El mayor es “. cubo = n2 * n2 * n2. Lea numero. n3. num2=0. Fin si. Fin. Si numero > 10 entonces imprimir “El número es mayor que 10”. Lea num1. Lea n1. n2. leer “Introduce el segundo número”. Fin. Fin si. Inicio Numero=0 leer “Introduce un número:”. Sino // n1 <= n2. Si numero < 20 entonces imprimir “El número es menor que 20”. Sino // n1 <= n3 imprimir “El mayor es “. Si n1 > n2 entonces // El mayor será n1 o n3 Si n1 > n3 entonces imprimir “El mayor es “. cuadrado = n1 * n1. cuadrado=0 leer “Introduce el primer número”. Fin si. 6. Algoritmo que lea dos números por teclado y muestre un mensaje por pantalla indicando si el cuadrado el primero es mayor que el cubo del segundo Inicio Num1=0. n3. Algoritmo que lea un número por el teclado e indique si el número leído es mayor que 10 y si el número leído es menor que 20. n2. n3. Lea num2. Fin si. Fin si Fin 5.Inicio Imprimir “Introduce 3 números”. Si cuadrado > cubo entonces imprimir “El cuadrado del 1º es mayor que el cubo del 2º”. El mayor será n2 o n3 Si n2 > n3 entonces imprimir “El mayor es “. debemos comparar n2 y n3. cubo=0. n1. .

descuento FIN 8. r=0 Lea (num) r = num mod 2 Si r = 0 Entonces imprimir “ Es par ” Sino imprimir “ Es impar ” fin_si Fin . Inicio: res = "S" frase = Espacios( 30 ) c= 0 si res = "S" entonces leer "Frase: " lea frase c=c+1 imprimir "Deseas introducir m s frases (S/N): " . Introducir tantas frases como queramos y contarlas. monto.res Fin si imprimir "El numero de frases introducidas son: " .7 Dado un monto calcular el descuento considerando que por encima de 100 el descuento es el 10% y por debajo de 100 el descuento es el 2%.c FIN 9. descuento=0 LEER “ di gi t e el m o nt o” Le a monto SI monto 3 100 ENTONCES descuento = monto * 10 / 100 SI NO descuento = monto * 2 / 100 FINSI imprimir “los valores”.Diseñar un algoritmo que permita leer un número y que mediante un mensaje indique su paridad. Inicio Num=0. INICIO Monto=0.

imprimir"El nuevo sueldo es ". Diseñe un algoritmo que calcule el nuevo sueldo de un empleado conociendo su sueldo actual bajo el siguiente criterio. NSUE). PROMEDIO FIN_INICIO NUM CON Número hasta el cual se generarán los múltiplos de 3 Variable de control . Inicio Sueldo=0. Realice un algoritmo Inicio Sue=0 Leea"Ingrese el sueldo: " Lea SUE = Si SUE<500000 entonces AUM = SUE*0.800.10.000 y un 22% en caso contrario. Escriba un programa que genere los primeros N múltiplos de 3 y calcule e imprima: la suma y el promedio INICIO NUMAX=0 SUMA = 0 VARCON = 1 si (CON <= NUM) entonces MULTIPLO = 3 * CON SUMA = SUMA + MULTIPLO CON = CON + 1 FIN SI PROMEDIO = SUMA / NUM IMPRIMA SUMA. A un trabajador se le aplica un aumento del 15% en su salario si _este es menor a 500. NSUE = SUE + AUM.15.000 mil pesos.12 * sueldo sino nsueldo =1. fin si fin 12.2 * sueldo fin_si imprimir nsueldo Fin 11. Aumente en 16% su sueldo si este es superior a s/. nsueldo=0 Leea “digite el sueldo” Lea sueldo Si (sueldo > 800000) entonces nsueldo =1.

Existen tres tipos de jubilaciones: por edad. hasta que se introduce un número negativo y mostrar la suma de dichos números. Fin si imprimir “la suma es:”. Años trabajados leer "Ingrese los anos de trabajo" Lea ATra leer "Ingrese la edad" Lea Edad Si (Edad >= 60 ) y (ATra < 25) Entonces imprimir "Se jubila por edad" Sino Si (Edad < 60) y (ATra >= 25) Entonces Imprimir "Se jubila por antiguedad joven" Sino Si (Edad >= 60) y (ATra >= 25) Entonces imprimir "Se jubila por edad adulta" Sino imprimir "No cumple con los requisito para jubilarse" Finsi Finsi Finsi Fin 14. Leer una secuencia de números. El sistema de pensión requiere clasificar a las personas que se jubilaran en el año de 2012. FIN . Determinar en qué tipo de jubilación. Las personas adscritas a la jubilación por antigüedad joven deben tener menos de 60 años y una antigüedad en su empleo de 25 años o más. Las personas adscritas a la jubilación por antigüedad adulta deben tener 60 años o más y una antigüedad en su empleo de 25 años o más. Las personas adscritas a la jubilación por edad deben tener 60 años o más y una antigüedad en su empleo de menos de 25 años.13. por antigüedad joven y por antigüedad adulta. INICIO Suma = 0. quedara adscrita una persona INICIO Edad Edad del empleado ATra.suma). leer “digite numero” lea numero si (numero > 0) entonces Suma = suma +numero.

Utili Fin 16.40 .10 Sino Si ATra < 10 Entonces Utili =Suel * 0. INICIO Htra=0. sabiendo que cuando las horas de trabajo exceden de 40.05 Sino Si ATra < 2 Entonces Utli = Suel * 0.07 Sino Si ATra < 5 Entonces Utili = Suel * 0.15 Sino Utili = Suel * 0. si las horas extras exceden de 8 se pagan las primeras 8 al doble de lo que se pagan las horas normales y el resto al triple. el resto se consideran horas extras y que estas se pagan al doble de una hora normal cuando no exceden de 8.15 Asigna como un porcentaje de su salario mensual que depende de su antigüedad en la empresa de acuerdo con la siguiente tabla: Tiempo Porcentaje Menos de 1 año 5 % del salario 1 año o más y menos de 2 años 7% del salario 2 años o más y menos de 5 años 10% del salario 5 años o más y menos de 10 años 15% del salario 10 años o más 20% del salario inicio ATra=0 (Años trabajados) Utili=0 (Utilidad) Sue=0 Sueldo Leer "Ingrese los anos trabajados" Lea ATra leer "Ingrese el sueldo" Lea Suel Si ATra < 1 Entonces Utili = Suel * 0. Determinar la cantidad de dinero que recibirá un trabajador por concepto de las horas extras trabajadas en una semana. valh=0 leer "Ingrese el numero de horas trabajadas" Lea Htra leer "Ingrese el valor de la hora" Lea ValH Si Htra > 40 Entonces HExt =Htra .20 Finsi Finsi Finsi Finsi Imprimir "La utilidad es de $".

numero3 leer (“Introduce numero1”). Elaborar un algoritmo que Lea 3 números y mostrar el mayor de ellos. leer“Introduce numero2”. FIN_SI FIN_SI FIN_SI 17. SINO SI (numero2 > numero3) ENTONCES imprimir (“El numero2 es el mayor”).Diseñe un algoritmo que lea tres longitudes y determine si forman o no un triángulo. SINO imprimir (“El numeo3 es el mayor”). isósceles (si tiene dos lados iguales) o escaleno (si tiene tres lados desiguales). INICIO numero1. suma=0 LEA L1. Si es un triángulo determine de que tipo de triángulo se trata entre: equilátero (si tiene tres lados iguales). SI (numero1 > numero2) ENTONCES imprimir (“Introduce numero3”). L3=0.HTra * ValH Finsi Imprimir "Sueldo devengado $".Si HExt > 8 Entonces Salario = (40 * ValH) + (8 * ValH * 2) + ((HExt . L2=0. Salario Fin 17. numero2. L3 // Determina el lado mayor mayor = L1 SI( L2 > mayor ) mayor = L2 SI( L3 > mayor ) mayor = L3 . SI (numero1 > numero3) ENTONCES imprimir(“El numero1 es el mayor”). L2.8) * ValH * 3) Sino Salario = (40 * ValH) + (HExt * ValH * 2) FinSi Sino Salario <. Lea numero3. Considere que para formar un triángulo se requiere que: "el lado mayor sea menor que la suma de los otros dos lados" Algoritmo INICIO L1=0. Lea numero1. Lea (numero2).

66 * tiempo fin−si Imprimir cg Fin . que pesa 70 kg. Inicio Lea act.08 * tiemp si no cg = 1.66 calorías por minuto. Las actividades que tiene permitido realizar son únicamente dormir o estar sentado en reposo./ / Determina la suma de los lados a excepción del lado mayor suma = L1 + L2 + L3 mayor // Determina de que tipo de triángulo se trata SI( mayor < suma ){ SI( ( L1 = L2 ) y ( L2 = L3 ) ) IMPRIMIR "Triángulo equilátero" SINO SI( ( L1 = L2 ) o ( L1 = L3 ) o ( L2 = L3 ) ) IMPRIMIR "Triángulo isósceles" SINO IMPRIMIR "Triángulo escaleno" SINO IMPRIMIR "No es un triángulo" FIN 18. Una persona enferma. tiemp Si act = dormido entonces cg = 1. Los datos que tiene son que estando dormido consume 1.08 calorías por minuto y estando sentado en reposo consume 1. se encuentra en reposo y desea saber cuantas calorías consume su cuerpo durante todo el tiempo que realice una misma actividad.

Sign up to vote on this title
UsefulNot useful