Ejercicios Resueltos

1.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima tanto el nombre como la edad 1. Inicio 2. Declaración de variables: nombre, edad 3. Leer nombre, edad 4. Escribir nombre, edad 5. Fin 2.- Mostrar su nombre, sexo edad y estado civil, que son ingresados por teclado 1. Inicio 2. Declaración de variables: nombre, sexo, estadocivil , edad 3. Leer nombre, sexo, edad, estadocivil 4. Escribir nombre, sexo, edad , estadocivil 5. Fin

3.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima, solo si la persona es mayor de edad, el nombre de la persona. 1. Inicio 2. Declaración de variables: nombre, edad 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Fin SI 6. Fin 4.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima solo si la persona es mayor de edad, el nombre de la persona, de lo contrario, imprima un mensaje que diga : “no puede votar”. 1. Inicio 2. Declaración de variables: nombre, edad // Ec = estado civil 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Sino 6. Escribir “no puede votar !!” 7. Fin SI 8. Fin

Si A>B Entonces Escribir A. edad 4. sexo.. Declaración de variables: nombre. estadocivil 4. SI (sexo = 1) y (estadocivil = 1) y (edad >= 18) Entonces Escribir nombre 5. NOTA: suponga que en el campo denominado sexo el numero 1 es masculino o el numero 2 es femenino 1. el nombre de la persona. “Es el mayor” 8.Desarrolle un algoritmo que permita leer dos valores distintos. sexo. Fin 7. el sexo (1 o 2) y el estado civil de cualquier persona e imprima solo si la persona es un hombre soltero mayor de edad. Inicio 2. sexo. 1. Fin 6. Declaración de variables: nombre. B = 0 3. Fin_Si 10. sexo. edad.. edad 3.. Inicio 2.Ingresar por teclado el nombre. SI (sexo = 1) y (edad >= 18) Entonces Escribir nombre 5. Solicitar la introducción de dos valores distintos 4.5. NOTA: en el campo de estado civil se graba el numero 1 en vez de soltero. Asignarlos a las variables A y B 6. Leer los dos valores 5. Inicializar variables: A = 0. “Es el mayor” 9. Leer nombre. edad 3. el numero 2 en vez de casado o el numero 3 en vez de otro. el nombre de la persona. la edad. Fin SI 6. la edad y el sexo de cualquier persona e imprima. Leer nombre. Inicio 2. solo si la persona es de sexo masculino y mayor de edad. determinar cual de los dos valores es el mayor y escribirlo. Fin . De lo contrario: Escribir B. 1.Ingresar por teclado el nombre. Fin SI 6. Si A = B Entonces vuelve a 3 porque los valores deben ser distintos 7. estadocivil .

Sino 11. B y C 5. Escribir el valor de la Hipotenusa 7. 1. Inicio 2. Repetir desde el paso 3 8. Escribir B “Es el mayor” 10. Inicio 2. Recuerde constatar que los tres valores introducidos por el teclado sean valores distintos. Fin_Si 9. Calcular el valor de Hip con la formula indicada 6.Desarrolle un algoritmo que realice la sumatoria de los números enteros comprendidos entre el 1 y el 10. Fin . Escribir C “Es el mayor” 12. Leer el valor de cada cateto 4..Determinar la hipotenusa de un triángulo rectángulo conocidas las longitudes de sus dos catetos.8. Sino 8. es decir. Fin 9. 1 + 2 + 3 + …. De lo contrario. Asignación Contador :N = N + 1 4. Escribir Suma 7. B y C respectivamente. Desarrolle el algoritmo correspondiente. Fin 10.CatB=0 3. Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales. Si N = 10 Entonces 6. Almacenarlo en la variable CatA y CatB 5. Declaración de Variables: CatA= 0. Suma = 0 3. Si A > B y A > C Entonces 6. El algoritmo debe imprimir cual es el mayor y cual es el menor. 1.. Fin_Si 13. Inicializar las variables A. Si B > A y B > C Entonces 9. Inicio 2.Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A.. Almacenar en las variables A. Leer los tres valores 4. B y C 3. Fin_Si 14. 1. Declaración de variables:N= 0. Asignación Acumulador:Suma = Suma + N 5. Escribir A “Es el mayor” 7. + 10.

Asignar a A = Temporal 8. Si no (De lo contrario) 9. Declaración de variables: N 3.. Asignarlo a la variable N 5. Declaración de Variables:A = 0. Sino: Escribir “Es impar” 8. Inicio 2.Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si dicho número es par o impar. Leer un número 4. Declaración de variables: R = 0. Fin 13. 1. Asignar a Temporal = B 6. Inicio 2.Desarrolle un algoritmo que permita determinar el área y volumen de un cilindro dado su radio (R) y altura (H). 1. 1. Inicio 2. Fin_Si 10. Fin 12. B 11. Leer el valor de Radio (R) y Altura (H) 4.. Asignar a B = A 7. Escribir el valor del Área y del Volumen 7.Desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor. Leer A y B 4. B = 0.. Calcular el Volumen aplicando la fórmula 5. Fin_Si 9. Si el residuo de dividir a N entre 2 es igual a cero 6. H = 0 3. si es el caso. Temporal = 0 3. Escribir “Orden = “.11. Si es Si: Entonces: Escribir “ Es par” 7. Si A<B Entonces 5. Calcular el valor del área aplicando la fórmula respectiva 6. Fin . A.

Mientras N <> 0 hacer 5. Promedio = 0. Fin_Si 15. Fin del ciclo mientras 10.Desarrolle un algoritmo que permita calcular Promedio de Notas. expresada en kilómetros por hora. Inicio 2. Inicio 2. Si N / J =0 6. Leer N 4. Declaración de variables: J = 2. Escribir N “no es primo” 14.Versal 6. S =0 3. Acumula= 0 3.Realice un algoritmo que a partir de proporcionarle la velocidad de un automóvil. Inicio 2. Escribir N “es primo” 12. Sino (De lo contrario) 13. J=J+1 8. Leer N 4.14. Fin Mientras 8. Leer Datos: Vel 4. Mientras J<= N / 2 hacer 5.. 1. Declaración de Variables: N = 0. Escribir “Promedio:”. Si S = 0 Entonces 11. Fin_Si 9. Fin 16. Declaración de Variables: Versal . Versal = (Vel * 1000) / 3600 5. Fin 15. Vel = 0 3. Fin . Promedio 10. 1. Promedio = Acumula/Cuenta 9. 1. Cuenta = Cuenta + 1 6..Desarrolle un algoritmo que permita leer un valor entero positivo N y determinar si es primo o no. S=S+1 7.. Acumula = Acumula + N 7. finaliza cuando N = 0. Escribir “resultado = “. proporcione la velocidad en metros por segundo.

que le permita calcular e imprimir la nómina para su cancelación a un total de 50 obreros calificados a quienes debe cancelar por horas trabajadas. Imprimir líneas de títulos de la nómina 4. La hora trabajada se pautó en 2500 Pesos 1. Numero_Obreros = Numero_Obreros . Escribir “Total : “.Desarrolle un algoritmo para la empresa Constructora Casas S. Leer Datos 11. Inicio 2.17. Mientras Numero_Obreros>0 6.A. Total_nómina= Totalnómina + Salario 8. Leer Datos 5. Salario = Numero_Hora_Trabajada * 30 7.. Escribir Registro 10. Declaración de Variables: Numero_Obreros =50 Numero_Hora_Trabajada = 0 Total_nomina = 0 3.. Total_nómina 13. Fin . Fin_Mientras 12.1 9.

n y el resultado de la sumatoria. Fin_Para 7. Para i = 0 a ex 5.18. crear y utilizar una función POTEN que tenga como parámetros la base x y el exponente i. p = p * bas 6. Fin Función poten 1. Fin_Para 7.. 1. ex 4.Escribir un programa que calcule la expresión: Ʃ x^i . Leer x. Inicio 2.. Inicio 2. Suma = Suma + poten (x. Declaración de Variables: bas i=0 ex p=0 3. Para i = 0 a n 5. Para evaluar cada uno de los términos de la sumatoria. i) 6.n) para cualquier par de valores de n y x. Exhibir x. Declaración de Variables: Suma = 0 i=0 3. (Ʃ  0. Escribir x.. Suma 8. Recibir bas. Retornar p 8.n. n 4.. Fin .

Escribir “El mes tiene”.12 Entonces dias_mes31 7. Fin_Si 10. Declaración de Variables: dias_mes=0 i 3. Fin_Si 6.8. dia_mes (mes). Si (mes < 1) o (mes > 12) Entonces 6. Declaración de Variables: mes= 0 3. Recibir i 4.19.5.7.')” 9. Sino (De lo contrario) 8. Si i=1.7.3.10.10.' dias. Fin_Si 8.8.3. Fin_Si 12. Fin_Si 8. Escribir “Introduzca un numero del 1 al 12:” 4. Si i=1. Inicio 2.12 Entonces dias_mes31 9. Si i=1.8. Escribir “El numero introducido no corresponde a ningun mes” 7.10.5..3.5. Fin Función dia_mes 1. Inicio 2. 1. Retornar dias_mes 11. Si (mes = 2) Entonces 10. Fin . Escribir “El o 29 si es año bisiesto'” 11.12 Entonces dias_mes31 5.7.Escribir un programa que reciba un numero del 1 al 12 desde el teclado y muestre el número de días correspondiente al mes que corresponda con ese día (usar funciones). Leer mes 5.

Imprima el nombre del empleado y su salario neto. y si es negativo que lo imprima. saque su promedio e imprima su nombre. 8) Desarrolle un algoritmo que le permita determinar dadas tres cajas cada una con 15 números. El número medio es aquel que no es el mayor ni el menor. 2) Desarrolle un algoritmo que permita determinar de una serie de números cuántos son par.2 etc. impar o cero.Ejercicios Por Resolver 1) Desarrolle un algoritmo que permita determinar si un número dado es par. el sexo y el estado civil de cualquier persona e imprima el nombre de la persona si es un hombre casado y mayor de 40 años o una mujer soltera menor de 50 años. 3) Desarrolle un algoritmo que lea un número. Calcule el salario neto. en cuál caja está un número dado. número de carnet y el promedio. teniendo en cuenta que si el número de horas trabajadas durante la semana es mayor de 48 horas. Recuerde que la serie de Fibonacci se genera empezando con los números 0 y 1 y calculando cada nuevo miembro como la suma de dos . la edad . 9) Desarrolle un algoritmo que le permita determinar el número medio de tres números. 10) Desarrolle un algoritmo que le permita obtener la sucesión de Fibonacci 0. impar o cero. esas horas demás se consideran horas extras y tienen un recargo del 35%. 7) Desarrolle un algoritmo para leer el nombre de un empleado.1. imprima el número si es negativo y el positivo del mismo. 4) Desarrolle un algoritmo que lea una serie de números.1. 5) Desarrolle un algoritmo que le permita leer el nombre. 6) Desarrolle un algoritmo que le permita leer las notas de las materias que ha cursado un estudiante hasta el momento. el salario básico por hora y el número de horas trabajadas durante una semana.

miembros precedentes en la sucesión. Imprima los primeros n términos de la sucesión. calcule Para X positivo: F(x) = (x . Elabore un algoritmo que calcule el total a pagar por la familia. para las familias con hijos en el colegio.6) 6 2 4 6 Para X negativo: F(x) = (x + 2) 2 + (x + 4) 4 + (x + 6) 6 2 4 6 12) Elabore un algoritmo. 13) El colegio “Mi angelito” desea calcular el monto a pagar por inscripción del nuevo año escolar. su nombre. el monto de la mensualidad del mes de septiembre por niño y el monto de la sociedad de padres. tipo de trabajador.2) 2 + (x . El porcentaje de aumento del sueldo viene dado por el tipo de trabajador que es: Tipo de trabajador „V‟ 10% „G‟ 15% „E‟ 20% „O‟ 30% Adicionalmente se le paga una prima por cada hijo la cual es conocida y la misma para todos.4) 4 + (x . si la sociedad de padres se cobra una vez por familiar y si se otorga un descuento por la cantidad de hijos en el colegio que viene dado por la siguiente tabla. Cantidad de hijos 2 niños 3 niños > 3 niños Descuento 10% 15% 20% . Para ello se conoce el numero de hijos que tiene la familia en el colegio. conociendo del mismo. que calcule el aumento de sueldo de un trabajador. 11) Elabore un algoritmo que dado un valor X. su sueldo y la cantidad de hijos que tiene. el monto de matricula por niño.

Sign up to vote on this title
UsefulNot useful