Ejercicios Resueltos

1.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima tanto el nombre como la edad 1. Inicio 2. Declaración de variables: nombre, edad 3. Leer nombre, edad 4. Escribir nombre, edad 5. Fin 2.- Mostrar su nombre, sexo edad y estado civil, que son ingresados por teclado 1. Inicio 2. Declaración de variables: nombre, sexo, estadocivil , edad 3. Leer nombre, sexo, edad, estadocivil 4. Escribir nombre, sexo, edad , estadocivil 5. Fin

3.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima, solo si la persona es mayor de edad, el nombre de la persona. 1. Inicio 2. Declaración de variables: nombre, edad 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Fin SI 6. Fin 4.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima solo si la persona es mayor de edad, el nombre de la persona, de lo contrario, imprima un mensaje que diga : “no puede votar”. 1. Inicio 2. Declaración de variables: nombre, edad // Ec = estado civil 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Sino 6. Escribir “no puede votar !!” 7. Fin SI 8. Fin

edad 4. Fin . Leer nombre. solo si la persona es de sexo masculino y mayor de edad. Si A = B Entonces vuelve a 3 porque los valores deben ser distintos 7. sexo. edad 3.5. SI (sexo = 1) y (estadocivil = 1) y (edad >= 18) Entonces Escribir nombre 5. Leer nombre. NOTA: en el campo de estado civil se graba el numero 1 en vez de soltero. sexo. edad.Ingresar por teclado el nombre. NOTA: suponga que en el campo denominado sexo el numero 1 es masculino o el numero 2 es femenino 1. Leer los dos valores 5. Fin 7.Desarrolle un algoritmo que permita leer dos valores distintos. Declaración de variables: nombre.. B = 0 3. “Es el mayor” 9. Fin 6. la edad y el sexo de cualquier persona e imprima.. Solicitar la introducción de dos valores distintos 4. estadocivil . Si A>B Entonces Escribir A. Fin SI 6. el sexo (1 o 2) y el estado civil de cualquier persona e imprima solo si la persona es un hombre soltero mayor de edad. la edad. estadocivil 4. “Es el mayor” 8.. Declaración de variables: nombre. Inicio 2. el numero 2 en vez de casado o el numero 3 en vez de otro. determinar cual de los dos valores es el mayor y escribirlo. Fin_Si 10. edad 3. Fin SI 6. sexo. Inicializar variables: A = 0. sexo. Inicio 2. Asignarlos a las variables A y B 6. el nombre de la persona. 1. el nombre de la persona. Inicio 2. De lo contrario: Escribir B. SI (sexo = 1) y (edad >= 18) Entonces Escribir nombre 5. 1.Ingresar por teclado el nombre.

Calcular el valor de Hip con la formula indicada 6. Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales. + 10. Almacenarlo en la variable CatA y CatB 5. 1. B y C respectivamente. Almacenar en las variables A. De lo contrario. Escribir A “Es el mayor” 7. Declaración de variables:N= 0. Asignación Contador :N = N + 1 4. Fin . Si B > A y B > C Entonces 9. Escribir B “Es el mayor” 10. Sino 11.. Asignación Acumulador:Suma = Suma + N 5. Si A > B y A > C Entonces 6. Desarrolle el algoritmo correspondiente. 1 + 2 + 3 + …. es decir. Inicializar las variables A... Si N = 10 Entonces 6. Repetir desde el paso 3 8. Recuerde constatar que los tres valores introducidos por el teclado sean valores distintos. B y C 3. Fin_Si 13. Escribir el valor de la Hipotenusa 7. Leer el valor de cada cateto 4. Inicio 2. Inicio 2. Fin_Si 9. Escribir Suma 7. Sino 8. B y C 5. Fin 9. Suma = 0 3. 1. 1. Declaración de Variables: CatA= 0. El algoritmo debe imprimir cual es el mayor y cual es el menor. Inicio 2.8. Fin_Si 14.Desarrolle un algoritmo que realice la sumatoria de los números enteros comprendidos entre el 1 y el 10. Fin 10.CatB=0 3.Determinar la hipotenusa de un triángulo rectángulo conocidas las longitudes de sus dos catetos.Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A. Escribir C “Es el mayor” 12. Leer los tres valores 4.

Declaración de variables: R = 0.Desarrolle un algoritmo que permita determinar el área y volumen de un cilindro dado su radio (R) y altura (H). A. Asignar a Temporal = B 6. Asignar a B = A 7. Si es Si: Entonces: Escribir “ Es par” 7.. Calcular el Volumen aplicando la fórmula 5. Si no (De lo contrario) 9. 1. Fin 13. Inicio 2. Declaración de variables: N 3. Si el residuo de dividir a N entre 2 es igual a cero 6. 1. Fin .. Declaración de Variables:A = 0. Temporal = 0 3. Asignar a A = Temporal 8. Leer A y B 4. Inicio 2. Fin_Si 9. H = 0 3.. B 11. Sino: Escribir “Es impar” 8. Fin 12. Leer un número 4. Escribir “Orden = “. Fin_Si 10. si es el caso. Leer el valor de Radio (R) y Altura (H) 4. Inicio 2.11. 1. B = 0. Calcular el valor del área aplicando la fórmula respectiva 6. Si A<B Entonces 5.Desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor.Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si dicho número es par o impar. Escribir el valor del Área y del Volumen 7. Asignarlo a la variable N 5.

Versal 6. Escribir N “no es primo” 14. Promedio = Acumula/Cuenta 9. Leer Datos: Vel 4. 1. Escribir “resultado = “. Si S = 0 Entonces 11. Leer N 4. Acumula = Acumula + N 7.. Inicio 2.Desarrolle un algoritmo que permita calcular Promedio de Notas. J=J+1 8. Fin_Si 15. Vel = 0 3. proporcione la velocidad en metros por segundo. Declaración de variables: J = 2. Sino (De lo contrario) 13. Inicio 2. Fin . Fin Mientras 8. Fin del ciclo mientras 10. S =0 3. Escribir “Promedio:”. Escribir N “es primo” 12. expresada en kilómetros por hora.Desarrolle un algoritmo que permita leer un valor entero positivo N y determinar si es primo o no. 1. Mientras J<= N / 2 hacer 5. Promedio = 0. Inicio 2. Declaración de Variables: Versal . Leer N 4. Promedio 10.. finaliza cuando N = 0. S=S+1 7.14. Fin 16. Acumula= 0 3.Realice un algoritmo que a partir de proporcionarle la velocidad de un automóvil. Versal = (Vel * 1000) / 3600 5. Cuenta = Cuenta + 1 6. Mientras N <> 0 hacer 5. Declaración de Variables: N = 0. 1.. Fin_Si 9. Si N / J =0 6. Fin 15.

Escribir Registro 10. Total_nómina 13.. Escribir “Total : “.. Leer Datos 5. que le permita calcular e imprimir la nómina para su cancelación a un total de 50 obreros calificados a quienes debe cancelar por horas trabajadas. Fin_Mientras 12. Declaración de Variables: Numero_Obreros =50 Numero_Hora_Trabajada = 0 Total_nomina = 0 3. Total_nómina= Totalnómina + Salario 8. La hora trabajada se pautó en 2500 Pesos 1. Inicio 2. Numero_Obreros = Numero_Obreros . Leer Datos 11. Mientras Numero_Obreros>0 6.1 9.Desarrolle un algoritmo para la empresa Constructora Casas S. Fin . Salario = Numero_Hora_Trabajada * 30 7.A.17. Imprimir líneas de títulos de la nómina 4.

Exhibir x.. ex 4. Inicio 2. Fin .. Fin_Para 7. i) 6. Recibir bas.Escribir un programa que calcule la expresión: Ʃ x^i . Fin_Para 7. 1. (Ʃ  0. n 4. Inicio 2. n y el resultado de la sumatoria. Suma 8. Fin Función poten 1. p = p * bas 6. Declaración de Variables: Suma = 0 i=0 3.n. Leer x.18... crear y utilizar una función POTEN que tenga como parámetros la base x y el exponente i.n) para cualquier par de valores de n y x. Para evaluar cada uno de los términos de la sumatoria. Suma = Suma + poten (x. Para i = 0 a ex 5. Para i = 0 a n 5. Escribir x. Retornar p 8. Declaración de Variables: bas i=0 ex p=0 3.

Leer mes 5. Si i=1.8. Recibir i 4. 1.7. Fin_Si 10.12 Entonces dias_mes31 9. Escribir “El o 29 si es año bisiesto'” 11. Escribir “El mes tiene”.5.3.7. Fin_Si 8.Escribir un programa que reciba un numero del 1 al 12 desde el teclado y muestre el número de días correspondiente al mes que corresponda con ese día (usar funciones).12 Entonces dias_mes31 7. Escribir “Introduzca un numero del 1 al 12:” 4.3.3. Si i=1. Retornar dias_mes 11. Fin_Si 6. Fin_Si 12.12 Entonces dias_mes31 5. Declaración de Variables: dias_mes=0 i 3. Inicio 2.7. Fin_Si 8. Inicio 2. Escribir “El numero introducido no corresponde a ningun mes” 7.10.5. Si i=1. Si (mes < 1) o (mes > 12) Entonces 6.8..5.10.10. dia_mes (mes). Fin Función dia_mes 1.8. Si (mes = 2) Entonces 10.')” 9. Declaración de Variables: mes= 0 3.' dias. Sino (De lo contrario) 8.19. Fin .

6) Desarrolle un algoritmo que le permita leer las notas de las materias que ha cursado un estudiante hasta el momento. 2) Desarrolle un algoritmo que permita determinar de una serie de números cuántos son par. teniendo en cuenta que si el número de horas trabajadas durante la semana es mayor de 48 horas.Ejercicios Por Resolver 1) Desarrolle un algoritmo que permita determinar si un número dado es par. impar o cero. el salario básico por hora y el número de horas trabajadas durante una semana.1. el sexo y el estado civil de cualquier persona e imprima el nombre de la persona si es un hombre casado y mayor de 40 años o una mujer soltera menor de 50 años. impar o cero.1. Imprima el nombre del empleado y su salario neto. 7) Desarrolle un algoritmo para leer el nombre de un empleado. esas horas demás se consideran horas extras y tienen un recargo del 35%.2 etc. 10) Desarrolle un algoritmo que le permita obtener la sucesión de Fibonacci 0. 9) Desarrolle un algoritmo que le permita determinar el número medio de tres números. 3) Desarrolle un algoritmo que lea un número. la edad . El número medio es aquel que no es el mayor ni el menor. en cuál caja está un número dado. y si es negativo que lo imprima. 8) Desarrolle un algoritmo que le permita determinar dadas tres cajas cada una con 15 números. Recuerde que la serie de Fibonacci se genera empezando con los números 0 y 1 y calculando cada nuevo miembro como la suma de dos . 4) Desarrolle un algoritmo que lea una serie de números. 5) Desarrolle un algoritmo que le permita leer el nombre. saque su promedio e imprima su nombre. imprima el número si es negativo y el positivo del mismo. número de carnet y el promedio. Calcule el salario neto.

su sueldo y la cantidad de hijos que tiene. conociendo del mismo.4) 4 + (x . Elabore un algoritmo que calcule el total a pagar por la familia. el monto de la mensualidad del mes de septiembre por niño y el monto de la sociedad de padres. tipo de trabajador. 13) El colegio “Mi angelito” desea calcular el monto a pagar por inscripción del nuevo año escolar. Cantidad de hijos 2 niños 3 niños > 3 niños Descuento 10% 15% 20% . Para ello se conoce el numero de hijos que tiene la familia en el colegio. que calcule el aumento de sueldo de un trabajador. 11) Elabore un algoritmo que dado un valor X. calcule Para X positivo: F(x) = (x .2) 2 + (x . su nombre.6) 6 2 4 6 Para X negativo: F(x) = (x + 2) 2 + (x + 4) 4 + (x + 6) 6 2 4 6 12) Elabore un algoritmo. el monto de matricula por niño. Imprima los primeros n términos de la sucesión. El porcentaje de aumento del sueldo viene dado por el tipo de trabajador que es: Tipo de trabajador „V‟ 10% „G‟ 15% „E‟ 20% „O‟ 30% Adicionalmente se le paga una prima por cada hijo la cual es conocida y la misma para todos. para las familias con hijos en el colegio.miembros precedentes en la sucesión. si la sociedad de padres se cobra una vez por familiar y si se otorga un descuento por la cantidad de hijos en el colegio que viene dado por la siguiente tabla.

Sign up to vote on this title
UsefulNot useful