P. 1
Algoritmos Ejercicios Resueltos

Algoritmos Ejercicios Resueltos

|Views: 15.838|Likes:
Publicado porAndres Aravena

More info:

Published by: Andres Aravena on Apr 30, 2012
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOCX, PDF, TXT or read online from Scribd
See more
See less

08/20/2013

pdf

text

original

Ejercicios Resueltos

1.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima tanto el nombre como la edad 1. Inicio 2. Declaración de variables: nombre, edad 3. Leer nombre, edad 4. Escribir nombre, edad 5. Fin 2.- Mostrar su nombre, sexo edad y estado civil, que son ingresados por teclado 1. Inicio 2. Declaración de variables: nombre, sexo, estadocivil , edad 3. Leer nombre, sexo, edad, estadocivil 4. Escribir nombre, sexo, edad , estadocivil 5. Fin

3.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima, solo si la persona es mayor de edad, el nombre de la persona. 1. Inicio 2. Declaración de variables: nombre, edad 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Fin SI 6. Fin 4.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima solo si la persona es mayor de edad, el nombre de la persona, de lo contrario, imprima un mensaje que diga : “no puede votar”. 1. Inicio 2. Declaración de variables: nombre, edad // Ec = estado civil 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Sino 6. Escribir “no puede votar !!” 7. Fin SI 8. Fin

edad 4. De lo contrario: Escribir B. edad 3. sexo. SI (sexo = 1) y (edad >= 18) Entonces Escribir nombre 5. edad 3.Ingresar por teclado el nombre.. Fin_Si 10.5. sexo. la edad. el nombre de la persona. 1. Inicio 2. solo si la persona es de sexo masculino y mayor de edad. Inicio 2. 1. Fin SI 6. Fin . Leer nombre. Si A = B Entonces vuelve a 3 porque los valores deben ser distintos 7. Declaración de variables: nombre. B = 0 3. Declaración de variables: nombre. estadocivil 4. Fin 6. “Es el mayor” 9. “Es el mayor” 8. Leer los dos valores 5. sexo. Inicializar variables: A = 0. edad.Ingresar por teclado el nombre. Fin 7. SI (sexo = 1) y (estadocivil = 1) y (edad >= 18) Entonces Escribir nombre 5.. el sexo (1 o 2) y el estado civil de cualquier persona e imprima solo si la persona es un hombre soltero mayor de edad. NOTA: suponga que en el campo denominado sexo el numero 1 es masculino o el numero 2 es femenino 1. estadocivil . determinar cual de los dos valores es el mayor y escribirlo. el nombre de la persona. Asignarlos a las variables A y B 6. Si A>B Entonces Escribir A.. sexo. Solicitar la introducción de dos valores distintos 4. Fin SI 6. Leer nombre.Desarrolle un algoritmo que permita leer dos valores distintos. la edad y el sexo de cualquier persona e imprima. NOTA: en el campo de estado civil se graba el numero 1 en vez de soltero. el numero 2 en vez de casado o el numero 3 en vez de otro. Inicio 2.

Escribir Suma 7. Si N = 10 Entonces 6. Suma = 0 3. Recuerde constatar que los tres valores introducidos por el teclado sean valores distintos. + 10. Inicio 2. Si A > B y A > C Entonces 6. Leer los tres valores 4. Declaración de variables:N= 0. De lo contrario. B y C respectivamente. B y C 3.. Sino 11. 1 + 2 + 3 + …. Inicio 2. Fin_Si 13. Escribir A “Es el mayor” 7. Inicio 2. Si B > A y B > C Entonces 9. Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales.CatB=0 3. Fin 10. Desarrolle el algoritmo correspondiente. 1. Repetir desde el paso 3 8. El algoritmo debe imprimir cual es el mayor y cual es el menor.. Declaración de Variables: CatA= 0. Fin 9. Asignación Contador :N = N + 1 4.Determinar la hipotenusa de un triángulo rectángulo conocidas las longitudes de sus dos catetos. Escribir C “Es el mayor” 12. Inicializar las variables A.8. Sino 8.Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A. es decir. B y C 5. Calcular el valor de Hip con la formula indicada 6. Almacenar en las variables A. Fin_Si 14. 1. Fin . Escribir el valor de la Hipotenusa 7. Leer el valor de cada cateto 4.Desarrolle un algoritmo que realice la sumatoria de los números enteros comprendidos entre el 1 y el 10. Fin_Si 9.. Asignación Acumulador:Suma = Suma + N 5. Almacenarlo en la variable CatA y CatB 5. 1. Escribir B “Es el mayor” 10.

Fin_Si 9. Asignar a Temporal = B 6. Leer un número 4. Fin 12. H = 0 3.Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si dicho número es par o impar. Asignar a B = A 7. Inicio 2.11. Si el residuo de dividir a N entre 2 es igual a cero 6. Asignar a A = Temporal 8.Desarrolle un algoritmo que permita determinar el área y volumen de un cilindro dado su radio (R) y altura (H). 1. Asignarlo a la variable N 5. Leer A y B 4. Declaración de Variables:A = 0. Si no (De lo contrario) 9. Si A<B Entonces 5. Declaración de variables: N 3.. Escribir el valor del Área y del Volumen 7. Calcular el Volumen aplicando la fórmula 5. 1. Escribir “Orden = “. 1. Fin 13. Inicio 2. A. Calcular el valor del área aplicando la fórmula respectiva 6. Leer el valor de Radio (R) y Altura (H) 4. Declaración de variables: R = 0. Inicio 2. Fin . Temporal = 0 3. si es el caso. Sino: Escribir “Es impar” 8.. B 11. Fin_Si 10. B = 0.Desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor. Si es Si: Entonces: Escribir “ Es par” 7..

Escribir “resultado = “. Leer N 4. Fin 15. 1. Declaración de Variables: N = 0. Promedio 10. Leer N 4. J=J+1 8. Mientras J<= N / 2 hacer 5. proporcione la velocidad en metros por segundo. Inicio 2. Promedio = Acumula/Cuenta 9. Cuenta = Cuenta + 1 6. expresada en kilómetros por hora. finaliza cuando N = 0. Inicio 2. Fin_Si 9. Vel = 0 3. Escribir N “es primo” 12. S=S+1 7.Desarrolle un algoritmo que permita calcular Promedio de Notas. Inicio 2.Realice un algoritmo que a partir de proporcionarle la velocidad de un automóvil. Fin del ciclo mientras 10. Fin 16.. Fin . Fin_Si 15. Declaración de Variables: Versal . 1. S =0 3. Fin Mientras 8.. Sino (De lo contrario) 13.14. Leer Datos: Vel 4. Declaración de variables: J = 2.Versal 6. 1. Promedio = 0.Desarrolle un algoritmo que permita leer un valor entero positivo N y determinar si es primo o no. Acumula = Acumula + N 7. Versal = (Vel * 1000) / 3600 5. Si N / J =0 6. Acumula= 0 3. Escribir “Promedio:”.. Mientras N <> 0 hacer 5. Escribir N “no es primo” 14. Si S = 0 Entonces 11.

Total_nómina 13.Desarrolle un algoritmo para la empresa Constructora Casas S. Total_nómina= Totalnómina + Salario 8. Numero_Obreros = Numero_Obreros . Imprimir líneas de títulos de la nómina 4.. Leer Datos 11. Escribir Registro 10. Leer Datos 5.. Inicio 2.A. que le permita calcular e imprimir la nómina para su cancelación a un total de 50 obreros calificados a quienes debe cancelar por horas trabajadas. Escribir “Total : “.1 9. Fin . La hora trabajada se pautó en 2500 Pesos 1. Salario = Numero_Hora_Trabajada * 30 7. Mientras Numero_Obreros>0 6. Declaración de Variables: Numero_Obreros =50 Numero_Hora_Trabajada = 0 Total_nomina = 0 3.17. Fin_Mientras 12.

n 4.Escribir un programa que calcule la expresión: Ʃ x^i . Fin Función poten 1.n.18. Fin_Para 7. Para evaluar cada uno de los términos de la sumatoria. Recibir bas. Para i = 0 a ex 5. Declaración de Variables: bas i=0 ex p=0 3. Inicio 2. Exhibir x. Leer x. Escribir x. 1. Para i = 0 a n 5. Fin . Suma = Suma + poten (x. Inicio 2. Retornar p 8... Fin_Para 7. i) 6.n) para cualquier par de valores de n y x. ex 4. Suma 8.. p = p * bas 6. n y el resultado de la sumatoria. Declaración de Variables: Suma = 0 i=0 3. crear y utilizar una función POTEN que tenga como parámetros la base x y el exponente i. (Ʃ  0..

Fin_Si 12.10. Si i=1.7.')” 9.8.3. Sino (De lo contrario) 8.7. Si i=1. dia_mes (mes). Inicio 2. Declaración de Variables: dias_mes=0 i 3. Escribir “El mes tiene”.8. Fin_Si 8. Fin Función dia_mes 1. Escribir “El o 29 si es año bisiesto'” 11. Escribir “Introduzca un numero del 1 al 12:” 4..5. Escribir “El numero introducido no corresponde a ningun mes” 7. Si i=1. Fin . 1.10.5. Retornar dias_mes 11. Inicio 2.10. Recibir i 4. Si (mes < 1) o (mes > 12) Entonces 6.Escribir un programa que reciba un numero del 1 al 12 desde el teclado y muestre el número de días correspondiente al mes que corresponda con ese día (usar funciones). Declaración de Variables: mes= 0 3.5. Si (mes = 2) Entonces 10.' dias.12 Entonces dias_mes31 5.7.19.3. Fin_Si 10.8. Fin_Si 6. Fin_Si 8.12 Entonces dias_mes31 9.3.12 Entonces dias_mes31 7. Leer mes 5.

2 etc. 2) Desarrolle un algoritmo que permita determinar de una serie de números cuántos son par. 5) Desarrolle un algoritmo que le permita leer el nombre. y si es negativo que lo imprima. la edad . impar o cero. en cuál caja está un número dado. 4) Desarrolle un algoritmo que lea una serie de números. Calcule el salario neto. 10) Desarrolle un algoritmo que le permita obtener la sucesión de Fibonacci 0.Ejercicios Por Resolver 1) Desarrolle un algoritmo que permita determinar si un número dado es par.1. 8) Desarrolle un algoritmo que le permita determinar dadas tres cajas cada una con 15 números. el sexo y el estado civil de cualquier persona e imprima el nombre de la persona si es un hombre casado y mayor de 40 años o una mujer soltera menor de 50 años. imprima el número si es negativo y el positivo del mismo. 9) Desarrolle un algoritmo que le permita determinar el número medio de tres números. 3) Desarrolle un algoritmo que lea un número. teniendo en cuenta que si el número de horas trabajadas durante la semana es mayor de 48 horas. número de carnet y el promedio. impar o cero. 7) Desarrolle un algoritmo para leer el nombre de un empleado. Recuerde que la serie de Fibonacci se genera empezando con los números 0 y 1 y calculando cada nuevo miembro como la suma de dos . El número medio es aquel que no es el mayor ni el menor. 6) Desarrolle un algoritmo que le permita leer las notas de las materias que ha cursado un estudiante hasta el momento. Imprima el nombre del empleado y su salario neto.1. el salario básico por hora y el número de horas trabajadas durante una semana. saque su promedio e imprima su nombre. esas horas demás se consideran horas extras y tienen un recargo del 35%.

4) 4 + (x . 13) El colegio “Mi angelito” desea calcular el monto a pagar por inscripción del nuevo año escolar.2) 2 + (x . calcule Para X positivo: F(x) = (x . conociendo del mismo. el monto de la mensualidad del mes de septiembre por niño y el monto de la sociedad de padres. Cantidad de hijos 2 niños 3 niños > 3 niños Descuento 10% 15% 20% .miembros precedentes en la sucesión. que calcule el aumento de sueldo de un trabajador. su nombre. Elabore un algoritmo que calcule el total a pagar por la familia. para las familias con hijos en el colegio. 11) Elabore un algoritmo que dado un valor X.6) 6 2 4 6 Para X negativo: F(x) = (x + 2) 2 + (x + 4) 4 + (x + 6) 6 2 4 6 12) Elabore un algoritmo. Imprima los primeros n términos de la sucesión. su sueldo y la cantidad de hijos que tiene. si la sociedad de padres se cobra una vez por familiar y si se otorga un descuento por la cantidad de hijos en el colegio que viene dado por la siguiente tabla. Para ello se conoce el numero de hijos que tiene la familia en el colegio. el monto de matricula por niño. tipo de trabajador. El porcentaje de aumento del sueldo viene dado por el tipo de trabajador que es: Tipo de trabajador „V‟ 10% „G‟ 15% „E‟ 20% „O‟ 30% Adicionalmente se le paga una prima por cada hijo la cual es conocida y la misma para todos.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->