Ejercicios Resueltos

1.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima tanto el nombre como la edad 1. Inicio 2. Declaración de variables: nombre, edad 3. Leer nombre, edad 4. Escribir nombre, edad 5. Fin 2.- Mostrar su nombre, sexo edad y estado civil, que son ingresados por teclado 1. Inicio 2. Declaración de variables: nombre, sexo, estadocivil , edad 3. Leer nombre, sexo, edad, estadocivil 4. Escribir nombre, sexo, edad , estadocivil 5. Fin

3.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima, solo si la persona es mayor de edad, el nombre de la persona. 1. Inicio 2. Declaración de variables: nombre, edad 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Fin SI 6. Fin 4.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima solo si la persona es mayor de edad, el nombre de la persona, de lo contrario, imprima un mensaje que diga : “no puede votar”. 1. Inicio 2. Declaración de variables: nombre, edad // Ec = estado civil 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Sino 6. Escribir “no puede votar !!” 7. Fin SI 8. Fin

el nombre de la persona. Fin_Si 10.Desarrolle un algoritmo que permita leer dos valores distintos. el nombre de la persona. Fin 7. Si A = B Entonces vuelve a 3 porque los valores deben ser distintos 7. sexo. NOTA: en el campo de estado civil se graba el numero 1 en vez de soltero. la edad. Fin 6. Declaración de variables: nombre. Fin SI 6. edad 3. determinar cual de los dos valores es el mayor y escribirlo..5.Ingresar por teclado el nombre. “Es el mayor” 8. B = 0 3. Inicio 2. SI (sexo = 1) y (edad >= 18) Entonces Escribir nombre 5. solo si la persona es de sexo masculino y mayor de edad. edad 3. NOTA: suponga que en el campo denominado sexo el numero 1 es masculino o el numero 2 es femenino 1. Fin . sexo. Inicio 2. “Es el mayor” 9. el numero 2 en vez de casado o el numero 3 en vez de otro. estadocivil 4. edad. SI (sexo = 1) y (estadocivil = 1) y (edad >= 18) Entonces Escribir nombre 5. edad 4.. Leer nombre. Leer los dos valores 5. Si A>B Entonces Escribir A. Inicio 2. la edad y el sexo de cualquier persona e imprima.Ingresar por teclado el nombre. Leer nombre. sexo. Declaración de variables: nombre. 1. el sexo (1 o 2) y el estado civil de cualquier persona e imprima solo si la persona es un hombre soltero mayor de edad. sexo.. Asignarlos a las variables A y B 6. Fin SI 6. De lo contrario: Escribir B. Solicitar la introducción de dos valores distintos 4. estadocivil . Inicializar variables: A = 0. 1.

Si A > B y A > C Entonces 6.Desarrolle un algoritmo que realice la sumatoria de los números enteros comprendidos entre el 1 y el 10. Fin . 1. 1. Escribir el valor de la Hipotenusa 7. El algoritmo debe imprimir cual es el mayor y cual es el menor. Si N = 10 Entonces 6. Almacenarlo en la variable CatA y CatB 5. Leer los tres valores 4. Declaración de variables:N= 0. Almacenar en las variables A. Sino 11. Inicializar las variables A. Inicio 2.CatB=0 3. B y C respectivamente. Escribir Suma 7. Suma = 0 3. Fin 9. 1 + 2 + 3 + ….Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A. Fin_Si 13. Desarrolle el algoritmo correspondiente. Fin_Si 14. Asignación Acumulador:Suma = Suma + N 5.Determinar la hipotenusa de un triángulo rectángulo conocidas las longitudes de sus dos catetos. B y C 3. De lo contrario. Sino 8. Si B > A y B > C Entonces 9.. + 10. Recuerde constatar que los tres valores introducidos por el teclado sean valores distintos. Calcular el valor de Hip con la formula indicada 6. Fin 10. es decir. Escribir B “Es el mayor” 10. Declaración de Variables: CatA= 0.8.. Leer el valor de cada cateto 4. Escribir A “Es el mayor” 7. Fin_Si 9. Asignación Contador :N = N + 1 4. B y C 5. Inicio 2. Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales.. Repetir desde el paso 3 8. 1. Inicio 2. Escribir C “Es el mayor” 12.

. 1. Si no (De lo contrario) 9. Leer A y B 4. Si A<B Entonces 5. Declaración de variables: N 3. Fin 13. Fin 12. Escribir “Orden = “. Si es Si: Entonces: Escribir “ Es par” 7. 1. Calcular el Volumen aplicando la fórmula 5. Asignar a B = A 7. Asignar a Temporal = B 6. Fin_Si 10. Sino: Escribir “Es impar” 8.Desarrolle un algoritmo que permita determinar el área y volumen de un cilindro dado su radio (R) y altura (H). A. H = 0 3.11. Si el residuo de dividir a N entre 2 es igual a cero 6.. Asignar a A = Temporal 8. si es el caso. 1.Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si dicho número es par o impar. Inicio 2. Declaración de variables: R = 0. Asignarlo a la variable N 5. B = 0.Desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor. Temporal = 0 3. Inicio 2. Leer el valor de Radio (R) y Altura (H) 4. B 11.. Declaración de Variables:A = 0. Fin_Si 9. Fin . Inicio 2. Escribir el valor del Área y del Volumen 7. Calcular el valor del área aplicando la fórmula respectiva 6. Leer un número 4.

Escribir N “no es primo” 14. Leer N 4.14. Vel = 0 3. Leer N 4. 1. Declaración de variables: J = 2. proporcione la velocidad en metros por segundo. Si N / J =0 6. 1. Inicio 2.Realice un algoritmo que a partir de proporcionarle la velocidad de un automóvil. Promedio 10. Promedio = 0. Escribir N “es primo” 12. finaliza cuando N = 0.. Declaración de Variables: Versal .Versal 6. Acumula = Acumula + N 7. Declaración de Variables: N = 0. Escribir “resultado = “.. Fin del ciclo mientras 10. Fin 15. Fin Mientras 8. S=S+1 7. Promedio = Acumula/Cuenta 9.Desarrolle un algoritmo que permita leer un valor entero positivo N y determinar si es primo o no. Escribir “Promedio:”. Inicio 2. Sino (De lo contrario) 13. 1. Inicio 2. Mientras N <> 0 hacer 5. Fin 16. Cuenta = Cuenta + 1 6. S =0 3. Fin .. J=J+1 8. Fin_Si 15. Fin_Si 9. Leer Datos: Vel 4. Acumula= 0 3. expresada en kilómetros por hora.Desarrolle un algoritmo que permita calcular Promedio de Notas. Versal = (Vel * 1000) / 3600 5. Si S = 0 Entonces 11. Mientras J<= N / 2 hacer 5.

1 9. Escribir Registro 10. Fin .. Inicio 2. Fin_Mientras 12. Total_nómina= Totalnómina + Salario 8. Mientras Numero_Obreros>0 6.Desarrolle un algoritmo para la empresa Constructora Casas S. Leer Datos 11. Leer Datos 5.A. Escribir “Total : “. La hora trabajada se pautó en 2500 Pesos 1. que le permita calcular e imprimir la nómina para su cancelación a un total de 50 obreros calificados a quienes debe cancelar por horas trabajadas. Numero_Obreros = Numero_Obreros . Imprimir líneas de títulos de la nómina 4..17. Total_nómina 13. Declaración de Variables: Numero_Obreros =50 Numero_Hora_Trabajada = 0 Total_nomina = 0 3. Salario = Numero_Hora_Trabajada * 30 7.

Recibir bas. n y el resultado de la sumatoria. Suma = Suma + poten (x. (Ʃ  0. Inicio 2. ex 4. Para i = 0 a ex 5.Escribir un programa que calcule la expresión: Ʃ x^i . i) 6. Fin_Para 7.. Leer x.n) para cualquier par de valores de n y x. crear y utilizar una función POTEN que tenga como parámetros la base x y el exponente i.. Exhibir x. Declaración de Variables: Suma = 0 i=0 3. Fin Función poten 1.. Fin_Para 7.. Suma 8. Retornar p 8.18. n 4. Para evaluar cada uno de los términos de la sumatoria. p = p * bas 6. 1. Escribir x.n. Para i = 0 a n 5. Fin . Declaración de Variables: bas i=0 ex p=0 3. Inicio 2.

19.3.10. Sino (De lo contrario) 8.10. Recibir i 4. Escribir “El numero introducido no corresponde a ningun mes” 7.12 Entonces dias_mes31 7.8.Escribir un programa que reciba un numero del 1 al 12 desde el teclado y muestre el número de días correspondiente al mes que corresponda con ese día (usar funciones). Leer mes 5. Fin_Si 6. Declaración de Variables: dias_mes=0 i 3. Declaración de Variables: mes= 0 3. Si i=1. dia_mes (mes). Fin_Si 12.5.8.8. Fin_Si 8. Escribir “Introduzca un numero del 1 al 12:” 4.12 Entonces dias_mes31 5. Fin Función dia_mes 1. Escribir “El o 29 si es año bisiesto'” 11.3.7. Si i=1.7. Fin . Fin_Si 10. Inicio 2. Si (mes = 2) Entonces 10. Retornar dias_mes 11.10.3.5. Escribir “El mes tiene”. 1.7.5. Inicio 2. Si i=1.')” 9. Fin_Si 8.. Si (mes < 1) o (mes > 12) Entonces 6.' dias.12 Entonces dias_mes31 9.

Calcule el salario neto. teniendo en cuenta que si el número de horas trabajadas durante la semana es mayor de 48 horas. Recuerde que la serie de Fibonacci se genera empezando con los números 0 y 1 y calculando cada nuevo miembro como la suma de dos . El número medio es aquel que no es el mayor ni el menor. el sexo y el estado civil de cualquier persona e imprima el nombre de la persona si es un hombre casado y mayor de 40 años o una mujer soltera menor de 50 años.1. Imprima el nombre del empleado y su salario neto.2 etc. imprima el número si es negativo y el positivo del mismo. impar o cero. en cuál caja está un número dado. 10) Desarrolle un algoritmo que le permita obtener la sucesión de Fibonacci 0. 3) Desarrolle un algoritmo que lea un número. saque su promedio e imprima su nombre. número de carnet y el promedio. la edad . y si es negativo que lo imprima. impar o cero. 8) Desarrolle un algoritmo que le permita determinar dadas tres cajas cada una con 15 números. el salario básico por hora y el número de horas trabajadas durante una semana. 2) Desarrolle un algoritmo que permita determinar de una serie de números cuántos son par. 5) Desarrolle un algoritmo que le permita leer el nombre. 9) Desarrolle un algoritmo que le permita determinar el número medio de tres números.Ejercicios Por Resolver 1) Desarrolle un algoritmo que permita determinar si un número dado es par. 7) Desarrolle un algoritmo para leer el nombre de un empleado. esas horas demás se consideran horas extras y tienen un recargo del 35%. 4) Desarrolle un algoritmo que lea una serie de números. 6) Desarrolle un algoritmo que le permita leer las notas de las materias que ha cursado un estudiante hasta el momento.1.

6) 6 2 4 6 Para X negativo: F(x) = (x + 2) 2 + (x + 4) 4 + (x + 6) 6 2 4 6 12) Elabore un algoritmo.4) 4 + (x . 13) El colegio “Mi angelito” desea calcular el monto a pagar por inscripción del nuevo año escolar. si la sociedad de padres se cobra una vez por familiar y si se otorga un descuento por la cantidad de hijos en el colegio que viene dado por la siguiente tabla. Cantidad de hijos 2 niños 3 niños > 3 niños Descuento 10% 15% 20% . Imprima los primeros n términos de la sucesión. el monto de matricula por niño. El porcentaje de aumento del sueldo viene dado por el tipo de trabajador que es: Tipo de trabajador „V‟ 10% „G‟ 15% „E‟ 20% „O‟ 30% Adicionalmente se le paga una prima por cada hijo la cual es conocida y la misma para todos. que calcule el aumento de sueldo de un trabajador. Para ello se conoce el numero de hijos que tiene la familia en el colegio. su sueldo y la cantidad de hijos que tiene. conociendo del mismo. para las familias con hijos en el colegio. el monto de la mensualidad del mes de septiembre por niño y el monto de la sociedad de padres.miembros precedentes en la sucesión.2) 2 + (x . calcule Para X positivo: F(x) = (x . tipo de trabajador. su nombre. 11) Elabore un algoritmo que dado un valor X. Elabore un algoritmo que calcule el total a pagar por la familia.

Sign up to vote on this title
UsefulNot useful