Ejercicios Resueltos

1.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima tanto el nombre como la edad 1. Inicio 2. Declaración de variables: nombre, edad 3. Leer nombre, edad 4. Escribir nombre, edad 5. Fin 2.- Mostrar su nombre, sexo edad y estado civil, que son ingresados por teclado 1. Inicio 2. Declaración de variables: nombre, sexo, estadocivil , edad 3. Leer nombre, sexo, edad, estadocivil 4. Escribir nombre, sexo, edad , estadocivil 5. Fin

3.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima, solo si la persona es mayor de edad, el nombre de la persona. 1. Inicio 2. Declaración de variables: nombre, edad 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Fin SI 6. Fin 4.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima solo si la persona es mayor de edad, el nombre de la persona, de lo contrario, imprima un mensaje que diga : “no puede votar”. 1. Inicio 2. Declaración de variables: nombre, edad // Ec = estado civil 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Sino 6. Escribir “no puede votar !!” 7. Fin SI 8. Fin

. sexo. Solicitar la introducción de dos valores distintos 4. edad 3. “Es el mayor” 8. el sexo (1 o 2) y el estado civil de cualquier persona e imprima solo si la persona es un hombre soltero mayor de edad. sexo. Fin 6. Fin 7. Inicio 2. estadocivil 4. Inicio 2.. edad. Leer nombre.Ingresar por teclado el nombre. Leer nombre. Fin SI 6.5. Si A = B Entonces vuelve a 3 porque los valores deben ser distintos 7. Inicio 2. estadocivil . B = 0 3. Fin . determinar cual de los dos valores es el mayor y escribirlo. sexo. NOTA: suponga que en el campo denominado sexo el numero 1 es masculino o el numero 2 es femenino 1. Asignarlos a las variables A y B 6. SI (sexo = 1) y (edad >= 18) Entonces Escribir nombre 5. SI (sexo = 1) y (estadocivil = 1) y (edad >= 18) Entonces Escribir nombre 5. solo si la persona es de sexo masculino y mayor de edad. Si A>B Entonces Escribir A. Fin SI 6.Desarrolle un algoritmo que permita leer dos valores distintos. Inicializar variables: A = 0. el numero 2 en vez de casado o el numero 3 en vez de otro. el nombre de la persona. “Es el mayor” 9. Fin_Si 10. edad 4. el nombre de la persona. Declaración de variables: nombre.. la edad y el sexo de cualquier persona e imprima. De lo contrario: Escribir B. 1. edad 3. la edad. Leer los dos valores 5. Declaración de variables: nombre. sexo.Ingresar por teclado el nombre. NOTA: en el campo de estado civil se graba el numero 1 en vez de soltero. 1.

Escribir B “Es el mayor” 10. El algoritmo debe imprimir cual es el mayor y cual es el menor.. Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales.. 1. Asignación Acumulador:Suma = Suma + N 5. Inicializar las variables A. Almacenar en las variables A. 1. De lo contrario. Leer el valor de cada cateto 4. Fin_Si 14. Declaración de Variables: CatA= 0. + 10. B y C respectivamente.CatB=0 3. Calcular el valor de Hip con la formula indicada 6. Si N = 10 Entonces 6. B y C 5. Escribir el valor de la Hipotenusa 7. Repetir desde el paso 3 8. es decir. Fin 10.Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A. Inicio 2. Inicio 2. Almacenarlo en la variable CatA y CatB 5. 1. Declaración de variables:N= 0.. Asignación Contador :N = N + 1 4. Leer los tres valores 4. Fin_Si 9.Desarrolle un algoritmo que realice la sumatoria de los números enteros comprendidos entre el 1 y el 10. 1 + 2 + 3 + …. Si B > A y B > C Entonces 9. Fin . Sino 11. Inicio 2. Escribir Suma 7. Sino 8. B y C 3. Suma = 0 3. Recuerde constatar que los tres valores introducidos por el teclado sean valores distintos. Fin_Si 13.Determinar la hipotenusa de un triángulo rectángulo conocidas las longitudes de sus dos catetos. Escribir A “Es el mayor” 7. Desarrolle el algoritmo correspondiente. Fin 9. Escribir C “Es el mayor” 12. Si A > B y A > C Entonces 6.8.

Fin 13. B = 0. 1.. B 11. Si A<B Entonces 5.. Inicio 2. A. Leer A y B 4. Escribir el valor del Área y del Volumen 7. Si no (De lo contrario) 9. Inicio 2.Desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor. 1. Calcular el valor del área aplicando la fórmula respectiva 6. Fin_Si 9. H = 0 3. Declaración de Variables:A = 0. Sino: Escribir “Es impar” 8. si es el caso.Desarrolle un algoritmo que permita determinar el área y volumen de un cilindro dado su radio (R) y altura (H).. Temporal = 0 3. Inicio 2. 1. Leer un número 4. Asignar a A = Temporal 8. Fin_Si 10. Fin 12.11. Escribir “Orden = “. Declaración de variables: N 3. Si es Si: Entonces: Escribir “ Es par” 7. Si el residuo de dividir a N entre 2 es igual a cero 6. Calcular el Volumen aplicando la fórmula 5. Asignarlo a la variable N 5. Fin . Leer el valor de Radio (R) y Altura (H) 4. Asignar a Temporal = B 6.Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si dicho número es par o impar. Declaración de variables: R = 0. Asignar a B = A 7.

Fin del ciclo mientras 10. finaliza cuando N = 0. S=S+1 7.14. Escribir “resultado = “. Fin 15. Escribir N “es primo” 12.Versal 6. Mientras N <> 0 hacer 5. Escribir “Promedio:”. Fin .. S =0 3. Promedio 10.Desarrolle un algoritmo que permita calcular Promedio de Notas. J=J+1 8. Acumula= 0 3.Desarrolle un algoritmo que permita leer un valor entero positivo N y determinar si es primo o no. Declaración de Variables: N = 0. Si N / J =0 6. Inicio 2. 1. Declaración de Variables: Versal . Fin_Si 15. Promedio = Acumula/Cuenta 9. Fin_Si 9. Escribir N “no es primo” 14. Declaración de variables: J = 2.. Fin 16. Leer Datos: Vel 4. Leer N 4. expresada en kilómetros por hora. 1. Si S = 0 Entonces 11. Vel = 0 3. Mientras J<= N / 2 hacer 5. Promedio = 0. Inicio 2. Acumula = Acumula + N 7. 1. Fin Mientras 8. Leer N 4.Realice un algoritmo que a partir de proporcionarle la velocidad de un automóvil. proporcione la velocidad en metros por segundo. Cuenta = Cuenta + 1 6. Sino (De lo contrario) 13. Versal = (Vel * 1000) / 3600 5. Inicio 2..

Declaración de Variables: Numero_Obreros =50 Numero_Hora_Trabajada = 0 Total_nomina = 0 3. Total_nómina 13. Total_nómina= Totalnómina + Salario 8.A. Mientras Numero_Obreros>0 6. Inicio 2. La hora trabajada se pautó en 2500 Pesos 1. Salario = Numero_Hora_Trabajada * 30 7.. Escribir “Total : “.. Numero_Obreros = Numero_Obreros .1 9. Leer Datos 11. Escribir Registro 10.17. Fin .Desarrolle un algoritmo para la empresa Constructora Casas S. Fin_Mientras 12. Imprimir líneas de títulos de la nómina 4. que le permita calcular e imprimir la nómina para su cancelación a un total de 50 obreros calificados a quienes debe cancelar por horas trabajadas. Leer Datos 5.

. crear y utilizar una función POTEN que tenga como parámetros la base x y el exponente i. Inicio 2. Fin .. Para i = 0 a ex 5.n) para cualquier par de valores de n y x. i) 6. Escribir x. Fin Función poten 1. ex 4. Leer x. Suma = Suma + poten (x. Fin_Para 7. Exhibir x. Para i = 0 a n 5. Para evaluar cada uno de los términos de la sumatoria.. Recibir bas.18. 1. n y el resultado de la sumatoria. (Ʃ  0.Escribir un programa que calcule la expresión: Ʃ x^i . Retornar p 8. n 4. Inicio 2. Declaración de Variables: bas i=0 ex p=0 3. Fin_Para 7. p = p * bas 6. Suma 8. Declaración de Variables: Suma = 0 i=0 3.n..

10. Escribir “El numero introducido no corresponde a ningun mes” 7.7.5. Fin . Retornar dias_mes 11. Si (mes < 1) o (mes > 12) Entonces 6.5. Fin_Si 10.. Inicio 2. Fin_Si 8. Si i=1.' dias. Fin_Si 6. dia_mes (mes). Fin Función dia_mes 1. Si i=1.7. Si i=1. Si (mes = 2) Entonces 10. Fin_Si 8.3. Fin_Si 12. Recibir i 4.8. Escribir “Introduzca un numero del 1 al 12:” 4.12 Entonces dias_mes31 5.8. Declaración de Variables: mes= 0 3. Escribir “El mes tiene”.3.10. Declaración de Variables: dias_mes=0 i 3. Inicio 2.12 Entonces dias_mes31 9.3.5. Leer mes 5. Sino (De lo contrario) 8.7.19.Escribir un programa que reciba un numero del 1 al 12 desde el teclado y muestre el número de días correspondiente al mes que corresponda con ese día (usar funciones).')” 9.10.8. Escribir “El o 29 si es año bisiesto'” 11. 1.12 Entonces dias_mes31 7.

1.2 etc.Ejercicios Por Resolver 1) Desarrolle un algoritmo que permita determinar si un número dado es par. El número medio es aquel que no es el mayor ni el menor. 5) Desarrolle un algoritmo que le permita leer el nombre. 4) Desarrolle un algoritmo que lea una serie de números. esas horas demás se consideran horas extras y tienen un recargo del 35%. 2) Desarrolle un algoritmo que permita determinar de una serie de números cuántos son par. impar o cero. número de carnet y el promedio. teniendo en cuenta que si el número de horas trabajadas durante la semana es mayor de 48 horas. la edad .1. impar o cero. imprima el número si es negativo y el positivo del mismo. 10) Desarrolle un algoritmo que le permita obtener la sucesión de Fibonacci 0. Imprima el nombre del empleado y su salario neto. Calcule el salario neto. 7) Desarrolle un algoritmo para leer el nombre de un empleado. y si es negativo que lo imprima. 9) Desarrolle un algoritmo que le permita determinar el número medio de tres números. el sexo y el estado civil de cualquier persona e imprima el nombre de la persona si es un hombre casado y mayor de 40 años o una mujer soltera menor de 50 años. saque su promedio e imprima su nombre. 6) Desarrolle un algoritmo que le permita leer las notas de las materias que ha cursado un estudiante hasta el momento. 8) Desarrolle un algoritmo que le permita determinar dadas tres cajas cada una con 15 números. 3) Desarrolle un algoritmo que lea un número. en cuál caja está un número dado. Recuerde que la serie de Fibonacci se genera empezando con los números 0 y 1 y calculando cada nuevo miembro como la suma de dos . el salario básico por hora y el número de horas trabajadas durante una semana.

11) Elabore un algoritmo que dado un valor X. su nombre. el monto de matricula por niño. que calcule el aumento de sueldo de un trabajador. calcule Para X positivo: F(x) = (x . Para ello se conoce el numero de hijos que tiene la familia en el colegio. 13) El colegio “Mi angelito” desea calcular el monto a pagar por inscripción del nuevo año escolar.6) 6 2 4 6 Para X negativo: F(x) = (x + 2) 2 + (x + 4) 4 + (x + 6) 6 2 4 6 12) Elabore un algoritmo. si la sociedad de padres se cobra una vez por familiar y si se otorga un descuento por la cantidad de hijos en el colegio que viene dado por la siguiente tabla. Elabore un algoritmo que calcule el total a pagar por la familia. El porcentaje de aumento del sueldo viene dado por el tipo de trabajador que es: Tipo de trabajador „V‟ 10% „G‟ 15% „E‟ 20% „O‟ 30% Adicionalmente se le paga una prima por cada hijo la cual es conocida y la misma para todos. para las familias con hijos en el colegio. conociendo del mismo. Imprima los primeros n términos de la sucesión.2) 2 + (x . Cantidad de hijos 2 niños 3 niños > 3 niños Descuento 10% 15% 20% . tipo de trabajador.4) 4 + (x . su sueldo y la cantidad de hijos que tiene.miembros precedentes en la sucesión. el monto de la mensualidad del mes de septiembre por niño y el monto de la sociedad de padres.