Ejercicios Resueltos

1.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima tanto el nombre como la edad 1. Inicio 2. Declaración de variables: nombre, edad 3. Leer nombre, edad 4. Escribir nombre, edad 5. Fin 2.- Mostrar su nombre, sexo edad y estado civil, que son ingresados por teclado 1. Inicio 2. Declaración de variables: nombre, sexo, estadocivil , edad 3. Leer nombre, sexo, edad, estadocivil 4. Escribir nombre, sexo, edad , estadocivil 5. Fin

3.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima, solo si la persona es mayor de edad, el nombre de la persona. 1. Inicio 2. Declaración de variables: nombre, edad 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Fin SI 6. Fin 4.- Ingresar por teclado el nombre y la edad de cualquier persona e imprima solo si la persona es mayor de edad, el nombre de la persona, de lo contrario, imprima un mensaje que diga : “no puede votar”. 1. Inicio 2. Declaración de variables: nombre, edad // Ec = estado civil 3. Leer nombre, edad 4. SI (edad >= 18) Entonces Escribir nombre 5. Sino 6. Escribir “no puede votar !!” 7. Fin SI 8. Fin

la edad. SI (sexo = 1) y (estadocivil = 1) y (edad >= 18) Entonces Escribir nombre 5.Desarrolle un algoritmo que permita leer dos valores distintos. Leer nombre.. Fin 6. edad 3. solo si la persona es de sexo masculino y mayor de edad. el sexo (1 o 2) y el estado civil de cualquier persona e imprima solo si la persona es un hombre soltero mayor de edad. el numero 2 en vez de casado o el numero 3 en vez de otro. Solicitar la introducción de dos valores distintos 4. 1.5. Inicio 2. edad 3.. Inicializar variables: A = 0. el nombre de la persona. NOTA: suponga que en el campo denominado sexo el numero 1 es masculino o el numero 2 es femenino 1. la edad y el sexo de cualquier persona e imprima. De lo contrario: Escribir B.Ingresar por teclado el nombre. “Es el mayor” 8. sexo. Fin SI 6. Inicio 2. Leer los dos valores 5.Ingresar por teclado el nombre. Fin_Si 10. Si A>B Entonces Escribir A. Fin 7. Inicio 2. “Es el mayor” 9. Asignarlos a las variables A y B 6. 1. edad 4. B = 0 3. NOTA: en el campo de estado civil se graba el numero 1 en vez de soltero. estadocivil 4. Fin . sexo. SI (sexo = 1) y (edad >= 18) Entonces Escribir nombre 5. sexo. Declaración de variables: nombre. estadocivil . sexo.. el nombre de la persona. determinar cual de los dos valores es el mayor y escribirlo. Declaración de variables: nombre. Si A = B Entonces vuelve a 3 porque los valores deben ser distintos 7. Fin SI 6. Leer nombre. edad.

B y C respectivamente.. Si B > A y B > C Entonces 9. Escribir B “Es el mayor” 10. Sino 11. De lo contrario. Escribir C “Es el mayor” 12. Fin . Inicializar las variables A. Fin_Si 14. Calcular el valor de Hip con la formula indicada 6. Leer el valor de cada cateto 4. Asignación Acumulador:Suma = Suma + N 5. Si N = 10 Entonces 6. Fin_Si 13. Inicio 2. 1 + 2 + 3 + ….Desarrolle un algoritmo que realice la sumatoria de los números enteros comprendidos entre el 1 y el 10. Si A > B y A > C Entonces 6. Inicio 2. B y C 3. Escribir el valor de la Hipotenusa 7. Repetir desde el paso 3 8. 1. Recuerde constatar que los tres valores introducidos por el teclado sean valores distintos. Asignación Contador :N = N + 1 4. Sino 8.. Escribir Suma 7..Desarrolle un algoritmo que permita leer tres valores y almacenarlos en las variables A. Fin 10. Fin_Si 9. Suma = 0 3. El algoritmo debe imprimir cual es el mayor y cual es el menor. es decir. Inicio 2. Escribir A “Es el mayor” 7. B y C 5. Almacenarlo en la variable CatA y CatB 5. Declaración de Variables: CatA= 0. Fin 9. Desarrolle el algoritmo correspondiente. 1.CatB=0 3.Determinar la hipotenusa de un triángulo rectángulo conocidas las longitudes de sus dos catetos. Leer los tres valores 4. + 10.8. Almacenar en las variables A. Presente un mensaje de alerta en caso de que se detecte la introducción de valores iguales. Declaración de variables:N= 0. 1.

Inicio 2. Fin_Si 9. Leer A y B 4. Fin 13. Leer un número 4. B = 0. Fin_Si 10... A. Inicio 2. Calcular el valor del área aplicando la fórmula respectiva 6. Leer el valor de Radio (R) y Altura (H) 4. Asignar a B = A 7.11. Asignar a Temporal = B 6.. B 11. 1. Si A<B Entonces 5. Fin 12. Declaración de Variables:A = 0. 1.Desarrolle un algoritmo que permita leer un valor cualquiera N y escriba si dicho número es par o impar. Escribir “Orden = “. Fin . Asignar a A = Temporal 8.Desarrolle un algoritmo que permita leer dos números y ordenarlos de menor a mayor. Inicio 2. Si el residuo de dividir a N entre 2 es igual a cero 6. Si no (De lo contrario) 9. Escribir el valor del Área y del Volumen 7. Declaración de variables: R = 0. Si es Si: Entonces: Escribir “ Es par” 7. 1. H = 0 3. Declaración de variables: N 3. Calcular el Volumen aplicando la fórmula 5. si es el caso. Temporal = 0 3. Sino: Escribir “Es impar” 8. Asignarlo a la variable N 5.Desarrolle un algoritmo que permita determinar el área y volumen de un cilindro dado su radio (R) y altura (H).

Promedio = Acumula/Cuenta 9. Promedio 10. finaliza cuando N = 0. Versal = (Vel * 1000) / 3600 5.Versal 6. Sino (De lo contrario) 13. Inicio 2.Realice un algoritmo que a partir de proporcionarle la velocidad de un automóvil.14. Inicio 2. Fin . Acumula= 0 3. J=J+1 8. proporcione la velocidad en metros por segundo. Escribir “Promedio:”. Inicio 2. Escribir N “es primo” 12. Si S = 0 Entonces 11. 1. Fin_Si 9. Declaración de Variables: N = 0. S =0 3.. Fin 15. Cuenta = Cuenta + 1 6. 1. 1.. Leer Datos: Vel 4. Escribir N “no es primo” 14. Leer N 4. Declaración de variables: J = 2. S=S+1 7. expresada en kilómetros por hora. Fin del ciclo mientras 10.Desarrolle un algoritmo que permita calcular Promedio de Notas. Mientras J<= N / 2 hacer 5. Leer N 4. Si N / J =0 6. Promedio = 0. Declaración de Variables: Versal .Desarrolle un algoritmo que permita leer un valor entero positivo N y determinar si es primo o no. Mientras N <> 0 hacer 5. Acumula = Acumula + N 7. Fin 16. Fin_Si 15. Vel = 0 3. Fin Mientras 8.. Escribir “resultado = “.

. Leer Datos 5. Declaración de Variables: Numero_Obreros =50 Numero_Hora_Trabajada = 0 Total_nomina = 0 3.Desarrolle un algoritmo para la empresa Constructora Casas S. Salario = Numero_Hora_Trabajada * 30 7. Inicio 2. La hora trabajada se pautó en 2500 Pesos 1.1 9. Escribir Registro 10. que le permita calcular e imprimir la nómina para su cancelación a un total de 50 obreros calificados a quienes debe cancelar por horas trabajadas. Total_nómina= Totalnómina + Salario 8.17.A. Imprimir líneas de títulos de la nómina 4. Leer Datos 11. Numero_Obreros = Numero_Obreros . Fin_Mientras 12. Escribir “Total : “. Total_nómina 13. Fin .. Mientras Numero_Obreros>0 6.

Fin_Para 7.. 1. Declaración de Variables: Suma = 0 i=0 3. n 4. p = p * bas 6. Inicio 2. Fin Función poten 1. Fin .Escribir un programa que calcule la expresión: Ʃ x^i .18. (Ʃ  0. Retornar p 8. Para i = 0 a n 5. Escribir x.n) para cualquier par de valores de n y x. Declaración de Variables: bas i=0 ex p=0 3. Para i = 0 a ex 5. Suma 8... ex 4. n y el resultado de la sumatoria. Leer x.n. Para evaluar cada uno de los términos de la sumatoria. Inicio 2. Recibir bas. i) 6. Suma = Suma + poten (x.. Exhibir x. Fin_Para 7. crear y utilizar una función POTEN que tenga como parámetros la base x y el exponente i.

7. Inicio 2. Declaración de Variables: dias_mes=0 i 3.8.12 Entonces dias_mes31 7.19.10. Escribir “El mes tiene”. Sino (De lo contrario) 8. Si (mes < 1) o (mes > 12) Entonces 6. Si i=1.7.3. Escribir “Introduzca un numero del 1 al 12:” 4.3. Fin_Si 8. Fin .5. Fin_Si 8.Escribir un programa que reciba un numero del 1 al 12 desde el teclado y muestre el número de días correspondiente al mes que corresponda con ese día (usar funciones).' dias. Declaración de Variables: mes= 0 3. 1. Recibir i 4. Leer mes 5. Si i=1. Escribir “El numero introducido no corresponde a ningun mes” 7. Inicio 2.3. Retornar dias_mes 11.5. dia_mes (mes).10.10. Si (mes = 2) Entonces 10.5. Fin_Si 10.8.12 Entonces dias_mes31 9.8. Si i=1. Escribir “El o 29 si es año bisiesto'” 11.12 Entonces dias_mes31 5. Fin_Si 6.')” 9. Fin_Si 12.. Fin Función dia_mes 1.7.

2 etc. el sexo y el estado civil de cualquier persona e imprima el nombre de la persona si es un hombre casado y mayor de 40 años o una mujer soltera menor de 50 años. 2) Desarrolle un algoritmo que permita determinar de una serie de números cuántos son par. El número medio es aquel que no es el mayor ni el menor. 6) Desarrolle un algoritmo que le permita leer las notas de las materias que ha cursado un estudiante hasta el momento. 8) Desarrolle un algoritmo que le permita determinar dadas tres cajas cada una con 15 números. número de carnet y el promedio. teniendo en cuenta que si el número de horas trabajadas durante la semana es mayor de 48 horas. el salario básico por hora y el número de horas trabajadas durante una semana. y si es negativo que lo imprima.1. en cuál caja está un número dado. 3) Desarrolle un algoritmo que lea un número. esas horas demás se consideran horas extras y tienen un recargo del 35%. la edad . 9) Desarrolle un algoritmo que le permita determinar el número medio de tres números. 5) Desarrolle un algoritmo que le permita leer el nombre. impar o cero. 10) Desarrolle un algoritmo que le permita obtener la sucesión de Fibonacci 0. 7) Desarrolle un algoritmo para leer el nombre de un empleado. saque su promedio e imprima su nombre.1. Imprima el nombre del empleado y su salario neto. Calcule el salario neto. impar o cero. Recuerde que la serie de Fibonacci se genera empezando con los números 0 y 1 y calculando cada nuevo miembro como la suma de dos . 4) Desarrolle un algoritmo que lea una serie de números. imprima el número si es negativo y el positivo del mismo.Ejercicios Por Resolver 1) Desarrolle un algoritmo que permita determinar si un número dado es par.

13) El colegio “Mi angelito” desea calcular el monto a pagar por inscripción del nuevo año escolar. Para ello se conoce el numero de hijos que tiene la familia en el colegio. 11) Elabore un algoritmo que dado un valor X. su nombre. el monto de la mensualidad del mes de septiembre por niño y el monto de la sociedad de padres. si la sociedad de padres se cobra una vez por familiar y si se otorga un descuento por la cantidad de hijos en el colegio que viene dado por la siguiente tabla. Cantidad de hijos 2 niños 3 niños > 3 niños Descuento 10% 15% 20% .6) 6 2 4 6 Para X negativo: F(x) = (x + 2) 2 + (x + 4) 4 + (x + 6) 6 2 4 6 12) Elabore un algoritmo. el monto de matricula por niño. Imprima los primeros n términos de la sucesión. Elabore un algoritmo que calcule el total a pagar por la familia.2) 2 + (x . conociendo del mismo.miembros precedentes en la sucesión. que calcule el aumento de sueldo de un trabajador.4) 4 + (x . para las familias con hijos en el colegio. tipo de trabajador. calcule Para X positivo: F(x) = (x . El porcentaje de aumento del sueldo viene dado por el tipo de trabajador que es: Tipo de trabajador „V‟ 10% „G‟ 15% „E‟ 20% „O‟ 30% Adicionalmente se le paga una prima por cada hijo la cual es conocida y la misma para todos. su sueldo y la cantidad de hijos que tiene.

Sign up to vote on this title
UsefulNot useful