P. 1
pseint

pseint

|Views: 5.292|Likes:
Publicado port3j3
Ejercicios desarrollados en pseint.
pseudocódigo.
Ejercicios desarrollados en pseint.
pseudocódigo.

More info:

Published by: t3j3 on Apr 19, 2012
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as TXT, PDF, TXT or read online from Scribd
See more
See less

09/18/2014

pdf

text

original

Proceso comision //comision de un empleado resp<-"s"; mientras resp="s" o resp="S" hacer Escribir "escoja las siguientes opciones"; Escribir

"1)si la venta del empleado es entre 100000 Escribir "2)si la venta del empleado es entre 300000 Escribir "3)si la venta del empleado es entre 500000 Escribir "4)si la venta del empleado es entre 800000 Escribir "5) si la venta es menor a 100000"; escribir "digite la venta del empleado"; leer v; Escribir "digite la opcion"; leer op; segun op Hacer 1: total<-v*0.03; Escribir "comision del vendedor es",total; 2: total<-v*0.04; escribir "comision del vendedor es",total; 3: total<-v*0.05; escribir "comision del vendedor es",total; 4: total<-v*0.06; escribir "comision del vendedor es",total; 5: escribir "no tiene comision"; FinSegun escribir "desea ingresar realizar otro calculo s/n"; leer resp; FinMientras FinProceso Proceso sin_titulo n<-1; c<-1; Repetir r<- n mod 2; si r=0 Entonces escribir n; Sino FinSi n<-n+1; Hasta Que n=100 c<-c+n; escribir c; FinProceso Proceso sin_titulo //multiplos 2 y3 numeros comprendidos 1 al 100 para num<-1 hasta 100 Hacer r<- num mod 5; si r=0 Entonces

y y y y

200000"; 500000"; 700000"; 1000000";

escribir num; FinSi FinPara FinProceso Proceso contador //elaborar un algoritmo que permita leer los datos de un empleado: Nombr e, tipo de empleado, numero de horas trabajadas y cuota que se le //paga por hora; calcular e imprimir el sueldo a pagar. Si el empleado e s Tipo1, se le pagan las horas extra(más de 40 horas)a 1.5 de la cuota //por hora, si es Tipo2,a 2; si es de Tipo3, a 2.5; y si es Tipo4 a 3 ve ces la cuota por hora. totalempleados<-0; sueldototal<-0; resp<-"s"; Mientras resp="s" o resp="S" hacer Escribir "DIGITE NOMBRE DEL EMPLEADO"; leer nom; Escribir "QUE TIPO DE EMPLEADO ES 1,2,3 O 4:"; LEER op; Escribir "DIGITE EL NUMERO DE HORAS TRABAJADAS"; LEER horas; Escribir "DIGITE EL VALOR DE LA HORA DE TRABAJO"; LEER valor; subtotal<-horas*valor; si op=1 Entonces si horas>40 Entonces hextras<-horas-40; extras<-hextras*1.5; subtotal<-subtotal+extras; escribir "Suledo a Pagar"," ",subtotal; Sino escribir "Suledo a Pagar"," ",subtotal; Sino FinSi FinSi si op=2 Entonces si horas>40 Entonces hextras<-horas-40; extras<-hextras*2; subtotal<-subtotal+extras; escribir "Suledo a Pagar"," ",subtotal; Sino escribir "Suledo a Pagar"," ",subtotal; Sino FinSi FinSi si op=3 Entonces si horas>40 Entonces hextras<-horas-40; extras<-hextras*2.5; subtotal<-subtotal+extras; escribir "Suledo a Pagar"," ",subtotal; Sino escribir "Suledo a Pagar"," ",subtotal;

Sino FinSi FinSi si op=4 Entonces si horas>40 Entonces hextras<-horas-40; extras<-hextras*3; subtotal<-subtotal+extras; escribir "Suledo a Pagar"," ",subtotal; Sino escribir "Suledo a Pagar"," ",subtotal; Sino FinSi FinSi totalempleados<-totalempleados+1; sueldototal<-sueldototal+subtotal; Escribir "Realizar otro calculo S/N"; LEER resp; FinMientras escribir "TOTAL"," ",totalempleados,"EMPLEADOS"," ","Total"," ",sueldoto tal," ","dolares"; FinProceso Proceso sin_titulo //elaborar un algoritmo que contabilice una cuenta de cheques.Al inicio se le introduce el nombre del cuentahabiente y el saldo inicial //A continuación se puede hacer depósitos y retiros. Cuando sea depósito se in crementa al saldo, y cuando sea retiro se resta. //este programa terminará cuando ya no desee hacer movimientos. Se requier e la impresión del siguiente reporte. cm<-0; sa<-0; resp<-"s"; mientras resp="S" o resp="s" Hacer Escribir "DIGITE NOMBRE DEL CUENTAHABIENTE"; leer nom; Escribir "DIGITE SALDO INICIAL"; leer saldoini; ESCRIBIR "VALOR DEL DEPOSITO"; LEER desp; Escribir "VALOR RETIRO"; Leer ret; saldo<-saldoini+desp; saldo<-saldoini-ret; sa<-sa+saldo; cm<-cm+1; Escribir "DESEA REALIZAR OTRO MOVIMIENTO S/N"; leer resp; FinMientras Escribir "MOVIMIENTO"," " ","SALDO"; escribir cm," ",sa; ","DEPOSITO"," ",desp," ","RETIRO", ",ret,"

FinProceso

Proceso sin_titulo //Elaborar un algoritmo que permita leer el tamaño de un ángulo en radianes o en grados y que imprima la tangente, secante,cotangente y cosecante. //Debe preguntar en qué tiene el tamaño del ángulo y dependiendo de si es en g rados o radianes, los cálculos deben hacerse de una u otra forma, //según corresponda. //1grado=0.0174775radianes resp<-"S"; repetir ESCRIBIR "DIGITE EL VALOR DEL ANGULO"; leer n; Escribir "EL VALOR DADO ES EN:"; Escribir "1) GRADOS"; Escribir "2) RADIANES"; leer op; segun op Hacer 1: rad<-n*(3.145926536/180); Escribir "TANGENTE DE"," ",tan(rad); Escribir "SECANTE DE"," ",asen(rad); Escribir "COTANGENTE DE"," ",atan(rad); Escribir "COSECANTE DE"," ",acos(rad); 2: Escribir "TANGENTE DE"," ",tan(n); Escribir "SECANTE DE"," ",asen(n); Escribir "COTANGENTE DE"," ",atan(n); Escribir "COSECANTE DE"," ",acos(n); FinSegun Escribir "Realizar otro calculo S/N"; LEER resp; hasta que resp="n" o resp="N" FinProceso

Proceso sin_titulo //Elaborar un algoritmo que permita leer una letra e imprima si es vocal o si es consonante resp<-"s"; Mientras resp="s" o resp="S" hacer ESCRIBIR "VOCAL O CONSONANTE"; Escribir "DIGITE UNA LETRA"; leer letra; si (letra="a" O letra="e" O letra="i" O letra="o" O letra="u")o(letra="A " O letra="E" O letra="I" O letra="O" O letra="U") Entonces escribir "ES UNA VOCAL"; Sino Escribir "ES UNA CONSONATE"; FinSi Escribir "Realizar otro calculo S/N"; LEER resp; FinMientras FinProceso

Proceso sin_titulo //Elaborar un algoritmo que permita leer los datos de un automóvil: marca, origen y costos; imprimir el impuesto a pagar y el precio //de venta incluido el impuesto.Si el origen es Alemania, el impuesto es 20%.Si es de Japón el impuesto es 30%, si es de Italia,15% y //si es de Usa,8%. resp<-"s"; Mientras resp="s" o resp="S" hacer Escribir "DATOS DE AUTOMIVIL"; Escribir "MARCA DEL VEHICULO"; leer marca; Escribir "COSTO DEL VEHICULO"; leer costo; Escribir "ORIGEN DEL VEHICULO"; Escribir "1)ALEMANIA"; Escribir "2)JAPON"; Escribir "3)ITALIA"; Escribir "4)USA"; leer op; Segun op Hacer 1: valor<-costo*0.2; pagar<-costo+valor; Escribir "VALOR DE IMPUESTO"," ",valor; Escribir "TOTAL A PAGAR"," ",pagar; 2: valor<-costo*0.3; pagar<-costo+valor; Escribir "VALOR DE IMPUESTO"," ",valor; Escribir "TOTAL A PAGAR"," ",pagar; 3: valor<-costo*0.15; pagar<-costo+valor; Escribir "VALOR DE IMPUESTO"," ",valor; Escribir "TOTAL A PAGAR"," ",pagar; 4: valor<-costo*0.08; pagar<-costo+valor; Escribir "VALOR DE IMPUESTO"," ",valor; Escribir "TOTAL A PAGAR"," ",pagar; FinSegun Escribir "Realizar otro calculo S/N"; LEER resp; FinMientras FinProceso Proceso sin_titulo //elaborar un algoritmo que permita leer los datos de un empleado: Nombr e, tipo de empleado, numero de horas trabajadas y cuota que se le //paga por hora; calcular e imprimir el sueldo a pagar. Si el empleado e s Tipo1, se le pagan las horas extra(más de 40 horas)a 1.5 de la cuota //por hora, si es Tipo2,a 2; si es de Tipo3, a 2.5; y si es Tipo4 a 3 ve ces la cuota por hora. resp<-"s"; Mientras resp="s" o resp="S" hacer Escribir "DIGITE NOMBRE DEL EMPLEADO";

leer nom; Escribir "QUE TIPO DE EMPLEADO ES 1,2,3 O 4:"; LEER op; Escribir "DIGITE EL NUMERO DE HORAS TRABAJADAS"; LEER horas; Escribir "DIGITE EL VALOR DE LA HORA DE TRABAJO"; LEER valor; subtotal<-horas*valor; si op=1 Entonces si horas>40 Entonces hextras<-horas-40; extras<-hextras*1.5; sueldo<-subtotal+extras; escribir "Suledo a Pagar"," ",sueldo; Sino escribir "Suledo a Pagar"," ",subtotal; Sino FinSi FinSi si op=2 Entonces si horas>40 Entonces hextras<-horas-40; extras<-hextras*2; sueldo<-subtotal+extras; escribir "Suledo a Pagar"," ",sueldo; Sino escribir "Suledo a Pagar"," ",subtotal; Sino FinSi FinSi si op=3 Entonces si horas>40 Entonces hextras<-horas-40; extras<-hextras*2.5; sueldo<-subtotal+extras; escribir "Suledo a Pagar"," ",sueldo; Sino escribir "Suledo a Pagar"," ",subtotal; Sino FinSi FinSi si op=4 Entonces si horas>40 Entonces hextras<-horas-40; extras<-hextras*3; sueldo<-subtotal+extras; escribir "Suledo a Pagar"," ",sueldo; Sino escribir "Suledo a Pagar"," ",subtotal; Sino FinSi FinSi Escribir "Realizar otro calculo S/N"; LEER resp; FinMientras

FinProceso Proceso sin_titulo //Un trapecio es isósceles si sus dos ángulos de la base son iguales. Elabo rar un algoritmo que lea los ángulos A y B //de la base y que imprima si el trapecio es isósceles o no. resp<-"s"; Mientras resp="s" o resp="S" hacer Escribir "TRAPECIO ISOSCELES"; escribir "DIGITE ANGULO A, DE LA BASE"; LEER a; escribir "DIGITE ANGULO B, DE LA BASE"; LEER b; si a=b Entonces escribir "TRAPECIO ISOSCELES"; Sino Escribir "No es Isosceles"; FinSi Escribir "Realizar otro calculo S/N"; LEER resp; FinMientras FinProceso Proceso sin_titulo //Dos triángulos son congruentes si tienen la misma forma y tamaño, es decir , sus ángulos y lados correspondientes son iguales //Elaborar un algoritmo que lea los tres ángulos y lados de dos triángulos e imprima si son congruentes. resp<-"s"; Mientras resp="s" o resp="S" hacer Escribir "DATOS DEL TRIANGULO A"; Escribir LEER a1; Escribir LEER a2; Escribir LEER a3; Escribir LEER n1; Escribir LEER n2; Escribir LEER n3; "DIGITE ANGULO 1 DEL TRIANGULO A"; "DIGITE ANGULO 2 DEL TRIANGULO A"; "DIGITE ANGULO 3 DEL TRIANGULO A"; "DIGITE EL VALOR DEL LADO 1 DEL TRIANGULO A"; "DIGITE EL VALOR DEL LADO 2 DEL TRIANGULO A"; "DIGITE EL VALOR DEL LADO 3 DEL TRIANGULO A";

Escribir "DATOS DEL TRIANGULO B"; Escribir LEER b1; Escribir LEER b2; Escribir LEER b3; Escribir LEER c1; Escribir LEER c2; "DIGITE ANGULO 1 DEL TRIANGULO B"; "DIGITE ANGULO 2 DEL TRIANGULO B"; "DIGITE ANGULO 3 DEL TRIANGULO B"; "DIGITE EL VALOR DEL LADO 1 DEL TRIANGULO B"; "DIGITE EL VALOR DEL LADO 2 DEL TRIANGULO B";

Escribir "DIGITE EL VALOR DEL LADO 3 DEL TRIANGULO B"; LEER c3; SI [[(a1=b1)y(a2=b2)y(a3=b3)] y [(n1=c1)y (n2=c2)Y (n3=c3)]] Entonces escribir "El Triangulo A y B SON CONGRUENTES"; Sino ESCRIBIR "LOS TRIANGULOS A Y B SON DIFERENTES"; FinSi Escribir "Realizar otro calculo S/N"; LEER resp; FinMientras FinProceso Proceso sin_titulo //En un almacén de venta de trajes, si compra uno se hace el 50% de descue nto, si compra 2, el 55% si compra 3, 60%, // y si compra más de 3 el 65%. Elaborar un algoritmo que lea la cantidad de trajes y el precio unitario(todos tienen el mismo precio) //e imprima el subtotal a pagar, el descuento, el desarrollo y el total a pagar. resp<-"s"; Mientras resp="s" o resp="S" hacer Escribir "DIGITE LA CANTIDAD DE TRAJES A COMPRAR"; leer trajes; Escribir "DIGITE PRECIO UNITARIO"; LEER precio; des1<-0.5; des2<-0.55; des3<-0.6; des4<-0.65; subtotal<-trajes*precio; si trajes=1 Entonces descuento<-subtotal*des1; total<-subtotal-descuento; Escribir "Subtotal"," ",subtotal; Escribir "Descuento de 50%"," ",descuento; Escribir "Total A Pagar"," ",total; Sino si trajes=2 Entonces descuento<-subtotal*des2; total<-subtotal-descuento; Escribir "Subtotal"," ",subtotal; Escribir "Descuento de 55%"," ",descuento; Escribir "Total A Pagar"," ",total; Sino si trajes=3 Entonces descuento<-subtotal*des3; total<-subtotal-descuento; Escribir "Subtotal"," ",subtotal; Escribir "Descuento de 60%"," ",descuento; Escribir "Total A Pagar"," ",total; Sino si trajes>3 Entonces descuento<-subtotal*des4; total<-subtotal-descuento; Escribir "Subtotal"," ",subtotal; Escribir "Descuento de 65%"," ",descuento;

Escribir "Total A Pagar"," ",total; Sino FinSi FinSi FinSi FinSi Escribir "Realizar otra orden S/N"; LEER resp; FinMientras FinProceso Proceso sin_titulo //De acuerdo con la clase de sus ángulos, los triángulos se clasifican en: //Rectángulo tiene un ángulo recto (igual a 90 grados) //obtusángulo tiene un ángulo obtuso (mayor que 90 grados pero menor que 180 grados) //Acutángulo los tres ángulos son agudos(menores que 90 grados) //Elabore un algoritmo que permita leer el tamaño de los tres ángulos(a,b,c) de un triángulo e imprima qué tipo es. resp<-"s"; Mientras resp="s" o resp="S" hacer Escribir "DIGITE ANGULO 1"; LEER a1; Escribir "DIGITE ANGULO 2"; LEER a2; Escribir "DIGITE ANGULO 3"; LEER a3; si (a1=90) Y (a2<>90) y (a3<>90) entonces escribir "TRIANGULO RECTANGULO"; Sino si (a1<>90) y (a2=90) y (a3<>90) entonces escribir "TRIANGULO RECTANGULO"; Sino si (a1<>90) y (a2<>90) y (a3=90) Entonces escribir "TRIANGULO RECTANGULO"; Sino FinSi FinSi FinSi si [(a1>90 y a1<=180) y[(a2<>a1) y (a3<>a1)]] Entonces escribir "TRIANGULO OBTUSANGULO"; Sino Si [(a2>90 y a2<=180) y [(a1<>a2) y (a3<>a2)]] Entonces Escribir "TRIANGULO OBTUSANGULO"; Sino si [(a3>90 y a3<=180) y [(a3<>a1) y (a3<>a2)]] Entonces Escribir "TRIANGULO OBTUSANGULO"; Sino FinSi FinSi FinSi si [(a1<90)y(a2<90)y(a3<90)] Entonces escribir "TRIANGULO ACUTANGULO"; Sino FinSi Escribir "Realizar otro Proceso S/N"; LEER resp;

FinMientras FinProceso

Proceso sin_titulo //Elabore un algortimo que lea los datos de un estudiante:Nombre y tres calificaciones parciales e imprimir el nombre // y la calificación final de acuerdo a lo siguiente: para aprobar el curs o debe tener 70 o más en cada una de las tres calificaciones, //la calificación final será el promedio. En caso de haber reprobado uno o más exámenes ordinarios, la calificación final será NA(NO ACREDITADA). resp<-"s"; Mientras resp="s" o resp="S" hacer Escribir "DIGITE NOMBRE DEL ESTUDIANTE"; Leer nom; Escribir "Digite Nota1"; leer nota1; Escribir "Digite Nota2"; leer nota2; Escribir "Digite Nota3"; leer nota3; si nota1>=70 y nota2>=70 y nota3>=70 Entonces pro<-nota1+nota2+nota3; res<-pro/3; Escribir nom; Escribir "Aprobado"; escribir "CALIFICACION FINAL:"," ",res; Sino pro<-nota1+nota2+nota3; res<-pro/3; Escribir nom; escribir "CALIFICACION FINAL:"," ","NO ACREDITADA ",res; FinSi Escribir "Realizar otra orden S/N"; LEER resp; FinMientras FinProceso Proceso sin_titulo //Un cliente ordena cierta cantidad de hojas de hielo seco, viguetas y a rmazones; las hojas de hielo seco tienen 20% de descuento //y las viguetas 15%.Los datos que se tienen por cada tipo de artículo son :la cantidad pedida y el precio unitario.Además, //si se paga de contado todo tiene un descuento de 7%. //pero además si la cantidad de hojas de hielo seco solicitada es mayor qu e 50, se hace un descuento adicional de 5% en caso de ser mayor //que 100 el descuento adicional es de 10%. //Elaborar un algoritmo que calcule e imprima el costo total de la orden , tanto para el pago de contado como para el caso de crédito. resp<-"s"; Mientras resp="s" o resp="S" hacer des1<-0.2; des2<-0.05; des3<-0.1;

des4<-0.15; des5<-0.07; Escribir "Ingrese Cantidad leer ho; Escribir "Digite el Precio leer precio1; Escribir "Ingrese Cantidad leer vi; Escribir "Digite el Precio leer precio2; Escribir "Ingrese Cantidad leer ar;; Escribir "Digite el Precio leer precio3;

de Hojas de Hielo Seco"; Unitario de Hojas de Hielo Seco"; de Viguetas"; Unitario de Viguetas"; de Armazones"; Unitario de Hojas de Armazones";

valortotal<-ho*precio1; descuento<-valortotal*des1; total<-valortotal-descuento; valortotal1<-vi*precio2; descuento1<-valortotal1*des4; pagar2<-valortotal1-descuento1; pagar3<-ar*precio3; si ho>=50 y ho<100 Entonces descuento1<-total*des2; pagar<-total-descuento1; cancelar<-pagar+pagar2+pagar3; Escribir "A)Costo Total de la de Orden"; escribir cancelar; Escribir "B)Pago Al Contado tiene un descuento del 7%. E l Valor a Pagar es de:"; descuento2<-cancelar*des5; total1<-cancelar-descuento2; Escribir total1; Sino si ho>=100 Entonces descuento2<-total*des3; pagar1<-total-descuento2; cancelar<-pagar1+pagar2+pagar3; Escribir "A)Costo Total de la de Orden"; escribir cancelar; Escribir "B)Pago Al Contado tiene un descuento del 7%. E l Valor a Pagar es de:"; descuento2<-cancelar*des5; total1<-cancelar-descuento2; Escribir total1; Sino valor1<-ho*precio1; descuento1<-valor1*des1; pagar1<-valor1-descuento1; valor2<-vi*precio2; descuento2<-valor2*des4; pagar2<-valor2-descuento2; valor3<-ar*precio3; valororden<-pagar1+pagar2+valor3; Escribir "A).Costo Total de la de Orden"; escribir valororden; Escribir "B).Pago Al Contado tiene un descuento del 7%. El Valor a Pagar es de:";

descuento3<-valororden*des5; total<-valororden-descuento3; Escribir total; FinSi FinSi Escribir "Realizar otra orden S/N"; LEER resp; FinMientras FinProceso

Proceso sin_titulo //Un cliente ordena cierta cantidad de hojas de hielo seco, viguetas y a rmazones; las hojas de hielo seco tienen 20% de descuento //y las viguetas 15%.Los datos que se tienen por cada tipo de artículo son :la cantidad pedida y el precio unitario.Además, //si se paga de contado todo tiene un descuento de 7%. //Elaborar un algoritmo que calcule e imprima el costo total de la orden , tanto para el pago de contado como para el caso de crédito. resp<-"s"; Mientras resp="s" o resp="S" hacer deshielo<-0.2; desvi<-0.15; pgcontado<-0.07; Escribir "Ingrese Cantidad de Hojas de Hielo Seco"; leer ho; Escribir "Digite el Precio Unitario de Hojas de Hielo Seco"; leer precio1; Escribir "Ingrese Cantidad de Viguetas"; leer vi; Escribir "Digite el Precio Unitario de Viguetas"; leer precio2; Escribir "Ingrese Cantidad de Armazones"; leer ar;; Escribir "Digite el Precio Unitario de Hojas de Armazones"; leer precio3; valor1<-ho*precio1; descuento1<-valor1*deshielo; pagar1<-valor1-descuento1; valor2<-vi*precio2; descuento2<-valor2*desvi; pagar2<-valor2-descuento2; valor3<-ar*precio3; valororden<-pagar1+pagar2+valor3; Escribir "A).Costo Total de la de Orden"; escribir valororden; Escribir "B).Pago Al Contado tiene un descuento del 7%. El Valor a Pagar es de:"; descuento3<-valororden*pgcontado; total<-valororden-descuento3; Escribir total; Escribir "Realizar otra orden S/N";

LEER resp; FinMientras FinProceso

Proceso sin_titulo // Elabore un algortimo para calcular e imprimir el precio de un terreno del cua l se tienen los siguientes datos: //largo, ancho y precio por metro cuadrado. Si el terreno tiene más de 500 metros cuadrados se hace un descuento de 17% y si //tiene más de 1000 el descuento es de 25%. resp<-"s"; mientras resp="s" des1<-0.17; des2<-0.25; Escribir "Ingrese leer ancho; Escribir "Ingrese leer largo; Escribir "Ingrese leer precio; o resp="S" hacer el ancho del Terreno"; el largo del Terreno"; el precio por metro cuadrado";

m2<-ancho*largo; valor<-m2*precio; si m2>=500 y m2<1000 Entonces descuento<-valor*des1; pagar<-valor-descuento; escribir "Valor A Pagar"," ",pagar; Sino si m2>=1000 Entonces descuento<-valor*des2; pagar<-valor-descuento; Escribir "Valor A Pagar"," ",pagar; Sino escribir "Valor A Pagar"," ",valor; FinSi FinSi Escribir "Realizar otro calculo S/N"; leer resp; FinMientras FinProceso

Proceso operador_O // Una escuela aplica dos exámenes a sus aspirantes, por lo que cada uno d e ello obtiene dos calificaciones //denotadas como c1 y c2. El aspirante que obtenga una calificación mayor que 90 en cualquiera de los examenes es aceptado; //en caso contrario es rechazado. resp<-"S"; mientras resp="S" o resp="s" hacer Escribir "Ingrese Nombre Del Estudiante"; leer nom; Escribir "Ingrese Calificacion1";

leer cal1; Escribir "Ingrese Calificacion2"; leer cal2; si cal1>=90 o cal2>=90 Entonces Escribir "Estudiante"," ",nom; Escribir " Aceptado"; Sino escribir "Rechazado"; FinSi Escribir "Ingresar Otro Alumno S/N"; leer resp; FinMientras FinProceso Proceso sin_titulo // Elaborar un algoritmo que lea la cantidad de dólares a comprar y el tip o de cambio en //pesos(costo de un dólar en pesos);calcular e imprimir la cantidad a paga r en pesos por la //cantidad de dólares indicada. resp<-"S"; Mientras resp="S" o resp="s" hacer Escribir "Digite cantidad de dolares a comprar"; leer cant; escribir "Digite costo de un dolar en pesos"; leer cambio; pagar<-cambio*cant; Escribir "Cantidad a pagar en Pesos es:"," ",pagar; FinMientras FinProceso

Proceso sin_titulo //Elaborar un algortimo que lea el radio de un c?culo e imprima el ?ea. // area=pi*r^2 resp<-"S"; Mientras resp="S" o resp="s" hacer Escribir "Digite Radio Del Circulo"; leer rad; area<-3.14*(rad^2); Escribir "El Area del Circulo es:"," ",area; Escribir "Realizar otro proceso S/N"; leer resp; FinMientras FinProceso

Proceso sin_titulo //Elaborar un algoritmo que lea el art?ulo y su costo; la utilidad es150 %

// y el impuesto es 15%; calcular e imprimir art?ulo,utilidad,impuesto y precio de venta. resp<-"S"; Mientras resp="S" o resp="s" hacer utilidad<-1.50; impuesto<-0.15; EScribir "Detalle Del Producto"; leer detalle; Escribir "Digite Costo del Producto"; leer costo; costo1<-costo*utilidad; utilidad1<-costo+costo1; costo2<-utilidad*impuesto; impuesto1<-utilidad1+costo2; EScribir "Producto"," ",detalle; Escribir "La Utilidad es de:"," ",costo1; Escribir "Valor de Impuesto:"," ",costo2; Escribir "Precio De Venta:"," ",impuesto1; Escribir "Realizar otro proceso S/N"; leer resp; FinMientras FinProceso

Proceso sin_titulo //Elabore un algoritmo que lea un número de pies y calcule e imprima su eq uivalente //en yardas,pulgadas,centímetros y metros, de acuerdo con las siguientes e quivalencias //1 pie=12 pulgadas 1 yarda=3 pies, 1 pulgada=2.54cm y 1metro=100cm resp<-"S"; Mientras resp="S" o resp="s" hacer Escribir "Ingrese Valor En Pies"; leer pies; pulgadas<-pies*12; yardas<-(pies*1)/3; cm<-pulgadas*2.54; mt<-cm*100; Escribir "Yardas"," ",yardas; Escribir "Pulgadas"," ",pulgadas; Escribir "Centimetros"," ",cm; Escribir "Metros"," ",mt; Escribir "Realizar otro proceso S/N"; leer resp; FinMientras FinProceso Proceso sin_titulo //Una temperatura en grados Centígrados(C) se puede convertir a su equival ente //Fahrenheit(F)con la fórmula //F=9/5C+32 //DE Fahrenheit a Centígrados con la fórmula: C=(F-32)5/9 //Elaborar un algoritmo que lea una temperatura en grados centígrados y ob tenga e //imprima la temperatura Fahrenheit equivalente.

resp<-"S"; Mientras resp="S" o resp="s" hacer Escribir "Ingrese Temperatura En Centigrados"; leer temp; f<-9/5*temp+32; Escribir "Temperatura Grados Fahrenheit es:"," ",f; Escribir "Realizar otro proceso S/N"; leer resp; FinMientras FinProceso

Proceso sin_titulo //La velocidad de la luz es 300000 kilometros por segundo. Elaborar un a lgoritmo que lea, //un tiempo en segundos e imprima la distancia que recorre en dicho tiem po. resp<-"S"; Mientras resp="S" o resp="s" hacer luz<-30000; Escribir "Ingrese Tiempo en Segundos"; leer seg; distancia<-luz*seg; Escribir "Distancia Recorrida "," ",distancia," ","km"; Escribir "Realizar otro proceso S/N"; leer resp; FinMientras FinProceso

Proceso sin_titulo //Los datos disponibles para la lectura son el nombre,califación1,califación 2,califación3 y califación4; de cada uno de los cuatro //exámenes presentados.La información que se debe imprimir es el Nombre y c alificación final multiplicando calificaciones1,2,3,y 4 //por los porcentajes 30,20,10y 40% respectivamente, y sumando los produ ctos. resp<-"S"; Mientras resp="S" o resp="s" hacer Escribir "Ingrese Nombre Del Estudiante"; leer nom; Escribir "Ingrese Califacion1"; leer cal1; Escribir "Ingrese Califacion2"; leer cal2; Escribir "Ingrese Califacion3"; leer cal3; Escribir "Ingrese Califacion4"; leer cal4; p1<-cal1*0.3; p2<-cal2*0.2; p3<-cal3*0.1; p4<-cal4*0.4;

cal<-p1+p2+p3+p4; escribir "estudiante"," ",nom; Escribir "Calificacion"," ",cal; Escribir "Realizar otro proceso S/N"; leer resp; FinMientras FinProceso Proceso sin_titulo //Elaborar un algoritmo para calcular el promedio de calificaciones de u n estudiante. //Los datos disponibles para la lectura son el nombre,califación1,califación 2,califación3 y califación4; de cada uno de los cuatro //exámenes presentados.La información que se debe imprimir es el Nombre y e l promedio de las calificaciones. //El promedio se obtiene sumando las cuatro calificaciones y dividiendo la suma entre 4. resp<-"S"; Mientras resp="S" Escribir "Ingrese leer nom; Escribir "Ingrese leer cal1; Escribir "Ingrese leer cal2; Escribir "Ingrese leer cal3; Escribir "Ingrese leer cal4; o resp="s" hacer Nombre Del Estudiante"; Califacion1"; Califacion2"; Califacion3"; Califacion4";

promedio<-(cal1+cal2+cal3+cal4)/4; Escribir "Estudiante"," ",nom; Escribir "Promedio" ," ",promedio; Escribir "Realizar otro proceso S/N"; leer resp; FinMientras FinProceso

Proceso sin_titulo //un algoritmo que calcule e imprima el costo de un terreno cuadrado o rectangul ar, //teniendo como datos la anchura y la longitud en metros, y el costo del metro c uadrado resp<-"S"; mientras resp="S" Escribir "Ingrese leer ancho; Escribir "Ingrese leer long; Escribir "Ingrese leer precio; o resp="s" hacer el ancho del Terreno"; longuitud del terreno"; valor de metro cuadrado";

m2<-(ancho*long)*precio; escribir "El precio del terreno es"," ",m2; Escribir "Realizar otro calculo S/N";

LEER resp; FinMientras FinProceso

Proceso sin_titulo //factura //correspondiente a una compra de un articulo determinado, del que //se adquieren una o varias unidades. El IVA es del 15% y si el precio //bruto ( precio venta mas IVA) es mayor de 10.000 dolares se debe //realizar un descuento del 5%. iva<-0.15; descuento<-0.05; Escribir "cantidad del producto"; leer cantidad; Escribir "Digite el valor unitario del producto"; leer valor; valortotal<-cantidad*valor; subtotal<-valortotal*iva; total<-valortotal+subtotal; si total>= 10000 Entonces des<-total*descuento; cancelar<-total-des; escribir "El Valor A Cancelar es de :",cancelar; Sino escribir "El Valor A Cancelar es de:",total; FinSi FinProceso

Proceso sin_titulo //Algoritmo que lea dos números por teclado y muestre un mensaje por panta lla //indicando si el cuadrado del primero es mayor que el cubo del segundo. resp<-"S"; mientras resp="S" o resp="s" hacer Escribir "Ingrese primer numero"; leer num; Escribir "Ingrese segundo numero"; leer num1; cuadrado<-num^2; cubo<-num1^3; si cuadrado>cubo Entonces escribir "el cuadrado de:",num; escribir "es el mayor"; Sino Escribir "el cubo de:",num; Escribir "es el mayor"; FinSi escribir "Digitar otro numero S/N"; leer resp; FinMientras FinProceso

Proceso sin_titulo //Algoritmo que lea un número por el teclado e indique si el número leído es m ayor //que 10 y si el número leído es menor que 20. resp<-"S"; mientras resp="S" o resp="s" hacer Escribir "Digite un numero"; leer numero; si numero>=10 y numero<=20 Entonces escribir "Numero mayor a 10 y menor que 20"; Sino si numero<10 y numero<20 Entonces Escribir "Numero menor a 10 y menor a 20"; Sino si numero >10 y numero>20 Entonces Escribir "Numero mayor a 10 y mayor a 20"; Sino FinSi FinSi FinSi escribir "digitar otro numero s/n"; leer resp; Fin

Proceso multiplicar_para escribir "ingrese que tabla desea"; leer t; i<-1; Para i<-1 hasta 12 Hacer m<-t*i; escribir m; i<-i+0; FinPara FinProceso

Proceso TABLA_MULTIPLICAR_repetir Escribir "ingrese tabla que dese"; leer t; i<-0; Repetir m<-t*i; escribir m; i<-i+1; Hasta Que i=13 FinProceso

Proceso PRIMO //numeros primos comprendidos 1 al 100

NC<- 0; PARA C<-1 HASTA 100 Hacer PARA C2<-1 HASTA C Hacer RES<-C MOD C2; SI RES=0 ENTONCES NC<- NC+1;FinSi FinPara SI NC=2 Entonces ESCRIBIR C; FinSi NC<-0; FinPara FinProceso

Proceso sin_titulo //Imprima todos los numeros impares hasta el 100 y que imprima c<-0; son<-1; mientras c<100 Hacer res<-c mod 2; si res<>0 entonces escribir c; Sino FinSi c<-c+1; FinMientras FinProceso

Proceso sin_titulo //imprima los numeros del 100 al 0 en orden decreciente c<-100; mientras c >=0 Hacer Escribir c; c<- c-1; FinMientras FinProceso

Proceso sin_titulo //imprima los numeros delm 1 al 100 c<-1; mientras c<101 Hacer Escribir c; c<-c+1; FinMientras FinProceso

Proceso sin_titulo

//factorial resp<-"S"; mientras resp="S" o resp="s" hacer Escribir "Digite Un Numero"; leer numero; a<-1; b<-numero*a; mientras a<numero Hacer b<-b*a; a<-a+1; FinMientras escribir b; escribir "Digitar otro numero S/N"; leer resp; FinMientras FinProceso Proceso sin_titulo //En el Hospital "Seguimos en crisis" tienen las siguientes tarifas: //tipos de enfermead costo/paciente/dia // 1 1500 // 2 1700 // 3 1900 //Para lo cual se necesita que usted elabore un informe con el siguiente formato : //Paciente Días hospitalizados Tipo de enfermedad //Total a pagar resp<-"S"; mientras resp="S" o resp="s" hacer Escribir "Digite Nombre Del Paciente"; leer nombre; Escribir "Ingrese dias Hospitalizados del paciente"; leer dias; Escribir "seleccione tipo de enfermeda"; Escribir "1)TIPO 1"; Escribir "2)TIPO 2"; Escribir "3)TIPO 3"; LEER op; segun op Hacer 1: costo<-dias*1500; escribir "Paciente"; Escribir nombre; escribir "Dias Hospitalizados"; escribir dias; escribir "Enfermedad"; escribir "Tipo 1"; Escribir "valor a cancelar"; escribir costo; 2: costo<-dias*1700; escribir "Paciente"; Escribir nombre; escribir "Dias Hospitalizados"; escribir dias; escribir "Enfermedad"; escribir "Tipo 1";

Escribir "valor a cancelar"; escribir costo; 3: costo<-dias*1900; escribir "Paciente"; Escribir nombre; escribir "Dias Hospitalizados"; escribir dias; escribir "Enfermedad"; escribir "Tipo 1"; Escribir "valor a cancelar"; escribir costo; FinSegun Escribir "Realizar otro proceso S/N"; leer resp; FinMientras FinProceso Proceso sin_titulo //El colegio "Mi angelito" desea calcular el monto a pagar por inscripción del nue vo año escolar, //para las familias con hijos en el colegio. Para ello se conoce el numero de hi jos que tiene la familia en el colegio, //el monto de matricula por niño, el monto de la mensualidad del mes de septiembre por niño y el monto de la sociedad de padres. // Elabore un algoritmo que calcule el total a pagar por la familia, si la soci edad de padres se cobra una vez por familiar, // y si se otorga un descuento por la cantidad de hijos en el colegio que viene dado por la siguiente tabla. //Cantidad de hijos Descuento //2 niños 10% 0.1% //3 niños 15% 0.15% //>3 niños 20% 0.2% ESCRIBIR "COLEGIO"; Escribir "MI ANGELITO"; resp<-"S"; mientras resp="s" o resp="S" Hacer Escribir "Ingrese el numero de Hijos que tiene la familia"; leer hijos; escribir "Valor de matricula"; leer matricula; Escribir "Valor Mensualidad de Septiembre"; leer mensualidad; escribir "Valor Sociedad De Padres"; leer aporte; matricula1<-hijos*matricula; mensualidad1<-hijos*mensualidad; total<-matricula1+mensualidad1+aporte; si hijos=2 Entonces descuento<-total*0.1; total1<-total-descuento; escribir "El valor A Cancelar es De:"; escribir total1; Sino si hijos=3 Entonces descuento<-total*0.15; total1<-total-descuento; escribir "El valor A Cancelar es De:";

escribir total1; Sino si hijos>3 Entonces descuento<-total*0.2; total1<-total-descuento; escribir "El valor A Cancelar es De:"; escribir total1; Sino escribir total; FinSi FinSi FinSi FinMientras FinProceso Proceso sin_titulo //Calcule el aumento de sueldo de un trabajador, // conociendo del mismo, su nombre, tipo de trabajador, su sueldo y la cantidad de hijos que tiene. // El porcentaje de aumento del sueldo viene dado por el tipo de trabajador que es: //Tipo de trabajador //'V' 10% 0.1% //'G' 15% 0,15% //'E' 20% 0,2% //'O' 30% 0,3% //Adicionalmente se le paga una prima por cada hijo la cual es conocida y la mis ma para todos. resp<-"S"; mientras resp="S" o resp="s" hacer prima<-20; Escribir "Ingrese nombre del empleado"; leer nombre; Escribir "Digite sueldo del empleado"; leer sueldo; Escribir "Cantidad de hijos"; leer hijos; escribir "Que Tipo De Trabajador Es"; escribir "1)V"; escribir "2)G"; escribir "3)E"; escribir "4)0"; LEER op; SEGUN op Hacer 1: porcentaje<-sueldo*0.1; aumento<-sueldo+porcentaje; bono<-hijos*prima; aumento1<-porcentaje+bono; total<-aumento+bono; escribir "Empleado"; Escribir nombre; Escribir "el aumento a su sueldo es de:"; Escribir aumento1; escribir "su sueldo es de:"; escribir total;

2: porcentaje<-sueldo*0.15; aumento<-sueldo+porcentaje; bono<-hijos*prima; aumento1<-porcentaje+bono; total<-aumento+bono; escribir "Empleado"; Escribir nombre; Escribir "el aumento a su sueldo es de:"; Escribir aumento1; escribir "su sueldo es de:"; escribir total; 3: porcentaje<-sueldo*0.2; aumento<-sueldo+porcentaje; bono<-hijos*prima; aumento1<-porcentaje+bono; total<-aumento+bono; escribir "Empleado"; Escribir nombre; Escribir "el aumento a su sueldo es de:"; Escribir aumento1; escribir "su sueldo es de:"; escribir total; 4: porcentaje<-sueldo*0.3; aumento<-sueldo+porcentaje; bono<-hijos*prima; aumento1<-porcentaje+bono; total<-aumento+bono; escribir "Empleado"; Escribir nombre; Escribir "el aumento a su sueldo es de:"; Escribir aumento1; escribir "su sueldo es de:"; escribir total; FinSegun escribir "Realizar otro calculo S/n"; leer resp; FinMientras FinProceso Proceso sin_titulo //Suponga que se leen los datos de tres artículos comprados en una tienda, //donde para cada articulo se conoce el nombre del artículo, //la cantidad a comprar del artículo y el precio del mismo. //Calcule el monto total a pagar por el articulo si adicionalmente se de sea cobrar el impuesto sobre la venta de 14.5%, //en aquellas compras cuyo monto supera los 500 dolares resp<-"S"; mientras resp="S" o resp="s" hacer impuesto<-0.145; Escribir "Ingrese Nombre del Primer Articulo"; leer a; escribir "Ingrese cantidad de producto"; leer cantidad; escribir "Ingrese el valor del producto";

leer valor; Escribir "Ingrese leer b; escribir "Ingrese leer cantidad1; escribir "Ingrese leer valor1; Escribir "Ingrese leer c; escribir "Ingrese leer cantidad2; escribir "Ingrese leer valor2;

Nombre del Segundo Articulo"; cantidad de producto"; el valor del producto"; Nombre del Tercer Articulo"; cantidad de producto"; el valor del producto";

total<-cantidad*valor; total1<-cantidad1*valor1; total2<-cantidad2*valor2; sumatotal<-total+total1+total2; si sumatotal>500 Entonces impuesto1<-sumatotal*impuesto; valorpagar<-sumatotal-impuesto; escribir "TOTAL A PAGAR "; Escribir valorpagar; Sino Escribir "TOTAL A PAGAR"; ESCRIBIR sumatotal; FinSi FinMientras FinProceso

Proceso sin_titulo //Elabore un algoritmo que dado un valor X, calcule //Para X positivo: //F(x) = (x - 2) 2 + (x - 4) 4 + (x - 6) 6 // 2 4 6 //Para X negativo: //F(x) = (x + 2) 2 + (x + 4) 4 + (x + 6) 6 // 2 4 6 Escribir "Ingres valor de x"; leer a; x1<-[(a-2)^2]/2+[(a-4)]^4/4+[(a-6)^6/6]; x2<-[(a+2)^2]/2+[(a+4)]^4/4+[(a+6)^6/6]; ESCRIBIR x1; Escribir x2; FinProceso Proceso sin_titulo //El Seniat ha establecido un nuevo impuesto a las compras de productos, el cuál e stá determinado por el tipo de artículo a facturar, // según la siguiente tabla: //Tipo de producto Tasa impuesto //Exclusivo 30% //Lujo 20% //Económico 10% //Accesible 5% //Para cada compra se conoce, monto de la compra y el tipo de producto.

//Se desea elaborar el algoritmo que nos permita para cada compra realizada, //calcular el impuesto que deberá cancelar el cliente y el monto total de la factu ra, //a la cuál se le realiza un descuento, cuyo porcentaje es conocido. resp<-"S"; mientras resp="s" o resp="S" hacer descuento<-0.05; Escribir "Ingrese El Monto De La Compra"; leer monto; escribir "Que Tipo De Producto Es"; escribir "1)Exclusivo"; escribir "2)lujo"; escribir "3)Economico"; escribir "4)accesible"; leer op; SEGUN op Hacer 1: impuesto<-monto*0.3; recargo<-monto+impuesto; descuento1<-recargo*descuento; total<-monto-descuento1; escribir "Tasa de Impuesto es de:"; escribir impuesto; escribir "Total A Pagar incluido descuento escribir total; 2: impuesto<-monto*0.2; recargo<-monto+impuesto; descuento1<-recargo*descuento; total<-monto-descuento1 ; escribir "Tasa de Impuesto es de:"; escribir impuesto; escribir "Total A Pagar incluido descuento escribir total; 3: impuesto<-monto*0.1; recargo<-monto+impuesto; descuento1<-recargo*descuento; total<-monto-descuento1; escribir "Tasa de Impuesto es de:"; escribir impuesto; escribir "Total A Pagar incluido descuento escribir total; 4: impuesto<-monto*0.05; recargo<-monto+impuesto; descuento1<-recargo*descuento; total<-monto-descuento1; escribir "Tasa de Impuesto es de:"; escribir impuesto; escribir "Total A Pagar incluido descuento escribir total; FinSegun ESCRIBIR "REALIZAR OTRO CALCULO S/N"; LEER resp; FinMientras FinProceso

del 5%";

del 5%";

del 5%";

del 5%";

Proceso sin_titulo //El Banco para el Pueblo está próximo a abrir sus puertas, por esta razón nec esita con suma urgencia la elaboración y //mantenimiento de un programa que le permita,mantener los saldos y movi mientos de las cuentas que manejará el banco. //El banco conoce para cada cuenta a aperturar, el número de cuenta, la cédu la del cliente, el nombre del cliente, el tipo de cuenta //(1- Ahorro, 2- Corriente, 3 - Fal y 4 - Préstamo) y por último, el saldo en cuenta. //Se desea elaborar un algoritmo, el cual permita leer los datos del cliente , calcular el interés y mostrar la siguiente información: //Para cada cliente: //1. Cedula, nombre y tipo de cuenta //2. Monto a pagar de interés, dado por la siguiente tabla //a. Para cuentas tipo 1 (ahorro) el 10% //b. Para cuentas tipo 2 (corriente) el 8% //c. Para cuentas tipo 3 (fal) el 12% //d. Para cuentas tipo 4 (prestamos) 0% //3. Saldo actual //4. Saldo nuevo con los intereses Escribir "ingrese numero de cuentas"; leer cuenta; Escribir "ingrese numero de cedula cliente"; leer cedula; Escribir "ingrese nombre del cliente"; leer nombre; escribir "saldo cuenta del cliente"; leer saldo; Escribir "Que tipo de cuenta es"; escribir "1)Ahorro"; escribir "2)corriente"; escribir "3)fal"; escribir "4)prestamo"; leer op; Escribir "INFORMACION PARA EL CLIENTE"; Segun op hacer 1: interes<-saldo*0.1; saldototal<-interes+saldo; escribir "cedula"; escribir cedula; escribir "Cliente"; Escribir nombre; escribir "Tipo De Cuenta"; Escribir "Cuenta de Ahorros"; escribir "Valor De Interes"; escribir interes; escribir "saldo Anterior"; escribir saldo; escribir " Saldo Actual"; escribir saldototal; 2: escribir "cedula"; escribir cedula; escribir "Cliente";

Escribir nombre; escribir "Tipo De Cuenta"; Escribir "Cuenta Corriente"; escribir "Valor De Interes"; escribir interes; escribir "saldo Anterior"; escribir saldo; escribir " Saldo Actual"; escribir saldototal; 3: interes<-saldo*0.12; saldototal<-interes+saldo; escribir "cedula"; escribir cedula; escribir "Cliente"; Escribir nombre; escribir "Tipo De Cuenta"; Escribir "Fal"; escribir "Valor De Interes"; escribir interes; escribir "saldo Anterior"; escribir saldo; escribir " Saldo Actual"; escribir saldototal; 4: escribir "cedula"; escribir cedula; escribir "Cliente"; Escribir nombre; escribir "Tipo De Cuenta"; Escribir "prestamo"; escribir "saldo Actual"; escribir saldo; FinSegun escribir "INFORMACIÓN PARA EL BANCO"; FinProceso

Proceso sin_titulo //La compañía de telefonía Acme, desea calcular el monto a cobrar a sus client es. //Si se conoce para un cliente el numero de teléfono, el total de llamadas realizadas en el mes y el total de minutos consumidos en esas llamadas. //Elaborar un algoritmo que permita calcular el monto a cobrar, el cual viene dado por la siguiente tabla //Minutos Bs. //0 - 50 100 //51 - 100 120 //101 - 200 150 //201 - 300 200 //> 300 250 //Adicionalmente, se realiza un descuento, el cual depende del total de llamadas realizadas y viene dado en la siguiente tabla: //Total llamadas Dscto //0 - 20 5% //21 - 100 7%

//101 - 200 //> 201 Escribir "ingrese numero telefono"; leer telefono; escribir "total de llamdas al mes"; leer llamadas; Escribir "Total de minutos"; leer minutos;

9% 10%

si minutos>=0 y minutos<=50 Entonces valorminutos<-minutos*100; consumo<-valorminutos*llamadas; si llamadas>=0 y llamadas<=20 Entonces descuento<-consumo*0.05; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>=21 y llamadas<=100 Entonces descuento<-consumo*0.07; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>=101 y llamadas<=200 Entonces descuento<-consumo*0.09; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>201 Entonces descuento<-consumo*0.1; vpagar<-consumo-descuento; escribir vpagar; Sino FinSi FinSi FinSi FinSi FinSi si minutos>=51 y minutos<=100 Entonces valorminutos<-minutos*120; consumo<-valorminutos*llamadas; si llamadas>=0 y llamadas<=20 Entonces descuento<-consumo*0.05; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>=21 y llamadas<=100 Entonces descuento<-consumo*0.07; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>=101 y llamadas<=200 Entonces descuento<-consumo*0.09; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>201 Entonces descuento<-consumo*0.1; vpagar<-consumo-descuento;

escribir vpagar; Sino FinSi FinSi FinSi FinSi FinSi si minutos>=101 y minutos<=200 Entonces valorminutos<-minutos*150; consumo<-valorminutos*llamadas; si llamadas>=0 y llamadas<=20 Entonces descuento<-consumo*0.05; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>=21 y llamadas<=100 Entonces descuento<-consumo*0.07; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>=101 y llamadas<=200 Entonces descuento<-consumo*0.09; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>201 Entonces descuento<-consumo*0.1; vpagar<-consumo-descuento; escribir vpagar; Sino FinSi FinSi FinSi FinSi FinSi si minutos>=201 y minutos<=300 Entonces valorminutos<-minutos*200; consumo<-valorminutos*llamadas; si llamadas>=0 y llamadas<=20 Entonces descuento<-consumo*0.05; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>=21 y llamadas<=100 Entonces descuento<-consumo*0.07; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>=101 y llamadas<=200 Entonces descuento<-consumo*0.09; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>201 Entonces descuento<-consumo*0.1; vpagar<-consumo-descuento; escribir vpagar; Sino FinSi FinSi

FinSi FinSi FinSi si minutos>300 Entonces valorminutos<-minutos*250; consumo<-valorminutos*llamadas; si llamadas>=0 y llamadas<=20 Entonces descuento<-consumo*0.05; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>=21 y llamadas<=100 Entonces descuento<-consumo*0.07; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>=101 y llamadas<=200 Entonces descuento<-consumo*0.09; vpagar<-consumo-descuento; escribir vpagar; Sino si llamadas>201 Entonces descuento<-consumo*0.1; vpagar<-consumo-descuento; escribir vpagar; Sino FinSi FinSi FinSi FinSi FinSi FINProceso Proceso sin_titulo //de los numeros comprendidos 1 al 100 imprima los numeros pares c<-1; mientras c<=100 Hacer residuo<- c mod 2; si residuo=0 Entonces escribir c; Sino FinSi c<-c+1; FinMientras FinProceso

Proceso sin_titulo // dado un numero, si es negativo que lo imprima. resp<-"s"; mientras resp="s" o resp="S" hacer escribir "ingrese numero"; leer numero;

residuo<- numero mod 2; si residuo<>0 Entonces escribir numero; FinSi escribir "ingresar otro numero s/n"; leer resp; FinMientras FinProceso Proceso par //Determinar si un número dado es par, impar o cero. resp<-"s"; mientras resp="S" o resp="s" hacer escribir "ingrese un numero"; leer numero; si numero =0 Entonces escribir numero; Sino residuo<- numero mod 2; si residuo<>0 Entonces escribir "Numero Impar"; Sino escribir "numero par"; FinSi FinSi escribir "Desea ingresar otro numero S/N"; leer resp; FinMientras FinProceso Proceso sin_titulo //Calcule la nómina salarial neto, de unos obreros cuyo trabajo se paga en horas. El cálculo se realiza de la siguiente forma: //Las primeras 35 horas a una tarifa fija. //Las horas extras se pagan a 1.5 más de la tarifa fija. //Los impuestos a deducir de los trabajadores varian, segun el sueldo me nsual si el sueldo es menos a $20.000,00 //el sueldo es libre de impuesto y si es al contrario se cobrará un 20% de impuesto. resp<-"s"; Mientras resp="s" o resp="S" hacer porcentaje<-1.5; impuesto<-0.2; Escribir "nombre de trabajador"; leer nombre; escribir "sueldo basico del trabajador"; leer mensual; escribir " valor de hora de trabajo"; leer valorhora; escribir "horas trabajadas"; leer horas; si horas<=35 Entonces valor<-horas*valorhora; sueldo<-valor+mensual; si sueldo<=20000 Entonces

escribir sueldo; Sino si sueldo>20000 entonces descuento<-sueldo*impuesto; sueldoneto<-sueldo-descuento; escribir sueldoneto; FinSi FinSi FinSi si horas>35 Entonces extras<-horas-35; valor1<-extras*porcentaje; valor<-35*valorhora; sueldo<-mensual+valor1+valor; si sueldo<20000 Entonces escribir sueldo; Sino si sueldo>20000 Entonces descuento<-sueldo*impuesto; sueldoneto<-sueldo-descuento; escribir sueldoneto; FinSi FinSi FinSi escribir "Ingresar Otro empleado S/N"; LEER resp; FinMientras FinProceso

Proceso salario //utilidades de un empleado Escribir "Ingrese nombre del empleado"; Leer empleado; escribir "ingrese salario de empleado"; leer salario; Escribir "ingrese el tiempo que lleva en el trabajo en meses"; Leer tiempo; Si tiempo<=12 Entonces utilidad<-(salario*5)/100; escribir empleado; escribir "SU UTILIDAD SERA DE:"; Escribir utilidad; Sino si tiempo<=24 Entonces utilidad<-(salario*7)/100; escribir empleado; escribir "SU UTILIDAD SERA DE:"; Escribir utilidad; Sino si tiempo<=60 Entonces utilidad<-(salario*10)/100; escribir empleado; escribir "SU UTILIDAD SERA DE:"; Escribir utilidad; Sino si tiempo<=120 Entonces

utilidad<-(salario*15)/100; escribir empleado; escribir "SU UTILIDAD SERA DE:"; Escribir utilidad; sino si tiempo>120 Entonces utilidad<-(salario*20)/100; escribir empleado; escribir "SU UTILIDAD SERA DE:"; Escribir utilidad; Sino FinSi FinSi FinSi FinSi FinSi FinProceso

Proceso subsidio Escribir "escoja las siguientes opciones"; Escribir "1) si la edad es entre 2 y 4"; Escribir "2) si la edad es entre 5 y 8"; Escribir "3) si la edad es entre 9 y 11"; Escribir "4) si la edad es entre 12 y 15"; leer op; segun op Hacer 1: subsidio<-60000; 2: subsidio<-100000; 3: subsidio<-150000; 4: subsidio<-200000; FinSegun escribir "subsidio es de"; Escribir subsidio; FinProceso

Proceso tabla //tabla de multiplicar hasta el 12 c<-0; escribir "digite la tabla de multiplicar que desea"; leer tabla; mientras c<=12 Hacer multiplicacion<-tabla*c; escribir multiplicacion; c<-c+1; FinMientras

FinProceso

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->