Está en la página 1de 10

Gua Obj. 2.2. Algoritmos Estructuras de Control Repetitivas 5to Cs.

A Estructuras de Control Repetitivas Se utilizan para efectuar operaciones que deben repetirse muchas veces, estas estructuras repiten una secuencia de instrucciones un nmero determinado de veces. Tambin se conocen como bucle o ciclo. Conceptos Bsicos  Iteracin: Consiste en repetir la ejecucin de una instruccin o un conjunto de ellas.  Acumulador: Es una variable que almacena valores en cada iteracin, en cantidades que no son constantes. Ejemplo: Suma Suma + Nmero

 Contador: Es una variable cuyo valor se incrementa o decrementa en una cantidad constante en cada iteracin. Ejemplo: Contador Contador + 2

Ciclos (Mientras, Repetir, Desde)  Ciclo Mientras: Ejecuta las instrucciones cuando se cumple una determinada condicin. Termina de ejecutarse cuando la condicin es falsa. Mientras condicin hacer Instrucciones Fin_mientras  Ciclo Repetir: Las instrucciones se ejecutan al menos una vez antes de evaluar la condicin, culmina cuando la condicin es Verdadera. Repetir Instrucciones Hasta que condicin  Ciclo Desde: Se realizan las acciones un nmero de veces definida por una variable que controla el nmero de iteraciones. Se utiliza cuando se conoce el nmero de iteraciones. Desde i 1 hasta N hacer Instrucciones Fin_desde Prof. Alexis Rodrguez alexisrtlaloc@gmail.com

Ejemplos  Ciclo Mientras: 1.- Disee un algoritmo que permita sumar nmeros mayores que 5. Anlisis Entrada: N: entero Salida: Suma: entero Proceso: Suma Suma + N Algoritmo Adicin Variables N, Suma: entero Inicio Suma 0 Escribir Ingrese un nmero Leer N Mientras N > 5 hacer Suma Suma + N Leer N Fin_mientras Escribir El resultado es:, Suma Fin Corrida al Fro N Suma 7 8 24 1 0 15 39

Prof. Alexis Rodrguez alexisrtlaloc@gmail.com

3.- Escriba un algoritmo que lea del teclado un nmero entero y que compruebe si es menor que 5. Si no lo es, debe volver a leer un nmero, repitiendo la operacin hasta que el usuario escriba un valor correcto. Finalmente debe escribir por pantalla el valor ledo. ALGORITMO Menor VARIABLES Num: ENTERO; INICIO; Escribir Teclee un nmero menor que 5; Leer num; MIENTRAS num >= 5, HACER; Escribir Teclee un nmero menor que 5; Leer num; FIN MIENTRAS; Escribir El nmero ledo es, num; FIN;

Prof. Alexis Rodrguez alexisrtlaloc@gmail.com

4.- Escriba un algoritmo que lea del teclado un nmero entero y que compruebe si est contenido en el rango (5,15). Si no lo es, debe volver a leer un nmero, repitiendo la operacin hasta que el usuario escriba un valor correcto. Finalmente debe escribir por pantalla el valor ledo. ALGORITMO Rango VARIABLES Num: ENTERO; INICIO; Escribir Teclee un nmero entre 5 y 15; Leer num; MIENTRAS num <= 5 o num >= 15, HACER; Escribir Teclee un nmero entre 5 y 15; Leer num; FIN MIENTRAS; Escribir El nmero ledo es, num; FIN; 5.- Escriba un algoritmo que lea del teclado un nmero entero y que compruebe si est contenido en el rango (5,15). Si no lo es, debe volver a leer un nmero, repitiendo la operacin hasta que el usuario escriba un valor correcto. Finalmente debe escribir por pantalla el valor ledo y el nmero de veces que ha sido ledo por el teclado. ALGORITMO Veces VARIABLES Num: ENTERO; INICIO; Escribir Teclee un nmero entre 5 y 15; Leer num; Veces 1; MIENTRAS num <= 5 o num >= 15, HACER; Escribir El nmero es incorrecto, intntelo de nuevo; Leer num; Veces Veces + 1; FIN MIENTRAS; Escribir El nmero ledo es, num; Escribir El nmero de intentos ha sido, Veces; FIN;

Prof. Alexis Rodrguez alexisrtlaloc@gmail.com

6.- Escriba un algoritmo que calcule e imprima la suma de los n primeros nmeros enteros positivos. El valor de n debe leerse del teclado. ALGORITMO Positivos VARIABLES i: ENTERO; s: REAL; INICIO; Leer n; s 0; i 1, MIENTRAS i <= n, HACER; s s + i; i i + 1; FIN MIENTRAS; Escribir La suma de los primeros , n, nmeros es , s; FIN; 7.- Escriba un programa que calcule el promedio de 10 nmeros. ALGORITMO Promedio_Nmeros; CONSTANTES N 10; VARIABLES I, Promedio, Suma, Num: ENTERO; Tecla: CARACTER; INICIO; Escribir Este programa calcula la suma de, N, nmeros; I 1; Suma 0; MIENTRAS I <= N, HACER; Escribir Ingrese un nmero entero; Leer N; Suma Suma + Num; i i + 1; FIN MIENTRAS; Promedio Suma/N Escribir El promedio de los, N, nmeros es:, Promedio; Escribir Presione la Tecla para Finalizar; Leer Tecla; FIN;

Prof. Alexis Rodrguez alexisrtlaloc@gmail.com

Prof. Alexis Rodrguez alexisrtlaloc@gmail.com

 Ciclo Repetir:

Prof. Alexis Rodrguez alexisrtlaloc@gmail.com

 Ciclo Desde:
1.- Realice un algoritmo que calcule la potencia de un nmero, dada la base y el exponente. Anlisis Entrada: Base, Exponente: entero i: entero (variable de control del ciclo) Salida: Potencia: entero Proceso: Potencia potencia *base Algoritmo Potenciacin Variables Base, exponente, i, potencia: entero Inicio Potencia 1 Escribir Ingrese la base y el exponente Leer base Leer exponente Desde i 1 hasta exponente hacer Potencia potencia * base Fin_desde Escribir El resultado es, Potencia Fin Corrida al Fro i Base Exponente 1 2 3 3 3

Potencia 1 3 9 27

Prof. Alexis Rodrguez alexisrtlaloc@gmail.com

Prof. Alexis Rodrguez alexisrtlaloc@gmail.com

Prof. Alexis Rodrguez alexisrtlaloc@gmail.com