Está en la página 1de 13

Pseudocdigo

Primera Parte

Fuente: Fundamentos de Programacin


Algoritmos, Estructuras de datos y Objetos. M. Alejandro Tllez Flores

Es un lenguaje de especicacin de agoritmos que utiliza palabras reservadas y exige la indentacin

Pseudocdigo

algoritmo <identificador_algoritmo> // declaraciones, sentencias no ejecutables inicio // acciones, sentencias ejecutables tanto simples como estructuradas fin

Comentarios

// Comentario de una lnea /* Comentario que ocupa ms de una lnea */

Datos
Es la expresin general que describe los objetos con los cuales opera el algoritmo, tambin conocidos como literales. Se podrn utilizar los siguientes tipos, entero real decimal lgico caractr cadena

Constantes
Son datos cuyo valor no cambia durante todo el desarrollo del algoritmo. La constantes podrn ser literales o con nombres (tambin denominadas simblicas).
const <tipo_de_dato> : <nombre_constante> = <valor>

Variables
Es un elemento cuyo valor puede cambiar durante el desarrollo del algoritmo. Se identica por su nombre y por su tipo, que determinar el conjunto de valores que podr tomar la variable.
var <tipo_de_dato> : <nombre_variable> [= <valor>]

Operadores
Aritmticos: + - * / % mod Lgicos: == != < > <= >= & | Alfanumricos: + Asignacin: = Lgico ternario: ? : ^

Tablas de verdad

a v v f f

b v f v f

!a f f v v

a&b v f f f

a|b v v v f

a ^b f v v f

Palabras reservadas
Son palabras que tienen un signicado especial, como: inicio y n.
si <condicin> entonces <acciones> fin_si si <condicin> entonces <acciones1> si_no <acciones2> fin_si segn sea <expresin_ordinal> entonces <lista_de_valores_ordinales> : <acciones> ... [si_no // El corchete indica opcionalidad <accionesN>] fin_segn mientras <condicin> hacer <acciones> fin_mientras

Decisin Simple: Decisin doble:

Decisin mltiple:

Repetitivas:

repetir <acciones> hasta_que <condicin>

desde <varible> = <v_inicial> hasta <v_final> , [incremento | decremento] hacer <acciones> fin_desde

Identicadores
Son los nombres que se dan a las constantes simblicas, variables, funciones, procedimientos, u otros objetos que manipula el algoritmo. Debe resultar signicativo, sugiriendo lo que representa. No podr conincidir con palabras reservadas, propias del lenguaje algortmico. Se recomienda un mximo de 50 caracteres. Comenzar siempre por un caractr alfabtico y los siguientes podrn ser letras, dgitos o guin bajo.

Ejemplos
algoritmo: multiplica var entero: nmero, resultado inicio leer(nmero) nmero = nmero * 2 resultado = nmero * 25 escribir(resultado) fin

algoritmo: media_aritmtica var entero: a,b,c,d,producto, suma real: media inicio leer(a,b,c,d) producto = a*b*c*d suma = a+b+c+d media = suma/4 escribir(producto, suma, media) fin

Ejemplos
algoritmo: libras_kilogramos const real: libra = 0.453592 var real: peso, kg, gr inicio leer(peso) kg = peso * libra gr = kg * 1000 escribir(Peso en kilos: + kg) escribir(Peso en gramos: + gr) fin

algoritmo: orden_alfabetico var caracter: a,b real: media inicio leer(a,b) si a < b entonces escribir(estn en orden) si_no si a = b entonces escribir(son iguales) si_no escribir(no estn en orden) fin_si fin_si fin

Sentencias de salto

Hacen que el ujo de control salte a otra parte del programa, entre las comnes se encuentran,

interrumpir Uno de sus usos es interrumpir un ciclo en un lugar determinado del cuerpo del mismo, en vez de esperar a que termine de modo natural. continuar Hace que el ujo de ejecucin alte el resto del cuerpo del ciclo para continuar con la siguiente iteracin, pero no interrumpe el ciclo. devolver Permite regresar un valor en una funcin, permitiendo retomar el ujo de ejecucin en el cdigo original de invocacin. lanzar Se suele utilizar en los lenguajes de programacin que poseen mecanismos de manipulacin de excepciones.

SubAlgoritmos (Programacin Modular)

El diseo descendente resuelve un problema efectuando descomposiciones en otros problemas ms sencillos a travs de distintos niveles de renamiento. Las ventajas son,

Varios programadores podrn trabajar simultneamente en la confeccin de un algoritmo. Se podr modicar un mdulo sin afectar a los dems. Las tareas, subalgoritmos, slo se escribirn una vez, aunque se necesiten en distintas ocasiones en el cuerpo del algoritmo.

Existen dos tipos de subalgoritmos: funciones y procedimientos.

Funciones
Una funcin toma cero, uno o ms valores, denominados argumentos o parmetros y segn el valor de stos, devuelve un resultado en el nombre de la funcin. Para invocar a una funcin se utiliza su nombre seguido por los parmetros actuales o reales entre parntesis en una expresin. Por ejemplo:
escribir(raiz2(16))

y si la funcin se denomina f y sus parmetros son a,b y c


escribir(f(a,b,c))

La sintaxis para la declaracin de funciones es,


funcin <modif> <tipo_de_dato>: <nombre_funcin>(lista_de_parmetros_formales) inicio [declaraciones_locales] <acciones> devolver(<expresin>) fin_funcin

y la lista de parmetros formales est denida de la siguiente manera,

<tipo_de_dato> : <nombre_del_parmetro>,...

Procedimientos
La diferencia principal entre una funcin y un procedimiento, radica en que ste ltimo no retorna ningn valor en su declaracin La invocacin a un procedimiento se realiza con la instruccin llamar o bien directamente con el nombre del procedimiento, es decir:
[llamar] <nombre_procedimiento>(lista_de_parmetros)

La sintaxis para la declaracin de procedimientos es,


procedimiento <modif>: <nombre_procedimiento>(lista_de_parmetros_formales) inicio [declaraciones_locales] <acciones> fin_procedimiento

y la lista de parmetros formales est denida de la siguiente manera,

<tipo_de_dato> : <nombre_del_parmetro>,...

Pseudocdigo
Primera Parte

Fuente: Fundamentos de Programacin


Algoritmos, Estructuras de datos y Objetos. M. Alejandro Tllez Flores