Está en la página 1de 2

Proceso sin_titulo dimension matriz[3,3] contador <- 0 ; num <- 0 ; num1 <- 1 para fila<-1 hasta 3 con paso

1 Hacer para columna<-1 hasta 3 con paso 1 Hacer matriz[fila,columna] <- azar(2) FinPara FinPara para fila<-1 hasta 3 con paso 1 Hacer escribir matriz[fila,1], " ", matriz[fila,2], " FinPara Repetir num <- num + 1 ; num1 <- num1 + 1 ; si matriz[num,num] = matriz[num1,num1] entonces contador <- contador + 1 ; Sino num1 <- 3 ; FinSi Hasta Que num1 = 3 Si contador = 7 Entonces escribir "todo ", matriz[1,1], " en la diagonal FinSi num <- 8 ; num1 <- 7 contador <- 1 ; Repetir num <- num - 1 ; num1 <- num1 - 1 ; contador <- contador + 1 ; num1 <- 1 ; Hasta Que num1 = 1 si contador = 2 Entonces escribir "todo ", matriz[1,1], " en la diagonal FinSi num <- 1 ; para num<-1 hasta 3 con paso 1 hacer num1 <- 0 contador <- 0 ; Repetir num1 <- num1 + 1 ; si matriz[num,1] = matriz[num,num1] entonces contador <- contador + 1 ; Sino num1 <- 3 ; FinSi Hasta Que num1 = 3 si contador = 3 Entonces escribir "todo ", matriz[1,1], " en la fila: ", FinSi FinPara num <- 1 ; para num<-1 hasta 3 con paso 1 hacer num1 <- 0 contador <- 0 ; Repetir

", matriz[fila,3]

de izquierda a derecha"

de derecha a izquierda"

num

num1 <- num1 + 1 ; si matriz[1,num] = matriz[num1,num] entonces contador <- contador + 1 ; Sino num1 <- 3 ; FinSi Hasta Que num1 = 3 si contador = 3 Entonces escribir "todo ", matriz[1,1], " en la columna: ", num FinSi FinPara FinProceso