P. 1
no Ejercicios+Practicos+Con+El+Uso+de+Pseint

no Ejercicios+Practicos+Con+El+Uso+de+Pseint

|Views: 984|Likes:
Publicado porgerrardo ortiz

More info:

Published by: gerrardo ortiz on Sep 26, 2011
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

08/21/2013

pdf

text

original

SUBSECRETARÍA DE EDUCACIÓN MEDIA SUPERIOR DIRECCIÓN GENERAL DE EDUCACIÓN TECNOLÓGICA INDUSTRIAL CENTRO DE BACHILLERATO TECNOLOGICO industrial y de servicios No.

265 Emiliano Zapata Salazar

Submódulo
“Aplicar los principios de programación en la solución de problemas”

EJERCICIOS PRACTICOS CON EL USO DE PSeINT
Software para realizar pseudocódigos y diagramas de flujo
28/06/2011 Microsoft MARVELI ALTAMIRANO IBARRA

mientras y para. que cursan el submódulo “Aplicar los principios de programación en la solución de problemas”. Imprimir la boleta del alumno con su promedio.html Ejercicio 1: Leer desde teclado el número de control.com/tutoriales/tutorial/z5464. el nombre y 5 calificaciones.abcdatos. que podrás encontrar en esta dirección electrónica: http://www. en este caso le nombraremos calcula_promedio. te he puesto unos comentarios en rojo para que ubiques las partes principales del programa. leer. según. Recuerda alumno que antes de iniciar con estos ejercicios debes leer el manual de usuario del programa PSeINT. Ya instalado el programa PSeINT. la palabra sin_titulo. Para iniciar el primer ejercicio.EJERCICIOS PRACTICOS CON EL USO DE PSeINT Este manual tiene como objetivo llevar a la práctica algunos ejercicios en el software PSeINT dedicado a realizar pseudocódigos y diagramas de flujo y es para los alumnos del cuarto semestre de la especialidad de Informática del centro de bachillerato tecnológico industrial y de servicios No 265. se sustituirá por el nombre del algoritmo que vamos a realizar. 1 . ubícate en icono donde se encuentra la hoja en blanco de la barra de acceso rápido y se presentará una imagen como la que te muestro a continuación. sientonces-sino. obtener el promedio. asignar. BARRA DE MENUS BARRA DE ACCESO RAPIDO COMANDOS AREA DE TRABAJO Los comandos que utilizaremos en estos ejercicios son: Escribir.

recuerda también que todas las instrucciones se terminan con punto y coma. debes revisar los errores para poder solucionarlos. debes dar clic en el comando que se encuentra del lado derecho. En este programa solo se utilizarán los comandos escribir. para introducir los valores debes dar clic en Leer y escribir las variables (una variable es un espacio de la memoria donde se guardará el valor introducido) necesarias. Para cualquier operación siempre se realiza de esta manera. Para ejecutar el programa y comprobar si realmente realiza lo que nos pidieron en el planteamiento del problema damos clic en la flecha verde de la barra de acceso rápido y obtendremos lo siguiente: Si al ejecutar el pseudocódigo te envía errores. da clic en escribir y entre comillas dobles debes colocar el mensaje que deseas que aparezca en la pantalla. Para calcular el promedio da clic en asignar y coloca del lado izquierdo del símbolo de asignación (<-) la variable donde se depositará el resultado y del lado derecho la operación que se va a realizar. Para imprimir en la pantalla un mensaje. leer y asignar.Recuerda que para iniciar cada línea de instrucción. 2 .

14 Escribir " ".c4. " Nombre del alumno: ". para enviar un mensaje de “Aprobado” o “Reprobado” según corresponda. 5 Leer c1. Le llamaremos a este ejercicio Calcula_promedio2. 7 Escribir " BOLETA DE CALIFICACIONES CON PROMEDIO".Nombre. Para cada pseudocodigo se puede generar el diagrama de flujo. 4 Escribir "Introduce las 5 calificaciones". si has ejecutado tu pseudocodigo y verificado que tengas la solucion correcta al problema no tienes que preocuparte por el diagrama.c2. 9 Escribir "Calificaciones: ".c2.c3. Ejercicio 2: Siguiendo el mismo problema ahora agregaremos una condicion (comando si-entonces-sino).promedio. 11 Escribir " ". ¡este es correcto!. 16 Escribir "Promedio final ".c3.c5. 12 Escribir " ". 6 promedio<-(c1+c2+c3+c4+c5)/5.c4. 10 Escribir " ". busca en la barra de acceso rapido el icono de “dibujar diagrama de flujo” y das clic y en ese momento se visualiza en una hoja el diagrama de flujo correspondiente. 1 Calcula_promedio2 2 Escribir "Introduce el numero de control y nombre del alumno ". De esta 18 Escribir " APROBADO".c1. Como te darás cuenta solo se incorporó una condición (comando si-entonces-sino) 17 Si promedio>=6 Entonces iniciando en la línea 17 del pseudocódigo y se termina en la línea 21. estando en la aplicación de la cual quieres generar el diagrama de flujo.c5. 3 21 FinSi 22 FinProceso .Nombre. 8 Escribir "Numero de control: ". 13 Escribir " ".Ahora veremos como se genera el diagrama de flujo. 3 Leer N_Control. N_Control. 15 Escribir " ". manera obtenemos un resultado como el siguiente: 19 Sino 20 Escribir " REPROBADO".

o las instrucciones que le siguen al Sino si la condición es falsa. La condición debe ser una expresión lógica.En el caso de que el promedio fuera menor a 6 se imprimiría al final “REPROBADO”. La cláusula Entonces debe aparecer siempre. como N es un valor desconocido tendremos que preguntar al usuario que valor 4 . ahora realizaremos el mismo ejercicio pero para N alumnos. la utilizamos para colocar las condiciones que sean necesarias para resolver el problema. De igual forma que el ejercicio 1. se evalúa la condición y se ejecutan las instrucciones que correspondan: las instrucciones que le siguen al Entonces si la condición es verdadera. La secuencia de instrucciones ejecutadas por la instrucción Si-Entonces-Sino depende del valor de una condición lógica.sino. si la condición es falsa no se ejecuta ninguna instrucción y la ejecución del programa continúa con la instrucción siguiente. Ejercicio 3: Bien. Recuerda que la estructura si – entonces. que al ser evaluada retorna Verdadero o Falso. Si <condición> Entonces <instrucciones> Sino <instrucciones> FinSi Al ejecutarse esta instrucción. En ese caso. puedes generar el diagrama de flujo. pero la cláusla Sino puede no estar.

desea darle a N y además utilizaremos el ciclo mientras. 17 Escribir " ". 23 Sino 24 Escribir " REPROBADO".c3. cada opción será ".c5.c4.Nombre.c5. 16 Escribir " ".c4. Mientras <condición> Hacer <instrucciones> FinMientras 5 .c3. 7 Leer N_Control. 10 promedio<-(c1+c2+c3+c4+c5)/5. 9 Leer c1. " pseudocódigos realizados 13 Escribir "Calificaciones: ". 12 Escribir "Numero de control: uno de los Nombre del alumno: ". 15 Escribir " ". 8 Escribir "Introduce las 5 calificaciones". 11 Escribir " BOLETA DE un menú utilizando el comando -según. en este manual de ejercicios. contador.Nombre. tres opciones.promedio. 21 Si promedio>=6 Entonces 22 Escribir " APROBADO". 25 FinSi 26 contador<-contador + 1. 4 Leer N.de Para finalizar realizaremosCALIFICACIONES CON PROMEDIO". 3 Escribir "¿Cuantos alumnos van a ser? ". 20 Escribir "Promedio final ". 14 Escribir " ".c1. 5 Mientras contador<=N Hacer 6 Escribir "Introduce el numero de control y nombre del alumno ".c2. ":". 27 FinMientras Ciclo while: en este ciclo se ejecutan las instrucciones mientras una condición sea 28 FinProceso verdadera. N_Control.c2. 19 Escribir " ". A este ejercicio le nombraremos Calcula_promedio3 1 Calcula_promedio3 2 contador <-1. 18 Escribir " ".

Le nombraremos menú. Segun <variable> Hacer <número1>: <instrucciones> <número2>.. Para terminar realizaremos un menú de tres opciones con el comando -según-. Ejercicio 4. se evalúa el contenido de la variable y se ejecuta la secuencia de instrucciones asociada con dicho valor.. y obviamente debes introducir los datos de los dos alumnos. 6 . en cada una de las opciones de colocaremos cada uno de los ejercicios realizados con anterioridad.Al ejecutar el pseudocódigo nos pregunta cuantos alumnos. dependiendo del valor almacenado en una variable de tipo numérico. en este ejemplo le hemos introducido el valor de 2. La secuencia de instrucciones ejecutada por una instrucción Segun depende del valor de una variable numérica.<número3>: <instrucciones> <. Al ejecutarse.> De Otro Modo: <instrucciones> FinSegun Esta instrucción permite ejecutar opcionalmente varias acciones posibles.

la variable <variable> recibe el valor <inicial> y se ejecuta la secuencia de instrucciones que forma el cuerpo del ciclo. cuya secuencia de instrucciones asociada se ejecutará sólo si el valor almacenado en la variable no coincide con ninguna de las opciones anteriores. Si se omite la cláusula Con Paso <paso>. Opcionalmente. denominada De Otro Modo.Cada opción está formada por uno o más números separados por comas. Si una opción incluye varios números. Para <variable> <. la secuencia de instrucciones asociada se debe ejecutar cuando el valor de la variable es uno de esos números. se puede agregar una opción final. Luego se incrementa la variable <variable> en <paso> unidades y se evalúa si el valor almacenado en <variable> superó al valor <final>. la variable <variable> se incrementará en 1. Si esto es falso se repite hasta que <variable> supere a <final>. 7 . En este pseudocódigo también utilizaremos un ciclo para.<inicial> Hasta <final> ( Con Paso <paso> ) Hacer <instrucciones> FinPara Al ingresar al bloque. dos puntos y una secuencia de instrucciones. Recuerda que la instrucción Para ejecuta una secuencia de instrucciones un número determinado de veces. En este caso el comando –para-. nos permitirá estar ejecutando el pseudocódigo las tres opciones del menú. Si desea ejecutar más veces solo incrementa el final. o sea tres veces.

Segun opcion Hacer 1: Escribir "Introduce el numero de control y nombre del alumno ". PARA SALIR DIGITA CERO".c4. Escribir "Promedio final ".promedio. Escribir " ".c3. Escribir "Introduce las 5 calificaciones".1 2 3 4 5 6 7 8 9 10 11 12 13 14 15 16 17 18 19 20 21 22 23 24 25 26 27 28 28 30 31 32 33 34 35 36 37 38 39 40 41 42 43 44 45 46 47 Proceso Menu Para ciclo<-1 Hasta 3 Con Paso 1 Hacer Escribir "MENU DE OPCIONES".c3.c2.c1. Escribir " BOLETA DE CALIFICACIONES CON PROMEDIO".Nombre.c5. Escribir " ". " Nombre del alumno: ".c5. Escribir " BOLETA DE CALIFICACIONES CON PROMEDIO".c3.Nombre. Escribir "Introduce un nuemero de opción".c2. Escribir " ". N_Control. Leer c1.c4. Escribir "Numero de control: ". Escribir "Calificaciones: ". Escribir " ". Escribir " ". Escribir "Numero de control: ". Escribir "Calificaciones: ".Nombre.c2. Escribir "2.c3.c2. Escribir " ". Escribir " ". FinSi 8 .c4. Escribir "Promedio final ". Escribir "Introduce las 5 calificaciones". Leer c1. Escribir "3.c5.Nombre. N_Control. 2: Escribir "Introduce el numero de control y nombre del alumno ". Escribir " ". Sino Escribir " REPROBADO".c4. Escribir " ". CALCULA PROMEDIO". promedio<-(c1+c2+c3+c4+c5)/5.promedio. Leer N_Control. CALCULA PROMEDIO E IMPRIME APROBADO O REPROBADO". PARA N ALUMNOS CALCULA PROMEDIO E IMPRIME APROBADO O REPROBADO". Escribir " ". Escribir "0. Escribir "1.c5. Si promedio>=6 Entonces Escribir " APROBADO". Escribir " ". Escribir " ".c1. Leer opcion. Leer N_Control. promedio<-(c1+c2+c3+c4+c5)/5. " Nombre del alumno: ".

Escribir " ". Si promedio>=6 Entonces Escribir " APROBADO". N_Control. Sino Escribir " REPROBADO". Escribir "Numero de control: ".c2.c3.c4.Nombre. Escribir " ". FinMientras De Otro Modo: Escribir "Opcion equivocada".48 49 50 51 52 53 54 55 56 57 58 59 60 61 62 63 64 65 66 67 68 69 70 7º 72 73 74 75 76 77 78 79 3: contador <-1. Mientras contador<=N Hacer Escribir "Introduce el numero de control y nombre del alumno ". Escribir " ". Escribir "Introduce las 5 calificaciones".Nombre. Escribir "¿Cuantos alumnos van a ser? ". contador.c4.c2.c5. Leer c1. promedio<-(c1+c2+c3+c4+c5)/5.promedio. " Nombre del alumno: ". FinSegun FinPara FinProceso 9 . Escribir " ".c1. Escribir "Calificaciones: ". Escribir " BOLETA DE CALIFICACIONES CON PROMEDIO". Escribir "Promedio final ". Escribir " ".c3. Escribir " ". FinSi contador<-contador + 1. ":".c5. Leer N_Control. Leer N.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->