Está en la página 1de 8

Alumno: Cantoia Noel

Comisin: A, Turno Maana, Ing. En Sist. Informticos

Ao calendario: 2011

Noel Cantoia

Algoritmo Matrices Inicio Entero Matriz[3][3],OP OP 1 Mientras (OP <> 0) hacer Escribir (Operaciones con Matrices) Escribir (1 Cargar Matriz) Escribir (2 Suma de matrices) Escribir (3 Producto entre matriz y escalar) Escribir (4 Producto entre matrices) Escribir (5 Traspuesta de la matriz) Escribir (6 Determinante de la matriz) Escribir (0 Finalizar) Repetir Escribir (Ingrese opcin) Leer (OP) Hasta (OP >= 0 y OP =< 6) Segun_Sea (OP) Caso 1: Llamar Carga (Matriz) Caso 2: Llamar Suma (Matriz) Caso 3: Llamar Producto_Escalar (Matriz) Caso 4: Llamar Producto (Matriz) Caso 5: Llamar Traspuesta (Matriz) Caso 6: Llamar Determinante (Matriz) Fin Segun_Sea Fin_Mientras Fin

Noel Cantoia

Procedimiento Carga (Entero M[3][3]) Inicio Entero I, J, OP OP 1 Mientras (OP<>0)hacer Para I 1,3 Para J 1,3 Escribir (Ingrese el elemento:,I,;,J) Leer (M[I][J]) Fin_Para Fin_Para Repetir Escribir (1 Cargar la matriz nuevamente) Escribir (0 Volver al menu principal) Leer (OP) Hasta (OP>=0 y OP<=1) Fin_Mientras Fin_Procedimiento

Noel Cantoia

Procedimiento Suma (Entero M[3][3]) Inicio Entero I, J, SUM[3][3], MR[3][3], OP OP 1 Mientras (OP<>0) hacer Escribir (Ingrese la matriz que quiere sumarle a la cargada anteriormente) Para I 1,3 Para J 1,3 Escribir (Ingrese elemento:,I,;,J) Leer (SUM[3][3]) Fin_Para Fin_Para Para I 1,3 Para J 1,3 MR[I][J] M[I][J] + SUM[I][J] Fin_Para Fin_Para Escribir (La matriz resultante es:) Para I 1,3 Para J 1,3 Escribir (MR[I][J]) Fin_Para Fin_Para Repetir Escribir (1 Sumar una matriz diferente) Escribir (0 Volver al menu principal) Leer (OP) Hasta (OP>=0 y OP<=1) Fin_Mientras Fin_Procedimiento

Noel Cantoia

Procedimiento Producto_Escalar (entero MT[3][3]) Inicio Entero MP[3][3], ES, X, Y, OP OP 1 Mientras (OP<>0)Hacer Escribir (Ingrese el valor entero del escalar a multiplicar) Leer (ES) Para X 1,3 Para Y 1,3 MP[X][Y] MT[X][Y]*ES Fin_Para Fin_Para Escribir (La matriz resultante es:) Para X 1,3 Para Y . 1,3 Escribir (MP[X][Y]) Fin_Para Fin_Para Repetir Escribir (1 Ingresar un valor escalar diferente) Escribir (0 Volver al menu principal) Leer (OP) Hasta (OP>=0 y OP<=1) Fin_Mientras Fin_Procedimiento

Noel Cantoia

Procedimiento Producto (Entero JU[3][3]) Inicio Entero MATNEW[3][3], X, Y, LIAN[3][3], OP OP 1 Mientras (OP<>0)Hacer Escribir (Matriz a Multiplicar (3x3)) Para X 1,3 Para Y 1,3 Escribir (Ingrese el elemento:, X, ,, Y) Leer(LIAN[X][Y]) Fin_Para Fin_Para Para X 1,3 Para Y 1,3 MATNEW[X][Y] JU[X][1]*LIAN[1][Y]+JU[X][2]*LIAN[2][Y] +JU[X][3]*LIAN[3][Y] Fin_Para Fin_Para Escribir (Producto de las dos matrices) Para X 1,3 Para Y 1,3 Escribir(MATNEW[X][Y]) Fin_Para Fin_Para Repetir Escribir (1 Ingresar una matriz a multiplicar diferente) Escribir (0 Volver al menu principal) Leer (OP) Hasta (OP>=0 y OP<=1) Fin_Mientras Fin_Procedimiento

Noel Cantoia

Procedimiento Traspuesta (entero MTZ[3][3]) Inicio Entero X, Y, OP OP 1 Mientras (OP>=0 y OP<=0)Hacer Escribir (La matriz traspuesta es:) Para Y 1,3 Para X 1,3 Escribir (MTZ[X][Y]) Fin_Para Fin_Para Repetir Escribir (1 Mostrar traspuesta nuevamente) Escribir (0 Volver al menu principal) Leer (OP) Hasta (OP>=0 y OP<=1) Fin_Mientras Fin_Procedimiento

Noel Cantoia

Procedimiento Determinante (entero JU[3][3]) Inicio Entero Determinante1, Determinante2, Resultado, F1, F2, F3, AUX[5][3], X, Y, OP F1 1 F2 1 F3 1 OP 1 Mientras (OP<>0)Hacer Para X 1,3 Para Y 4,5 AUX[X][Y] JU[X][Y-3] Fin_Para Para Y 1,3 AUX[X][Y] JU[X][Y] Fin_Para Fin_Para Para Y 1,3 F1 F1*AUX[Y][Y] F2 F2*AUX[Y+1][Y] F3 F3*AUX[Y+2][Y] Fin_Para Determinante1 F1+F2+F3 F1 1 F2 1 F3 1 Para Y 3,1 F1 F1*AUX[4-Y][Y] F2 F2*AUX[5-Y][Y] F3 F3*AUX[6-Y][Y] Fin_Para Determinante2 F1+F2+F3 Resultado Determinante1-Determinante2 Escribir (El determinante de la matriz cargada previamente es:, Resultado) Repetir Escribir (1 Mostrar determinante nuevamente) Escribir (0 Volver al menu principal) Leer (OP) Hasta (OP>=0 y OP<=1) Fin_Mientras Fin_Procedimiento

Noel Cantoia