P. 1
Trucos Para Access

Trucos Para Access

|Views: 636|Likes:
Publicado porGiovanni Terrazas

More info:

Published by: Giovanni Terrazas on Sep 21, 2011
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOCX, PDF, TXT or read online from Scribd
See more
See less

03/06/2013

pdf

text

original

¿Se puede crear campos desde una base de datos hacia otra? o con un archivo ejecutable.

La pregunta es para agregar campos en la base de datos de un cliente sin tener que estar presente en la PC, osea se le envia el archivo lo ejecuta y automaticamente se agreguen los campos a la base de datos en cuestion. Public Function CrearCamposRemotamente() Dim app As Application Set app = CreateObject("Access.Application") app.OpenCurrentDatabase "C:\Documents and Settings\x\Mis documentos\ACCESS 2000\Clientes.mdb" app.DoCmd.SetWarnings False app.DoCmd.RunSQL "ALTER TABLE CODIVA ADD COLUMN EmpresaEnvio TEXT (255), DireccionEnvio TEXT (255), CodPostalEnvio TEXT (10), " & _ "PoblacionEnvio TEXT (150), ProvinciaEnvio TEXT (100), PaisEnvio INTEGER" app.DoCmd.SetWarnings True app.CloseCurrentDatabase Set app = Nothing End Function

Codigo de barras
para que lea codigo de barras: hola a todos ... tengo un problema estoy realizando un sistema escolar mismo que despliega informacion en reportes dicha informacion se encuentra en codigo de barras para lo que utilizo la fuente 3of9barcode, el problema esta en que como lo menciona esta fuente para que la pistola del codigo de barras pueda reconocerla necesito agregar un * al principio y al final y pues no tengo ni idea de como hacerlo debido a que la información la obtengo de la base de datos en access enotnces como le agrego al reporte que realizo en datareport esos asteriscos... ojala me haya explicado bien .... espero una respuesta gracias

Fre3of9x.Restore 'RESTAURA EL FORMULARIO para usar en campos de consultas (fechas): Mes: (Formato([FechaNConf].RunCommand acCmdAddInManager 'MUESTRA LOS COMPLEMENTOS DoCmd..[column](4) 'SELECCIONA LA COLUMNA 4 ="Página " & +Val(31)+1+[Página] ' COMIENZA POR LA PAGINA 32 HASTA. Funciones: =Formato(([Subtotal]*[Bonificacion]).0.Yuliana: tenés que ir al diseño del informe donde aparece el codigo de barras.RunCommand acCmdAnswerWizard 'MUESTRA LA AYUDA DE ACCEES DoCmd.1)) ----. por ejemplo uno es Code 128AB Tall."Fijo") 'PONE EL NUMERO en dos decimales =[id_cliente]."mmm"" '""aaaa")) . Búscate el font en Internet (encotnrarás muchos tipos) y solo deberás aplicarle este tipo de letra al lugar donde se encuentre tu código Prueba varias veces que el tamaño sea el correcto de manera que las lectoras lo puedan leer sin problemas.. EAN13. SemanaProgramada: Formato$([FechaRetiro]. Code39.0) ----. Si he logrado ayudate te agradezco que cierres la pregunta.> Ingresa la semana del año o se puede usar "ww" TotalRecepcion: Suma(Round([CantUnitaria]."0000")&"*" Existen fuentes para imprimir codigo de barras 3of9. de lo contrario me avisas.ttf Las cuales utilizas poniendoles un asterisco al inicio y al final Code 128AB: No tienes que hacer ningun tipo de configuración especial El código de barras se maneja como un tipo de fuente (al igual que Arial)."ee".> Redondea un numero a tantos decimales DoCmd. Free3of9 todas . Ubicá el control que muestra el código y formatealo de la siguiente manera: supongamos que el control tiene como origen un campo de una tabla/consulta que se llama IdAlumno: tenés que poner en el origen ="*"&format(IdAlumno.

CodigoProducto]) =DSuma(" INGRESO .NombreProducto]).[HSNormales]-[THSPresencia]."[HSPresencia]<>0") lngExistencian = Nz(DSum("CantidadI"."Sucursal". "IdProducto =" & Me. "ingresos"."Ultimo Valor de la Compra".0."Varios") =DMáx("[IdRto]".NAño: Año([FechaNConf]) 'NOS DEVUELVE EL NUMERO DEL AÑO Nmes: Mes([FechaNConf]) 'NOS DEVUELVE EL NUMERO DEL MES Alicuota_%: Formato(0) & Formato(" %") FUNCIONES DE DOMINIO: =Abs(Suma([NOIngresoalCertamen]=Falso)) 'PONE UN VALOR NEGATIVO EN POSITIVO.Nz(DSum("Cantidad"."IdProducto =Formularios![Productos]![Codigo]") 'SUMA LOS TOTALES DE LA CONSULTA ventas del pro CUANDO IdProducto ES IGUAL AL CODIGO DEL FORMULARIO."Ultimo Valor de la Compra"."Ajuste".DMáx([Ultimo Valor de la Compra]![ÚltimoDePrecioC]."Boleta A") ' CUENTA LA CANTIDAD DE REGISTROS DE LA TABLA "Boleta A" CODIGO VISUAL BASIC: ."[Codigo]=Formularios![Lista de Productos]![Codigo]") 'PARA SABER SI ESTA DUPLICADO DESPUES ACCION CANCELAR EVENTO Y DETENER MACRO =DSuma("Totales"."[Productos]"."[Boleta B]")+1 Expr1: DSuma("THSPcia".CodigoProducto]) =DMáx("[IdBoletaB]".Fecha") DBúsq("[Codigo]".cboProducto).NombreProducto]). 0) =DCont("*".[Ultimo Valor de la Compra]![Codigo]=[Detalles de compras."[DetalleHSPresenciaCalculo]".DMáx([Ultimo Valor de la Compra]![ÚltimoDePrecioC].[Ultimo Valor de la Compra]![Codigo]=[Detalles de compras."ventas del pro".cboProducto)."MOVIMIENTO_BBVA". =DBúsq("[TotalStock]"."Datos de la empresa") 'BUSCA EL DATO "Aplicacion" EN LA TABLA "Datos de la empresa" =N(EsNulo([Detalles de compras."Ultimo Valor de la Compra"."DetalleSectorTHSPcia".0."Fecha <= Forms!Banco."[Remito]")+1 =DMáx([Ultimo Valor de la Compra]![ÚltimoDePrecioC]. Y EL EJ: SUMA CUANDO [NOIngresoalCertamen]=Falso) =Mayús([Color]) Ciudades: Mayús([Ciudad]) =Mayús([Apellido y Nombres]) TipoAjustes: Elegir([Tipo de Ajustes]. 0) .(0)) =DBúsq("[Aplicacion]"."IdRegistro =[DetallesCargaHS]![IdRegistro]") Ausentismo: SiInm([HSNormales]>[THSPresencia]."StockPedidos-Recepiones-Ordenes-Despacho".CodigoProducto])) Dotacion: DCont("[IDEmpleado]". "egresos".[Ultimo Valor de la Compra]![Codigo]=[Detalles de compras. "IdProducto =" & Me.SALIDA "."Codigo = [IdProducto] ") =SiInm(EsNulo([Detalles de compras.

Me!cmdSizeButton. GoTo.Ancho.Alto.PreviousControl. Sólo lectura.DataEntry = True 'PONE EN ESTADO DE ENTRADA DE DATOS A VERDADERO vbNewLine 'RETORNO DE CARRO SEGUIDO DE NUEVA LINEA.BackColor=16777215 ' PONE EL FONDO EN COLOR BLANCO Me.Name 'nombre del control previo MsgBox Screen. PROPIEDADES DE UN INFORME EN TRUE PASAR A FALSE Y MODIFICAMOS QUE IMPRIMIMOS IDCodigo.Report. (12 cm) DoCmd.ActiveForm.PreviousControl. (1000) 'Margen izquierdo .SetFocus 'para devolver una referencia al último control que ha recibido el enfoque.Name 'nombre del Form Activo MsgBox Screen.Margen desde arriba.PrecioUn = Format(Codigo.ActiveDatasheet.DefaultValue = Forms!Suscriptores!IDSuscriptores 'PONE COMO VALOR POR DEFECTO if KeyCode = 49 And Shift=2 Then 'SE HA PULSADO CTROL+1 CdoCombinado52. (12000).Form. (5 cm). (2500). NextRecord y PrintSection .00") 'FORMATEA A 2 DECIMALES Text1.Name 'nombre de la aplicacion MsgBox Screen. Down.Cancel 'NO IMPRIME UNA SECCION DE UN INFORME MoveLayout. Height) DoCmd.Name 'nombre de la hola activa Me. "#0.MoveSize (5320).RunCommand acCmdRecordsGoToNext DoCmd. Next 'MUESTRA LOS 'MUESTRA LA AYUDA DE .MsgBox Screen.SelStart = Len(Text1) 'SELECCIONA TODO EL TEXTO Me.RecordSource = Form_ListaDeFacturas.ShowToolbar 'MUESTRA LA BARRA DE HERRAMIENTAS SendKeys "{Home}+{End}" CAMBIAR EL ANCHO DEL FORMULARIO : MoveSize(Right.Application. DoCmd.MoveSize (5320).Name 'nombre del control activo MsgBox Screen. (18 cm). Print. Width.Form. (8500) 'son en CM lo de abajo DoCmd.RunCommand acCmdAddInManager COMPLEMENTOS DoCmd.Height = 1440 ' 1440 twips = 1 inch.MoveSize (10 cm).Parent. DoCmd.ActiveControl.RunCommand acCmdAnswerWizard ' Edit.Name 'nombre de la aplicacion MsgBox Screen.Column(2). (5000).RecordSource 'AL ABRIR EL INFORME INGRESA COMO ORIGEN DEL INFORME SEGUN EL DEL FORMULARIO ListaDeFacturas Screen. (2200).

RunCommand acCmdNewObjectForm 'ABRE ASISTENTE PARA CREA UN NUEVO FORM DoCmd.RunCommand acCmdAlignmentAndSizing 'alineacion y tamanño DoCmd.RunCommand acCmdAppMove 'MUEVE TOD ACCESS DoCmd.RunCommand acCmdAddWatch 'AGREGAR INSPECION NO FUNCIONA EN UN BOTON. acRecordsMenu.RunCommand acCmdDocMaximize 'MAXIMIZA LA VENTANA ACTIVA DoCmd.RunCommand acCmdAppSize ' PONE EL CURSO MOVER DoCmd. DoCmd. .RunCommand acCmdClose ' CIERRA LA VENTANA ACTIVA DoCmd.RunCommand acCmdAppMinimize 'MINIMIZA TODO ACCESS DoCmd.RunCommand acCmdAutoCorrect 'aBRE EL ASISTENTE DE AUTOCORRECCION DoCmd.DoMenuItem acFormBar. acNewRec 'SE MUEVE A UN NUEVO REGISTRO .RunCommand acCmdDatabaseProperties 'MUESTRA LAS PROPIEDADES DE LA BASE DE DATOS Application.Restore 'RESTAURA EL FORMULARIO DoCmd.RunCommand acCmdMicrosoftOnTheWeb ' ABRE INTERNET EXPLORER DoCmd.RunCommand acCmdAppMaximize 'MAXIMIZA TODO ACCESS DoCmd.RunCommand acCmdSaveRecord 'GUARDAR EL REGISTRO DoCmd.RunCommand acCmdOfficeClipboard 'ABRE EL PORTAPAPELES DoCmd.ACCEES DoCmd. .RunCommand acCmdOptions 'ABRE EL FORM DE OPCIONES DE ACCESS DoCmd.RunCommand acCmdDataEntry DoCmd. DoCmd. acSaveRecord.RunCommand acCmdExport 'EXPORTAR EL OBJETO ACTIVO DoCmd.RunCommand acCmdAdvancedFilterSort 'FILTRO U ORDEN AVANZADO DoCmd.RunCommand acCmdAlignBottom 'ALINEAR INFERIOR DoCmd.RunCommand acCmdCloseWindow ' CIERRA LA VENTANA ACTIVA DoCmd.GoToRecord .RunCommand acCmdAnalyzeTable 'ASISTENTE PARA ANALIZAR TABLAS.RunCommand acCmdAppRestore ' RESTAUARA TODO ACCESS DoCmd.RunCommand acCmdMoreWindows 'ABRE PARA SELECIONAR VENTANA DoCmd.RunCommand acCmdSetDatabasePassword 'ABRE LA VENTANA PARA PONER CONTRASEÑA AL MDB DoCmd.RunCommand acCmdExit 'SALE DE ACCESS DoCmd. acMenuVer70 'GUARDA EL REGISTRO DoCmd.RunCommand acCmdOptions 'ABRE LA VENTAN DE OPCIONES DE ACCESS DoCmd.RunCommand acCmdWindowHide DoCmd.

CreateReport 'crea UN INFORME Application. 'SELECCIONA EL FORM DoCmd.DoCmd. True 'VISUALIZA LA BARRA DE ESTADO Menú contextual Hay varias maneras en Access de conseguir que el botón derecho del ratón no permita al curioso usuario de nuestra aplicación el entrar en el diseño de nuestro formulario y despedazarlo sin piedad.Close acForm. de esta manera cada vez que toquen el botón derecho desplegaran la barra de herramientas que hemos creado anteriormente Metodos Abreviados de MS Access Teclas de Método Abreviado para introducir datos repetitivos. WindowMode:=acHidden DoCmd. "[Ordenes]") + 1 DoCmd. . "frmPrincipal". Usar las teclas de método abreviado globales de Microsoft Access Usar las teclas de método abreviado para seleccionar texto o datos Usar las teclas de método abreviado para modificar texto o datos Usar las teclas de método abreviado para desplazarse en la vista Hoja de datos Usar las teclas de método abreviado de los menús Usar las teclas de método abreviado de las ventanas y los cuadros de diálogo Usar las teclas de método abreviado globales de Microsoft Access Para imprimir el objeto actual o seleccionado CTRL+P Para abrir un cuadro combinado ALT+FLECHA ABAJO Para avanzar una línea FLECHA ABAJO Para avanzar una página AVANZAR PÁGINA Para retroceder una línea FLECHA ARRIBA Para retroceder una página RETROCEDER PÁGINA Para salir del cuadro combinado o el cuadro de lista TAB . "" EJECUTA LA MACRO Forms!frmPrincipal.Echo False Application.SetOption "Show Status Bar".Close acForm ' CIERRA EL FORMULARIO DoCmd.OpenForm FormName:="frmPagos".Name DoCmd.CreateForm 'crear un formulario Application. una forma es convirtiendo la base de datos en un archivo MDE (se encuentra en el menú herramientas). pero hay otra más curiosa: Creamos una barra de herramientas totalmente personalizada (sin el botón diseño si no nos interesa que este) y después en el menú de inicio de la base de datos ponemos esta barra de herramientas como menú contextual.GoToRecord .RunMacro "Lista de Productos. esta es sencilla.SegPreciosMod".SelectObject acForm. Me.SetFocus Forms!Ordenes1!NroOrden = DMax("[NroOrden]". . acFirst 'se mueve al primero REGISTRO DoCmd.RunCommand acCmdZoom75 Application.OpenForm "frmParmVentasLibro" 'ABRE EL FORM DoCmd.

utilice la tecla de flecha opuesta. cerrar un cuadro de diálogo o cerrar una hoja de propiedades ALT+F4 Usar las teclas de método abreviado para seleccionar texto o datos . en el modo Desplazamiento exclusivamente CTRL+BARRA ESPACIADORA Para seleccionar la columna situada a la derecha.Para cambiar entre el modo de Edición (con el punto de inserción mostrado) y el modo Desplazamiento F2 Para alternar entre las ventanas abiertas CTRL+F6 Para restaurar la ventana minimizada seleccionada cuando todas las ventanas están minimizadas ENTRAR Para cerrar la ventana activa CTRL+W Para revisar la ortografía F7 Para abrir el cuadro Zoom con el fin de introducir cómodamente expresiones y otro texto en áreas de entrada de datos pequeñas MAYÚS+F2 Para salir de Microsoft Access. Al seleccionar texto en un campo Presione Para ampliar la selección un carácter a la derecha MAYÚS+FLECHA DERECHA Para ampliar la selección una palabra a la derecha CTRL+MAYÚS+FLECHA DERECHA Para ampliar la selección un carácter a la izquierda MAYÚS+FLECHA IZQUIERDA Para ampliar la selección una palabra a la izquierda CTRL+MAYÚS+FLECHA IZQUIERDA Nota Para cancelar una selección. si está seleccionada la columna actual FLECHA DERECHA Para seleccionar la columna situada a la izquierda. Al seleccionar un campo o un registro Presione Para seleccionar el campo siguiente TAB Para cambiar entre el modo de Edición (con el punto de inserción mostrado) y el modo Desplazamiento F2 Para cambiar entre seleccionar el registro actual y el primer campo del registro actual en el modo Desplazamiento MAYÚS+BARRA ESPACIADORA Para ampliar la selección al registro anterior. si el registro actual está seleccionado MAYÚS+FLECHA ARRIBA Para ampliar la selección al registro siguiente. FLECHA ABAJO Para deshacer la extensión anterior MAYÚS+F8 Para cancelar el modo de Extensión ESC Al seleccionar una columna en la vista Hoja de datos Presione Para seleccionar la columna actual o cancelar la selección de la columna. si el registro actual está seleccionado MAYÚS+FLECHA ABAJO Para seleccionar todos los registros CTRL+A o CTRL+MAYÚS+BARRA ESPACIADORA Para obtener más información acerca de cómo seleccionar campos o registros. haga clic en Al ampliar una selección Presione Para ampliar una selección a campos adyacentes en la misma fila en la vista Hoja de datos FLECHA IZQUIERDA o FLECHA DERECHA Para ampliar una selección a filas adyacentes en la vista Hoja de datos FLECHA ARRIBA. si está seleccionada la columna actual FLECHA IZQUIERDA .

a continuación. en un subformulario. en los campos de una sola línea FIN Para moverlo al final del campo. ENTRAR o FLECHA DERECHA Para moverse al último campo del registro actual. a continuación. en los campos de una sola línea INICIO Para moverlo al principio del campo en los campos de varias líneas CTRL+INICIO Al copiar. presione F2 para mostrarlo. escriba el número de registro y presione ENTRAR Al desplazarse entre campos y registros Presione Para moverse al campo siguiente TAB. en los campos de varias líneas CTRL+FIN Para moverlo al principio del campo. en el modo Desplazamiento FIN Para moverse al campo anterior MAYÚS+TAB o FLECHA IZQUIERDA Para moverse al primer campo del registro actual en el modo Desplazamiento INICIO . se vuelve a consultar la tabla base del formulario exclusivamente MAYÚS+F9 Usar las teclas de método abreviado para desplazarse en la vista Hoja de datos Al ir a un registro específico Presione Para moverse al cuadro de número de registro. presione ESC dos veces para deshacer primero los cambios del campo actual y. Al mover el punto de inserción en un campo Presione Para moverlo un carácter a la derecha FLECHA DERECHA Para moverlo una palabra a la derecha CTRL+FLECHA DERECHA Para moverlo un carácter a la izquierda FLECHA IZQUIERDA Para moverlo una palabra a la izquierda CTRL+FLECHA IZQUIERDA Para moverlo al final del campo.) Para insertar la hora actual CTRL+DOS PUNTOS (:) Para insertar el valor predeterminado para un campo CTRL+ALT+BARRA ESPACIADORA Para insertar el valor del mismo campo del registro anterior CTRL+APÓSTROFO (') Para agregar un registro nuevo CTRL+SIGNO MÁS (+) Para eliminar el registro actual CTRL+SIGNO MENOS (-) Para guardar los cambios realizados en el registro actual MAYÚS+ENTRAR Para cambiar entre los valores de una casilla de verificación o un botón de opción BARRA ESPACIADORA Para insertar una nueva línea CTRL+ENTRAR Al actualizar campos con datos actuales Presione Para volver a consultar las tablas base. si ambos han cambiado. los del registro actual ESC Al introducir datos en la vista Hoja de datos o Formulario Presione Para insertar la fecha actual CTRL+PUNTO Y COMA (.Usar las teclas de método abreviado para modificar texto o datos Nota: Si el punto de inserción no está visible. mover o eliminar texto Presione Para copiar la selección al Portapapeles CTRL+C Para cortar la selección y copiarla al Portapapeles CTRL+X Para pegar el contenido del Portapapeles en el punto de inserción CTRL+V Para eliminar la selección o el carácter situado a la izquierda del punto de inserción RETROCESO Para eliminar la selección o el carácter situado a la derecha del punto de inserción SUPR Al deshacer cambios Presione Para deshacer la escritura CTRL+Z o ALT+RETROCESO Para deshacer cambios realizados en el campo actual o en el registro actual.

con un submenú visible.Para moverse al campo actual del registro siguiente FLECHA ABAJO Para moverse al campo actual del último registro en el modo Desplazamiento CTRL+FLECHA ABAJO Para moverse al último campo del último registro en el modo Desplazamiento CTRL+FIN Para moverse al campo actual del registro anterior FLECHA ARRIBA Para moverse al campo actual del primer registro en el modo Desplazamiento CTRL+FLECHA ARRIBA Para moverse al primer campo del primer registro en el modo Desplazamiento CTRL+INICIO Al desplazarse a otra pantalla de datos Presione Para avanzar una pantalla AVANZAR PÁGINA Para retroceder una pantalla RETROCEDER PÁGINA Para avanzar una pantalla hacia la derecha CTRL+AVANZAR PÁGINA Para avanzar una pantalla hacia la izquierda CTRL+RETROCEDER PÁGINA Al mover columnas Presione Para activar el modo Desplazamiento (MOV aparece en la esquina inferior derecha de la pantalla) Para mover la columna seleccionada a la derecha una columna en el modo Desplazamiento FLECHA DERECHA Para mover la columna seleccionada a la izquierda una columna en el modo Desplazamiento FLECHA IZQUIERDA Para desactivar el modo Desplazamiento ESC Ir al principio Usar las teclas de método abreviado de los menús Al utilizar un menú para Presione Mostrar el menú contextual MAYÚS+F10 Mostrar el menú del icono del programa (en la barra de título del programa) ALT+ESPACIO Seleccionar el comando siguiente o anterior del menú o submenú FLECHA ABAJO o FLECHA ARRIBA (con el menú o el submenú mostrados) Seleccionar el menú situado a la izquierda o la derecha o bien. con un submenú visible. cerrar sólo el submenú ESC Usar las teclas de método abreviado de las ventanas y los cuadros de diálogo Al utilizar una ventana para Presione Cambiar al programa siguiente ALT+TAB Cambiar al programa anterior ALT+MAYÚS+TAB Mostrar el menú Inicio de Windows CTRL+ESC Cerrar la ventana Base de datos activa CTRL+W Cambiar a la siguiente ventana Base de datos CTRL+F6 Cambiar a la ventana Base de datos anterior CTRL+MAYÚS+F6 Al utilizar un cuadro de diálogo presione Cambiar a la siguiente ficha de un cuadro de diálogo CTRL+TAB o CTRL+AV PÁG Cambiar a la ficha anterior de un cuadro de diálogo CTRL+MAYÚS+TAB o . cambiar entre el menú principal y el submenú FLECHA IZQUIERDA o FLECHA DERECHA Seleccionar el primer o el último comando del menú o el submenú INICIO o FIN Cerrar el menú y el submenú visibles a la vez ALT Cerrar el menú visible o bien.

sino que crea un ejecutable el propio Access que tan solo sirve para abrir tu aplicación. Incluyen desde bases con códigos de programación que permite incluir tus propios códigos. Ocupa demasiado (debes siempre hacerlo en Cd).exe. Por otra parte. activar o desactivar la casilla de verificación BARRA ESPACIADORA Moverse a la opción introduciendo la primera letra del nombre de la opción en un cuadro de lista desplegable Tecla de letra correspondiente a la primera letra del nombre de la opción que desea seleccionar (cuando está seleccionado un cuadro de lista desplegable) Seleccionar la opción o activar o desactivar la casilla de verificación introduciendo la letra subrayada en el nombre de la opción ALT+ tecla de letra Abrir un cuadro de lista desplegable ALT+FLECHA ABAJO (cuando está seleccionado un cuadro de lista desplegable) Cerrar un cuadro de lista desplegable ESC (cuando está seleccionado un cuadro de lista desplegable) Realizar la acción asignada al botón predeterminado en el cuadro de diálogo ENTRAR Cancelar el comando y cerrar el cuadro de diálogo ESC Al editar en un cuadro de texto Presione Moverse al comienzo de la entrada INICIO Moverse al final de la entrada FIN Moverse un carácter a la izquierda o a la derecha FLECHA IZQUIERDA o FLECHA DERECHA Moverse una palabra a la izquierda o a la derecha CTRL+FLECHA IZQUIERDA o CTRL+FLECHA DERECHA Seleccionar desde el punto de inserción hasta el comienzo de la entrada MAYÚS+INICIO Seleccionar desde el punto de inserción hasta el final de la entrada MAYÚS+FIN Seleccionar o anular la selección de un carácter a la izquierda MAYÚS+FLECHA IZQUIERDA Seleccionar o anular la selección de un carácter a la derecha MAYÚS+FLECHA DERECHA Seleccionar o anular la selección de una palabra a la izquierda CTRL+MAYÚS+FLECHA IZQUIERDA Seleccionar o anular la selección de una palabra a la derecha CTRL+MAYÚS+FLECHA DERECHA DevelopersTools Son las herramientas de desarrollo de Access. no contempla la posibilidad de incluir archivos mde.CTRL+RE PÁG Moverse a la opción o grupo de opciones siguiente TAB Moverse a la opción o grupo de opciones anterior MAYÚS+TAB Moverse por las opciones del cuadro de lista desplegable seleccionado o entre algunas opciones de un grupo de opciones Teclas de flecha Realizar la acción asignada al botón seleccionado. no crea un archivo setup. Desde luego son interesantes. Ten en cuenta que por ejemplo el empaquetador para distribuir aplicaciones. en un equipo sin licencia. y al menos hasta la versión de Access 2000.. pero quizás (y es una opinión muy particular) su relación contenido/precio no es muy buena. u otro ejecutable de tu aplicación. sino que tan sólo mdb. con lo cual las protecciones de código son prácticamente nulas. No . hasta un empaquetador para distribución de tus aplicaciones desarrolladas en Access.

La solución estaría en utilizar otra función parecida denominada DatePart. ¿Cómo mostrar rápidamente una lista de constantes de Access 2000? Para mostrar una lista de las constantes intrínsecas de Access. OK? ¿Cómo ocultar tablas en Access 2000?. Si necesita ver o tener acceso a la tabla de nuevo."q"). Según Ignacio también es posible utilizar el atributo t y funciona igual. También puede pulsar F2 para mostrar el examinador de Objetos y elegir la librería apropiada. En la ventana de Base de datos. No añada ningún registro. por razones de seguridad. te aconsejo que le des un vistazo. Para ello. ¿Cómo modificar el valor inicial de un campo autonumérico?.obstante. Pero me habeís mandado algún correo diciéndome que esto no funciona para nada. De esta manera. cambie el nombre de la tabla que desea ocultar con el prefijo usys.[Fecha]). . Si quiere que un campo designado como autonumérico inicie en un número diferente a 1. Nueva York Si. si conoces a alguien que tenga el developers. haga clic con el botón derecho del ratón en informe de Facturación. Tonawanda. basta con abrir cualquier módulo y pulsar CTRL+J. no desea que sus tablas de Microsoft Access aparezcan de manera predeterminada en la ventana Base de datos. Cree una consulta de tipo "append" para añadir el único registro en la segunda tabla para la primera ficha. Haga clic en la ficha Ver. Para Añadir la base de datos al informe Abra la base de datos. En Mostrar. que no puede visualizarse en la ventana Base de datos. Haga clic en Aceptar. Por Garth Schulte. seleccione la casilla de verificación Objetos de sistema. Access mostrará una lista desplegadle con las constantes. la tabla se convierte en un objeto del sistema. la sintaxis de esta es Datepart("q". ésta es la forma de conseguirlo: Cree la primera tabla que contenga el campo de tipo contador con el número en el que quiere que inicie la numeración. y después pulse Vista de Diseño. con la q le indicas a la función que te saque el trimestre. Para ello: En el menú Herramientas. puede elegir que se muestren los objetos del sistema en la ventana Base de datos. Formato de Fechas Para sacar el número de trimestre de una fecha determinada podes utilizar la función Format([Fecha]. Cree un registro en la segunda tabla ingresando un número uno menos que el número con el que desea iniciar el contador de la primera tabla. Cree una segunda tabla con un único campo de tipo numérico de entero largo con el mismo nombre que el campo contador de la otra tabla. existe una manera sencilla de ocultarlas. haga clic en Opciones. Siempre hay algo que te podrá servir.

y después escriba el siguiente texto en el cuadro de propiedades: =Left(CurrentProject. solo para Access 2000 ¿Cómo modificar el valor inicial de un campo autonumérico?. y después pulse Propiedades.Name)-4) En el Menú Ver . Cree un registro en la segunda tabla ingresando un número uno menos que el número con el que desea iniciar el contador de la primera tabla. Haga clic en la pestaña de Datos. Cree una consulta de tipo "append" para añadir el único registro en la segunda tabla para la primera fich . Cree una segunda tabla con un único campo de tipo numérico de entero largo con el mismo nombre que el campo contador de la otra tabla. No añada ningún registro. Si quiere que un campo designado como autonumérico inicie en un número diferente a 1.Len(CurrentProject.Haga clic en la herramienta de Cuadro de Texto en el cuadro de herramientas. escriba Base de Datos.Name. Haga clic con el botón derecho del ratón sobre el cuadro de texto. haga clic en Imprimir Vista Preliminar para ver los resultados. ésta es la forma de conseguirlo: Cree la primera tabla que contenga el campo de tipo contador con el número en el que quiere que inicie la numeración. y después pulse en la izquierda del campo de Fecha en el encabezado del informe. En la etiqueta para el cuadro de texto sin encuadernación que usted añadió.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->