EJERCICIOS 11-08-2011

1. Escribir los números del 1 al 10. Proceso sin_titulo Para x<-1 Hasta 10 Con Paso 1 Hacer escribir x FinPara FinProceso 2. Escribir la suma de los números del 1 al 10. Proceso sin_titulo sum<-0 Para x<-1 Hasta 10 Con Paso 1 Hacer sum<-sum+x FinPara Escribir sum FinProceso 3. Leer un número. Escribir lo números entre el 1 y el indicado. Proceso sin_titulo leer num Para x<-1 Hasta num Con Paso 1 Hacer escribir x FinPara FinProceso 4. Leer un número. Escribir los números entre el 1 y el indicado solo si la cifra ingresada es menor a 20. Proceso sin_titulo escribir "Ingrese numero" leer num Para x<-1 Hasta num Con Paso 1 Hacer Si num<=20 Entonces escribir x Sino FinSi FinPara FinProceso

Proceso sin_titulo prom<-0 cont<-0 escribir "ingrese pesos" Para x<-1 Hasta 10 Con Paso 1 Hacer leer num cont<-cont+num FinPara prom<-cont/10 escribir "el promedio de pesos es: ". indicar el promedio.5. Un sistema ingresa las edades de los alumnos de un curso de 8 integrantes. Proceso sin_titulo cont<-0 escribir "ingrese edades" Para x<-1 Hasta 8 Con Paso 1 Hacer leer num Si num >= 30 Entonces cont<-cont+1 Sino FinSi FinPara escribir "Alumnos mayores a 30: ". Indicar cuantos son mayores de 30 años. Un sistema ingresa el peso de un grupo de 10 personas. cont FinProceso 6. prom FinProceso .

dif FinProceso . dif FinProceso Hasta Que sum>total escribir "Se sobre paso el estanque" FinProceso 8. Sobran: ". Indicar cuando la cantidad de productos que circula es superior a 100 productos o si el total que haya pasado desde el inicio sea superior a 1000 y terminar cuando se llegue a esa cifra. Esto lo registra en la cifra de productos que pasa en un minuto. Un sensor de movimiento registra la cantidad de material que circula por la maquina.. Sobran: ". Proceso sin_titulo sum<-0 dif<-0 Repetir escribir "ingrese numero de productos" leer num sum<-sum+num Si num >= 100 | sum >= 100 Entonces escribir "La cantidad ingresada es mayor a 100 o el total de la suma es superior a 100" FinSi Hasta Que sum >= 1000 dif<-sum-1000 escribir "ha llegado a los 1000 productos.7. con los ingresos especificados en litros. Un sistema de llenado indica cuanto combustible se ingresa a un estanque de 2000 lts. Proceso sin_titulo dif<-0 cont<-0 Escribir "ingrese litros" Mientras cont < 2000 Hacer leer num cont<-cont+num Si cont > 2000 Entonces dif<-cont-2000 Sino FinSi FinMientras escribir "estanque lleno. Indicar cuando el ingreso de combustible supera la capacidad del estanque.

Un sistema de control de pasajero indica cuantas personas viajan en cada vehículo que circula por una carrera. Proceso sin_titulo sum<-0 dif<-0 Escribir "ingrese una cifra" leer cifra Repetir Escribir "ingrese numeros" leer num sum<-sum+num Hasta Que sum >= cifra Si sum >= cifra Entonces escribir "ingrese numero a restar" leer sgte dif<-sum-sgte Sino FinSi escribir dif FinProceso 10. El sistema se detiene cuando llega a 100. ingresar números hasta que la suma acumulada sea igual a esa cantidad. dif FinProceso . Pasajeros sobrantes: ". Si se pasa tiene que restar la siguiente. Proceso sin_titulo cont<-0 dif<-0 Repetir escribir "ingrese cantidad de pasajeros" leer num cont<-cont+num Hasta Que cont >= 100 Si cont > 100 Entonces dif<-cont-100 Sino FinSi Escribir "limite de pasajeros exedido. Dada una cifra.9.

Sign up to vote on this title
UsefulNot useful