Está en la página 1de 2

Instrucciones de instalacin de OpenGL en DEVC++ sobre Windows, adems como compilar y ejecutar su primer programa de OpenGL.

Las instrucciones originales estn publicadas en la pgina: http://onecore.net/dev-c-opengl.htm Para obtener La ltima versin del DevC++ esta aqu. Link obtenido de la pgina principal de http://dev-c.softonic.com/ http://sourceforge.net/projects/dev-cpp/files/Binaries/Dev-C%2B%2B%204.9.9.2/devcpp4.9.9.2_setup.exe/download?use_mirror=voxel Una vez instalado el DevC++ se procede a Instalar el soporte de OpenGL de acuerdo con las siguientes instrucciones: Lo primero es conseguir el Devpak Installation de OpenGL If youre opting to install the devpak instead of dll files manually, you have to download the OpenGL devpak. You can download Nigels OpenGL devpak from: http://www.nigels.com/glt/devpak/glut.3.7.6+.DevPak From the list on the page Download glut.3.7.6+.DevPak to a local folder. In DevC++, open the package manager: Tools->Package Manager. Here,you can see the preinstalled packages that came with your distribution of dev-cpp. To Install the glut package, click on Package->Install Package. Browse to the location where youve downloaded the glut devpak. Once you done with adding, it will appear in the package manager list. Now you can safely exit package manager. Now youre ready to write program on OpenGL with devcpp. You dont need to follow the compiler configuration explained below if youve downloaded the OpenGL devpak. Una vez instaldo el soporte de OpenGL cargue un ejemplo y lo compil siguiendo estas instrucciones: Make a new project: File->New->Project... Select Empty Project type from the Basic tab window Make sure C++ project is selected Add the .cpp file to the project:

Project->add to project select the .cpp file Define the linker options: Project->Project options In the Parameters tab window add the following line in the Linker pane: -lglut32 -lglu32 -lopengl32 -lwinmm -lgdi32 click ok Compile and run the project: Execute->Compile & run