P. 1
MPLAB ® IDE, SIMULATOR, EDITOR USER’S GUIDE

MPLAB ® IDE, SIMULATOR, EDITOR USER’S GUIDE

|Views: 29|Likes:
Publicado porGuillermo Hernandez

More info:

Published by: Guillermo Hernandez on Jul 26, 2011
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

05/12/2014

pdf

text

original

F1

Displays the appropriate help topic when pressed from a
window (e.g., File Registers Window).

F2

Executes the Debug > Break Settings command to open
the Break Settings dialog.

F3

Executes the Edit > Find command to find strings.

F4

Executes the Edit > Replace command to replace strings.

F5

Executes the Debug > Halt command to halt debugging.

F6

Executes the Debug > Reset command to issue a reset to
the emulated or simulated processor.

F7

Executes the Debug > Step command to execute a single
opcode from program memory.

F8

Executes the Debug > Step Over command to step over a
call instruction in program memory.

F9

Executes the Debug > Run command to issue a run to the
emulated/simulated processor.

F10

Executes the Project > Make Project command to initiate a
“make” for the current project.

MPLAB®

IDE User’s Guide

DS51025E-page 234

2001 Microchip Technology Inc.

F11

Executes the Execute > DOS Command To Window com-
mand to run a DOS command and capture its output in a
window.

Shift+F3

Executes the Edit > Repeat Find command to repeat the
last find operation.

Shift+F4

Executes the Edit > Repeat Replace command to repeat
the last replace operation.

Shift+F5

Executes the Debug > Halt Trace command to halt the
execution trace for the simulated processor.

Shift+F9

Executes the File > Close All command to close all files
and windows.

Ctrl+F2

Executes the Project > Open Project command to open the
Open Project Dialog.

Ctrl+F3

Executes the Project > Edit Project command to open the
Edit Project Dialog.

Ctrl+F7

Executes the Options > Environment Setup to open the
Environment Setup dialog.

Ctrl+F8

Executes the Windows > Show Symbol List command to
open the Symbol List dialog.

Ctrl+F10

Executes the Project > Build All command to build all the
source files for the current project.

Alt+F4

Executes the File > Exit command to end your MPLAB
Editor session.

Alt+F10

Executes the Project > Build Node command to build the
current node.

Shift+Ctrl+F2Executes the Debug > Clear Program Memory command to
clear all of program memory to an “erased” state.

Shift+Ctrl+F3Executes the Debug > System Reset command to reset the
entire emulator system.

Shift+Ctrl+F5Executes the Debug > POR Reset Emulation command to
open the POR Reset dialog.

2001 Microchip Technology Inc.

DS51025E-page 235

MPLAB Editor Default Key Commands

A
p
p
e
n
d
ic
e
s

Part

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->