P. 1
MPLAB ® IDE, SIMULATOR, EDITOR USER’S GUIDE

MPLAB ® IDE, SIMULATOR, EDITOR USER’S GUIDE

|Views: 29|Likes:
Publicado porGuillermo Hernandez

More info:

Published by: Guillermo Hernandez on Jul 26, 2011
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

05/12/2014

pdf

text

original

For PIC17CXXX or PIC18CXXX devices (that support extended memory)
operating with an emulator in either microprocessor or extended
microcontroller mode, you may select off-chip memory from a target board.
Select Options > Development Mode and click the Configuration tab to
access the Processor Mode. Select Options > Development Mode and click
the Memory tab to access Off-Chip Memory.

To import (download) a data file to target memory, select File > Import >
Import to Target Memory
to display the dialog box for selecting a file to import
through the emulator to target memory. The file must be a valid HEX file in the
Intel extended hex file format (INHX32). The file can be created by building an
MPLAB IDE project or by exporting program memory.

Figure 1.6: Import Target Memory Dialog (MPLAB ICE 2000)

Downloading data to off-chip memory on a target board does not
automatically update that memory range in the Program Memory window. To
perform this function, use the Window > Modify > Read Range feature. See
Section1.11.14.

2001 Microchip Technology Inc.

DS51025E-page 111

MPLAB IDE Toolbar and Menu Options

M
P
L
A
B
ID
E

R
e
f
e
r
e
n
c
e

Part

1.4.7

Export

1.4.7.1

Export Trace Buffer

Select File > Export > Export Trace Buffer to display a dialog box that will
allow you to save the emulator or simulator trace buffer to the selected file.

1.4.7.1.1. MPLAB ICE 2000 Trace Buffer

Figure 1.7: Export Trace Buffer Dialog (MPLAB ICE 2000)

Note:If you have a full trace buffer with maximum length labels, saving
the trace for the MPLAB ICE 2000 emulator could require over 7
MB. Saving the complete trace buffer as it appears in the Trace
Window (address, data, disassembled code and external logic
probe lines) can exceed 1 MB for the MPLAB SIM simulator.

File nameType the name of the file into in the File Name box or select the
name of an existing file you want to overwrite from the list.

Save file as
type

Specify the type of file the trace buffer will be saved as. The list
of files shown will be restricted to those of the type you specify.

FoldersSelect the folder where you want to save the file.

DrivesSelect the disk drive where you want to save the file.

OKClick OK to save the data to the file. If you specify the name of
a file that already exists, MPLAB Editor confirms the overwrite.

CancelNote: Clicking Cancel cancels the entire Save operation.

Read OnlySelect Read Only if you wish to prevent the file from being
overwritten later.

MPLAB®

IDE User’s Guide

DS51025E-page 112

2001 Microchip Technology Inc.

1.4.7.1.1. MPLAB SIM Trace Buffer

Figure 1.8: Export Trace Buffer Dialog (MPLAB SIM)

RangeSelect the range (0 to 8191) of the trace buffer that you
want to save. Enter the desired value for the Start line
number and for the End line number.

Filter Data: AllWrites the complete trace buffer to the selected file.

Filter Data:
Opcode/
Data Only

Saves Opcode / Data only (for PIC17CXXX external
read/write cycles). Available only with the MPLAB ICE
2000.

Filter Data:
Address Only

Saves Address only.

2001 Microchip Technology Inc.

DS51025E-page 113

MPLAB IDE Toolbar and Menu Options

M
P
L
A
B
ID
E

R
e
f
e
r
e
n
c
e

Part

1.4.7.2

Export Memory

Select File > Export > Export Memory to display the Export Memory dialog
box and export memory contents to a file.

If you have a programmed PICmicro MCU device that you may wish to copy
to other devices later, you can save the device’s program memory by reading
it into MPLAB IDE (using the Read Device option from the device programmer
menu), then exporting the results of the Read to a HEX file using the File >
Export > Export Memory
option. Later, you can program another device by
importing the file into MPLAB IDE and using the Program/Verify option from
the device programmer menu.

Figure 1.9: Export Memory Dialog

Note:All locations (including the empty locations) in the range you select
when you export will overwrite program memory when you import
later. In contrast, the Build Project process ignores empty locations
when creating a HEX file.

Memory areasDetermine which memory areas you want to save in
the build output file.

Program MemorySelect to save program memory. Also state the Start
and End address of program memory to save (entire
range is the default).

Configuration BitsSelect to save configuration bit settings.

IDsSelect to save ID information, if applicable.

EEPROM MemorySelect to save EEPROM memory, if applicable.

Calibration MemorySelect to save the calibration memory, if applicable.

MPLAB®

IDE User’s Guide

DS51025E-page 114

2001 Microchip Technology Inc.

1.4.8

Print (Ctrl+P)

Select File > Print to print some or all of the current file on your currently
selected printer.

The Print dialog allows you to specify the details of how the file is to be printed
and on which printer.

By default, MPLAB IDE uses the same printer that you specified the last time
you printed a file. The default details of the printing, such as line wrapping,
page headers, tab size, and line numbering are taken from the window edit
modes set on the current window. You can configure both these settings with
the Options > Current Editor Modes menu command.

The dialog box shows the name of the printer that MPLAB IDE is currently
using—if you haven't specified otherwise, this will be your system default
printer.

1.4.8.1

Print Current File Options

Figure 1.10: Print Current File Dialog

Output formatDetermine the format of the output file.

Disassembled CodeSelect to save in disassembled code format.

HEX CodeSelect either hex code format INHX32 or INHX85
(Intel split hex) format.

Setup PrinterClick Setup Printer to change printers, printer font,
or page margins.

Whole FileClick Whole File (the default) to print entire file.

2001 Microchip Technology Inc.

DS51025E-page 115

MPLAB IDE Toolbar and Menu Options

M
P
L
A
B
ID
E

R
e
f
e
r
e
n
c
e

Part

1.4.9

Print Setup

Select File > Print Setup to set up details of the printer that MPLAB IDE will
use, run an individual printer’s setup dialog, and select the font. MPLAB IDE
records the values you set with the Print Setup option for the selected printer.
Thus, you can have different settings for different printers. These values
become the defaults.

Figure 1.11: Printer Setup Dialog

File > Print Setup lets you specify:

•Which printer to use
•What page margins are to be applied when you print on this device
•What font to use with this printer

Selected TextClick Selected Text to print only the text that is
highlighted. This option is available only if you have
text highlighted.

Line RangeClick Line Range and fill in the start and end line
numbers to print a range of lines. You can use the
words “start” and “end” to represent the first and last
lines of the file.

Number LinesSelect Number Lines to print lines with numbering.

Wrap Long LinesSelect Wrap Long Lines to fold lines too long to fit
the page rather than being truncated.

Page HeadersSelect Page Headers to start each page with a
header giving the file name and other information.

MPLAB®

IDE User’s Guide

DS51025E-page 116

2001 Microchip Technology Inc.

File > Print Setup also allows you to run the printer’s own setup dialog to set
device-specific information.

Because MPLAB IDE is a text editor rather than a word processor, you’re
restricted to choosing fixed pitchfonts, where the characters are all the same
width.

If you run your printer’s own setup dialog after selecting a font, you may find
that the font is no longer available; some printers offer different fonts in
different operating modes.

1.4.10

Exit (Alt+F4)

Select File > Exit to terminate your MPLAB IDE session.

If any of the files you’re working with have changed and you haven’t saved the
changes to disk, MPLAB IDE will prompt you to save each one in turn. You
can choose to save the changes, discard them, or cancel the exit operation.
You will also be prompted to save the current project.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->