P. 1
Manual de Erwin Case

Manual de Erwin Case

|Views: 1.222|Likes:
Publicado porRiver Vega Cordova

More info:

Published by: River Vega Cordova on Jul 06, 2011
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOC, PDF, TXT or read online from Scribd
See more
See less

08/04/2013

pdf

text

original

HERRAMIENTA CASE: ERWIN

TALLER DE BASE DE DATOS – 2009 –I

UNFV - FIEI

Para este caso como creamos un nuevo modelo escogemos “Create a new model”.Creación de un esquema de base de datos.1) 1:N (0. Ofi_telef.Emp_fax.La creación de un modelo básico de datos Abrimos el programa y nos encontramos un primer cuadro de diálogo "ModelMart Connection Manager". Emp_provincia.N) EMPLEADO (1. Prop_tipo. Ofi_num) Inspecciona (Emp_num. como muestra en la Figura 1. Ofi_num). Emp_nom. Ofi_CP.N) Inspeccion a trabaja 1:N PROPIEDAD (0. Emp_apel. Emp_direcc. 3 . Prop_direcc. Esto no explicará todos los aspectos de ERWIN. Ger_descuento) Socio (Emp_num. Insp_coment) Gerente (Emp_num. pero si lo mínimo necesario para crear y usar los modelos de datos para esta clase. Ofi_fax) Propiedad (Prop_num. Emp_CP. Soc_tasa_hora) 1 . Esto consiste en tres puntos principales: 1 .N) Es un (0. Oficina (Ofi_num. Insp_fecha. Para la creación del diagrama partiremos del siguiente diagrama de E-R. Ofi_direcc.Introducción Este breve tutorial explica el proceso de crear un modelo de datos utilizando ERWIN.1) (1. (1. Emp_telef . Ofi_nombre. o la apertura de un modelo existente.N) N:M (1.Creación de la base de datos. 2 . Prop_provincia. Ger_salar.1) 1:1 (1. El siguiente cuadro de dialogo nos pedirá elegir entre la creación de un nuevo modelo. Emp_ciudad. . Prop_precio. Simplemente cancelamos.1) GERENTE SOCIO OFICINA Empleado (Emp_num.1) gestion a (1.Creación de un modelo de datos básico (modelo de datos Conceptual). Ofi_provincia. Prop_num.

Tendremos la oportunidad de cambiar esta opción más tarde. elegimos Lógico/Físico (Logical/Physical) como el nuevo tipo modelo. Esta opción nos permitirá cambiar fácilmente entre un modelo lógico (Diagrama de ER) y un modelo físico (esquema de base de datos). Figura 2: Selección de un modelo . mostrado en la Figura 2. Oracle.Figura 1: Crear un nuevo modelo El siguiente cuadro de diálogo. DB2. También. nos pedirá elegir la plantilla para crear el nuevo modelo. como Microsoft Access . En este punto. pero por el momento elegimos Microsoft Access. podemos asociar el modelo con un sistema de administración de bases de datos. etc.

Menu “Format”: Varias opciones. abrir. que mostrará el diagrama de ER. Cuando creamos objetos estos aparecerán en esta parte. Menu “Model”: Permite ver las propiedades de las relaciones.. la cardinalidad. Figura 3: El lugar de trabajo de ERWIN Figura 3a:Barra de menus Menu “File”: Dentro de este menu se encuentran la opciones de crear un nuevo diagrama. -> Entity display: Varias opciones para las entidades como: mostrar identificador de la clave ajena. que muestra una jerarquía de artículos. Menu “View”: Se seleccionan las barras de menu que queremos tener activas. migrar clave ajena. Menu “Tools”: ->Reverse engineer: esta opcioón permite pasar el modelo lógico a uno físico. El lugar de trabajo consiste en dos partes principales. las más relevantes son: -> Display level: Permite ver las entidades del diagrama de distintos modos. A la izquierda está el navegador. -> Relationship display: varias opciones para la relación como ver el verbo de la relacion. cortar.... Menu “Window”: Varias opciones para ver las ventanas de distintos modos. Menu “Edit”: Copiar un elemento del diagrama. imprimir. guardar... A la derecha la parte de diseño . identificador de clave primaria. crear dominios. . dominios. Menu “Help”: Manual de ayuda. pegar y seleccionar todo. atributos.. como entidades. la integridas referencial.. entidades. dominios y áreas.ERWIN mostrará ahora la ventana principal en la cual se realizará la mayor parte del diagrama. como muestra la figura 3. exportar e importar.

Además. Color de fuente. Buscar y crear informe. Dar zoom. Relación 1:N identificada. Ver diagrama a nivel de definición. Esto al realizar la relación entre dos entidades no migrará la clave primaria de la primera entidad y no la pondrá como clave ajena en la segunda. Model->Model Properties para ver la ventana mostrada en la Figura 3b: . Esto nos mostrará al lado de la clave primaria el icono de una llave. Relación N:N. Cambiar entre modelo físico y lógico 1 2 3 4 5 6 7 8 9/ 10 /11 /12 /13/14 15 123456789101112131415Tipo de fuente. Quitar zoom. Subrayado.1 2 3 4 5 6 7 8 9 10 11 1234567891011- Nuevo. Ver diagrama a nivel de entidad. Tamaño fuente. Cread subtipo. Color de línea de entidad. Crear entidad. Menu Format->Entity Display -> desactivamos Foreign Key Designator (FK). Antes de comenzar estableceremos ciertas preferencias: Menu Format->Entity Display -> activamos Primary Key Designator. podemos elegir entre dos anotaciones diferentes de diagramas E-R. Abrir. Seleccionar. Cursiva. Permite escribir un verbo en la relación. Ver diagrama a nivel de atributo. Ajuste de Preferencias ERWIN puede acomodar varios datos que modelan las anotaciones y las convenciones. Menu Format->Entity Display -> desactivamos Show Migrated Attributes. Menu Format->Relationship Display -> activamos Verb Phrase. Color de fondo. No mostrará la clave ajena (FK). Negrita. Relación 1:N no identificada. Dibujar figuras. Guardar. Imprimir.

Figura 3b: Elección de anotación Creación de una Entidad Para crear una nueva entidad. como muestra la Figura 6. y el atributo (s) clave no primaria. Pulsamos tabulador una vez más y añadimos el resto de atributos no primarios. Vemos que el nombre para la entidad es E/x. antes del nombre del atributo aparece el icono de una llave que nos indica que es la clave primaria. y nos situaremos en la parte de clave primaria. o click derecho sobre “Entities” en el navegador. En general. como muestra la Figura 4. . Al pinchar sobre la entidad vemos las tres partes principales de esta: el nombre de la entidad. Figura 4: Una nueva entidad Agregando los atributos Una vez cambiado el nombre (en nuestro caso EMPEADO) pulsamos de nuevo tabulador. hacemos clic sobre el icono de entidad ( ) sobre la barra de herramientas. para modificar una de estas tres partes de la entidad pulsaremos la tecla de tabulación para situarnos en la parte que deseamos modificar. Si pinchamos sobre el icono de entidad. Vemos que debido a las preferencias que elegimos anteriormente (Primary Key Designator). donde x es algún número (2 en este caso). entonces deberemos hacer click sobre la zona de diseño en donde queremos que aparezca la entidad. Emp_Num en nuestro caso. el atributo(s) clave primaria.

Socio. Figura 7: Las entidades . la naturaleza de las claves para estas entidades se hará clara. Entidad Atributos Ofi_Num (pk) Ofi_direcc Ofi_ciudad Ofi_provincia Ofi_CP Ofi_nombre Ofi_telefono Ofi_Fax Entidad Atributos OFICINA INSPECCIÓN Insp_fecha Insp_Comentario Prop_ID (pk) Prop_Street Prop_City Prop_State GERENTE PROPIEDAD Prop_Type Prop_Baths Prop_Rooms Prop_MonthlyRent SOCIO Ger_salar Ger_coche Soc_tasa_horas Notar que algunas entidades no tienen claves primarias (Gerente.Cuando realicemos las relaciones del diagrama.Figura 6: La entidad de Empleado Vamos a repetir el proceso de creación de entidad para las entidades y atributos que aparecen en la siguiente lista.

Relación identificada Comenzaremos con dos relaciones. Suponiendo que la regla del negocio vigente aquí está en que cada propiedad tiene a lo más una inspección por día. Figura 9. y muchos a muchos. cada Propiedad puede someterse a muchas inspecciones. entre Inspección y Empleado y entre Inspección y Propiedad. Relaciones "uno a muchos" . ERWIN nos permite que distinguir entre identificación y no identificación en relaciones de tipo uno a muchos. que no es muy provechosa. Cada inspección debe ser realizada por un empleado. Una relación que se identifica se crea haciendo clic primero sobre el icono de relación que se identifica ( ). En los cuadros de texto podemos definir la etiqueta que se colocara sobre la relación en lugar de R/1. Proporcionamos un verbo significativo a la relación. ¿Dada suceso de entidad de “hijo” (Inspección) tiene que ver con un suceso de la entidad “padre” (Empleado)?. y en la entidad “hijo”(inspección Presionamos dos veces sobre la relación para abrir la ventana de definición de relación y rellenarlo como muestra figura 11. . La inspección está relacionada con Propiedad como con Empleado en una relación de uno a muchos. En este caso sí. uno a muchos". Figura 8: Relación identificada Figura 9: Definición de la relación Notar que ERWIN ha proporcionado una etiqueta " R/1 "para la relación. cada Empleado lleva a cabo muchas Inspecciones. Para crear la relación pinchamos sobre la entidad “padre” (uno) y luego sobre la entidad “hijo” (muchos) Además vemos que aparece mediante la anotación escogida (Model->Model Properties) tres lineas al final de la linea indicando muchos y una linea continua que indica la identificación. Cada Inspección se emprende en una Propiedad. Por esta razón.Creación de Relaciones ERWIN permite la creación de relaciones con tres clases básicas de la conectividad: de uno a uno. decimos que la relación entre la Inspección y la Propiedad es un relación de uno a mucho. como vemos en la figura 8. Como antes. hacemos click sobre el icono. Cada Inspección es llevada a cabo por un Empleado. Presionamos dos veces el ratón sobre la relación y se abrirá una ventana en la cual podemos cambiar el nombre a la relación. también podremos definir la cardinalidad . o no es considerado una inspección apropiada. La participación de Empleado en la relación es obligatoria. Dentro de la categoría uno a muchos. elegimos la cardinalidad y tenemos la opción de indicar si se permiten valores nulos o no. click en la entidad “padre” (empleado).

la oficina es la entidad “padre” y el empleado es la entidad “hijo”. cada empleado debe tener que ver con una sola oficina.Relación no identificada La relación entre Empleado y Oficina es algo diferente. pero esta no se identifica.Ya que la clave primaria de empleado no incluye la clave primaria del oficina. que usa una línea discontinua en vez de una línea continua. . debemos hacer clic sobre el icono de relación que se no identifica ( ). y cada propiedad es manejada por una y sólo una oficina. Figura 12.Figura 10: Relación no identificada Figura 11: Definición de la relación . Para tal relación. En esta relación uno a mucho. y que no se permiten nulos. una. Figura 12: Relación no identificada Figura 13: Relación que se no identifica con participación obligatoria La cardinalidad indica que cada oficina tiene que ver con uno o varios (pero no cero) empleados. Cada empleado es adjudicado a una y sólo una oficina. En otras palabras. Completamos las relaciones creando una relación entre oficina y propiedad en la cual cada oficina maneja cero. El Tipo de relación indica que esta es una relación que se no identifica. esta es una relación que se no identifica. Esta es una relación de tipo uno a muchos. y cada oficina tiene a uno o varios Empleados. o más propiedades. Figura 12. Figura 13. porque la clave primaria del Oficina no es parte de la clave primaria de la Empleado.

Podemos especificar que Gerente y Socio son subtipos del Empleado. nosotros podemos definir los dominios una vez. luego sobre el supertipo (Empleado). y se nos presentará una venta como la figura 15. Sólo los socios tienen una tasa por hora. en vez de hacer clic sobre el supertipo otra vez. hacemos click otra vez sobre el icono de subtipo. La ventaja de este es la coherencia a través de atributos y facilidad del mantenimiento. Segundo. Ahora.Subtipos y Supertipos Hay dos clases de empleados entre los que deseamos distinguir: gerentes y socios. En un diagrama de E-R. definir los dominios para cada atributo.luego los aplicaremos a nuestros atributos. y aplicarlo a múltiples atributos. Figura 15: Diccionario de dominios . Para hacer esto. Uno de los rasgos atractivos de los dominios. Hacemos click primero sobre el icono de subtipo.Creación de un esquema de base de datos Ahora crearemos un esquema de base de datos basado en el diagrama creado anteriormente Esto consta de dos partes principales. aseguramos que todas las entidades (fuertes) fundamentales tienen una clave primaria. Primero. pero tiene además un pequeño número de atributos específicos. haga click sobre el icono de subtipo en el diagrama entre empleado y gerente y seguidamente en socio. Cada una de estas dos clases de empleados tiene todas las propiedades del Empleado. En el menu Model -> Domain Dictionary. usaremos el icono de subtipo ( ). es que los dominios pueden ser compartidos por más de un atributo. Indicar que el Gerente es un subtipo de Empleado. Sólo los gerentes tienen un sueldo y una concesión de coche. Figura 14. Figura 14: Diagrama final 2 . luego sobre el subtipo (Gerente). Definiremos todos los dominios que necesitaremos en nuestro diagrama . Para incluir al socio como un subtipo.

Figura 17 : Adjudicar un tipo de datos al nuevo dominio Figura 16: Nuevo dominio Volveremos a la ventana de Diccionario de dominio y veremos que un nuevo dominio. ha sido creado. como muestra la figura 17. A continuación creamos otro dominio para provincia como char(2). Aquí. Click sobre los puntos suspensivos que aparecen a la derecha del cuadro llamado “Valid” y veremos una ventana en la cual podemos crear reglas de validación como muestra la Figura 18. Pulsamos sobre la etiqueta “Datatype”. Volveremos a la ventana de las Reglas de la Validación. Crearemos una nueva regla de validación para el dominio estado. como Emp_num. Click sobre “New” para crear un nuevo dominio. Prop_num. Tecleamos el Código como el nombre del dominio en el cuadro de texto de “Logical name” como muestra la Figura 16. .Crearemos primero un nuevo dominio que podremos aplicar a identificadores numéricos que usaremos. y Ofi_num. Ahora tenemos que especificar los códigos de provincia que constituyen valores válidos para el dominio. Figura 19. Click sobre “New” y lo denominamos Códigos de provincia y aceptamos. y elegimos integer como “Datatype” para este dominio. Codigo. hacemos click en “Valid values list” y comenzamos a teclear códigos estatales válidos en la primera columna de Valor Válida.

Duplex. Apartamento.2) Crear una nueva regla de validación con un valor Mínimo = 0 COMENTARIO CHAR(255) TIPO CHAR(25) Crear una nueva regla de llamada el Tipo de Propiedad con una lista de valores válidos: Casa. Comercial FECHA FECHA PRECIO INTEGER Crear una nueva regla llamada no número entero negativo con un valor Mínimo = 0 NUMERO ENTERO NO INTEGER Crear un nuevo validan la regla llamada número entero no NEGATIVO negativo con un valor Mínimo = 0 .Figura 18: Reglas de Validación Figura 19: Valores validos del dominio Repetiremos el proceso para el resto de dominios que se detallan a continuación: DOMINIO NOMBRE DIRECC CIUDAD CP TELEFONO SALARIO DATATYPE REGLA DE VALIDACIÓN CHAR(20) CHAR(100) CHAR(50) CHAR(10) CHAR(15) DECIMAL(9.

y una lista de dominios sobre el lado derecho. Asociamos un dominio con un atributo pinchando primero sobre el atributo. Figura 20. ATRIBUTO Emp_num Emp_nom Emp_apel Emp_calle Emp_ciudad Emp_provincia Emp_CP Emp_telefono Emp_Fax Prop_num Prop_calle Prop_ciudad Prop_provincia Prop_CP Prop_tipo Prop_precio Prop_habitaciones DOMINIO Codigo Nombre Nombre Calle Ciudad Estado Zipcode Teléfono ATRIBUTO Ofi_num Ofi_calle Ofi_CP Ofi_nombre Ofi_telefono Ofi_fax Insp_fecha Insp_comentario DOMINIO Codigo Calle Zipcode Nombre Teléfono Fax Fecha Comentario Dinero Dinero Dinero Teléfono Ger_salar Codigo Ger_coche Calle Soc_tasa_hora Ciudad Estado Zipcode Tipo de Propiedad Dinero Numero entero no negativo Para ello presionamos dos veces el ratón sobre una de las entidades en el diagrama. No recibiremos ningún mensaje informativo adicional de que esta asociación ha sido hecha. luego haciendo click sobre el dominio a asociar. Veremos una lista de atributos en la izquierda.Aplicación de dominios a atributos Una vez creados los dominios debemos asociarlos a sus atributos correspondientes. .

Creación de la base de datos. para transformar el diagrama de E-R lógico en un esquema Relacional físico. simplemente elegimos Físico en vez de Lógico en el cuadro combinado () en lo alto de la ventana como muestra la figura 21. Primero.Figura 20: Asociación de un dominio con un atributo Finalmente activamos las propiedades que desactivamos al comienzo. comprobaremos nuestro esquema relacional para asegurarnos que todos los tipos de datos son correctos. Conversión de un Diagrama de E-R en un Esquema Relacional Finalmente. Este proceso consta de varias partes. Ahora crearemos una base de datos física basada en el esquema relacional desarrollado anteriormente. Segundo. Figura 21: Modelo Físico del Esquema Relacional 3 . crearemos una base de datos de Access .

. y en “Browse” buscamos la base de datos que hemos creado previamente.vacía para tener nuestra base de datos. Tercero. utilizaremos ERWIN para engendrar un conjunto de tablas dentro de la base de datos que se corresponde a nuestro esquema relacional. veremos una ventana indicando los resultados de la generación de esquema. Después de esto pulsamos en “Connect”. Figura 23: Conexión con la base de datos Si todo va bien. Figura 23. Figura 22 Figura 22: Generar esquema Pusltamos en generar y veremos una nueva ventana. Figura 24. Una vez creada la base de datos en blanco en Access debemos ir al menu Tools->Forward Engineer/Schema Generation (En modo Physical). Tecleamos ADMIN como “User Name”.

Figura 25. Figura 25: Base de datos .Figura 24: Esquema generado Finalmente abrimos la base de datos de Access que creamos antes y verificamos que la base de datos ha sido creada acorde al esquema de E-R .

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->