P. 1
Crear páginas web con KompoZer

Crear páginas web con KompoZer

|Views: 760|Likes:
Publicado porartyhjkluhgfvbj

More info:

Published by: artyhjkluhgfvbj on Jun 14, 2011
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOCX, PDF, TXT or read online from Scribd
See more
See less

04/26/2013

pdf

text

original

Crear páginas web con KompoZer

KompoZer le permite crear sus propias páginas y publicarlas en la web. No tiene que saber HTML para usar KompoZer; es tan fácil de usar como un procesador de textos. Los botones de la barra de herramientas le permiten añadir listas, tablas, imágenes, enlaces a otras páginas, colores y tipos de letra. Puede ver qué aspecto tendrá su documento en la web a medida que lo crea, y lo puede compartir fácilmente con otros usuarios, con independencia del tipo de navegador o programa de correo con soporte de HTML que utilicen.

Comenzar una nueva página
Crear una nueva página
KompoZer es un editor de HTML (Hypertext Markup Language) que permite la creación y edición de páginas web. Además, es un editor WYSIWYG, por lo que se puede visualizar la forma en que se mostrará la página al tiempo que se crea. No es necesario conocer HTML ya que la mayoría de las funciones básicas del HTML se encuentran disponibles como órdenes en la barra de herramientas y en los menús. KompoZer también le permite la edición del código fuente HTML si lo desea. Para ver o editar el código fuente HTML, abra el menú Ver, y escoja Código fuente HTML, o pulse la pestaña Etiquetas <HTML> en la barra de herramientas de modo de edición de la parte inferior de la ventana de KompoZer. Para crear una página web utilice uno de los métodos que a continuación se describen. Una vez haya comenzado una página, puede agregar y editar texto de la misma manera en la que lo haría en un procesador de textos. Para crear una nueva página en KompoZer:
y

Haga clic en el botón Nuevo de la barra de herramientas de KompoZer.

Para comenzar a partir de un archivo HTML almacenado en su disco local: 1. Abra el menú Ventana y seleccione KompoZer. Se mostrará la ventana de KompoZer. 2. Abra el menú Archivo y seleccione Abrir Archivo.... Se mostrará el cuadro de diálogo Abrir archivo HTML. 3. Localice en su disco local el archivo que desee editar. 4. Haga clic en Abrir para mostrar el archivo escogido en la ventana de KompoZer. Para editar una página web:

1. Abra KompoZer 2. Haga clic en el menú Archivo y seleccione Abrir dirección. Se mostrará el cuadro de diálogo Abrir dirección web. 3. Escriba la URL de la página a editar (por ejemplo, http://www.mozilla.org) y haga clic en el botón Crear. Se mostrará la página en KompoZer. KompoZer también da la opción de crear un documento nuevo usando el formato XHTML. Para crear un documento XHTML, active la opción crear un documento XHTML en el cuadro de diálogo Crear un nuevo documento o plantilla. Consejo: en la ventana de KompoZer se pueden abrir rápidamente los archivos con los que se ha estado trabajando más recientemente mediante la apertura del menú Archivo, seleccionando Páginas recientes y escogiendo el archivo deseado de la lista. [ Volver al principio de la sección ]

Pestañas - Editar varios documentos
KompoZer permite editar varios documentos al mismo tiempo. En lugar de cambiar de una ventana a otra para editar más de un documento, KompoZer ofrece la posibilidad de las Pestañas. Se pueden abrir varios documentos al mismo tiempo con KompoZer en la misma ventana pero en distintas pestañas. Las pestañas pueden abrirse usando Ctrl+T o bien seleccionando Crear en: Nueva pestaña dentro del cuadro de diálogo Crear un nuevo documento o plantilla. Aunque se tengan varias pestañas abiertas, cada una es gestionada independientemente. Se indica el estado de cada documento; por ejemplo, si ha sido modificado y necesita ser guardado, aparecerá un icono de un disquete rojo en la pestaña correspondiente. [ Volver al principio de la sección ]

Guardar y visualizar la nueva página
Se pueden guardar los documentos de KompoZer como HTML o como sólo texto. Al guardar un documento en HTML se mantiene el formato del documento, como los estilos de texto (por ejemplo, negrita o cursiva), tablas, enlaces e imágenes. Al guardar un documento como formato de sólo texto se eliminan todas las etiquetas HTML pero se mantiene el texto del documento. Para guardar un documento como archivo HTML:
y

Abra el menú Archivo y escoja Guardar o bien pulse el botón Guardar en la barra de herramientas de redacción. Si no se ha proporcionado aún un título a la página, KompoZer le pedirá que lo haga. KompoZer mostrará el título de la página en la barra de título de la ventana

Cuando guarda una página en KompoZer. El título del documento también aparecerá en la lista de marcadores si se guarda la página en ella. títulos y listas . Abra el menú Archivo y seleccione Exportar a texto. La ventana de KompoZer permanecerá abierta tras la nueva ventana de Navigator. A continuación. Para cambiar el nombre o la dirección de un archivo HTML existente: y Escoja Archivo > Guardar como y seleccione un nombre o ubicación diferente. Tenga en cuenta que los cambios actuales se perderán. continuará viendo la imagen en el documento tanto en KompoZer como en Navigator. Para ver la página en una ventana del navegador con el fin de comprobar los enlaces: y Abra el menú Archivo y escoja Visualizar página en el navegador (o haga clic sobre Navegar en la barra de herramientas de redacción). las imágenes y otros archivos. KompoZer le pedirá que introduzca el título de la página. Asegúrese de que conserva la extensión . todos los componentes de la página (el HTML. si la dirección de la imagen es relativa a la dirección de la página (comienza con file:///). Sin embargo. Dar formato a párrafos. 2. entonces no verá la imagen en la versión local del documento. Si la dirección de una imagen es absoluta (comienza con http://) y se encuentra conectado a Internet. KompoZer le pedirá que introduzca el nombre del archivo y que especifique la ubicación donde desea que se guarde. el nombre del archivo y la ubicación. Introduzca el nombre y la ubicación en la que se desea guardar el archivo.html en el nombre del archivo. Nota: las imágenes no aparecen en los documentos guardados en formato de sólo texto. Si sólo quiere guardar la parte HTML de la página. Para guardar un documento como archivo de sólo texto: 1. el archivo debe tener la extensión .cuando se muestre la página en el navegador. Cuando almacene o edite documentos usando XHTML. Si aún no ha guardado el documento. Vea Preferencias de KompoZer para más información sobre cómo cambiar la configuración de KompoZer al guardar páginas. Consejo: se puede escoger Revertir desde el menú Archivo para retomar la copia más recientemente guardada del documento en el que se está trabajando.xhtml. debe cambiar la preferencia de KompoZer relativa al almacenamiento de páginas. Los archivos con una directiva DOCTYPE de tipo XHTML que tengan extensión . tales como archivos de sonido y hojas de estilo). se guardan en el disco local.html no serán considerados como documentos xhtml.

y así sucesivamente. sin afectar al espaciado anterior o posterior a éste. Abra el menú Formato y escoja Lista. o Numerada: Los elementos están enumerados. Título 2 para el siguiente nivel. Para dar formato a un elemento de una lista: 1. o Dirección: puede ser utilizado para la firma de una página web que indique el autor de la página y una persona con la cual contactar para obtener más información. Para dar formato de titular al texto: 1. Por ejemplo. Este formato aparece a menudo en el pie de las páginas web bajo una línea horizontal.Título 6: aplica un formato de titular al párrafo. 2. Con el texto normal la mayoría de los navegadores eliminan los espacios extra. 2. Haga clic para emplazar el punto de inserción donde quiera que comience el formato o seleccione el texto al que desea aplicar el formato. Haga clic para emplazar el punto de inserción dentro de la línea de texto a la que se desea aplicar el formato. por ejemplo: usuario@ejemplo. datos en columna y mensajes de correo que se desea sean mostrados con un tipo de letra de ancho fijo. Navigator mostrará el formato dirección en cursiva. 3. el texto que utiliza el estilo preformato se muestra con los espacios en blanco intactos. 2. o Título 1 . Utilice la lista desplegable de la barra de formato y escoja el grado de titular que desee.com Quizá se desee añadir la fecha y un aviso de copyright. Sin embargo. preservando el diseño del texto original. o Cuerpo del texto: aplica el tipo de letra y estilo por omisión al texto normal.Para aplicar un formato a un párrafo. Título 1 es el titular de mayor grado mientras que Título 6 es el de menor grado. escoja Título 1 para el título principal. El párrafo incluye un margen superior y otro inferior. comience desde la ventana de KompoZer: 1. Escoja el estilo de lista: 4. o No numerada: cada elemento tiene una viñeta (punto) a su lado (como en esta lista). . Haga clic para emplazar el punto de inserción en cualquier sitio dentro del texto al que desea aplicar el formato. o Párrafo: inserta una etiqueta de párrafo (se utiliza para comenzar un nuevo párrafo). Escoja un formato de párrafo utilizando la lista desplegable de la barra de herramientas de formato: 3. tabulaciones y retornos de carro. o Preformato: éste es útil para elementos del tipo de ejemplos de código. desde 1 (mayor) a 6 (menor).

escoja Alinear y seleccione un tipo de alineado. Para cambiar el estilo de las viñetas o de los números: 1. Nota: también se puede utilizar la barra de formato para alinear el texto. a la izquierda o a la derecha: 1. En el caso de las listas no numeradas se puede modificar el estilo de la viñeta. Seleccione una viñeta o un estilo de numeración de la lista desplegable. Abra el menú Formato y escoja Propiedades de la lista. Para cambiar uno o más de los elementos de la lista a texto normal: 1. [ Volver al principio de la sección ] o Lista no numerada Trabajar con listas Para finalizar una lista y continuar escribiendo texto normal: y Haga clic para emplazar el punto de inserción al final del último elemento de la lista y presione Enter (Return en Mac OS) dos veces hasta el final de la lista. Haga clic para emplazar el punto de inserción dentro del elemento de la lista o seleccione los elementos de la lista. En el caso de listas numeradas se puede especificar un número de comienzo. El texto del término aparecerá resaltado a la izquierda y el texto de la definición aparecerá sangrado. Haga clic para emplazar el punto de inserción dentro del párrafo o la línea de texto que se desea alinear. Truco: se puede aplicar rápidamente un estilo de lista a un bloque de texto seleccionando ese texto y haciendo clic sobre los botones de Lista numerada de la barra de formato. Abra el menú Formato. 2. al centro. 3. 2. por ejemplo. Haga clic para emplazar el punto de inserción dentro del texto del elemento de la lista que desea modificar o seleccione uno o más elementos de la lista si se desea aplicar un estilo nuevo a toda la lista entera. Consejo: también puede hacer doble clic en una viñeta o número de la lista para mostrar el cuadro de diálogo de propiedades de la lista.o Término y Definición: estos dos estilos trabajan juntos creando una apariencia del estilo de los glosarios. Utilice la etiqueta Término para la palabra que se está definiendo y la etiqueta Definición para la definición. . Para alinear un párrafo o texto de la página.

En vez de especificar un tipo de letra que podría no estar disponible para todos los que vayan a ver la página web. 2. Abra el menú Formato y escoja uno de los siguientes: 3. haga clic en el botón de lista no numerada) de la barra de formato. Times y Courier por lo general se ven de la misma manera cuando se muestran en cada uno de los distintos ordenadores. Para una lista numerada. Nota: no aparecen todos los tipos de letra instalados en el ordenador. 3. Si prefiere utilizar los tipos de letra personalizados por el navegador del lector seleccione Anchura variable o Anchura fija. generalmente es mejor seleccionar uno de los tipos de letra proporcionados por el menú ya que éstos funcionan en todos los ordenadores. puede hacer clic en cualquier lugar dentro de un elemento de la lista y pulsar Tab para aumentar el sangrado en un nivel. Arial. para una lista no numerada. 4. [ Volver al principio de la sección ] Cambiar el color. . Para colocar texto sangrado bajo un elemento de una lista: 1. estilo y tipo de letra Para cambiar el estilo. Seleccione el texto sobre el que desea aplicar el formato. Escriba el texto que desea sangrar. Por ejemplo. 2. los tipos de letra Helvetica. Haga clic para emplazar el punto de inserción dentro del elemento de la lista. Para juntar dos listas adyacentes: 1. Presione Mayús-Enter para crear otro párrafo sangrado. Presione Mayús-Enter para crear el sangrado libre. Asegúrese de seleccionar todos los elementos de ambas listas. Pulse Mayús+Tab para reducir el sangrado en un nivel. Si selecciona un tipo de letra diferente. podría no visualizarse de la misma manera en otro ordenador. haga clic en el botón de lista numerada (o. 2. o Tipo de letra: úselo para seleccionar un tipo de letra. Tenga en cuenta que cualquier texto existente entre las dos listas también pasará a formar parte de la nueva lista. Seleccione las dos listas que desea unir. Truco: se puede incrementar o decrementar el sangrado de los elementos de la lista haciendo clic en cualquier lugar dentro de un elemento de la lista y pulsando a continuación los botones Sangrado o Desangrado de la barra de herramientas de formato. Haga clic sobre el botón de lista numerada o no numerada para juntar las listas.2. o presione Enter para crear el siguiente elemento de la lista. color o tipo de letra del texto seleccionado: 1. Alternativamente.

Tamaño: úselo para seleccionar un tamaño de letra relativo o escoja una de las opciones para incrementar o decrementar el tamaño del texto (relativo al texto circundante). Continúe escribiendo. Continúe escribiendo. o Estilo de texto: úselo para seleccionar un estilo. Truco: para cambiar con rapidez el color del texto al último utilizado. puede escribir un color específico o escribir simplemente un nombre de color en inglés (por ejemplo. Pulse el bloque de color de fondo en la barra de herramientas de formato. negrita o subrayado. o para aplicar un estilo estructurado. Si está familiarizado con los códigos hexadecimales de color del HTML. como cursiva. blue). 2. 4. [ Volver al principio de la sección ] Buscar y reemplazar texto Para buscar texto dentro de la página en la que se está trabajando: . Abra el menú Formato y seleccione Eliminar todos los estilos de texto. Para seguir escribiendo texto con todos los estilos eliminados: 1. por ejemplo. Pulse Aceptar. seleccione el texto. Esto es útil cuando se desea usar un único color en líneas de texto separadas. También puede utilizar una imagen como fondo. 3. o Para cambiar el color de fondo de la página: 1. presione Mayús y haga clic sobre el selector de color. Abra el menú Formato y escoja Eliminar todos los estilos de texto. 2. 3. Encontrará un útil conversor de códigos de colores aquí. 3. [ Volver al principio de la sección ] Eliminar o deshabilitar los estilos de texto Para eliminar todos los estilos de texto (negrita. 2. o Color de texto: úselo para seleccionar un color mediante el selector de color. Haga clic en cualquier punto de la página. cursiva y demás) de un texto: 1. Vea Configuración de fondos y colores de página. Escoja un color de fondo del cuadro de diálogo de color de fondo. Emplace el punto de inserción donde desee deshabilitar los estilos de texto. Seleccione el texto. Código.

Verá el cuadro de diálogo Buscar y reemplazar. Abra el menú Editar y seleccione Buscar y reemplazar. Haga clic sobre Cerrar cuando haya terminado. la búsqueda encontrará coincidencias tanto en letras mayúsculas como en minúsculas. Si no selecciona esta opción. [ Volver al principio de la sección ] Insertar líneas horizontales . haga clic sobre Buscar siguiente para buscar la siguiente coincidencia. 4. 3. 2. Haga clic en Buscar siguiente para comenzar la búsqueda. 3. Cuando KompoZer localice la primera coincidencia. Haga clic para emplazar el punto de inserción donde desee comenzar la búsqueda. Escriba el texto que desea localizar en el campo Buscar texto. 6. Haga clic en Reemplazar para cambiar el texto seleccionado por el texto de reemplazo. Para buscar y reemplazar texto dentro de la página en la que se está trabajando: 1. o Buscar en todo el documento: úsela para buscar hasta el final de la página y volver a la parte superior o inferior. KompoZer seleccionará la siguiente coincidencia del texto. 2. Verá el cuadro de diálogo Buscar y reemplazar. Abra el menú Editar y seleccione Buscar y reemplazar. Haga clic en Reemplazar y buscar para reemplazar el texto seleccionado y encontrar la siguiente coincidencia. Para acotar la búsqueda seleccione una o más de las siguientes opciones: o Coincidencia de mayúsculas/minúsculas: úsela para especificar si la búsqueda distinguirá entre mayúsculas y minúsculas. Haga clic sobre Cerrar cuando haya terminado. 5. Escriba el texto que desea localizar y el texto por el cual lo quiere reemplazar. Haga clic en Reemplazar todos para cambiar cada una de las coincidencias del del documento por el texto de reemplazo. o Buscar en todo el documento: úsela para buscar hasta el final de la página y volver a la parte superior o inferior. o Buscar hacia atrás: úsela para buscar desde el punto de inserción hasta el inicio de la página. dependiendo de si la búsqueda es hacia adelante o hacia atrás. Haga clic para emplazar el punto de inserción donde desee comenzar la búsqueda. 5. Haga clic en Buscar siguiente para buscar la siguiente coincidencia. 4. o Buscar hacia atrás: úsela para buscar desde el punto de inserción hasta el inicio de la página.1. 7. Para acotar la búsqueda seleccione una o más de las siguientes opciones: o Coincidencia de mayúsculas/minúsculas: úsela para especificar si la búsqueda distinguirá entre mayúsculas y minúsculas.

[ Volver al principio de la sección ] Insertar caracteres especiales Para insertar caracteres especiales como tildes. Vea la sección Editor avanzado de propiedades. para mayor detalle. 2. Haga clic sobre Usar como opción predeterminada para utilizar estas configuraciones como las predeterminadas para la próxima vez que se inserte una línea horizontal. . 4. Truco: se puede seleccionar Etiquetas HTML del menú Ver para que se muestren todos los elementos HTML en cajas amarillas. 3. largo. comience desde la ventana de KompoZer: 1. la anchura de la línea cambiará siempre que la ventana de KompoZer o del navegador sea redimensionada. Para editar manualmente las propiedades de la línea horizontal haga clic sobre Edición avanzada. o Altura: escriba un número para el alto de la línea (en píxeles). Edite cualquiera de estas propiedades: o Anchura: escriba el ancho y luego escoja % de la ventana o píxeles. 2. o Alineación: especifique cómo desea que se alinee la línea (a la izquierda. o Sombreado 3-D: selecciónelo para añadir profundidad a la línea mediante la adición de un bisel sombreado. Haga clic para emplazar el punto de inserción donde desee que aparezca la línea.Las líneas horizontales se utilizan normalmente para separar diferentes secciones de un documento de forma visual. Si especifica la anchura como un porcentaje. 1. alineación y sombreado de una línea. Se puede hacer doble clic sobre cualquiera de estas cajas para que se visualice el cuadro de diálogo del Editor avanzado de propiedades para esa etiqueta o elemento HTML. marcas de copyright o símbolos monetarios: 1. 3. 2. centrada o a la derecha). Seleccione una categoría de caracteres. Abra el menú Insertar y seleccione Caracteres y símbolos. ancho. Verá el cuadro de diálogo Insertar carácter. Para insertar una línea horizontal (también llamada regla) dentro de la página. Establecer las propiedades de una línea horizontal Se puede personalizar el alto. Haga doble clic en la línea para mostrar el cuadro de diálogo Propiedades de la línea horizontal. Abra el menú Insertar y seleccione Línea horizontal. Haga clic para emplazar el punto de inserción donde desee que aparezca el carácter especial.

seleccione Barras de herramientas y asegúrese de que la barra de herramientas del modo de edición está seleccionada). Para trabajar con el código fuente HTML siga uno de estos métodos: y y y Posicione el punto de inserción donde desee incluir el código HTML o seleccione el texto que quiere editar. un enlace o una línea horizontal. imágenes y líneas horizontales se puede utilizar el editor avanzado de propiedades. JavaScript y CSS a los objetos. En el cuadro de diálogo Insertar HTML introduzca las etiquetas y texto. y a continuación abra el menú Insertar y seleccione HTML. Seleccione el carácter que desea insertar de la lista desplegable Carácter. Haga clic en Edición avanzada para abrir el Editor avanzado de propiedades. [ Volver al principio de la sección ] Insertar elementos y atributos HTML Si sabe cómo trabajar con el código fuente HTML podrá insertar etiquetas adicionales. Seleccione Símbolos comunes para insertar caracteres especiales como el símbolo de copyright o fracciones. Si no está seguro de cómo trabajar con el código fuente. 6. una imagen. atributos de estilo y JavaScript en la página. abra la lista desplegable Letra y seleccione la letra sobre la cual quiere poner la tilde (nota: no todas las letras tienen una forma acentuada). 4. o Se puede continuar escribiendo en el documento (o en una ventana de redacción de correo) mientras se mantiene el cuadro de diálogo abierto. eliminar o modificar los atributos HTML y sus valores asociados. Se puede usar este editor para añadir atributos HTML. un enlace interno. como una tabla. Haga clic en Cerrar cuando termine de insertar caracteres especiales. es preferible que no utilice este editor. es preferible que no lo modifique. 5. (Si no ve esta barra. si es que desea utilizarlo de nuevo. abra el menú Ver. Haga clic en Insertar. . Haga doble clic sobre el elemento para abrir el cuadro de diálogo de las propiedades asociadas al elemento. Abra el menú Ver y seleccione Código fuente HTML o haga clic sobre la pestaña Etiquetas <HTML> en la barra de herramientas del modo de edición en la parte inferior de la ventana de KompoZer.Si escoge Mayúsculas acentuadas o Minúsculas acentuadas. Utilizar el editor avanzado de propiedades Para añadir atributos HTML y JavaScript a objetos como tablas. Seleccione un elemento. Nota: a menos que entienda claramente cómo añadir. Haga clic en Insertar.

Haga clic en Edición avanzada para abrir el editor avanzado de propiedades del objeto. lleve a cabo los siguientes pasos: 1. Haga clic sobre Aceptar para aplicar los cambios del cuadro de diálogo del editor avanzado de propiedades. Podrá entonces editar el nombre del atributo o el valor mediante el uso de los campos editables Atributo y Valor de la parte inferior del cuadro de diálogo. 5. Nota: Los atributos obligatorios se encuentran resaltados en la lista de atributos. haga clic en Aceptar para salir del cuadro de diálogo Propiedades. 2. El nuevo atributo se añadirá automáticamente cuando haga clic en el campo Valor. [ Volver al principio de la sección ] Validar el HTML Antes de subir el documento a un servidor web (publicarlo). Comprobar únicamente de manera visual la página web en su navegador favorito no significa que su documento vaya a aparecer correctamente al ser abierto en otros navegadores. De nuevo. selecciónelo de la lista y haga clic en Eliminar. . Los documentos que contienen HTML validado son menos propicios a causar problemas en su visualización por los diferentes navegadores.Si no está viendo actualmente el cuadro de diálogo del editor avanzado de propiedades. cada una de las cuales tiene una lista con las propiedades actuales del objeto seleccionado: o Atributos HTML: haga clic en esta pestaña para visualizar o introducir atributos HTML adicionales. KompoZer coloca comillas dobles de forma automática en el texto del atributo. vea Preferencias de KompoZer. seleccione el atributo que desee editar. Para eliminar un atributo. Para más información sobre el uso de estilos CSS en KompoZer. Para editar una propiedad o atributo en cualquiera de estas tres pestañas. 3. 6. Haga doble clic sobre el objeto que desea modificar para abrir su cuadro de diálogo Propiedades. El editor avanzado de propiedades tiene tres pestañas. Para añadir un nuevo atributo. o Estilo incrustado: haga clic sobre esta pestaña para visualizar o introducir propiedades CSS (hojas de estilo en cascada) adicionales mediante el atributo <style>. escriba su nombre en el campo Atributo de la parte inferior del cuadro de diálogo. o Eventos JavaScript: haga clic en esta pestaña para visualizar o introducir eventos JavaScript. Desde el menú Ver (o la barra de herramientas del modo de edición) escoja Etiquetas HTML. es una buena práctica comprobar antes el formato del HTML del documento con el objetivo de asegurarse de que cumple con los estándares web. 4.

Vista preliminar: seleccione este modo para visualizar y editar el documento de la manera exacta en la que aparecerá en la ventana de un navegador. el modo Normal reaparecerá. Sin embargo. por lo que se visualiza la forma en la que se mostrará el documento al tiempo que se crea. Abra el menú Herramientas y seleccione Validar HTML. quizá se desee cambiar el modo de edición. que comprueba si la sintaxis HTML del documento se ajusta al estándar HTML 4. Cada modo de edición permite continuar trabajando en el documento. Para validar la sintaxis del documento HTML: 1. .01. KompoZer permite saltar rápidamente entre cuatro modos de edición o vistas. Este servicio proporciona además información sobre cómo corregir los errores. 2. pero muestra niveles variables de etiquetas HTML (e iconos de etiquetas). KompoZer le preguntará si hacerlo antes de proceder. Código fuente: seleccione este modo para ver y editar el documento como código fuente HTML sin formato. El resto de iconos de las etiquetas HTML quedarán ocultos. KompoZer abrirá una nueva ventana con los resultados de su documento una vez que el servicio de validación de la W3C examine su archivo html. Etiquetas HTML: seleccione este modo para que se muestren los iconos de todas las etiquetas HTML. Seleccione este modo para que se muestren los bordes de las tablas y los iconos de los vínculos internos. Antes de escoger un modo de edición: y Abra el menú Ver. Cuando se guarde el documento. Nota: hay que estar conectado a Internet para utilizar esta característica. KompoZer utiliza el Servicio de validación de HTML de la W3C. Si no ha guardado los cambios. seleccione Mostrar/Ocultar y asegúrese de que la opción Barra de modo de edición está marcada. excepto porque los enlaces y las funciones JavaScript estarán desactivadas. [ Volver al principio de la sección ] Escoger el modo de edición correcto Normalmente no se necesitará cambiar el modo predeterminado de edición (Normal). si se desea trabajar con el código fuente HTML del documento. La Barra de modo de edición dispone de cuatro pestañas: y y y y Normal: éste es el modo de edición WYSIWYG.KompoZer proporciona un modo apropiado para comprobar que el documento cumple los estándares HTML de la W3C (World Wide Web Consortium).

Las propiedades predeterminadas de la etiqueta se aplicarán al texto dentro de la página web. Escoja la sección de propiedades que desee editar:  Propiedades del texto  Propiedades del borde  Propiedades del fondo  Propiedades de la caja  Propiedades aurales  Extraer y crear estilo genérico Seleccionando cualquiera de las opciones excepto la última se abrirá la pestaña de la sección correspondiente del editor CSS (más información sobre CSS en la sección Utilizar hojas de estilo). Este modo de aplicación de estilo está disponible en todos los modos excepto el modo de edición Código fuente. [ Volver al principio de la sección ] Utilizar la barra de estado para dar formato a la página web KompoZer dispone de una innovadora característica de aplicación de estilos incrustados y etiquetas class e id al texto seleccionado mediante la barra de estado. Etiquetas HTML. Estilos incrustados: en cualquiera de los modos de edición Normal. y en consecuencia todos los estilos para esa etiqueta desaparecerán. Eliminar etiqueta: al hacer clic en Eliminar etiqueta se eliminará la etiqueta de estilo. y y y y Seleccionar: al hacer clic en Seleccionar se seleccionara el texto completo limitado por la etiqueta de estilo. . se pueden definir estilos propios que serán almacenados según el estilo de código CSS de la W3C. Haga clic en Estilos incrustados. enlaces. La opción Extraer y crear estilo genérico permite extraer información de estilo a una regla de estilo y guardarla en una hoja de estilos externa/interna. objetos incrustados y archivos GIF animados no están activos en ninguno de los modos de edición. o Vista preliminar las etiquetas que recubren la posición actual se muestran en la barra de estado de KompoZer. Al hacer clic en Cambiar etiqueta el texto de la etiqueta correspondiente se vuelve editable en la barra de estado. Las propiedades de estilo de cada una de las etiquetas pueden ser modificadas seleccionando una opción del menú contextual. Con la sección correspondiente abierta. Para cambiar las propiedades de estilo incrustadas: 1. Para visualizarlos en su estado activo. 3. se puede cambiar la etiqueta usada para el texto con el mínimo esfuerzo.Nota: las funciones JavaScript. 2. Haga clic con el botón derecho sobre la etiqueta que desee editar. Java. Escriba pues la etiqueta deseada y presione Enter. Cambiar etiqueta: al utilizar esta opción. haga clic en el botón Navegar de la barra de herramientas de redacción para cargar la página dentro de una ventana del navegador. marcos.

CaScadeS permite dos modos de edición de hojas de estilo: 1. Para proporcionar estilo al documento html que se edita. imágenes. Con estilos incrustados. para mayor detalle. A diferencia de los estilos incrustados. [ Volver al principio de la sección ] Crear hojas de estilo con KompoZer Al usar CaScadeS. vea la sección Trabajar con plantillas. Clases: se muestran las etiquetas de clase (si existen) de la hoja de estilos actual aplicada al documento. Vea la sección Editor avanzado de propiedades. En caso de que no haya hoja de estilo. se creará una nueva automáticamente. Modo para principiantes: este modo permite crear reglas asociadas a selectores de clase o selectores de tipo de elemento. Propiedades avanzadas: permite usar el editor de propiedades avanzado para agregar atributos HTML y JavaScript a objetos como tablas. ID: se muestran las etiquetas ID (si existen) de la hoja de estilos actual aplicada al documento. Con hojas de estilo externas. CaScadeS puede iniciarse haciendo clic en el menú Herramientas y seleccionando Editor CSS. Para aplicar una clase al texto seleccionado simplemente haga clic en esa etiqueta de clase. 2. Hacer editable y Eliminar área editable. Con hojas de estilo internas. Para más información sobre plantillas. etc. Haga clic en el botón de elemento <style>. las hojas de estilo internas o externas ayudan a mantener separadas la información del contenido de la del estilo. KompoZer dispone de un editor de hojas de estilo denominado CaScadeS. . Cascade Style Sheets) pueden usarse para proporcionar estilo a un documento HTML de tres maneras: 1. CaScadeS puede ser utilizado para producir tanto hojas de estilo internas como externas. Modo avanzado: este modo permite crear reglas sin restricciones. enlaces. Usar hojas de estilo en cascada Las hojas de estilo en cascada (CSS. Para aplicar una etiqueta determinada al texto seleccionado simplemente haga clic en esa etiqueta ID. 2.y y y y Plantillas: se ofrecen dos opciones. que pueden ser utilizadas al trabajar con plantillas. Para crear una hoja de estilo interna: 1. 3. se pueden crear tanto hojas de estilo internas como externas.

Haga clic en el botón de elemento <link>. Rellene el nombre de la regla.(Opcional) Rellene la información sobre Lista de medios y Título de la hoja de estilo. o Para crear una hoja de estilo externa: 1. Para usar una hoja de estilos concreta al crear o modificar reglas. Escriba la URL de la hoja de estilo en el panel de la derecha. se creará un nuevo fichero en el sistema de archivos local. Aural) del panel de la derecha. Para ver todas las definiciones de una regla de estilo. Para crear reglas nuevas: 1. Guarde también el documento inmediatamente antes de cerrar el editor CSS. o (Opcional) Rellene la información sobre Lista de medios y Título de la hoja de estilo. Caja. Consejo: utilice el botón Recargar del panel de la izquierda si la hoja de estilo no se descarga inmediatamente. Fondo. El panel de la derecha mostrará opciones para especificar el tipo de regla a crear. 2. Las reglas pueden ser definidas usando las pestañas de estilo (Texto. Haga clic en Crear regla de estilo. El panel de la derecha mostrará entonces los detalles de la hoja de estilo en la pestaña General. selecciónela en el panel de la izquierda y haga clic en la pestaña General del panel de la derecha. Active comprobar al crear una hoja de estilo alternativa si ésta es una alternativa. Haga clic en el botón Regla del panel de la izquierda. se pueden crear reglas para cada hoja de estilo de forma individual. Elija una entre las siguientes: o estilo con nombre (introduzca abajo el nombre de la clase) o estilo aplicado a todos los elementos del tipo (introduzca el tipo abajo) o estilo aplicado a todos los elementos coincidentes con este selector 3. Consejo: guarde siempre el documento html antes de agregar una hoja de estilo local. La pestaña General mostrará todas las definiciones aplicadas a la regla. 4. 3. Haga clic en Crear hoja de estilo. 2. Bordes. Usar hojas de estilo en cascada . Si no existe ya. 2. [ Volver al principio de la sección ] Crear reglas para las hojas de estilo Después de crear una o más hojas de estilo para el documento html. selecciónela en el panel de la izquierda haciendo clic sobre ella con el botón izquierdo del ratón.

Con hojas de estilo internas. En caso de que no haya hoja de estilo. KompoZer dispone de un editor de hojas de estilo denominado CaScadeS. Con hojas de estilo externas. Consejo: guarde siempre el documento html antes de agregar una hoja de estilo local. Haga clic en Crear hoja de estilo. 2. Haga clic en el botón de elemento <link>. A diferencia de los estilos incrustados. [ Volver al principio de la sección ] Crear hojas de estilo con KompoZer Al usar CaScadeS. 3. o (Opcional) Rellene la información sobre Lista de medios y Título de la hoja de estilo. CaScadeS permite dos modos de edición de hojas de estilo: 1. Con estilos incrustados. o (Opcional) Rellene la información sobre Lista de medios y Título de la hoja de estilo. Haga clic en el botón de elemento <style>. las hojas de estilo internas o externas ayudan a mantener separadas la información del contenido de la del estilo. Active comprobar al crear una hoja de estilo alternativa si ésta es una alternativa. Para proporcionar estilo al documento html que se edita. 2. Escriba la URL de la hoja de estilo en el panel de la derecha. Si no existe ya. 2. CaScadeS puede iniciarse haciendo clic en el menú Herramientas y seleccionando Editor CSS. Modo avanzado: este modo permite crear reglas sin restricciones. 2.Las hojas de estilo en cascada (CSS. se creará una nueva automáticamente. 3. . Para crear una hoja de estilo interna: 1. se pueden crear tanto hojas de estilo internas como externas. Para crear una hoja de estilo externa: 1. Guarde también el documento inmediatamente antes de cerrar el editor CSS. se creará un nuevo fichero en el sistema de archivos local. CaScadeS puede ser utilizado para producir tanto hojas de estilo internas como externas. Cascade Style Sheets) pueden usarse para proporcionar estilo a un documento HTML de tres maneras: 1. Modo para principiantes: este modo permite crear reglas asociadas a selectores de clase o selectores de tipo de elemento.

CaScadeS permite dos modos de edición de hojas de estilo: . La pestaña General mostrará todas las definiciones aplicadas a la regla. KompoZer dispone de un editor de hojas de estilo denominado CaScadeS. Caja. CaScadeS puede iniciarse haciendo clic en el menú Herramientas y seleccionando Editor CSS. 3. Fondo. selecciónela en el panel de la izquierda y haga clic en la pestaña General del panel de la derecha. 2. Usar hojas de estilo en cascada Las hojas de estilo en cascada (CSS. Con hojas de estilo externas. selecciónela en el panel de la izquierda haciendo clic sobre ella con el botón izquierdo del ratón. [ Volver al principio de la sección ] Crear reglas para las hojas de estilo Después de crear una o más hojas de estilo para el documento html. Haga clic en el botón Regla del panel de la izquierda. Aural) del panel de la derecha. Para ver todas las definiciones de una regla de estilo. Con hojas de estilo internas. CaScadeS puede ser utilizado para producir tanto hojas de estilo internas como externas. Haga clic en Crear regla de estilo. El panel de la derecha mostrará entonces los detalles de la hoja de estilo en la pestaña General. Rellene el nombre de la regla. El panel de la derecha mostrará opciones para especificar el tipo de regla a crear. Las reglas pueden ser definidas usando las pestañas de estilo (Texto. Para proporcionar estilo al documento html que se edita. Bordes. 4. Para crear reglas nuevas: 1. las hojas de estilo internas o externas ayudan a mantener separadas la información del contenido de la del estilo. se pueden crear reglas para cada hoja de estilo de forma individual. Elija una entre las siguientes: o estilo con nombre (introduzca abajo el nombre de la clase) o estilo aplicado a todos los elementos del tipo (introduzca el tipo abajo) o estilo aplicado a todos los elementos coincidentes con este selector 3. 2.Consejo: utilice el botón Recargar del panel de la izquierda si la hoja de estilo no se descarga inmediatamente. A diferencia de los estilos incrustados. Con estilos incrustados. Para usar una hoja de estilos concreta al crear o modificar reglas. Cascade Style Sheets) pueden usarse para proporcionar estilo a un documento HTML de tres maneras: 1.

3. Escriba la URL de la hoja de estilo en el panel de la derecha. [ Volver al principio de la sección ] Crear reglas para las hojas de estilo Después de crear una o más hojas de estilo para el documento html. Para crear reglas nuevas: 1. 2. se creará un nuevo fichero en el sistema de archivos local. o (Opcional) Rellene la información sobre Lista de medios y Título de la hoja de estilo. El panel de la derecha mostrará entonces los detalles de la hoja de estilo en la pestaña General. se pueden crear tanto hojas de estilo internas como externas. El panel de la derecha mostrará opciones para especificar el tipo de regla a crear. Modo para principiantes: este modo permite crear reglas asociadas a selectores de clase o selectores de tipo de elemento. Consejo: utilice el botón Recargar del panel de la izquierda si la hoja de estilo no se descarga inmediatamente.1. Consejo: guarde siempre el documento html antes de agregar una hoja de estilo local. Active comprobar al crear una hoja de estilo alternativa si ésta es una alternativa. Si no existe ya. Guarde también el documento inmediatamente antes de cerrar el editor CSS. Haga clic en Crear hoja de estilo. se creará una nueva automáticamente. Para crear una hoja de estilo externa: 1. selecciónela en el panel de la izquierda haciendo clic sobre ella con el botón izquierdo del ratón. Para usar una hoja de estilos concreta al crear o modificar reglas. 2. En caso de que no haya hoja de estilo. Para crear una hoja de estilo interna: 1. 2. 2. Elija una entre las siguientes: . Haga clic en el botón Regla del panel de la izquierda. Modo avanzado: este modo permite crear reglas sin restricciones. [ Volver al principio de la sección ] Crear hojas de estilo con KompoZer Al usar CaScadeS. se pueden crear reglas para cada hoja de estilo de forma individual. Haga clic en el botón de elemento <style>. Haga clic en el botón de elemento <link>. o (Opcional) Rellene la información sobre Lista de medios y Título de la hoja de estilo.

estilo con nombre (introduzca abajo el nombre de la clase) estilo aplicado a todos los elementos del tipo (introduzca el tipo abajo) estilo aplicado a todos los elementos coincidentes con este selector 3. Para crear una hoja de estilo interna: 1. se pueden crear tanto hojas de estilo internas como externas. Haga clic en Crear regla de estilo. Para proporcionar estilo al documento html que se edita. Haga clic en el botón de elemento <style>. [ Volver al principio de la sección ] Crear hojas de estilo con KompoZer Al usar CaScadeS. Con hojas de estilo externas. selecciónela en el panel de la izquierda y haga clic en la pestaña General del panel de la derecha. 2. Fondo. CaScadeS puede iniciarse haciendo clic en el menú Herramientas y seleccionando Editor CSS. Haga clic en Crear hoja de estilo. Cascade Style Sheets) pueden usarse para proporcionar estilo a un documento HTML de tres maneras: 1. las hojas de estilo internas o externas ayudan a mantener separadas la información del contenido de la del estilo. CaScadeS puede ser utilizado para producir tanto hojas de estilo internas como externas. En caso de que no haya hoja de estilo. La pestaña General mostrará todas las definiciones aplicadas a la regla. 2. Usar hojas de estilo en cascada Las hojas de estilo en cascada (CSS. Con hojas de estilo internas. Caja. 4. KompoZer dispone de un editor de hojas de estilo denominado CaScadeS. Bordes. Modo avanzado: este modo permite crear reglas sin restricciones. 3. Rellene el nombre de la regla. Aural) del panel de la derecha. o (Opcional) Rellene la información sobre Lista de medios y Título de la hoja de estilo. Para ver todas las definiciones de una regla de estilo. 2. o o o Las reglas pueden ser definidas usando las pestañas de estilo (Texto. CaScadeS permite dos modos de edición de hojas de estilo: 1. Modo para principiantes: este modo permite crear reglas asociadas a selectores de clase o selectores de tipo de elemento. . Con estilos incrustados. A diferencia de los estilos incrustados. se creará una nueva automáticamente.

Haga clic en Crear regla de estilo. Fondo. Elija una entre las siguientes: o estilo con nombre (introduzca abajo el nombre de la clase) o estilo aplicado a todos los elementos del tipo (introduzca el tipo abajo) o estilo aplicado a todos los elementos coincidentes con este selector 3. 3. Escriba la URL de la hoja de estilo en el panel de la derecha. Cascade Style Sheets) pueden usarse para proporcionar estilo a un documento HTML de tres maneras: 1. 4. o (Opcional) Rellene la información sobre Lista de medios y Título de la hoja de estilo. La pestaña General mostrará todas las definiciones aplicadas a la regla. . 2. Bordes. Rellene el nombre de la regla. selecciónela en el panel de la izquierda y haga clic en la pestaña General del panel de la derecha. Active comprobar al crear una hoja de estilo alternativa si ésta es una alternativa. Con estilos incrustados. Consejo: utilice el botón Recargar del panel de la izquierda si la hoja de estilo no se descarga inmediatamente. Caja. El panel de la derecha mostrará opciones para especificar el tipo de regla a crear. 2. se creará un nuevo fichero en el sistema de archivos local. Aural) del panel de la derecha. Con hojas de estilo internas. se pueden crear reglas para cada hoja de estilo de forma individual. Haga clic en el botón Regla del panel de la izquierda. selecciónela en el panel de la izquierda haciendo clic sobre ella con el botón izquierdo del ratón. Para crear reglas nuevas: 1. [ Volver al principio de la sección ] Crear reglas para las hojas de estilo Después de crear una o más hojas de estilo para el documento html. Si no existe ya. Haga clic en el botón de elemento <link>. Para ver todas las definiciones de una regla de estilo. 2. Las reglas pueden ser definidas usando las pestañas de estilo (Texto. Guarde también el documento inmediatamente antes de cerrar el editor CSS. Usar hojas de estilo en cascada Las hojas de estilo en cascada (CSS. El panel de la derecha mostrará entonces los detalles de la hoja de estilo en la pestaña General. Para usar una hoja de estilos concreta al crear o modificar reglas. Consejo: guarde siempre el documento html antes de agregar una hoja de estilo local.Para crear una hoja de estilo externa: 1.

A diferencia de los estilos incrustados. 2. [ Volver al principio de la sección ] . las hojas de estilo internas o externas ayudan a mantener separadas la información del contenido de la del estilo. Guarde también el documento inmediatamente antes de cerrar el editor CSS. Consejo: guarde siempre el documento html antes de agregar una hoja de estilo local. Si no existe ya. Active comprobar al crear una hoja de estilo alternativa si ésta es una alternativa. Consejo: utilice el botón Recargar del panel de la izquierda si la hoja de estilo no se descarga inmediatamente. 2. KompoZer dispone de un editor de hojas de estilo denominado CaScadeS. Haga clic en el botón de elemento <style>. Para crear una hoja de estilo interna: 1. se pueden crear tanto hojas de estilo internas como externas. [ Volver al principio de la sección ] Crear hojas de estilo con KompoZer Al usar CaScadeS. o (Opcional) Rellene la información sobre Lista de medios y Título de la hoja de estilo. Para proporcionar estilo al documento html que se edita. 2. Modo para principiantes: este modo permite crear reglas asociadas a selectores de clase o selectores de tipo de elemento. Con hojas de estilo externas. 3. En caso de que no haya hoja de estilo. se creará una nueva automáticamente. se creará un nuevo fichero en el sistema de archivos local. Escriba la URL de la hoja de estilo en el panel de la derecha.3. Modo avanzado: este modo permite crear reglas sin restricciones. Haga clic en Crear hoja de estilo. CaScadeS puede iniciarse haciendo clic en el menú Herramientas y seleccionando Editor CSS. CaScadeS puede ser utilizado para producir tanto hojas de estilo internas como externas. Para crear una hoja de estilo externa: 1. o (Opcional) Rellene la información sobre Lista de medios y Título de la hoja de estilo. CaScadeS permite dos modos de edición de hojas de estilo: 1. Haga clic en el botón de elemento <link>.

En caso de que no haya hoja de estilo. se pueden crear reglas para cada hoja de estilo de forma individual. selecciónela en el panel de la izquierda haciendo clic sobre ella con el botón izquierdo del ratón. 2. Para crear reglas nuevas: 1. Bordes. Haga clic en el botón Regla del panel de la izquierda. Con estilos incrustados.Crear reglas para las hojas de estilo Después de crear una o más hojas de estilo para el documento html. se creará una nueva automáticamente. Para ver todas las definiciones de una regla de estilo. CaScadeS permite dos modos de edición de hojas de estilo: 1. Elija una entre las siguientes: o estilo con nombre (introduzca abajo el nombre de la clase) o estilo aplicado a todos los elementos del tipo (introduzca el tipo abajo) o estilo aplicado a todos los elementos coincidentes con este selector 3. Caja. Con hojas de estilo externas. 2. 3. Fondo. Modo avanzado: este modo permite crear reglas sin restricciones. . Modo para principiantes: este modo permite crear reglas asociadas a selectores de clase o selectores de tipo de elemento. 2. selecciónela en el panel de la izquierda y haga clic en la pestaña General del panel de la derecha. 4. las hojas de estilo internas o externas ayudan a mantener separadas la información del contenido de la del estilo. Usar hojas de estilo en cascada Las hojas de estilo en cascada (CSS. Para usar una hoja de estilos concreta al crear o modificar reglas. A diferencia de los estilos incrustados. El panel de la derecha mostrará opciones para especificar el tipo de regla a crear. Rellene el nombre de la regla. CaScadeS puede iniciarse haciendo clic en el menú Herramientas y seleccionando Editor CSS. CaScadeS puede ser utilizado para producir tanto hojas de estilo internas como externas. Para proporcionar estilo al documento html que se edita. Cascade Style Sheets) pueden usarse para proporcionar estilo a un documento HTML de tres maneras: 1. Haga clic en Crear regla de estilo. Aural) del panel de la derecha. El panel de la derecha mostrará entonces los detalles de la hoja de estilo en la pestaña General. La pestaña General mostrará todas las definiciones aplicadas a la regla. KompoZer dispone de un editor de hojas de estilo denominado CaScadeS. Las reglas pueden ser definidas usando las pestañas de estilo (Texto. Con hojas de estilo internas.

o (Opcional) Rellene la información sobre Lista de medios y Título de la hoja de estilo. 2. Rellene el nombre de la regla. Guarde también el documento inmediatamente antes de cerrar el editor CSS. 2. o (Opcional) Rellene la información sobre Lista de medios y Título de la hoja de estilo. El panel de la derecha mostrará entonces los detalles de la hoja de estilo en la pestaña General. se pueden crear tanto hojas de estilo internas como externas. El panel de la derecha mostrará opciones para especificar el tipo de regla a crear. Active comprobar al crear una hoja de estilo alternativa si ésta es una alternativa. 2. Elija una entre las siguientes: o estilo con nombre (introduzca abajo el nombre de la clase) o estilo aplicado a todos los elementos del tipo (introduzca el tipo abajo) o estilo aplicado a todos los elementos coincidentes con este selector 3. Haga clic en el botón de elemento <link>. Si no existe ya. Haga clic en el botón Regla del panel de la izquierda. Para crear una hoja de estilo externa: 1. se pueden crear reglas para cada hoja de estilo de forma individual. 3. . 4. Para crear reglas nuevas: 1. [ Volver al principio de la sección ] Crear reglas para las hojas de estilo Después de crear una o más hojas de estilo para el documento html.[ Volver al principio de la sección ] Crear hojas de estilo con KompoZer Al usar CaScadeS. se creará un nuevo fichero en el sistema de archivos local. Para crear una hoja de estilo interna: 1. Haga clic en Crear regla de estilo. Para usar una hoja de estilos concreta al crear o modificar reglas. Consejo: guarde siempre el documento html antes de agregar una hoja de estilo local. Haga clic en el botón de elemento <style>. selecciónela en el panel de la izquierda haciendo clic sobre ella con el botón izquierdo del ratón. Escriba la URL de la hoja de estilo en el panel de la derecha. Haga clic en Crear hoja de estilo. Consejo: utilice el botón Recargar del panel de la izquierda si la hoja de estilo no se descarga inmediatamente.

Las reglas pueden ser definidas usando las pestañas de estilo (Texto. . Bordes. Aural) del panel de la derecha. La pestaña General mostrará todas las definiciones aplicadas a la regla. Para ver todas las definiciones de una regla de estilo. Fondo. Caja. selecciónela en el panel de la izquierda y haga clic en la pestaña General del panel de la derecha.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->