P. 1
Derive

Derive

|Views: 29|Likes:

More info:

Published by: Abraham Garcia Sanchez on May 02, 2011
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

05/02/2011

pdf

text

original

1

1.1

El programa DERIVE 5
Introducción

DERIVE es un paquete de software con capacidad para desarrollar cálculo simbólico, análisis gráfico y manipulación numérica. Se trata de un programa que se ejecuta en el entorno Windows y que, por lo tanto, presenta las características habituales que tienen dichas aplicaciones. Al ejecutar el programa aparece la siguiente ventana:

Menú Principal

Barra de Título

Barra de Estado

Barra de Órdenes

Línea de Edición

Barra de Símbolos

Para realizar las distintas operaciones con el programa DERIVE se puede hacer uso, bien de los botones de la barra de órdenes, o bien del menú principal que aparece en la parte superior de la pantalla (sólo se podrá trabajar con las opciones y botones que no estén “apagados”). Trabajar con los botones es habitualmente más rápido, pero no contempla todas las posibilidades del programa. Al situar el puntero del ratón sobre cualquier botón, aparece una pequeña ventana que muestra su función. Dicha función también se describe en la barra de estado. Las opciones del programa se distribuyen en forma de árbol, de modo que cuando se selecciona una de ellas se despliega un menú en el que aparecen nuevas opciones. La forma más sencilla de utilizar los menús es a través del ratón. No obstante, también se puede trabajar por medio del teclado (lo cual puede resultar más cómodo y rápido cuando se tiene suficiente soltura). Para desplegar un menú del menú principal, basta con presionar Alt + letra subrayada en opción . Una vez desplegado el menú se puede seleccionar una opción presionando la letra que aparece subrayada. Además, algunas opciones pueden ser directamente ejecutadas con la combinación de teclas que aparece a su derecha. Cuando trabajemos a través de menús, lo expresaremos por la secuencia de opciones, por ejemplo: Archivo → Abrir significa que se elige la opción Abrir dentro del menú Archivo.

Matemáticas con DERIVE 5

2

El programa DERIVE tiene tres tipos distintos de ventanas: 1. La Ventana de Álgebra, es la que aparece al iniciar el programa y se utiliza para trabajar con expresiones simbólicas o numéricas. 2. La Ventana de Gráficas 2D, se utiliza para dibujar una o varias gráficas en dos dimensiones. 3. La Ventana de Gráficas 3D, permite representar una o varias gráficas en tres dimensiones. El programa, como cualquier otra aplicación Windows, permite tener abiertas varias de estas ventanas, siendo “la ventana activa” aquella cuya barra de título esté “encendida”.

Una de las ventajas de DERIVE es que permite crear nuevas utilidades a partir de las ya existentes, pudiéndose guardar en ficheros de extensión .MTH. Estos comandos tienen que ser cargados en la memoria del ordenador antes de ser utilizados por primera vez en un documento de trabajo. El programa DERIVE ofrece una ayuda tan completa como fácil de usar, ¡UTILÍZALA!.

raíz cuadrada de a. a más b. a1 . a↓1 ¬q p∧q p∨q s` s∪t s∩t subíndice para vectores y matrices. a partido por b. base e de los ln ( ln(b) = 1). raíz cuadrada de − 1.1416 área del círculo de radio unidad. a elevado b. e elevado a a. a por b. a es distinto de b. intersección de s y t.Matemáticas con DERIVE 5 3 1. a es menor o igual que b. s Ctrl+u t s Ctrl+n t s\t 1. logaritmo neperiano de a. Teclado a+b a−b a/b a ∗ b ⇔ ab aˆb a∗b a∧b √ a sqrt(a) ⇔ Ctrl+q a a! a/ = b a <= b a >= b inf #e ⇔ Ctrl+e pi ⇔ Ctrl+p #i ⇔ Ctrl+i #eˆa ⇔ exp(a) ⇔ Crtl+e ˆa ln(a) ⇔ log(a) a Ctrl+o a Ctrl+b 1. a sub 1 p p p s and q or q imp q Ctrl+t a 6= b a≤b a≥b ∞ e b b i π = 3. a menos b. complementario de s. p “y” q. p implica q. diferencia entre los conjuntos s y t. unión de s y t. “no” q. p “o” q. a◦ a grados = a · π/180 radianes.3 Edición con DERIVE Para introducir expresiones en la Ventana de Álgebra es necesario utilizar la línea de edición que se muestra a continuación. e unidad imaginaria. . infinito. factorial de a.2 Operadores fundamentales Ratón ±a a+b a−b a/b Definición más y menos a. a es mayor o igual que b.

Matemáticas con DERIVE 5 4 Introducir Introducir y simplificar Introducir y aproximar Aproximar Simplificar para que aparezca en la Ventana de Álgebra. Para seleccionar una expresión distinta de la actual se puede utilizar el ratón o bien el teclado. al escribir un nuevo carácter aparecerá en la posición del cursor sin borrar la expresión. Si el texto de la línea de edición no aparece seleccionado. Cuando se trabaja con DERIVE. También se puede recuperar una expresión completa escribiendo # seguido del número que corresponde a su línea. . El resto de los botones de la línea de edición permiten. mientras que ⇑ + ← . muchas veces es interesante introducir comentarios aclaratorios. La forma más cómoda de mover una o varias expresiones seleccionadas consiste en hacer clic sobre ellas con el botón derecho del ratón. ↓ . ya sea en forma algebraica ó numérica . o bien mostrar tanto la expresión como el resultado de la misma. Una vez escrita la expresión. Al ejecutar una opción. las teclas ↓ y ↑ permiten seleccionar expresiones completas. Como consecuencia. Para seleccionar varias expresiones consecutivas es necesario hacer clic a la derecha de la primera (resp. ↑ permiten seleccionar subexpresiones de la expresión activa. la expresión permanece seleccionada en la línea de edición. Si el cursor no está en la línea de edición. es necesario pulsar la tecla ← (Enter) o hacer clic en el botón Nótese que una vez introducida la expresión y/o su resultado en la Ventana de Álgebra. hacer clic con el botón derecho del ratón sobre la expresión delante de la cual queremos colocar las expresiones y elegir la opción Pegar. última) expresión y arrastrar el ratón hacia abajo (resp. Una forma de seleccionar toda la expresión en la línea de edición es hacer doble clic sobre ella. al introducir un nuevo carácter la expresión desaparece. ésta actuará sobre dicha expresión (por ejemplo. de nuevo en forma algebraica ó numérica . mientras que es posible seleccionar una parte haciendo clic y arrastrando. Esto se realiza mediante la opción Insertar → Objeto de texto o con el botón . Haciendo clic con el ratón se selecciona una expresión completa. al ejecutar Plot se dibujará la gráfica de la expresión activa). Las expresiones introducidas en la Ventana de Álgebra se van numerando consecutivamente. para situarse en ella es necesario hacer clic con el ratón o pulsar la tecla F2 . La que aparece seleccionada es la que denominaremos “expresión activa”. → . bien obtener el resultado de la expresión. escoger la opción Cortar. hacia arriba). Utilizando el teclado. Una expresión activa se puede recuperar en la línea de edición presionando F3 o F4 (este último introduce la expresión entre paréntesis). y sucesivos clics permiten seleccionar subexpresiones de ésta.

1.. Abre una nueva ventana vacía. También permite guardar los valores de configuración de la Ventana de Álgebra.DFW).DFW.. Este proceso se puede detener pulsando la tecla Esc . es mediante la opción Archivo → Abrir o hacer doble clic sobre el nombre del archivo (en este último caso. Cierra la ventana activa. . La forma habitual de recuperar un fichero. la cual permite ejecutar las siguientes opciones: Nuevo Abrir Pegar Borrar Aproximar Insertar texto Resolver Substituir Integral Suma Producto Guardar Editar Imprimir Cortar Copiar Vector Matriz Simplificar Límite Derivada Gráficos 2D Gráficos 3D Ayuda Seguidamente se muestran todas las posibilidades que aparecen en el menú principal del programa cuando está activa la Ventana de Álgebra: • Archivo → Nuevo Abrir. Abre un fichero de trabajo ya existente.Matemáticas con DERIVE 5 5 En algunas ocasiones las operaciones de cáculo pueden requerir mucho tiempo o incluso no ser posibles.4 Menú de la Ventana de Álgebra A continuación se muestra la barra de órdenes de la Ventana de Álgebra.. Cerrar • Guardar Guardar como. no es necesario ejecutar previamente DERIVE). guardado en una sesión de trabajo anterior en formato . Guarda el contenido de la ventana activa en un archivo (por defecto con extensión . Permite elegir el nombre y la ubicación del fichero en el que guardar el contenido de la ventana activa..

. Cierra el programa.. FORTRAN. Recupera las expresiones eliminadas con el último uso del opción Borrar.. Copia el área marcada al portapapeles (formato mapa de bits). así como el rango que se desea imprimir..... El botón imprime directamente sin posibilidad de realizar cambios en las opciones.... ofreciendo la posibilidad de guardar las Ventanas de Álgebra. Permite visualizar una presentación preliminar antes de imprimir.. Vínculos con objetos OLE. Vista Previa Permite guardar el fichero en formato BASIC... Edita la expresión activa.. Permite introducir un comentario que aparece en la barra de estado cuando la expresión está activa. Borra los objetos seleccionados (también tecla Supr ).. Activa un objeto incrustado o vinculado. Permite elegir los márgenes de la página.. Copia los objetos seleccionados al portapapeles. Selecciona todos los objetos de la Ventana de Álgebra activa. Demo.. Exportar I Configurar la Página. Carga en memoria ficheros de utilidades (sin mostrarlos en pantalla) que contienen nuevos comandos y funciones para que puedan ser utilizados. Anotación.... Carga un fichero de extensión . Permite seleccionar la impresora y sus propiedades.Matemáticas con DERIVE 5 Leer I Mth. Mueve los objetos seleccionados al portapapeles. Utilidades. C o PASCAL. dentro de la ventana activa. Modifica los vínculos de un objeto OLE. Imprimir.MTH en la ventana activa.. Objeto Borrar. 6 Carga un fichero ASCII de datos como una matriz. .. Datos. Carga un fichero de demostración que muestra paso a paso algunas posibilidades del programa. Recuperar • Seleccionar Todo Cortar Copiar Pegar Marcar y Copiar. Inserta los objetos del portapapeles. Salir • Edición → Objeto de Derive.

Sustituir Subexpresión. Objeto OLE.. • Editar ( Autor) → Expresión. Encuentra la solución algebraica o numérica de una ecuación respecto a una variable seleccionada. • Resolver → Expresión... Es la forma de introducir expresiones en la Ventana de Álgebra activa. Factorizar. Permite sustituir una variable por un valor determinado o por una función de otras variables. • Objeto de texto. Factoriza una expresión.. Sustituir Variable.. Resuelve un sistema de ecuaciones. Inserta un texto en la Ventana de Álgebra activa.... Simplifica una expresión devolviendo su valor exacto.... • Vector. Realiza la expansión algebraica de una expresión. Sirve para crear matrices de tamaño máximo 100 × 100. .Matemáticas con DERIVE 5 7 • Insertar → Gráfica 2D. • Simplificar → Normal Expandir. Permite introducir vectores de 100 elementos como máximo... Inserta una gráfica 3D en la Ventana de Álgebra activa........ Permite sustituir una o todas las ocurrencias de una subexpresión seleccionada por otra subexpresión. Matriz. Gráfica 3D....... • Aproximar. • Sistema. Simplifica una expresión devolviendo un valor aproximado... Inserta un objeto OLE en la Ventana de Álgebra activa. Inserta una gráfica 2D en la Ventana de Álgebra activa.

Calcula el polinomio de Taylor de una función de una variable en torno a un punto y del grado que se desee... Permite escoger si el nombre de las variables puede tener uno o varios caracteres. Vector... si las letras mayúsculas y minúsculas son tratadas como iguales o distintas y el sistema de numeración de los datos de entrada.. de una función respecto a una de sus variables. Calcula la derivada parcial... Realiza el producto de una función respecto a una de sus variables que varía en una unidad a partir de un mínimo y hasta un valor máximo. Permite escoger el formato de los datos de salida.. Permite especificar el tipo y el dominio de una variable.. Integrales. el botón el mismo valor que . Genera un vector cuyas componentes son el resultado de evaluar una función cuando una de sus variables evoluciona desde un valor inicial hasta un valor final. del orden deseado. Permite asignar un valor o expresión a una variable. La segunda muestra el resultado de evaluar una función para los valores de la primera columna. Tabla. Preferencias de Entrada.... Función.. La primera presenta los valores de una variable desde un valor inicial hasta uno final. Permite definir una función. Cuando devuelve la preción está en modo aproximado. Restablecer todas las Preferencias Restaura los valores por defecto de los tres menús anteriores... Cacula la integral... destacando el poder elegir entre precisión exacta y aproximada. Realiza la suma de una función respecto a una variable que varía en una unidad desde un valor mínimo hasta uno máximo. Permite escoger diferentes modos de trabajo. Calcula el límite de una función cuando una de sus variables tiende a un determinado valor. • Preferencias de Salida...Matemáticas con DERIVE 5 8 • Cálculo → Límites.. • Productos. Sumas y Series. Dominio de una Variable. definida o indefinida.... Derivadas. Polinomios de Taylor. Genera un tabla formada por dos columnas. • Definir → Valor para una Variable. .... de una función respecto a una variable. Preferencias de Simplificación...

El botón permite abrir una nueva o cambiar a una ya existente. Da la posibilidad de imprimir el tiempo de cálculo y las anotaciones. así como las fuentes y el color de los diferentes elementos de las ventanas. Muestra todas las ventanas abiertas en forma de mosaico horizontal. El botón permite abrir una nueva o cambiar a una ya existente. Oculta/muestra los gráficos en la Ventana de Álgebra activa. Ocultar Etiquetas Ocultar Gráficos Ocultar Texto Ocultar Objetos OLE • Ventana → Cascada Mosaico Horizontal Mosaico Vertical Mostrar Pestañas • Nueva Ventana 2D Muestra todas las ventanas abiertas en forma de cascada.Matemáticas con DERIVE 5 9 • Opciones → Pantalla I Impresión I Permite escoger la alineación de los nuevos objetos. Inicio • Renumerar Expresiones Renumera automáticamente las expresiones en orden creciente. Abre una nueva Ventana de Gráficas en tres dimensiones. También permite elegir el formato de la página (márgenes. Abre una nueva Ventana de Gráficas en dos dimensiones. cabecera. Muestra todas las ventanas abiertas en forma de mosaico vertical. bien utilizando la configuración original o bien la empleada en la última sesión de trabajo. así como elegir el tipo de letra.) y la configuración de la impresora. Oculta/muestra objetos OLE en la Ventana de Álgebra activa. etc. Entre ellas cabe destacar la posibilidad de ejecutar el programa. pie de página. Muestra/oculta las distintas barras de herramientas del programa. Muestra todas las ventanas abiertas mediante fichas. Permite escoger algunas opciones de inicio de DERIVE. Oculta/muestra los números de las expresiones en la Ventana de Álgebra activa. Nueva Ventana 3D Barras de Herramientas I . Oculta/muestra texto en la Ventana de Álgebra activa.

Matemáticas con DERIVE 5 10 • Ayuda → Contenidos Indice Muestra el contenido de la ayuda mediante niveles referidos a un mismo tema. .. actualizaciones. 1. Muestra una lista ordenada alfabéticamente de las opciones y de los comandos del programa. Anotación Modo trazar Centrar en el cursor Reducción vert. etc.. utilidades. Reducción hor. Muestra cómo obtener más información acerca del uso de DERIVE. Muestra información sobre el programa. manuales. Imprimir Copiar ventana Dibujar Centrar en el origen Zoom hacia fuera Seleccionar rango Ampliación hor. Guardar Alg.. permitiendo seleccionar un término de búsqueda. Abrir Alg. A través de la página Web del programa se pueden obtener versiones trial. la cual permite ejecutar las siguientes opciones: Nueva Alg. Ventana Alg.5 Menú de la Ventana de Gráficas 2D Seguidamente se muestra la barra de órdenes de la Ventana de Gráficas en dos dimensiones. Zoom hacia dentro Borrar último dibujo A continuación se muestran todas las opciones que aparecen en el menú principal del programa cuando está activa la Ventana de Gráficas 2D. Ampliación vert.. Acerca de Derive. Contiene un listado de las preguntas más habituales y sus correspondientes respuestas. Preguntas Más Frecuentes • Recursos Adicionales Conectarse a la Página Web de Derive.

. También es posible ejecutar esta opción haciendo doble clic sobre el comentario. Opción similar a la de la Ventana de Álgebra. las gráficas copiadas con la opción anterior. Opción similar a la de la Ventana de Álgebra.. Copia el contenido de la ventana al portapapeles. Permite guardar la Ventana de Gráficas 2D como un fichero en formato DIB.. Configurar la Página. Salir • Editar → Anotación. TARGA o TIFF.. Borra todos los comentarios.. Actualiza. Vista Previa Imprimir. Permite introducir un comentario que aparecerá en la posición del cursor. la última. Borra todas las gráficas. . Opción similar a la de la Ventana de Álgebra. JPEG..Matemáticas con DERIVE 5 11 • Archivo → Incrustar Actualizar Cerrar • Exportar I Copia el contenido de la Ventana de Gráficas 2D en la Ventana de Álgebra donde están definidas las expresiones. Opción similar a la de la Ventana de Álgebra. o todas menos la última. Opción similar a la de la Ventana de Álgebra. Permite modificar un comentario ya insertado en el gráfico seleccionándolo previamente (haciendo clic sobre él). Borrar Gráfica I Borrar Todas las Gráficas • Borrar Anotación Borrar Todas las Anotaciones Copiar la Ventana Marcar y Copiar • Insertar → Gráfica • Anotación Dibuja la gráfica de la expresión seleccionada en la Ventana de Álgebra. en la Ventana de Álgebra. Opción similar a la de la Ventana de Álgebra. Borra un comentario previamente seleccionado haciendo clic sobre él. Permite borrar gráficas: la primera.

Para ello se usan las siguientes teclas: → .. Cuando se activa. • Opciones → Pantalla I Permite visualizar o no los ejes. escoger el nombre de los ejes y determinar el color de los gráficos y del fondo. Permite establecer la relación entre las longitudes relativas de los ejes. ← .Matemáticas con DERIVE 5 12 • Seleccionar → Sistema de Coordenadas.. el cursor.. sus divisiones.) y la configuración de la impresora. Opción similar a la anterior. el cursor se convierte en un cuadrado que recorre las gráficas de las funciones... Permite representar funciones complejas: la parte real se dibuja con trazo fino y la parte imaginaria con trazo grueso.. pie de página. Permite elegir la posición exacta del cursor. Ctrl + ← . Permite elegir el formato de la página (márgenes. • Región.. Permite cambiar el color de la siguiente gráfica.. Permite representar expresiones sin la necesidad de aproximarlas previamente. Permite representar expresiones sin la necesidad de simplificarlas previamente. Posición del Cursor. También es posible definir el formato de la malla.. cabe la posibilidad de determinar su tamaño y de unirlos o no mediante líneas. se muestra siempre la parte del gráfico donde está el cursor. cabecera. Impresión I Modo de Trazado • Perseguir al Cursor Simplificar antes de Dibujar Aproximar antes de Dibujar Auto-Escalar Nuevas Gráficas Cambio de Color Representar parte Real e Imaginaria . Ajusta automáticamente la escala del eje de ordenadas. o Ctrl + → .. Cuando está activado. También da la posibilidad de imprimir las gráficas en color o en blanco y negro. Relación de Aspecto.. Permite seleccionar la zona y la malla que se desea que aparezca en pantalla... Cuando se dibujan puntos. Permite seleccionar el tipo de coordenadas de representación gráfica: rectangulares o polares. Rango de la Gráfica.

• Editar → Menú similar al de la Ventana de Gráficas 2D. 1. la cual permite ejecutar las siguientes opciones: Nueva Alg. Cuando esta ventana está activa en el menú principal del programa aparecen las siguientes opciones: • Archivo → Menú similar al de la Ventana de Gráficas 2D. Imprimir Copiar ventana Borrar dibujo seleccionado Zoom hacia fuera Zoom hacia dentro Dibujar Girar dibujo Girar arriba Girar dcha. salvo la opción Gráfica.6 Menú de la Ventana de Gráficas 3D En primer lugar se presenta la barra de órdenes de la Ventana de Gráficas en tres dimensiones. el color y el número de paneles de la gráfica. Abrir Alg. Ventana Alg.. que permite seleccionar el rango.. • Ayuda → Menú similar al de la Ventana de Álgebra. • Insertar → Menú similar al de la Ventana de Gráficas 2D. Girar izda. • Seleccionar → .Matemáticas con DERIVE 5 13 • Ventana → Menú similar al de la Ventana de Álgebra. Anotación Modo trazar Ajustar rango Fijar ojo Contraer Magnificar Girar abajo Guardar Alg.

. Opción similar a la de la Ventana de Gráficas 2D. Menú similar al de la Ventana de Gráficas 2D. Opción similar a la de la Ventana de Gráficas 2D.. Opción similar a la de la Ventana de Gráficas 2D. es posible moverse a través de las líneas que delimitan los paneles del gráfico. Opción similar a la de la Ventana de Gráficas 2D. Activa la rotación continua de las gráficas. Impresión I Modo de Trazado • Rotar las Gráficas Simplificar antes de Dibujar Aproximar antes de Dibujar Auto-Escalar Nuevas Gráficas Cambio de Color • Ventana → Menú similar al de la Ventana de Álgebra.. Permite elegir el punto del espacio desde donde se visualiza el gráfico.. También se puede escoger el color del fondo y establecer los grados que gira la gráfica en cada movimiento. • Ayuda → Menú similar al de la Ventana de Álgebra.. usando la combinación de teclas: ⇑ +( → . • Región.Matemáticas con DERIVE 5 14 Sistema de Coordenadas. esféricas o cilíndricas. Permite seleccionar el tipo de coordenadas de representación gráfica: rectangulares. • Opciones → Pantalla I Permite visualizar o no los ejes. Cuando está activado. Posición del Ojo. . ↑ o ↓ )... Opción similar a la de la Ventana de Gráficas 2D. Ajusta automáticamente la escala del eje z. ← . Relación de Aspecto.. así como el tiempo transcurrido entre dos movimientos consecutivos. Opción similar a la de la Ventana de Gráficas 2D. la caja y la leyenda... Rango de la Gráfica.

. 10. . 100]. a2n . — Se recuerda que la división matricial no existe. 49. 10) genera el vector [16. su valor por defecto es 1. 16. — A := [[a1 . 100]. Al escribir A/B. 100]. am1 . m el valor inicial. . .. a1n . VECTOR(kˆ2. DERIVE calcula A ∗ B −1 . k. — A := [a11 . . . . . En este comando f es la función. . k la variable. . s). • Definir una matriz — Editar (Autor) → Matriz o el botón . . n el valor final y s la razón de la progresión aritmética. 25. Por ejemplo: VECTOR(kˆ2. • Componente i-ésima de un vector — [x1 . . m + s. 81. xn ] ↓ i. k toma los valores: m. VECTOR(kˆ2. xn ] sub i ⇔ [x1 .. es decir. 81. . . • Potencia n-ésima de una matriz: Aˆn. . . 4. k. k. 25. . DERIVE permite crear un vector cuyas componentes son el resultado de evaluar una función. a21 . . 4. . 64. 36. Genera matrices con una única fila. . 64. m. Existen dos posibilidades: — Cálculo → Vector. . . ≤ n. 36. 36. . • Producto matricial — A ∗ B ⇔ AB. 4. Si m y/o s no aparecen. 10) genera el vector [1. . m + 2s. . . amn ]. • Definir un vector a partir de una función .1 Álgebra lineal con DERIVE Teoría de matrices • Definir un vector — Editar (Autor) → Vector o el botón — x := [x1 . donde una de sus variables sigue una progresión aritmética desde un valor inicial hasta uno final. . . la función debe estar seleccionada en la Ventana de Álgebra. . • Suma matricial: A + B. an ]]. . .Matemáticas con DERIVE 5 15 2 2. . xn ] . . Antes de usar esta opción. n. 9. 64. 49. k. 2) genera el vector [16. — VECTOR(f. .

En el siguiente cuadro de diálogo. x)... • Determinante de una matriz: DET(A).2 Resolución de ecuaciones DERIVE permite resolver tanto una ecuación algebraica como sistemas de ecuaciones.. el método Cualquiera calcula todas las soluciones de forma numérica. 2.. Equivalente al método Algebraico y el dominio Complejo.. Si f es una función que depende al menos de la variable x. Se pueden encontrar únicamente raíces reales eligiendo dominio Real.. Equivalente al método Cualquiera y el dominio Complejo. el método Algebraico resuelve la ecuación algebraicamente (mediante fórmulas)... o encontrar todas las raíces (reales y complejas) escogiendo dominio Complejo. • Traspuesta de una matriz: A` (acento grave)..... • Rango de una matriz: RANK(A)... • Sistemas de Ecuaciones: Tanto para sistemas de ecuaciones lineales como no lineales.... seleccionar el método Numérico.. — APPROX(SOLVE(f. x)). la ecuación f = 0 se puede resolver respecto de esta variable de las siguientes formas: — Escribir la ecuación y a continuación seleccionar Resolver → Expresión o ......Matemáticas con DERIVE 5 16 • Inversa de una matriz: Aˆ − 1.... Si se desea encontrar una solución en un determinado intervalo... cuando el número de variables sea mayor que el de ecuaciones. • Matriz identidad de orden n: IDENTITY_MATRIX(n).... X Sistemas lineales La resolución del sistema de ecuaciones lineales = b1 a11 x1 + · · · + a11 xn a21 x1 + · · · + a2n xn = b2 . Si no se encuentra ninguna solución.. • Traza de una matriz: TRACE(A). • Una ecuación algebraica: Cabe destacar que la representación gráfica de funciones de una única variable permite obtener de forma aproximada sus raíces reales... — SOLVE(f... es importante destacar que en los procedimientos comentados a continuación es necesario elegir tantas variables a despejar como ecuaciones tenga el sistema. am1 x1 + · · · + amn xn = bm        se puede llevar a cabo mediante cualquiera de los siguientes procedimientos: . y todas las variables en caso contrario..

escoger a continuación el número de ecuaciones del sistema. . . and gm (x1 . .. . . . . am1 x1 + · · · + amn xn = bm ] o o a11 x1 + · · · + a1n xn = b1 and . . xn ) = bm hacer clic en el botón método Cualquiera. . el sistema no tiene solución. . . sistema. . . . Si DERIVE devuelve “false”.. xn ) = bm se puede llevar a cabo mediante cualquiera de los siguientes procedimientos: — Escribir el sistema de ecuaciones de alguna de las siguientes formas: [g1 (x1 . . . en consecuencia. ... xn ) = bm ] o g1 (x1 . xn ) = b1 and . y seleccionar las m variables que queramos despejar y el — SOLVE(sistema. . gm (x1 . . . .. . and am1 x1 + · · · + amn xn = bm a11 x1 + · · · + a1n xn = b1 ∧ · · · ∧ am1 x1 + · · · + amn xn = bm hacer clic en el botón método Algebraico.. xn ) = b2 . .. . sólo pueden hallar una solución aún cuando posea varias. . El primer argumento. . El primer argumento. . en algunas ocasiones. . . xn ) = b1 . con un número menor de ecuaciones.. . . .. . . .. . xn ) = b1    g2 (x1 .. . .. el sistema no tiene solución. sistema.. . xim son las m variables que queremos despejar. Si las m ecuaciones del sistema lineal no son independientes. [xi1 . [xi1 . representa el sistema de ecuaciones escrito de alguna de las tres formas indicadas en el apartado anterior y xi1 . .. . .Matemáticas con DERIVE 5 17 — Utilizar el comando Resolver → Sistema. . los procedimientos anteriores devuelven un sistema equivalente (con las mismas soluciones que el inicial) de ecuaciones independientes y. . . .. y seleccionar las m variables que queramos despejar y el — APPROX(SOLVE(sistema. elegir las n variables). . xim son las m variables que queremos despejar.. .... . ... . . introducir las ecuaciones y elegir las m variables respecto de las cuales se quiere resolver el sistema (si n < m.. Si DERIVE devuelve “false”. . . — Escribir el sistema de ecuaciones de alguna de las siguientes formas: [a11 x1 + · · · + a1n xn = b1 .    gm (x1 . . .. . . xim ])). xn ) = b1 ∧ · · · ∧ gm (x1 . xn ) = bm o g1 (x1 . Los procedimientos anteriores no siempre permiten encontrar la solución del sistema y. . . . Para hallar la solución se repite alguno de los procedimientos anteriores con el nuevo sistema de ecuaciones. X Sistemas no lineales La resolución del sistema de ecuaciones no lineales  g1 (x1 . representa el sistema de ecuaciones escrito de alguna de las tres formas indicadas en el apartado anterior y xi1 . . . . . xim ]).

Para su utilización es necesario cargar previamente. Devuelve el polinomio característico de A en potencias de w.. generalmente DERIVE no puede encontrar los autovalores en forma algebraica (valor exacto). w). de forma numérica (valor aproximado) utilizando el botón • Autovectores de A — EXACT_EIGENVECTOR(A. Este comando devuelve el subespacio propio asociado al autovalor w. @2. (1998). xn ] el vector de variables. . siendo [x1 . 2. — APPROX_EIGENVECTOR(A. . xn ]). Para un autovalor obtenido de forma numérica (valor aproximado) devuelve el vector nulo. . el fichero ALGEBRA. En esta sección se presentan algunas utilidades que se pueden encontrar en el disquete que acompaña al libro de Sanz et al. mediante la opción Archivo → Leer → Utilidades. Devuelve la matriz asociada a la aplicación lineal f respecto de las bases canónicas. en tal caso. Para conocer la multiplicidad de cada autovalor. se calcula el polinomio característico y se factoriza mediante la opción Simplificar → Factorizar. . el resultado no tiene por qué ser un autovector.. • Polinomio característico de A — CHARPOLY(A). . de forma numérica. [x1 . .4 Utilidades creadas con DERIVE Se pueden crear nuevas utilidades a partir de las ya existentes. • Autovalores de A — EIGENVALUES(A). expresándolo como un vector donde las diferentes variables vienen referidas mediante @1. Cuando un autovalor no se puede calcular de forma algebraica y se obtiene un valor aproximado. Para matrices de orden superior a 4. es posible obtener una aproximación a uno de sus autovectores utilizando este comando. w. Para ejecutar estas utilidades basta con escribirlas en la línea de edición. Sólo es necesario realizar este proceso una vez en cada fichero de trabajo.MTH copiado con anterioridad en la carpeta C:\DfW5\Users.3 Diagonalización de matrices Dada una matriz cuadrada A. Si dicho comando se emplea con un autovalor que se puede obtener de forma algebraica (valor exacto). • — MAT_CAN(f. . . Debe utilizarse cuando el autovalor w se ha obtenido de forma algebraica (valor exacto). w).Matemáticas con DERIVE 5 18 2. se pueden obtener los autovalores . Devuelve un vector con los diferentes autovalores de la matriz A pero sin especificar su multiplicidad. ..

. siendo A ∈ Mn×n la matriz de la forma cuadrática y B ∈ Mm×n la matriz de restricciones. . . B). siendo [x1 . . . xn ] el vector de variables. C). [x1 . — APL_AS(A. . . xn ]). siendo [x1 . xn ] el vector de variables. . . . xn ] . . Devuelve la matriz asociada a la aplicación lineal f respecto de dos bases. . . B la matriz cuyas filas son los vectores de la base del espacio de partida y C la matriz cuyas filas son los vectores de la base del espacio de llegada. — MENORES_PRINCIP_REST(A. . . Devuelve un vector cuyos elementos son los menores principales de la matriz A. xn ] el vector de variables de dicha aplicación. . [x1 . — MAT_SIM(Q. [x1 . Devuelve la aplicación lineal cuya matriz asociada respecto de dos bases es A. . Devuelve un vector cuyos elementos son los n − m últimos menores principales de la matriz orlada. . C). . xn ] el vector de variables de dicha aplicación. . . Devuelve la aplicación lineal cuya matriz asociada respecto de las bases canónicas es A. xn ]). B. . . siendo [x1 . B la matriz cuyas filas son los vectores de la base del espacio de partida y C la matriz cuyas filas son los vectores de la base del espacio de llegada. — APL_CAN(A. . Devuelve la matriz simétrica asociada a la forma cuadrática Q. — MENORES_PRINCIPALES(A). . . B. . . . siendo [x1 . . .Matemáticas con DERIVE 5 19 — MAT_AS(f. . xn ] . [x1 . .

3. calculando límites. x. a través de cualquier recta que pasa por (x0 . xn ) ↓ m). Calcula el límite de la función f cuando x tiende a x0 .Matemáticas con DERIVE 5 20 3 Cálculo con DERIVE Derive también permite trabajar en el ámbito del análisis matemático. . . para obtener el vector Antes de dibujar las curvas con el comando PLOT hay que ejecutar explícitamente. y0 ). . . x0 . es decir. Por ejemplo: f (x) :=IF(x ≥ 0. derivadas. . −1). — VECTOR(f (x. valor1. y. . m. x. etc. . integrales. . . . — LIM(f. h = f ◦ g. La función f (x) queda definida por valor1 cuando se cumple condición.. — LIM(f. . n. . de dos formas alternativas: — Cálculo → Vector. . A continuación se describen las principales posibilidades en este campo. . x. Define la función compuesta.. Calcula el límite de la función f cuando x tiende a x0 por la izquierda. Para funciones de dos variables. . . además hay que escoger k como variable. los límites direccionales se calculan con el siguiente comando: — LIM2(f.. Calcula el límite de la función f cuando x tiende a x0 por la derecha. Calcula el límite direccional cuando (x. . x0 . m + 2s. x0 . m + s. x0 ). • Curvas de nivel de una función Es posible generar un vector cuyas componentes son las curvas de nivel de la función f (x. xn ) := f (g (x1 . . Crea un vector cuyas componentes son las curvas de nivel m. y0 ) a lo largo de líneas rectas de pendiente @1. x. y por valor2 en caso contrario. s). 1). . g (x1 . y) = k debe estar seleccionada en la Ventana de Álgebra. la ecuación f (x.1 Límites y continuidad • Funciones definidas a trozos — f (x) :=IF(condición. hasta el nivel n. y) → (x0 . xn ) ↓ 1. y). y0 ). x. • Límite de una función Para funciones de una variable se puede calcular el límite de las siguientes formas: — Escribir la función y seleccionar la opción Cálculo → Limites o el botón — LIM(f. y) = k. o bien asegurarnos de que la opción Opciones → Simplificar antes de Dibujar está activada en la Ventana de Gráficas 2D. valor2 ). Antes de usar esta opción. polinomios de Taylor. • Composición de funciones — h (x1 . También se puede utilizar el operador “sub” en lugar de ↓. k. −x) define la función valor absoluto (ABS(x)).

Devuelve la matriz Jacobiana de la función f respecto de las variables x1 . Calcula la derivada de f respecto de la variable x. . basta con reiterar el proceso el número de veces que sea necesario. [x. Por ejemplo: GRAD(xˆ2 + yˆ2.2 Cálculo diferencial • Derivada de una función — Seleccionar la función y escoger la opción Cálculo → Derivadas o el botón — DIF(f. x. • Polinomio de Taylor de una función de una variable — Escribir la función y seleccionar la opción Cálculo → Polinomios de Taylor. 3). . y. z). y). y) := xˆ2 + yˆ2. 1). [x. y). q). . . . [x1 . Si queremos calcular una derivada parcial respecto de dos o más variables. — GRAD(f. . x2 . . xn . y]). Conviene destacar que f tiene que ser dada a través de un vector. [x. Calcula el vector gradiente de f respecto de las tres variables x. Si f (x. y. y]). . — TAYLOR(f. Calcula el polinomio de Taylor de grado q de la función f en el punto a. x2 . y) se obtiene mediante DIF(DIF(f (x. 3]). [x. y]. x. y. Por ejemplo: ∂5f (x. y]) devuelve el vector [2x. Por ejemplo: ∂ 4f (x. xn . x2 . Calcula la derivada de orden n de f respecto de la variable x. x2 . . [x1 . y) := [xˆ2 + yˆ2. z) se obtiene mediante DIF(f (x. . un vector cuyas componentes son las variables respecto a las cuales se va a derivar. hay que escribir JACOBIAN([f (x. Los métodos anteriores nos permiten calcular derivadas parciales de cualquier orden respecto de una misma variable. . Calcula el vector gradiente de f respecto de las variables x1 . . y. . a. • Matriz Jacobiana — JACOBIAN(f. . xn ]). xn ]). x). — DIF(f. hay que escribir JACOBIAN(f (x. utilizando el comando DIF una sola vez. y)]. . consiste en escribir. . ∂x3 ∂y Otro método para calcular derivadas parciales de order superior a 1. [2. . ∂x2 ∂y 3 • Gradiente de una función — GRAD(f ).Matemáticas con DERIVE 5 21 3. 2y]. xˆ2 − y]. en lugar de una única variable. Por ejemplo: Si f (x. z. n). . x.

— VOLUME(x. Por ejemplo: ¸ Z 2 ·Z 1 3 2 (x + xy ) dy dx se obtiene mediante INT(INT(xˆ3 + xyˆ2. Esta expresión se dibuja directamente si la opción Opciones → Simplificar antes de Dibujar está activada en la Ventana de Gráficas 2D. z. z1 . y. y1 . z. z)) calcula x1 y1 z1 . • Función Gamma de Euler — Γ(p) ⇔ GAMMA(p) (escrito con mayúsculas). 2) devuelve la derivada de segundo orden de z con respecto a y. Visualiza el área comprendido entre el eje de abscisas y la gráfica de la función. entonces: IMP_DIF(x + y + z + cos(xyz) − 1. en el intervalo [a. x). 1) devuelve la derivada de primer orden de z con respecto a x. 2). a. DERIVE también dispone de la siguiente posibilidad gráfica relacionada con la integración: — PLOTINT(f. Calcula la integral definida de la función f respecto de la variable x en el intervalo [a. — INT(f. f (x. y. y2 . siendo x la variable independiente e y la dependiente. • Función Beta de Euler — EULER_BETA(p. y) dy dx.3 Cálculo integral • Integral de una función — Escribir la función y seleccionar la opción Cálculo → Integrales o el botón — INT(f.Matemáticas con DERIVE 5 22 • Derivada de la función implícita — IMP_DIF(f. b). x. n). x. q). y. IMP_DIF(x + y + z + cos(xyz) − 1. caso contrario hay que ejecutar Las integrales dobles y triples se pueden calcular de alguna de las siguientes formas: — Reiterando la orden INT el número de veces que sea necesario. x2 . y2 . . z) dz dy dx. En antes de dibujarla. dada la ecuación x + y + z + cos(xyz) − 1 = 0 que nos define a z como función implícita de x e y. y1 . x2 . b]. x. y. 1). a. y. x1 . b). z2 . Por ejemplo. b]. z. x1 . 0. x. y. Este procedimiento sigue siendo válido aún cuando y dependa de más de una variable. 1. x. f (x. — AREA(x. Calcula una primitiva de la función f respecto de la variable x. y. y)) calcula x1 y1 ¸ ¸ Z x2 ·Z y2 ·Z z2 f (x. Devuelve la derivada de orden n de la función implícita que se deduce de la ecuación f = 0. 1 0 ¸ Z x2 ·Z y2 f (x. 3.

Ed. . (1998). z) . Kutzler. A. . [x1 . [x1 . . Prácticas de matemáticas con DERIVE. (1994). . Problemas de matemáticas aplicados a la economía y la empresa (Resueltos con ordenador ). (2000).: Kutzler & KokolVoljc. 6. an ] . xn . Ed. . — IMP_DIF_CRUZ(f.: RA-MA. . Introducción a DERIVE 5. Problemas de Álgebra lineal. Matemática práctica con DERIVE para Windows. mediante la opción Archivo → Leer → Utilidades. .4 Utilidades creadas con DERIVE Para su utilización es necesario cargar previamente. [a1 . C. Devuelve ∂2z (x. ejercicios y tratamiento en DERIVE. an ). en el punto (a1 . .: Ediciones S. y Paulogorran. Ed. et al. 4. 3. (1995).: Alfonsa García. . Devuelve la matriz Hessiana de la función f de variables x1 . Matemáticas con DERIVE en la economía y la empresa. . q) .Matemáticas con DERIVE 5 23 3. x2 . Sólo es necesario realizar este proceso una vez en cada fichero de trabajo. Garcia. Ed. (1994). . y). (1998). x2 . et al. xn ] . y Kokol-Voljc. . xn ]). . et al. basta con escribirlas en la línea de edición: — HESSIANA(f. Calcula el polinomio de Taylor de grado q (q ≤ 2) de la función f. 5. el fichero CALCULO. B. x. . A. 2. V. a2 . J.: RA-MA. Bibliografía 1. Getan. C. P. xn . x2 . . — MULTITAYLOR(f. . a2 . . Ed. . Para ejecutar las distintas utilidades creadas con DERIVE. . Gonzalez. Perez. de variables x1 . . Ed. . donde z está definida como función ∂x∂y implícita de las variables x e y a partir de la ecuación f = 0. . y.: Prentice Hall Iberia. . Cuestiones.MTH copiado con anterioridad en la carpeta C:\DfW5\Users. . Sanz. x2 . .

En la definicion de una funcion. automáticamente reconoce que dicha letra es el vector cuyas componentes son esas variables. ––––––––––––––––––––––––– Explicar lo que es el portapapeles . no hace falta escribir de que variables depende.Matemáticas con DERIVE 5 24 Cuando se utiliza una letra con distintos subíndices en una expresión. lo reconoce implicitamente (bastaria con f:=) Mirar en la pagina 420 como se clasifican formas cuadraticas con parametros.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->