Está en la página 1de 2

Macros

Si realiza frecuentemente una tarea en Microsoft Excel, puede automatizarla mediante una macro. Una
macro consiste en una serie de comandos y funciones que se almacenan en un módulo de Microsoft
Visual Basic y que puede ejecutarse siempre que sea necesario realizar la tarea. Por ejemplo, si suele
escribir cadenas largas de texto en las celdas, puede crear una macro para dar formato a esas celdas y
que se ajuste el texto.

Grabar macros Al grabar una macro, Excel almacena información sobre cada paso dado cuando se
ejecuta una serie de comandos. A continuación, se ejecuta la macro para que repita los comandos. Si se
comete algún error mientras se graba la macro, también se graban las correcciones que se realicen.

Elaboración de una macro en Excel

Siga de manera detallada los siguientes pasos:

1. Abra un documento nuevo de Microsoft Excel

2. Haga clic en la opción Herramientas, de la barra de menú y luego clic sobre Macro 

3. Luego clic sobre la opción Grabar nueva macro… del menú que se
despliega.
4. A continuación aparece la ventana como la mostrada en la figura 1
5. Asigne como nombre ejercicio1, en la cuadrícula pequeña digite e,
Guardar macro en: Este libro. En el recuadro de Descripción: digite la fecha y
su nombre.
6. Pulse el botón de comando Aceptar
7. A continuación elabore la siguiente presentación como muestra la figura
2, para ver el funcionamiento de la nueva Macro.

8. Como puede apreciar, la figura


muestra dos cuadros, el primero con los
detalles de las unidades y el segundo
con daros agrupados por tipo de
producto.

9. Utilice las formulas (Como por


ejemplo, para el total por artículo
=C5*D5), para el TOTAL
=SUMA(E5:E20).
10. Asigne a cada cuadro su
respectivo formato de presentación.
11. Elabore un gráfico de
cualquier tipo con los datos agrupados.
12. Haga clic sobre el botón
detener grabación de la ventana
pequeña para cerrar la macro.

13. Abra la Hoja2 y pulse la


combinación de teclas ctrl.+e.

14. Repita el mismo procedimiento


con tres libros más ¿Qué sucede?