Está en la página 1de 61

Manual Kursus MS Access XP dan Database

PENGENALAN MANUAL KURSUS ACCESS

Didalam situasi pekerjaan masa kini , pelbagai maklumat perlu


disimpan dan dikemaskini untuk tujuan merekod data. Oleh yang
demikian Microsoft Access telah digunakan dengan meluasnya oleh
seseorang pengguna untuk menghasilkan pengkalan data. Antara
kaedah yang anda akan pelajari menggunakan nota kursus ini adalah
• Membina asas pengkalan data
• Menghasil dan mengubah jadual/ table
• Menghasilkan borang/form
• Menghasilkan laporan/ report
• Mencari dan mengubah rekod
• Menghasilkan queri untuk menapis rekod
Adalah diharapkan anda dapat mempelajari kaedah, teknik yang
berguna disepanjang kursus dan manual ini juga dapat dijadikan
rujukan anda setelah pulang ke tempat kerja atau semasa anda
melakukan latihan ulangan. Akhir kata, kami berharap anda dapat
mengaplikasikan apa yang akan/telah kami tunjukajar sepanjang
kursus ini.
Sekiranya terdapat masalah atau soalan mengenai access sila
kemukakan kepada kami di :

Active Mind training services


No H-3-13, Jalan Seksyen 3/8,
Taman Kajang Utama, 43000,
Kajang, Selangor Darul Ehsan
Telefon: 03-8731-2005 Fax: 03-87331-1006
Email: izder2@yahoo.com alamat web : www.activemind.com.my

Mukasurat 1
Manual Kursus MS Access XP dan Database

TOPIK 1 MEMULAKAN ACCESS DAN PENGGUNAANNYA


Memulakan Microsoft Access
1. Klik Start > Programs > Microsoft Access
2. Anda akan dipaparkan dengan helaian kosong berikut

Fungsi Elemen Antara Muka Perisian Microsoft Access XP

Elemen Fungsi
Title Bar Untuk memaparkan nama perisian
(Microsoft Access).
Menu Bar Mengandungi menu utama bagi
Microsoft Access.
Database Toolbar Memaparkan butang-butang atau ikon
yang boleh digunakan untuk
melaksanakan operasi kerja Microsoft
Access.
Startup Windows Ini merupakan kawasan di mana semua
operasi kerja dalam pembinaan
pangkalan data akan dilaksanakan.
Status Bar Untuk memaparkan maklumat
mengenai fail yang sedang clibuka atau
digunakan.

Mukasurat 2
Manual Kursus MS Access XP dan Database
Butang Minimize Untuk menyembunyikan paparan skrin
Microsoft Access.
Butang Restore Untuk meminima dan memaksimakan
saiz paparan skrin Microsoft Access.
Butang Close Untuk menutup perisian Microsoft
Access dengan pantas.
Taskpane Tetingkap ini memaparkan segala
maklumat mengenai tugas yang
sedang, telah atau akan dilaksanakan
oleh Microsoft Access. Contoh: senarai
nama fail yang telah dibuka.

Menggunakan arahan pada menu bar

Menu File:
Menu ini mengandungi semua arahan berkaitan pengurusan
fail Access yang dibina seperti membina fail baru, membuka dan
menutup fail, menyimpan fail baru atau lama, mencetak dan
sebagainya.

Menu Edit:
Menu ini mengandungi semua arahan berkaitan dengan proses
pengubahsuaian fail Access seperti memotong, menyalin, menampal
dan sebagainya.

Menu View:
Menu ini mengandungi semua arahan berkaitan dengan

Mukasurat 3
Manual Kursus MS Access XP dan Database
bentuk paparan fail Access di skrin. la turut digunakan untuk
memaparkan toolbar selain daripada yang tertera pada skrin
antara muka Microsoft Access.

Menu Insert:
Menu ini mengandungi semua arahan yang berkaitan dengan
proses penambahan elemen di dalam fail Access seperti menambah
table, query, form dan sebagainya.

Menu Tools:
Menu ini mengandungi semua arahan yang berkaitan dengan
proses semakan ke atas setiap fail Access seperti semakan
ejaan, tatabahasa dan sebagainya. Kemudahan lain yang
disediakan di bawah pilihan menu ini ialah pembinaan
Relationships, Analyze, Macro dan sebagainya.

Menu Window:
Menu ini mengandungi semua arahan yang berkaitan dengan
paparan fail Access di skrin. Turut dipaparkan di dalam pilihan
menu ini ialah senarai fail Access di dalam pelbagai format.

Menu Help:
Menu ini mengandungi semua arahan yang berkaitan dengan
kemudahan bantuan yang disediakan oleh Microsoft Access.

Menggunakan Toolbar
Pada antara muka Microsoft Access, anda dipaparkan dengan Database
Toolbar sahaja. Toolbar ini juga akan sentiasa berubah mengikut operasi
kerja yang dilaksanakan oleh pengguna.

Mukasurat 4
Manual Kursus MS Access XP dan Database
Walau bagaimanapun, anda sebenarnya boleh menambah atau
memaparkan toolbar-toolbar yang lain.
Memaparkan Toolbar Yang Dikehendaki
1. Klik View > Toolbars dan anda akan dipaparkan dengan menu
berikut:

2. Anda akan dapati pilihan Database telah ditandakan. Untuk


anda mengaktifkan Web toolbar, anda cuma perlu klik padanya dan
ianya akan ditandakan
3. Anda akan dapati Web toolbar dipaparkan di bawah Database
toolbar seperti berikut:

Terdapat pelbagai kategori objek utama didalam access yang


dapat diperhatikan seperti tables, forms, queries, reports,pages
macros dan modules.Setiap objek ini mempunyai elemen-
elemen dan fungsinya yang tersendiri.

Mukasurat 5
Manual Kursus MS Access XP dan Database

Elemen-elemen asas didalam Microsoft Access


Jadual

Jadual mengandungi data


oleh itu ia merupakan
elemen terpenting didalam
pengkalan data.

Setiap pengkalan data


harus mempunyai pelbagai
jadual yang mengandungi
informasi penting seperti
rekod pekerja, pesanan
pelanggan , kaedah
penghantaran dan nama
vendor.Data tidak
seharusnya berulang
didalam jadual yang
berlainan.

Setiap Jadual
mengandungi baris yang
dinamakan rekod dan
kolumn yang dipanggil field

Primary key/kunci primary

Untuk membezakan antara


satu rekod dengan yang
lain , jadual boleh
mengandungi kunci
primary atau primary key

Kunci primary ini adalah


penentu utama – seperti
no pesanan , kod produk
atau ID pengguna yang
mana ianya adalah unik
untuk setiap rekod.Kunci
primary ini juga adalah
satu maklumat dimana
ianya tidak berubah
sentiasa

Mukasurat 6
Manual Kursus MS Access XP dan Database
Queries

Queri boleh membantu


pengguna didalam
membuat proses menapis,
menyusun , mencari rekod
didalam pengkalan data.

Semasa queri mencari data


dan menunjukkan kepada
pengguna, ia adalah
bergantung kepada kriteria
yang telah ditetapkan.
Sesuatu queri juga dapat
melakukan pengiraan yang
mudah menggunakan data
yang sedia ada melalui
formula.

Borang

Borang membenarkan
pengguna untuk
memasukkan atau melihat
data dengan lebih mudah.

Borang mengawal dan


memudahkan kaedah
memasukkan data.
Menggunakan borang juga
adalah lebih cantik dan
menarik berbanding
dengan jadual atau queri.
Dengan borang juga,
gambar atau imej boleh
diletakkan

Mukasurat 7
Manual Kursus MS Access XP dan Database

Laporan

Laporan menukarkan
data menjadi bentuk
dokumentasi yang sedia
untuk dicetak. Laporan
boleh diubahsuai untuk
kemahuan pengguna
bergantung kepada
jenis data yang perlu di
perlihatkan
Dengan menggunakan
laporan, pengguna
boleh mengumpulkan
data, melakukan
formula pengiraan dan
meletakkan judul serta
mukasurat untuk
memudahkan ianya
dibaca.

Mukasurat 8
Manual Kursus MS Access XP dan Database

PELAJARAN 2: PEMBINAAN JADUAL (TABLE)


Objektif pembelajaran: Anda akan dapat mempelajari
asas membina jadual menggunakan design view dan jenis-
jenis data yang boleh dipakai didalam Access

Didalam Microsoft Access ,jadual atau table merupakan sumber


maklumat utama didalam sesebuah pengkalan data. Tanpa kehadiran
table, semua elemen atau fungsi lain seperti queri dan sebagainya
tidak dapat dilaksanakan. Secara amnya, data-data didalam table
disusun dalam bentuk hamparan elektronik sepertimana excel .Ia
merupakan konsep baris (row ) dan juga lajur (column) didalam
setiap perwakilan datanya. Didalam Access , Lajur mewakili medan
atau fields manakala baris pula akan mewakili rekod.
Menggunakan Blank Database
1. Pada Taskpane, di bawah opsyen New, klik Blank Database.

Lihat rajah berikut:


2. Anda akan dipaparkan dengan kotak dialog File New Database

Mukasurat 9
Manual Kursus MS Access XP dan Database
seperti berikut:

3. Pada kekotak File name:, taipkan nama fail anda sebagai


Maklumat Koperasi.
4. Klik Create dan anda akan dipaparkan pula dengan kotak dialog
berikut:

5. Dwi klik Create table in Design view.


6. Anda akan dipaparkan dengan paparan Design View seperti
berikut:

Mukasurat 10
Manual Kursus MS Access XP dan Database

Memasukkan Field Name (Nama Medan)

1. Klik pada baris pertama di bawah lajur Field Name (Nama


Medan) dan taipkan data: Kod Ahli.
2. Tekan kekunci Tab atau Enter dan kursor anda akan berpindah ke tab
Data Type (Jenis Data) seperti berikut:

Menetapkan Data Type (Jenis Data)

1. Klik pada butang muat turun di sebelah Data Type (Text)


seperti berikut:

Mukasurat 11
Manual Kursus MS Access XP dan Database
2. Klik Number.
3. Lihat hasilnya seperti berikut:

Jenis-Jenis Data (Data Type)

Sebelum anda pergi kepada pelajaran seterusnya, di sini diperjelaskan


terlebih dahulu fungsi-fungsi Data Type supaya anda dapat
memahaminya dengan lebih baik.
Data Type Fungsi
Text Format ini membenarkan aksara
huruf, nombor dan tanda-tanda
bacaan digunakan. Jumlah aksara
maksima yang boleh dimuatkan di
dalam medan untuk format ini ialah
sebanyak 255.
Memo Format ini hampir sama dengan
format text tetapi is boleh
menampung jumlah maksima
sebanyak 64,000 aksara.
Number Format ini membenarkan nilai
numeric (nombor) digunakan.
Date/Time Format ini untuk memaparkan data
berbentuk tarikh dan masa.
Currency Format ini untuk membolehkan data
dipaparkan dalam bentuk kewangan.
la boleh digabungkan dengan
beberapa elemen khas seperti tanda
koma, titik perpuluhan dan tanda $.

Mukasurat 12
Manual Kursus MS Access XP dan Database
AutoNumber Format ini membenarkan nombor
dimasukkan secara automatic.
Yes/No Format ini berunsur logikal. la
menerima data-data dalam
kelompok logikal seperti
Benar/Salah, On/Off dan Ya/Tidak.
OLE Object . Format ini memerlukan rantaian atau
hubungan dengan objek yang
dihasilkan dari program luar. lanya
boleh berupa bentuk seperti imej,
video dan graf

Memasukkan Data Seterusnya Ke Dalam Jadual

1. Kembali kepada jadual tadi, masukkan data-data seterusnya


seperti berikut:
Untuk lebih jelas, sila rujuk kepada penyataan di bawah:
Data-data yang dimasukkan ke dalam jadual di atas ialah:
Field Name Data Type
Kod Ahli Text
No K/P Text
Nama Ahli Text
Alamat Rumah Text

Mukasurat 13
Manual Kursus MS Access XP dan Database
Field Name Data Type
Telefon Text
H/Phone Text
Mula Jadi Ahli Date/Time
Yuran Bulanan Currency
Bayar Yuran? Yes/No

Penting:
Data yang dimasukkan ke dalam Field Name tidak boleh menerima
tanda noktah atau titik.

Menyimpan Jadual
1. Klik File > Save.
2. Anda akan dipaparkan dengan kotak dialog berikut:

Taipkan nama fail di sini.


3. Pada kekotak Table Name, taipkan nama fail Yuran Ahli.
4. Klik OK dan ands akan dipaparkan pula dengan mesej berikut:

5. Sila pastikan anda mengkik pada butang No. Sekiranya butang Klik di
pilih , satu field autonumber secara automatik akan ditambah dan
primary key diberi kepada field berkenaan

Mukasurat 14
Manual Kursus MS Access XP dan Database

Menetapkan Medan Primary Key secara manual

1. Klik pada medan Kod Ahli seperti berikut:

2. Klik pada butang Primary Key diatas toolbar seperti berikut:

3. Anda akan dapati paparan seperti berikut:

Penting:

Menetapkan primary key bukanlah suatu kemestian, tetapi ia boleh


memudahkan tugasan anda untuk membezakan setiap rekod yang
terkandung di dalam pangkalan data.Antara kelebihan yang diperolehi
adalah seperti berikut:
• Mempercepatkan proses mencari, menyusun serta mencapai
maklumat.
• Menguruskan susun atur rekod dengan lebih berkesan.
• Mengelakkan pertindihan data terutamanya sekiranya data tersebut
adalah unik seperti no ahli atau kad pengenalan.
• Memudahkan operasi menghubungkan antara satu jadual dengan
satu jadual yang lain.

Mukasurat 15
Manual Kursus MS Access XP dan Database

Menetapkan Field Properties

1. Kita ambil nama medan Mula Jadi Ahli sebagai contoh.

2. Klik pada nama medan tersebut seperti berikut

3. Lihat pada Field Properties sepertimana berikut

4. Klik pada format dan butang muat turun akan tertera di hujung kotak
seperti berikut

5. Klik pada butang tersebut dan satu senarai format tarikh akan
dipaparkan

6. Anda juga boleh menaip sendiri tarikh mengikut format seperti

Mukasurat 16
Manual Kursus MS Access XP dan Database
DD/MM/YYYY dimana DD mewakili akan haribulan, MM mewakili
bulan dan YYYY mewakili tahun.

Penting : Tekan pada kekunci F1 (help ) pada papan kekunci untuk


melihat lagi nota mengenai jenis format data untuk tarikh

7. Lihat pada paparan berikut

Menetapkan Penggunaan data menggunakan Input Mask

Input mask digunakan untuk data-data yang mempunyai format khas


tertentu seperti no kad pengenalan , no telefon dan no siri atau no
pekerja . Menggunakan input mask mempunyai kelebihan dimana anda
tidak perlu lagi mengisi format yang diperlukan seperti / atau ( ) dimana
ianya boleh disetkan sebelum memasukkan data. Sila ikuti langkah-
langkah yang berikut

1. Pilih medan field No k/p . Format untuk kad pengenalan adalah


seperti berikut: 700311-05-9988 .

2. Klik pada field properties dan pilih Input mask . Pada ruangan

sebelah kiri , sila klik pada butang bertanda

Mukasurat 17
Manual Kursus MS Access XP dan Database
3. Input mask wizard akan diaktifkan seperti berikut. Sila pilih
pada format social security number yang menyerupai no kad
pengenalan. Klik next

4. Klik pada ruangan Input Mask . Simbol 0 yang dilihat mewakili


berapa digit yang boleh diterima dan adalah wajib .Buang no yang
tertera dengan menggunakan delete key dan gantikan dengan
format berikut: 000000-00-0000 . Placeholder character pula
bermaksud data digantikan dengan simbol tertentu sebelum diisi

Mukasurat 18
Manual Kursus MS Access XP dan Database
5. Klik Next

6. Klik pada pilihan with the symbols in the mask…untuk


menetapkan input mask tersebut dan klik butang next

7. Klik finish untuk selesaikan wizard ini.

Sekarang, data yang ingin diisi pada field Kad Pengenalan akan mengikut
format input mask yang telah ditetapkan.

Menetapkan Index

Tujuan menetapkan index adalah untuk mengelakkan dari berlakunya


sebarang penindihan maklumat. Ia ditetapkan pada mana-mana medan
yang anda kehendaki. Ia juga boleh mempercepatkan proses pencarian
maklumat atau data didalam sesebuah sistem pengkalan data. Disamping itu
, ianya turut membantu anda menyusun data-data didalam sesebuah sistem
dengan urutan yang dikehendaki.

Ikuti langkah-langkah berikut:

Mukasurat 19
Manual Kursus MS Access XP dan Database
1. Kita ambil nama medan No k/p di field jadual anda dan klik pada
baris medan tersebut

2. Klik pada indexed yang terkandung didalam field properties seperti


berikut:

3. Klik pada butang muat turun di hujung kotak

4. Klik yes (no duplicates ) dan anda akan dapat paparan sedemikian

5. Pilihan ini akan menghalang daripada berlakunya sebarang


pertindihan maklumat. Tidak akan wujud situasi dimana dua rekod
memiliki nilai yang sama.

Mukasurat 20
Manual Kursus MS Access XP dan Database

PELAJARAN 3: PENGGUNAAN DATASHEET VIEW


Objektif pembelajaran: Anda akan dapat mempelajari
melihat jadual menggunakan datasheet view dan mengisi
rekod didalam jadual tersebut

Menggunakan Datasheet View

Jadual didalam access mempunyai 2 mod view penting iaitu design dan
datasheet view. Sekiranya jadual ingin dibina, anda perlu berada dibahagian
design view untuk menetapkan jenis data field. Menerusi Datasheet View
pula, rekod-rekod bagi semua medan yang telah anda bina akan
dimasukkan. Anda juga boleh melaksanakan operasi-operasi lain seperti
memasukkan rekod baru, menambah dan memadam rekod, mencari data
rekod dan lain-lain. Pada pelajaran seterusnya akan menjelaskan kepada
anda bagaimana anda perlu melaksanakan beberapa operasi yang
dimaksudkan.

Memasukkan Rekod Ke Dalam Jadual

Rekod seterusnya akan dimasukkan ke dalam jadual menggunakan paparan


Datasheet View. Ikuti langkah-langkah berikut:

1. Klik View > Datasheet View atau klik pada butang tersebut yang
tertera pada Table Design toolbar seperti berikut:

Mukasurat 21
Manual Kursus MS Access XP dan Database

Anda boleh terus klik pada butang ini atau klik terlebih dahulu pada
butang muatturun. Selepas itu, klik pada Datasheet View.
Datasheet view
2. Masukkan rekod data sepertimana dibawah ini

3. Saiz lajur (column) boleh diubah dengan cara meletakkan


kursor pada tempat berikut:

4. Anda akan dipaparkan dengan simbol anak panah berpalang


seperti berikut:

6. Klik dan Heret ke kiri untuk mengecilkan saiz lajur (column).


7. Klik dan Heret ke kanan untuk membesarkan saiz lajur (column).

Mukasurat 22
Manual Kursus MS Access XP dan Database

Letakkan
Kursor disini
dan heret

8. Saiz row (baris) juga boleh diubah dengan cara meletakkan kursor
pada pada baris dan mengheretnya

Mengubah saiz medan pada field properties


Sekiranya anda dapati ruangan untuk anda memasukkan data-data tertentu
tidak mencukupi, anda perlu mengubah field size yang tertera didalam field
properties. Ikuti langkah-langkah berikut:

1. Sebagai contoh , anda ingin mengubah field saiz untuk medan nama
ahli
2. Gantikan nilai 50 kepada 35 , maka medan tersebut akan dapat
menerima jumlah teks sebanyak 35 aksara.
3. Lihat rajah berikut

4. Simpan perubahan yang anda lakukan

Penting : Sekiranya anda mengurangkan saiz medan setelah data diisikan ,


anda TIDAK dapat memperolehi data itu semula setelah kembali kepada
saiz asal .

Mukasurat 23
Manual Kursus MS Access XP dan Database

Melihat rekod didalam datasheet


Rajah menunjukkan Nombor rekod

Sekiranya anda memasukkan rekod yang begitu banyak didalam satu jadual
sehingga tidak mampu untuk dipaparkan oleh skrin sepenuhnya, anda
Cuma perlu klik pada anak panah yang terdapat didalam penunjuk
nombor rekod sebagaimana yang tertera diatas.
Menyunting Data Medan Pada Paparan Datasheet View

Andaikan anda telah melakukan kesilapan pada salah satu daripada data
medan. Contoh: data medan Alamat sepatutnya merupakan data medan
Bandar. Ikuti langkah-langkah penyuntingan berikut:

1. Dwi klik pada medan Alamat


2. Medan tersebut akan berada dalam keadaan seperti berikut:

3. Taipkan Bandar dan perubahan berikut akan berlaku:

Mukasurat 24
Manual Kursus MS Access XP dan Database

4. Klik di mana-mana ruangan kosong.

5. Simpan perubahan dengan cara klik pada butang Save.

Menambah Rekod Baru

1. Rekod baru boleh ditambah dengan mudah iaitu dengan cara


meletakkan kursor pada bans kosong yang terakhir

2. Tambahkan rekod-rekod baru ke dalamnya.

3. Simpan perubahan.

Mencari Data
1. Letakkan kursor pada medan yang bersesuaian.
2. Sebagai contoh, sekiranya anda ingin mencari data yang berkaitan
dengan Nama Ahli Tan Chee Leong, sila letakkan kursor anda pada
mana mana rekod di medan Nama Ahli.
3. Klik butang Find seperti berikut:

Mukasurat 25
Manual Kursus MS Access XP dan Database
3. Anda akan dipaparkan dengan tetingkap berikut:

5. Pada kekotak Find What, taipkan Tan Chee Leong seperti


berikut:
6. Klik Find Next
7. Anda akan dapati kursor anda berada pada data rekod ahli seperti
berikut

10.Ini menunjukkan carian anda telah selesai. Anda juga boleh


menggunakan kaedah ini untuk mengubah suai data dengan menggunakan
replace. Gantikan Nama yang bersesuaian di bahagian replace > Replace
with
11. Klik OK.
Carian Gagal

1. Adakalanya anda akan dipaparkan dengan tetingkap mesej yang


sama dengan mesej yang menunjukkan carian anda telah selesai
seperti berikut ketika anda cuba mencari sesuatu rekod:

Mukasurat 26
Manual Kursus MS Access XP dan Database
2. Ini menunjukkan rekod tersebut gagal ditemui kerana ianya tiada di
dalam senarai.
3. Klik OK.

Menambah Rekod Baru Menggunakan butang new record

Anda boleh mula memasukkan rekod-rekod baru dengan


menggunakan butang new rekod diatas toolbar atau dibawah jadual.

4. Tambahkan rekod baru seperti di dalam contoh berikut:

5. Simpan perubahan yang dilakukan

Memadam reokd

1. Klik pada data rekod yang ingin dipadamkan sebagaimana contoh


berikut:

Mukasurat 27
Manual Kursus MS Access XP dan Database
2. Rajah diatas menunjukkan rekod ke 6 akan dipadamkan

3. Klik kekunci delete atau klik pada butang delete rekod seperti berikut

4. Anda akan dipaparkan dengan kotak dialog box berikut

5. Klik Yes sekiranya anda ingin membuang rekod tersebut. Untuk latihan
ini gunakan No . Penting: Data yang telah dibuang tidak dapat diundo
dan anda terpaksa memasukkan data tersebut semula

6. Simpan perubahan yang telah anda lakukan

Menutup Fail Database

1. Klik Fail > Close atau klik pada butang close yang terdapat di hujung
tetingkap jadual anda

Membuka Fail Database

1. Klik Fail > open atau klik pada butang open sepertimana berikut

Mukasurat 28
Manual Kursus MS Access XP dan Database
2. Anda akan dipaparkan dengan tetingkap open seperti berikut:

3. Klik pada nama fail maklumat ahli koperasi atau nama yang telah
diberikan sebelum ini

4. Klik open dan Dwi Klik pada jadual tersebut

Keluar dari Microsoft Access

Untuk keluar dari Access atau menutup fail anda gunakan

1. Exit atau klik pada butang close yang terletak di hujung kanan bar title

Mukasurat 29
Manual Kursus MS Access XP dan Database

Pelajaran 4 MENYUSUN DAN MENAPIS REKOD

Objektif Pembelajaran: Anda dapat mempelajari akan kaedah menyusun


dan menapis data menggunakan butang toolbar.

Seringkali apabila anda memasukkan data ianya tidak tersusun dan


menyukarkan untuk melihat data. Dengan access terdapat 2 kaedah yang
memudah kan penyusunan data iaitu mengunakan butang sort ascending
atau descending atau dengan menggunakan queries.

Menyusun rekod berdasarkan primary key

1. Buka semula fail yuran ahli

2. Anda perlu berada dalam mod database view untuk operasi ini

3. Klik pada butang design view untuk berpindah kepada mod berikut

4. Sila tambahkan primary key. Primary key boleh dibatal dan disetkan
semula menggunakan butang yang sama

5. Selepas itu, anda perlu kembali ke datasheet view

6. Apabila anda dipaparkan dengan tetingkap mesej berikut:

Mukasurat 30
Manual Kursus MS Access XP dan Database

7. Klik Yes untuk menyimpan jadual anda

Menyusun rekod berdasarkan medan

Medan boleh disusun secara menaik (ascending ) dan menurun


(descending) . Sila ikut akan langkah langkah berikut sebagai contoh

1. Klik pada nama medan Nama ahli yang tertera pada field selector seperti
berikut

2. Anda akan dapati seluruh rekod pada nama medan tersebut diaktif dan
dihitamkan.

3. Klik File > Sort > Sort Ascending untuk membuat susunan menaik atau

klik pada butang berikut

4. Klik > sort > Sort Descending untuk membuat susunan menurun atau

klik pada butang berikut :

• Nama ahli akan disusun mengikut abjad dari A hingga Z apabila


anda memilih sort ascending

• Nama ahli akan disusun menyongsang dari abjad Z ke A apabila

Mukasurat 31
Manual Kursus MS Access XP dan Database
anda memilih sort descending

Membatalkan arahan menyusun rekod

Klik rekod > remove filter/sort

Anda akan dapati Nama ahli kembali ke kedudukan asal

Menapis Data Menggunakan 'Filter By Selection'


Filter by selection membenarkan anda menapis rekod yang sedia ada
dengan rekod yang dipilih. Sebagai contoh, anda ingin menapis data ahli
yang telah membayar yuran sahaja. Ikuti Iangkah-langkah berikut:

1. Klik dan hitamkan pada salah satu daripada rekod yang mengandungi
data Telah membayar yuran yang tertera di bawah nama medan
Catatan seperti berikut:

2. Klik Records > Filter > Filter By Selection atau klik pada
butang berikut:

3. Anda akan dapati hanya rekod yang mengandungi data Telah


membayar yuran sahaja yang dipaparkan.

Membatalkan Arahan 'Filter By Selection'

Klik Records > Remove Filter/Sort atau klik pada butang berikut:

Mukasurat 32
Manual Kursus MS Access XP dan Database

Menyusun Rekod Menggunakan 'Filter By Form'

Sebagai contoh, anda ingin menapis data Nama Ahli. Ikuti Iangkah-
Iangkah berikut:

1. Aktifkan medan berkenaan.


2. Klik Records > Filter > Filter By Form atau klik pada butang
berikut:
4. Rajah tersebut ialah tetingkap Filter by Form.
5. Andaikan anda ingin menapis data ahli yang bernama Muhaiza
Sulaiman. Sila klik pada butang muat turun yang tertera pada medan
Nama Ahli seperti berikut:

6. Satu senarai nama akan dipaparkan dan kiik pada Muhaiza


Sulaiman
7. Klik Filter > Apply Filter/Sort
Anda akan diperlihatkan dengan paparan berikut

Rekod Muhaiza Sulaiman telah dipaparkan di skrin


Batalkan arahan filter by form dengan menggunakan kaedah yang
sama sebagaimana membatalkan arahan menapis sebelum ini

Mukasurat 33
Manual Kursus MS Access XP dan Database

Pelajaran 5: PEMBINAAN QUERY

Objektif Pembelajaran :
Anda akan dapat mempelajari kaedah untuk membina queri
dan menapis rekod berdasarkan data dari jadual yang telah
dibina. Anda juga dapat mempelajari kaedah membina
formula didalam queri

Queri seringkali digunakan untuk menapis , menyusun dan


mencari rekod yang dikehendaki dengan mudah. Queri juga
adalah penting sekiranya anda perlu menghasilkan formula
tertentu yang tidak dapat dihasilkan melalui jadual .

Asas membina query ringkas


Anda perlu kembali kepada database window seperti berikut:
1. Pada menu object klik queries
2. Klik new
3. Anda akan dipaparkan dengan tetingkap New Query
4. Klik design view > ok
5. Anda akan dipaparkan pula dengan tetingkap show table

Mukasurat 34
Manual Kursus MS Access XP dan Database
6. Dwi klik pada yuran ahli dan klik pada butang close
7. Dwi klik pada medan kod ahli dan lihat hasilnya
8. Klik pada medan kosong di sebelah medan kod ahli dan klik pada
butang muat turun
9. Klik pada medan no K/P dan anda akan dapati medan tersebut
tertera pada design grid
10. Berpandukan kaedah yang sama, lengkap kan design grid berikut
dengan memasukkan kesemua medan yang ada

Penting: Anda juga boleh mengklik kepada judul data yuran ahli untuk
memilih keseluruhan data field dan heret kepada ruang pertama grid

11. Lihat pada contoh yang berikut

Anda telah berjaya meletakkan keseluruhan data diruangan grid didalam


queri

Membuat Perubahan pada Query


1. Aktifkan medan telefon dan Bandar seperti berikut

Mukasurat 35
Manual Kursus MS Access XP dan Database

2. Tekan kekunci delete dan anda akan dapati kedua medan


tersebut dihilangkan dari medan yang sedia ada.
3. Untuk memasukkan kembali medan telefon dan Bandar, seret
kedua dua medan dari medan data yuran ahli kedalam ruang
diantara nama ahli dan mula jadi ahli

Memaparkan Query Yang Terhasil

1. Klik butang Run seperti berikut:


2.Query yang telah anda bina sebentar tadi telah pun dipaparkan.

3. Anda juga mendapati tiada sebarang rekod di bawah medan Jabatan


kerana ianya merupakan medan yang baru dibina. Masukkan data rekod ke
dalamnya seperti berikut:
1. Menetapkan bentuk paparan rekod pada query
2. Anda perlu kembali pada query design view
3. Klik view > design view dan anda akan diperlihatkan dengan paparan
sepertimana
4. Klik pada butang muat turun yang tertera pada arahan sort dibawah
medan nama ahli
5. Klik Ascending dan anda akan dapati nama ahli disusun mengikut
abjad menaik (ascending)

Mukasurat 36
Manual Kursus MS Access XP dan Database
Menyimpan query
1. Klik pada butang save
2. Anda akan dipaparkan dengan tetingkap save as seperti berikut
3. Pada kotak query name, taipkan nama fail query sebagai Nama
ahli mengikut turutan
4. Klik Ok
5. Anda akan dapati nama fail query anda telah disenaraikan di
dalam tetingkap database berikut

Membina Query Berdasarkan Kriteria

1. Kembali kepada Query Design View.


2. Klik pada Criteria di bawah medan Yuran Bulanan.
3. Taipkan 50 dibahagian kriteria yuran seperti dibawah

4. Klik butang Run (!) dan anda akan diperlihatkan dengan


paparan berikut:

5. Anda akan dapati hanya rekod ahli yang mempunyai yuran


bulanan sebanyak $50.00 sahaja yang dipaparkan di dalam

Mukasurat 37
Manual Kursus MS Access XP dan Database
jadual.

6. Simpan fail tersebut dengan klik File > Save as dan


anda akan dipaparkan dengan tetingkap seperti berikut:

7. Taipkan Nama Ahli Berdasarkan yuran untuk queri


tersebut
8. Klik OK.

Membina pengiraan didalam queri


Anda juga boleh melakukan pengiraan menggunakan
queri.Dalam contoh ini, anda ingin melakukan pengiraan
tambahan yuran bulanan sebanyak $30.00 setiap orang
Untuk latihan ini, sila ikuti langkah dibawah
1. Buka kembali paparan queri anda didalam design view
2. Buangkan segala kiteria yang telah wujud sebelum ini
menggunakan kekunci delete
3. Tukarkan kedudukan yuran bulanan dengan mengklik
pada kolum tersebut seperti berikut

4. Heret kedudukan data yuran bulanan kepada ruang disebelah


kanan sekali selepas ruang bayar yuran

Mukasurat 38
Manual Kursus MS Access XP dan Database
5. Pada ruang baru disebelah kanan yuran bulanan taipkan berikut
dibahagian Field:

Yuran Terkini : [Yuran Bulanan] + 30

Penting : Sila pastikan simbol : dan [ yuran bulanan] ditaip


dengan betul untuk memungkinkan formula dilakukan dengan betul

6. Klik kekotak show dibawah ruang yuran terkini yang baru ditaipkan

Paparkan nilai baru pengiraan tersebut dengan menekan butang ! pada

toolbar anda.
7. Kolumn baru dengan judul yuran terkini dipaparkan berserta dengan
pengiraan bagi setiap data.
8. Simpan hasil kerja anda

Mukasurat 39
Manual Kursus MS Access XP dan Database

Contoh queri ddngan pengiraan menggunakan formula

Mukasurat 40
Manual Kursus MS Access XP dan Database

PELAJARAN 6: PENGGUNAAN RELATIONSHIP

Objektif pembelajaran: Anda akan mempelajari kaedah untuk


membina perhubungan data didalam access yang melibatkan lebih dari
satu jadual untuk menghubungkaitkannya

Relationship atau hubungan data melibatkan hubungkait lebih dari satu


jadual. Dalam satu proses pembinaan relationship , terdapat pelbagai criteria
yang perlu diambil kira dan yang paling utama adalah jenis perhubungan
atau join type yang digunakan. Terdapat 3 jenis perhubungan data yang
boleh dihasilkan iaitu
One to one: contoh gaji pekerja dan jabatan dalam jadual berlainan
berdasarkan no pekerja
One to many: contoh nama pelanggan dan barang yang dibeli dalam
jadual yang berlainan berdasarkan no pelanggan
Many to one: contoh jenis produk yang terdapat dan nama syarikat
didalam jadual berlainan berdasarkan no syarikat

Sebelum anda didedahkan dengan penggunaan Relationship, bina sebuah


jadual baru di dalam pangkalan data Maklumat Ahli
Namakannya sebagai fail Maklumat Ahli. Masukkan data-data berikut
ke dalam mod Design View.

Ikuti langkah-langkah seterusnya:


1. Simpan jadual tersebut ke dalam fail Maklumat Ahli tanpa
Primary Key.
2. Klik butang Datasheet View dan masukkan maklumat-maklumat

Mukasurat 41
Manual Kursus MS Access XP dan Database
yang diperlukan seperti berikut:

3. Simpan dan tutup jadual tersebut setelah selesai

Memilih dan memasukkan jadual (table ) ke dalam tetingkap


relationship

1. Ketika tetingkap database sedang aktif anda perlu klik pada butang
relationship seperti berikut

2. Anda akan dipaparkan dengan tetingkap show table seperti berikut

3. Dwi klik pada table maklumat ahli dan yuran ahli

Mukasurat 42
Manual Kursus MS Access XP dan Database
4. Klik pada butang close pada tetingkap show table

5. Anda akan diperlihatkan dengan tetingkap relation ship seperti


berikut

6. Besarkan saiz paparan senarai medan maklumat peribadi ahli dan


yuran ahli sehingga menjadi seperti berikut

(Relationships) Di Antara Jadual

1. Pindahkan kedudukan dengan cara klik dan heret pada table


sehingga menjadi seperti berikut:
2. Seret medan K o d A h l i yang memiliki Primary Key dari
table Yuran Ahli dan lepaskan ia pada medan Kod Pekerja yang
terkandung di dalam jadual Maklumat ahli.
3. Tetingkap Edit Relationships dipaparkan:

Mukasurat 43
Manual Kursus MS Access XP dan Database

4. Klik butang Create untuk membina hubungan.tersebut


5. Anda akan diperlihatkan dengan paparan sedemikian:

6. Hubungan seumpana ini boleh diubah dengan cara dwi klik pada
garisan penghubung tersebut dan tetingkap Edit relationship akan
terpapar seterusnya.

Mengubah ciri-ciri perhubungan data diantara jadual

6. Dwi klik pada garisan penghubung data dan tetingkap edit


relationship akan dipaparkan

7. Klik join type dan anda akan dipaparkan dengan tetingkap berikut

8. Klik pada pilihan ke 2

Mukasurat 44
Manual Kursus MS Access XP dan Database
9. Klik ok pada tetingkap Join Properties

10. Klik ok sekali lagi pada tetingkap Edit relationships

11. Anda akan kembali ke tetingkap relationship

12. Kali ini anda akan dapati anak panah terbentuk dihujung garisan
penyambung seperti berikut

Menambahkan 'Referential Integrity' (Pengesahan Data) Ke


Dalam Relationships

1. Dwi klik pada garisan penghubung.


2. Anda akan dipaparkan semula dengan tetingkap Edit Relationships
seperti berikut:
3. Klik pada kekotak kecil Enforce Referential Intergrity untuk
mengaktifkannya, klik juga pada pilihan kotak cascade update dan
cascade delete
4. Lihat rajah berikut:

4. Klik OK

Mukasurat 45
Manual Kursus MS Access XP dan Database

5. Anda akan lihat perubahan pada garis relationship sepertimana


dibawah ini

6. Save relationship yang telah anda bina.


7. Untuk melihat hasil relationship anda, klik pada objek jadual
8. Dan pilih jadual Yuran ahli. Dwi klik untuk membuka jadual
tersebut
9. Anda akan dipaparkan sepertimana berikut. Terdapat satu tanda
+ pada hujung kiri jadual anda.

10. Untuk melihat data dari jadual maklumat ahli , klik pada setiap

butang + data dijadual tersebut

Mukasurat 46
Manual Kursus MS Access XP dan Database

11. Anda akan dapat melihat data-data pada jadual Maklumat ahli
disini. Untuk menutup kolumn atau data yang tidak perlu dilihat klik
pada menu Format dan pilih Hide column.

12. Anda juga boleh memaparkan data yang tidak ditunjukkan


dengan memilih menu format dan pilih Unhide column.

Mukasurat 47
Manual Kursus MS Access XP dan Database

PELAJARAN 7: PEMBINAAN BORANG (FORM)

Objektif pembelajaran: Anda akan mempelajari kaedah membina


borang Access menggunakan form wizard dan mengubahsuainya

Borang digunakan dan dihasilkan didalam Access untuk melihat satu


rekod pada satu paparan sahaja. Anda boleh membina borang sekiranya
sering memasukkan data dan memudahkan pengguna melihat rekod-
rekod yang sedia ada.
Menggunakan Form Wizard
Menerusi tajuk ini, anda akan didedahkan dengan pembinaan sebuah
borang (form) yang ringkas. Ikuti langkah-langkah berikut:
1. Pada tetingkap Database, klik pada Objects: Forms dan anda akan
dipaparkan dengan tetingkap berikut:

2. Klik pada butang new dan anda akan dipaparkan dengan tetingkap
berikut . Penting : Butang new perlu dipilih kerana anda perlu
menetapkan jadual/ queri dimana medan data perlu digunakan nanti

Mukasurat 48
Manual Kursus MS Access XP dan Database

3. Klik Form Wizard dan butang muat turun yang terdapat pada
mesej Choose the table or query where the object's data
comes from

4. Pilih table Yuran Ahli untuk dijadikan sebagai sumber pembinaan


borang dengan mengklik padanya.
5. Klik OK dan anda akan dipaparkan pula dengan tetingkap Form
Wizard seperti berikut:

6. Pilih medan daripada senarai Available Fields untuk dimasukkan


ke dalam senarai Selected Fields.

Mukasurat 49
Manual Kursus MS Access XP dan Database

7. Lihat rajah berikut:

8. Sekiranya anda ingin memasukkan kesemua medan tersebut, anda


cuma perlu aktifkan kesemua medan yang ada dan klik pada butang
>>.
9. Kiik Next dan anda akan dipaparkan dengan tetingkap berikut pula:

10. Aktifkan pilihan Columnar dan klik Next.


11. Klik Standard > Next dan tetingkap berikut akan dipaparkan

Mukasurat 50
Manual Kursus MS Access XP dan Database

12. Pada dialog box What title do you want for your form ? taipkan
tajuk untuk borang anda . Contoh : Borang ahli
13. Klik Finish dan borang akan dipaparkan
Untuk berpindah dari satu rekod ke rekod yang lain , gunakan butang
penunjuk arah dibawah form/borang tersebut

Mengubah bentuk borang


1. Klik pada burang design view dan anda akan dipaparkan dengan
rajah berikut

Mukasurat 51
Manual Kursus MS Access XP dan Database

2. Klik pada butang autoformat


3. Anda akan dipaparkan dengan tetingkap berikut

4. Klik pada bentuk warna borang yang anda kehendaki kemudian klik
ok
5. Anda akan dapati latarbelakang warna borang akan berubah
mengikut pilihan anda
Seterusnya anda juga boleh mengubah beberapa elemen didalam
borang dengan menggunakan butang khusus sepertimana berikut
Walaubagaimana pun akifkan terlebih dahulu nama medan terbabit
sepertimana dibawah

Mukasurat 52
Manual Kursus MS Access XP dan Database

Memasukkan form header


Sediakan ruangan kosong diantara form header dan detail dengan cara
klik dan seret
1. Klik pada butang label yang terkandung didalam toolbox disebelah
kiri borang seperti berikut

2. Lakarkannya dibawah form header dan taipkan borang peribadi


ahli
3. Aktifkan ruang label tersebut untuk menukarkan saiz font kepada 14
dan jajarkan ianya ke tengah
4. Simpan borang tersebut dengan cara klik pada butang save.
5. Klik pada butang view seperti untuk melihat hasil daripada
perubahan yang dilakukan
6. Anda akan dipaparkan dengan perubahan yang telah dibuat
7. Simpan dan Tutup borang tersebut

Mukasurat 53
Manual Kursus MS Access XP dan Database

PELAJARAN 8: PENYEDIAAN LAPORAN (REPORTS)

Objektif pembelajaran: Anda akan mempelajari kaedah

menghasilkan report atau laporan menggunakan wizard . Laporan

adalah elemen access yang dapat melihat keseluruhan data dan

rekod sebelum dicetak

Menghasilkan Laporan Menggunakan Report Wizard

1. Pada tetingkap Database, kiik Objects: Reports.


2. Anda akan dipaparkan dengan tetingkap berikut:
3. Klik butang New

4. Klik Report Wizard dan pilih table Yuran Ahli

5. Klik OK dan anda dipaparkan pula dengan tetingkap berikut:


6. Masukkan medan-medan yang dikehendaki dari senarai available
Fields ke dalam senarai Selected Fields.

Mukasurat 54
Manual Kursus MS Access XP dan Database

7. Klik Next dan tetingkap berikut dipaparkan:Tetingkap ini meminta


anda menetapkan kumpulan atau kategori untuk sesebuah rekod
dipersembahkan. Klik Bandar

8. Klik Butang > dan lihat hasilnya

9. Klik next dan tetingkap berikut dipaparkan

10. Klik pada medan yang disediakan , klik pada butang muat turun
dan pilih medan nama ahli untuk disusun dengan susunan
ascending seperti berikut

Mukasurat 55
Manual Kursus MS Access XP dan Database

11. Klik next dan kekalkan lay out stepped kemudian klik next

12. Anda akan dipaparkan dengan tetingkap selanjutnya

13. Klik Format > Next dan tetingkap berikut dipaparkan

14. Taipkan tajuk laporan ahli mengikut jabatan

Mukasurat 56
Manual Kursus MS Access XP dan Database

15. Klik finish dan akan dipaparkan dengan laporan berikut

16. Anda boleh mengubah suai laporan tersebut menggunakan


mod design view sepertimana dijelaskan dalam topik membina
borang sebelum ini

17. Simpan laporan tersebut

Mukasurat 57
Manual Kursus MS Access XP dan Database

PENGGUNAAN MAKROS

Objektif pembelajaran:
Anda dapat mempelajari kaedah membina makro tertentu didalam access
dengan mudah dan mengujinya

Makro merupakan satu elemen didalam Access yang membolehkan


penggunanya mengautomasikan pengkalan data melalui arahan-arahan
untuk melaksanakan sesuatu tugas. Dengan menggunakan makro, tugas-
tugas tertentu seperti membuka borang dan mencetak laporan dapat
dijalankan dengan automatik. Kaedah makro digunakan sekiranya proses
yang sering digunakan berulang kali dan melibatkan banyak proses
langkah kerja.

Untuk menghasilkan makro yang ringkas yang dapat membuka jadual


anda sila ikuti langkah selanjutnya

1. Klik pada makro di bahagian objek


2. Klik new dan kemudian anda akan dipaparkan dengan paparan
berikut. Makro tidak dapat dibina menggunakan wizard

3. Klik pada bahagian action dan pilih pilihan msgbox . Pilihan ini
akan memberikan satu kotak mesej untuk memberitahu
pengguna.
4. Pada pilihan action argument, isikan sepertimana berikut

Mukasurat 58
Manual Kursus MS Access XP dan Database

5. Dibawah pilihan action msgbox klik dan pilih pilihan opentable.


Pilihan ini akan membolehkan jadual dibuka secara automatik
6. Pada pilihan action argument untuk opentable, pilih sepertimana
berikut pula

7. Dibawah pilihan action open mesej , pilih Maximize, jadual akan


dibuka dengan secara maksima
8. Paparan anda seharusnya dipaparkan seperti dibawah:

9. Klik pada butang save, berikan nama seperti: bukajadual.


10. Uji makro anda dengan menekan butang ! untuk melihat hasilnya.
Bina makro lain untuk menambah kemahiran anda membina makro
sendiri

Mukasurat 59
Manual Kursus MS Access XP dan Database

Latihan membina jadual didalam Access


1. Buka fail database yang baru
2. Berikan nama database itu sebagai Latihan1
Didalam jadual design view binakan field data sepertimana dibawah:
Field Name Data Type
Id Text
Nama Text
Negeri Text
Gaji Currency
Telefon Text
3. Tetapkan imput mask untuk
• ID menggunakan Input mask seperti berikut: “T”00
• telefon menggunakan Input mask seperti berikut “(“00”)”-
000000
Isi kan data sepertimana jadual dibawah ini
ID
Nama Negeri Gaji Telefon
T11 Mohamed Sabri
B. Mohd Arsad Pahang $ 3,000.00 (09)-5736653
T12 Norazam B. Ibun Kuala Lumpur $ 500.00 (03)-6136632
T13 Haji Yusof B.
Hamid Kedah $ 5,000.00 (04)-4686562
T14
Mohd Itan Saady
B. Yeop Pahang $ 3,780.00 (09)-4662341
T15 Muthaiah A/L
Suppiah Kedah $ 766.00 (04)-6320424
T16 Salasiah bt
Othman Selangor $ 2,544.00 (03)-6230117
T17
Rosman Yaakob Selangor $ 1,788.00 (03)-8034556
T18
Hanisah Samuri Melaka $2,100.00 (06)-2357788

4. Letakkan primary key pada ID data anda.


5. Simpan Jadual anda dengan nama Jadual pekerja

Mukasurat 60
Manual Kursus MS Access XP dan Database

Latihan Borang menggunakan Design view

1. Buka database Latihan1 yang telah dibina sebelum ini


2. Pada Form , klik butang new dan klik pada pilihan jadual Latihan1
3. Heret keseluruhan data ke bahagian detail
4. Pastikan anda menukarkan saiz data berpadanan dengan data yang
ada.contoh: Kecilkan kotak data untuk ID
5. Berikan ruang untuk judul menggunakan form page dan
namakannya “Borang pekerja Baru”. Besarkan teks judul tersebut
kepada 16 pt.
6. Tukarkan judul berikut dengan border shadow dan garis
tulisannya 3
7. Warnakan latarbelakang borang, warna teks dan tukar bentuk teks
kepada Tahoma agar kelihatan menarik
8. Simpan borang anda dengan nama “borang pekerja”
9. Lihat pada paparan form view untuk melihat hasilkerja anda

Mukasurat 61