Está en la página 1de 58

TUTORIAL DE MATHCAD

Este tutorial esta hecho para Mathcad 12 profesional.

Este tutorial esta hecho para Mathcad 12 profesional. Introducción: Ventajas del Mathcad Mathcad es una

Introducción: Ventajas del Mathcad

Mathcad 12 profesional. Introducción: Ventajas del Mathcad Mathcad es una herramienta muy poderosa para trabajar con

Mathcad es una herramienta muy poderosa para trabajar con ecuaciones, números, textos y gráficas al mismo tiempo (word, excel y mathematica en el mismo software). Mathcad realiza los cálculos de la misma forma que tu lo haces, eso significa que se ve y escribe tal como lo harias en una hoja de papel y un lápiz. La interfase en la pantalla es una hoja blanca en la cual puedes colocar ecuaciones, gráficas, datos, funciones o anotaciones de texto en cualquier lugar de la hoja, Mathcad te permite usar el lenguaje matemático sin problema.

En cualquier lenguaje de programación se veria así:

x =−( B + SQRT ( B **2 4* A * C )) /(2* A)

En una hoja de cálculo, las ecuaciones colocadas en las celdas se verian algo como esto:

=−( B1 + SQRT ( B1* B1 4* A1* C1)) /(2* A1)

En Mathcad, la misma ecuación se ve como la observas en un texto o libro de referencia.

x :=

−b b + b 2 − 4⋅a⋅c 2⋅a
−b b
+ b
2 − 4⋅a⋅c
2⋅a

La única diferencia es que en Mathcad las ecuaciones y gráficas están "vivas". Si cambias cualquier dato, variable, ecuación o gráfica, Mathcad lo recalcula inmediatamente y lo vuelve a dibujar, esto lo podrás observar más adelante. En este momento es importante aclarar que Mathcad resuelve las ecuaciones de arriba hacia abajo y de izquierda a derecha, por lo que es necesario colocar las ecuaciones respetando lo que resuelve primero. Con Mathcad puedes resolver desde problemas muy simples hasta problemas muy complejos ya sea en forma numérica o simbólica y te permite visualizar las ecuaciones o gráficas en dos y tres dimensiones. Los libros electrónicos de Mathcad te permiten el acceso a un amplio material de conceptos matemáticos y material de referencia que están "vivos" y listos para ser copiados y pegados para ser usados en sus documentos. Lo más importante es que Mathcad te proporciona todas las herramientas necesarias para hacer tu trabajo de principio a fin, sin necesidad de usar paquetes diferentes. Mathcad te permite resolver problemas, formular ideas, analizar datos, modelos y probar escenarios para seleccionar la mejor solución y presentar, documentar y comunicar tus resultados. Usando la red también puedes compartir tus documentos de Mathcad con colegas o cualquier persona, esto significa que el trabajo colaborativo es fácil de realizar en cualquier momento y enriquecerlo con el lenguaje matemático.

El objetivo de este tutorial es de autoestudio y la recomedación es empezar a leerlo y seguir las lecciones y ejercicios resueltos en el manual. Es importante mencionar que esta hecho para la versión 12 por lo que si usa alguna versión anterior, probablemente no funcione igual.

Generalidades en Mathcad

Generalidades en Mathcad

En Mathcad puedes

Generalidades en Mathcad En Mathcad puedes Lección 1 Barra de herramientas de Mathcad y paletas del

Lección 1 Barra de herramientas de Mathcad y paletas del menú .

1 Barra de herramientas de Mathcad y paletas del menú . Propiedades de la ventana de

Propiedades de la ventana de MATHCAD

Antes de que aprendas acerca de las propiedades de Mathcad. Tómate un momento para observar los menús de la ventana de Mathcad.

Menú principal

los menús de la ventana de Mathcad. Menú principal Aquí encontrarás los comandos gráficos y matemáticos,

Aquí encontrarás los comandos gráficos y matemáticos, así como las funciones simbólicas que te sirven para editar y administrar tus hojas de Mathcad.

Abajo del menú view puedes observar y seleccionar los siguientes comandos, los cuales te recomiendo que actives para que se muestre la tableta de cada uno de ellos. En caso de que no aparezcan los puedes activar seleccionando Math en el menú de View

seleccionando M a t h en el menú de V i e w Calculadora Gráficas Matrices

Calculadoraseleccionando M a t h en el menú de V i e w Gráficas Matrices Evaluación

GráficasM a t h en el menú de V i e w Calculadora Matrices Evaluación Cálculos

Matricesa t h en el menú de V i e w Calculadora Gráficas Evaluación Cálculos Boleano

Evaluaciónen el menú de V i e w Calculadora Gráficas Matrices Cálculos Boleano Programación Alfabeto Griego

Cálculosde V i e w Calculadora Gráficas Matrices Evaluación Boleano Programación Alfabeto Griego Lo que debe

Boleanoi e w Calculadora Gráficas Matrices Evaluación Cálculos Programación Alfabeto Griego Lo que debe aparecer, después

ProgramaciónCalculadora Gráficas Matrices Evaluación Cálculos Boleano Alfabeto Griego Lo que debe aparecer, después de hacer lo

Alfabeto GriegoMatrices Evaluación Cálculos Boleano Programación Lo que debe aparecer, después de hacer lo que te acabo

Lo que debe aparecer, después de hacer lo que te acabo de decir

Simbólico Si colocas el cursor sobre cada ícono, podrás ver el nombre de cada uno

Simbólico

Si colocas el cursor sobre cada ícono, podrás ver el nombre de cada uno de ellos, observa que cada ícono tiene un conjunto de herramientas que puedes usar para desarrollar tu hoja de trabajo.

En la siguiente figura se muestra el menú el cual es muy similar al de word con el cual podemos abrir una hoja en blanco, abrir un archivo existente, mandar a grabar o a imprimir, revisar la ortografía, herramientas para cortar, copiar o pegar, así como regresar (undo), alinear horizontalmente o verticalmente las regiones ya elaboradas, herramientas para insertar funciones, unidades, hiperlinks, objetos o tablas así como para consultar el help

objetos o tablas así como para consultar el help También existe otro menú el cual describiré

También existe otro menú el cual describiré a continuación, que sirve para definir el tipo de texto a insertar así como el tipo de letra y su tamaño, también se puede cambiar el tipo de letra (bold, italic y underline) y la indentación del párrafo, bullets, numerado, superscript y subscript.

El menú de formato sirve para definir las características principales del tipo formato para los textos, así como el tipo y tamaño de letra a usar, así como la indentación del texto.

de letra a usar, así como la indentación del texto. El último menú es para llamar

El último menú es para llamar los recursos disponibles con que cuenta el software (manuales, tutoriales, guías rápidas, sitio del software y tablas de referencias).

rápidas, sitio del software y tablas de referencias). Lección 2: Trabajando con regiones en Mathcad Cada
rápidas, sitio del software y tablas de referencias). Lección 2: Trabajando con regiones en Mathcad Cada

Lección 2: Trabajando con regiones en Mathcad

referencias). Lección 2: Trabajando con regiones en Mathcad Cada ecuación, texto o gráfica en una hoja

Cada ecuación, texto o gráfica en una hoja de Mathcad esta definida por una región, la cual podemos editar simplemente seleccionándola. La región seleccionada se muestra en forma de un rectángulo con líneas delgadas alrededor de él. Si mueves el cursor sobre las líneas, el cursor se cambiará a una pequeña mano que sirve para mover esa región al lugar que deseas. Una región de texto es diferente a una región matemática ya que se ven diferentes. La de texto muestra pequeños cuadros en los extremos que sirven para agrandar o acortar la región y en la región matemática o ecuaciones aparece una línea azul la cual podemos usar para editar la expresión que se encuentra ahí.

Ejemplo 1

Observa una región de texto

Región matemática o de ecuaciones

región de texto

a := 8

Por default cuando colocas el cursor sobre algún lugar de la hoja espera que empieces a definir una región matemática, pero si oprimes la barra espaciadora después de escribir la primera letra, entonces se cambia a región de texto (el cual puedes invocar con la doble comilla "). de cualquier manera en el menú de Insert puedes seleccionar el tipo de región que quieras definir.

Moviendo regiones

Puedes seleccionar múltiples regiones seleccionado con el mouse una región rectangular y aquellas que queden seleccionadas aparecerán con líneas punteadas, las cuales puedes mover todas al mismo tiempo, para deseleccionarla simplemente coloca el mouse fuera de ellas y apriete el botón izquierdo y desaparecerán las líneas punteadas.

Si por error seleccionaste alguna región de más, la puedes deseleccionar simplemente usa la tecla de shift y con el mouse marque la región que no deseas.

Otra manera de ver las regiones también se puede activar, seleccionando Region en el menú de View y aparecen todas las regiones que tenemos en el documento activo.

Nota: Es importante que recuerdes que el documento se evalúa de izquierda a derecha y de arriba hacia abajo por lo que recuerda en colocar las regiones matemáticas en orden para que el software pueda evaluar lo que deseas realizar. Las regiones de texto no importa el orden en que se coloquen.

Ejemplo 2

X := 20

X 2 = 400

Y := 6 3 Y = 1.817
Y := 6
3
Y = 1.817
4 4 q q :=
4 4 q
q :=

q := 5

Observa que en dos de los ejemplos anteriores estamos respetando este concepto para poder evaluar lo que deseo y en el último ejemplo no aparece el resultado deseado.

Para borrar alguna región, seleccionala y con la tecla de suprimir se borra, también lo puedes hacer con el ícono de cut (tijeras en el menú superior o en el menú de Edit), si la región es matemática, arrastre el mouse dentro de ella para que toda la región cambie de color aquellos elementos que deseas borrar, se pueden seleccionar todos. Recuerde que si borras algo por accidente puedes restaurarlo seleccionando Undo en el menú de Edit.

Nota: Puedes cambiar el número de veces en que el undo puede funcionar hacia atras, eso se cambia en preferences del menú tools

hacia atras, eso se cambia en preferences del menú tools Lección 3: Editando expresiones matemáticas y

Lección 3: Editando expresiones matemáticas y de texto.

Lección 3: Editando expresiones matemáticas y de texto. Escribiendo expresiones matemáticas Coloca el cursor en el

Escribiendo expresiones matemáticas

Coloca el cursor en el espacio en blanco y escribe 1+ y observa la pantalla

1 +

el espacio en blanco y escribe 1+ y observa la pantalla 1 + Después de que

Después de que tecleas el signo mas (+) aparece una pequeña marca negra donde podrás continuar escribiendo la expresión que deseas.

1 + 2 = 3

escribiendo la expresión que deseas. 1 + 2 = 3 Después de teclear el signo de

Después de teclear el signo de igual (recuerda que el signo de igual esta en el menú de la calculadora)

Las operaciones básicas las puedes encontrar en la paleta de la calculadora

Escribiendo texto

Para definir una región de texto, selecciona el área donde quieras hacerlo, posicionando el cursor rojo. Escribe una doble comilla y eso te permite seleccionar la región de texto, también puedes hacer lo mismo seleccionando Region text en el menú de Insert. Otra forma de hacer lo mismo es si empiezas a escribir lo que deseas y cuando se oprime la barra espaciadora se cambia a región de texto. Nota que es región de texto porque aparecen los cuadros negros en los extremos de la región límite. Una vez que termines de escribir lo que quieres, coloca el cursor fuera de la región y oprime el boton izquierdo del mouse. Si deseas editar cualquier región simplemente seleccionala y modifica aquello que deseas cambiar

seleccionala y modifica aquello que deseas cambiar Lección 4 Trabajando con estilos de Mathcad y templates

Lección 4 Trabajando con estilos de Mathcad y templates

Lección 4 Trabajando con estilos de Mathcad y templates Introducción Existen actualmente 10 formatos diferentes los

Introducción

Existen actualmente 10 formatos diferentes los cuales puedes usar cuando se inicia un nuevo documento, también puedes crear nuevos templates, tal que ellos esten disponibles para otros documentos.

Usando templates

Para usar un template, selecciona File/New, entonces selecciona el template deseado de la lista mostrada, o busca tu propio directorio de templates que previamente hayas realizado para usarlo o revisarlo.

Usando estilos

Los estilos en cada template son visibles en el menú de Format Bar. Si la barra de formato no está visible, selecciona View Toolbars Formatting. Salva los estilos de tu trabajo, porque puedes aplicarlos como encabezados

En cada región de texto puedes redefinir los fonts, tamaños e indentación para cada nuevo encabezado. Para crear o modificar un estilo, selecciona Format Style. Para guardar tus estilos y posteriormente usarlos en un nuevo archivo, primero debes guardar el archivo template.

Creando Templates

Para crear un nuevo template o revisarlo es muy fácil. Debes:

Crear los estilos del texto y el formato de los números

Seleccionar los fonts y tamaños para las regiones matemáticas

Agregar cualquier mapa de bits que quieras en cada página tales como líneas en la parte superior o inferior del archivo

Colocar el número de página, nombres del archivo y fechas actuales en los encabezados o pies de página

Definir los formatos para los números.

Entonces guarda el archivo bajo Save as y selecciona Mathcad Template. Asegurate que tienes la extensión final .mct. Las características que previamente definiste y guardaste estarán disponibles para el siguiente archivo que quieras, ahorrandote tiempo de retrabajo para cada archivo. Esto hace tus archivos

más consistentes visualmente.

Esto hace tus archivos más consistentes visualmente. Lección 5: Definiendo variables Con frecuencia quieres

Lección 5: Definiendo variables

Ejemplo 3

age := 23

Nota que cuando escribes los dos puntos, es similar a presionar el operador que se encuentra en la paleta de

la calculadora, Mathcad despliega :=. El operador (dos puntos igual) en Mathcad se usa para definiciones o

asignaciones. Para ver cual es el valor de age, solamente escribe la variable y finalmente el signo de igual.

age = 23

Si

quieres asignar un valor diferente a age, solamente selecciona la región donde asignaste el valor de 23 a

la

derecha de la definición, con la tecla de backspace borra el valor de 23 y coloca el nuevo valor. Observa

que tan pronto como presionas el enter, la variable age cambia a su nuevo valor definido, debido a la habilidad de variar el valor de un nombre, esta definición se le llama variable en Mathcad. Ahora puedes usar esta variable en una ecuación.

age10 = 230

O usar la variable para definir otra variable

old := age10

old = 230

Trata de definir algunas variables de tu interés. Puedes llamarles como gustes y úsalas en tu hoja de trabajo. Recuerda que asignas el operador [:] para definiciones y teclea [=] para calcular respuestas

1. Realizar expresiones matemáticas y algebra con operadores matemáticos

Las paletas de los operadores están accesibles a traves del menú o directamente en la parte superior de la ventana. Primero selecciona en la hoja de trabajo el lugar donde deseas colocar el cursor (cruz roja) y posteriormente selecciona de la paleta o inserte el operador matemático que deseas usar en tu hoja. Para familiarizarse con el menú ve al menú de Insert y observa la lista de funciones matemáticas ya preestablecidas en el software (370 funciones) y listas para usarse y colocarse en el lugar que decidas.

y listas para usarse y colocarse en el lugar que decidas. cursor insertar funciones Ahora veamos

cursor

insertar funciones

Ahora veamos algunos ejemplos de cálculos que podemos realizar. Dichos cálculos los realiza el software internamente con 15 decimales, pero para mostrar pocos decimales seleccione Result en el menú Format y especifíca el número de decimales que quieres que te muestre el software, inclusive puedes seleccionar la forma en que te presenta los resultados (general, decimal, notación científica, ingenieril o fraccionaria).

De la paleta de la calculadora puedes accesar todas las operaciones básicas +,-,* y / además de las funciones trigonométricas, raíz cuadrada, logaritmo de base 10, logaritmo natural, así como los números naturales, incluyendo el signo de igual (observa que en esta paleta hay dos signos de igualdad)

Con la paleta de la calculadora realiza los siguientes ejemplos, para obtener el resultado de la operación hecha selecciona el signo de = (igual) en esa misma paleta, o de la barra de herramientas.

Ejemplo 4

Ejemplo 5

Ejemplo 6

Ejemplo 7

Ejemplo 8

Ejemplo 9

Ejemplo 10

Ejemplo 11

Ejemplo 12

Ejemplo 13

2.457 10 ⋅ 8 ⋅sin(1.2) = 281.349 23⋅123 + 4 3 1.3 e log(1567.3) ⋅
2.457 10
8
⋅sin(1.2)
= 281.349
23⋅123
+ 4 3
1.3
e
log(1567.3) ⋅
=
3.829
×
10 16
π ⎞
cos
5 ⋅
2 ⎠
2−3i
(2.45 + 4i) + e = −4.865 + 2.957i
sin(30⋅deg)
cos(30⋅deg) = 0.577
3⋅e
ln(x)
d
x = 1.702
x
e
0.5
5 e
= 8.244
( 2.5 ) ln e log(0.5) = −8.305 5 ⎞ 6.4 csc ⎛ 29 ⎝
(
2.5
)
ln e
log(0.5) = −8.305
5
6.4 csc
⎛ 29
⋅deg − sec(81⋅deg)
60
= 0.72
2⋅cot(12⋅deg)
5
⋅ (
2
)
x
5x
x
d x
0
= 2.5
5 (
2
)
5x
x
d x
0
π
π
4
2
θ
⎛ ⎞
2⋅π⋅θ
3⋅π⋅φ
5 ⋅ ⎛ ⎞
⎝ ⎠
φ
cos
sin
⋅ e
⎝ ⎠
5
10
⎠ d θ d φ
1
2
ln
cos(θ)
+ sin (φ) 3
2
θ 2
+
φ
1
1

= 105.322

Te recomiendo que cambies la forma de mostrar los resultados numéricos para que observes las diferencias entre cada una de ellas. Ahora lo puedes hacer y observa como los resultados anteriormente mostrados se cambian al formato solicitado, y esto lo puedes cambiar en cualquier momento.

Nota: Siempre que se manejen ángulos, estos se pueden expresar en radianes (rad) o grados (deg), pero es importante tener en cuenta que Mathcad siempre asume que el valor dado esta en radianes a menos que se le indique lo contrario, por lo que es muy importante recordarlo siempre. He aquí algunos ejemplos.

Ejemplo 14

sin(45deg) = 0.707

sin

⎛ ⎠ ⎞ = 0.707

π

4

sin(45) = 0.851

sin(45rad) = 0.851

⎝ π 4 sin ( 45 ) = 0.851 sin ( 45 ⋅ rad ) =

Lección 6: Utilizando unidades

sin ( 45 ⋅ rad ) = 0.851 Lección 6: Utilizando unidades Una de las características

Una de las características interesantes de Mathcad es la habilidad en el manejo de unidades durante los cálculos y para convertir las cantidades automáticamente. Por ejemplo, puedes definir variables en términos de unidades predefinidas (kilometros) simplemente multiplicando el número deseado por km. En este ejemplo definiremos el radio de la tierra y su superficie como una función.

r := 6370km

A(r)

y su superficie como una función. r := 6370 ⋅ km A(r) := 4 ⋅π r

:=

4⋅π r 2

(El simbolo π está también disponible en la paleta de la calculadora y en la paleta del alfabeto Griego) entonces puedes evaluar estas expresiones directamente o hacer más cálculos que los involucre.

A (r)

=

5.099

×

10

14 m 2

Observa que el resultado muestra automáticamente las unidades en términos de las unidades base (las cuales se pueden definir desde el inicio o cambiarlas en cualquier momento) en este caso SI (Sistema Internacional). Para ver la superficie de la tierra en hectáreas, selecciona el resultado y aparece en el extremo derecho un cuadrito negro, el cual sirve para que escribas las unidades en que deseas ver ese resultado.

El resultado en hectáreas es:

A (r)

=

5.099

×

10

10

hectare

Una lista de todas unidades previamente predefinidas se puede observar, seleccionando Unit del menú Insert.

w

:= 100joule

definir w

w

= 100 Nm

µm

=

1

×

10

6

m

smoot := 5.23ft

definir smoot

smoot

=

1.594

×

10

µm 6.273 10 7

=

×

6

µm

smoot

Las propiedades de las unidades son muy convenientes porque nos permite darnos cuenta si hemos cometido algún error en los cálculos. Por ejemplo, la fuerza calculada abajo debe estar en newtons (o alguna unidad equivalente de fuerza).

m a := 10 ⋅ sec mass := 2⋅kg
m
a
:=
10
sec
mass := 2⋅kg

F := massa F := mass ⋅

F = 20 s newton

Observa que aparece un factor extraño de segundos, por lo que algo esta mal. Observa las unidades de la

aceleración y te podrás dar cuenta que la aceleración debe tener unidades de m/s 2 lo cual no es así en la definición previa.

Mathcad soporta los siguientes sistemas de unidades:

SI (metro, kilogramo, segundo, etc.)

MKS (metro, kilogramo, segundo)

CGS (centímetro, gramo, segundo)

US (pies, libras, segundo)

NONE (desactiva todas la unidades, pero si el usuario las define aún trabajan)

Las siguientes abreviaturas son usadas más comunmente

masa (kg, gm, lb)

tiempo (sec, hr)

carga (coul)

fuerza (N, dyne, lbf)

potencia (watt, kW, hp)

longitud (m, cm, ft)

corriente (amp)

temperatura (K, R)

presión (Pa, atm, torr, in_Hg, psi)

temperatura (K, R) presión (Pa, atm, torr, in_Hg, psi) Manejo de unidades En Mathcad puedes utilizar

Manejo de unidades

En Mathcad puedes utilizar unidades y el software desplegará los resultados mostrando las unidades seleccionadas por el usuario.

Ahora selecciona worksheet options y unit system en el menú de tools para que escogas el sistema de unidades que quieres utilizar en el documento. (SI, MKS, CGS, U.S, None).

Ejemplo 15

2540km

2hr

=

352.778 m

s

Para insertar las unidades, si no deseas hacerlo en forma manual, selecciona Unit en el menú de Insert y observa todas las unidades previamente definidas en el software.

Si le preguntas el valor de la gravedad, el software ya lo tiene previamente definido (escribe la letra g minúscula y después selecciona el signo de = y obtendrás el valor de la gravedad).

g

=

9.807

m

s 2

c

=

2.998

×

10 8

m

s

gravedad

velocidad de la luz

Observa que algunas letras o nombres de algunas variables ya están previamente definidas en el software por lo que si usas los nombres de esas variables el software te lo indicará, colocando una pequeña marca en la parte inferior de la variable para indicarte que estas usando una variable ya previamente definida, para que decidas cambiarla o redefinirla otra vez. (hay que tener cuidado ya que si vuelves a usar esa misma variable o nombre, ya cambió su valor a la nueva definición y debes de recordarlo).

Ejemplo 16

g := 23456⋅108⋅ 586 g = 6.132 × 10 7
g := 23456⋅108⋅ 586
g
=
6.132
×
10 7

Ojo: observa la marca debajo de la letra g

Lo que acabo de realizar es cambiar el valor de g que estaba previamente definido y si ahora le preguntas de nueva cuenta cuando vale la gravedad, te responderá el último valor previamente definido por ti, como se muestra en el ejemplo anterior, también observa la marca debajo de la letra g donde te indica que esa variable ya esta previamente definida. (mi recomendación es que uses otra letra que no sea reservada).

g =

6.132

×

10 7

uses otra letra que no sea reservada). g = 6.132 × 10 7 Lección 7: Definiendo

Lección 7: Definiendo funciones

g = 6.132 × 10 7 Lección 7: Definiendo funciones La sintaxis usada para definir funciones

La sintaxis usada para definir funciones en Mathcad es la misma que puedes observar en el tutorial. Por ejemplo, coloca el cursor en una posición donde deseas escribir.

Ejemplo 17

f()x :=

x 2

Nota que el uso del operador de asignación de funciones en Mathcad se usa para definir variables en Mathcad. Una vez que defines la función f(x), puedes usarla de muchas maneras.

Escribe un valor numérico en lugar del argumento de f(x)

f(5) = 25

Define una variable y evalúa la función con ese argumento

x := 7

f (x) = 49

Define un rango variable y sustituye este valor como argumento de la función (en la lección 10 profundarizaremos en este tema de rango variables)

a := 0 3 f(a) = 0 1 4 9
a := 0
3
f(a)
=
0
1
4
9

Ahora define una nueva función en términos de f(x)

Este operador se encuentra en el menú de matrix

g()y := fy( g(x) = 55
g()y
:= fy(
g(x) = 55

) + 6

g(7) = 55

Recuerda que la variable x en este momento tiene un valor de 7

x = 7

f(7) = 49

Puedes definir una expresión construyéndola del teclado o de la paleta de operadores matemáticos, como se describe arriba y también puedes incluir cualquier función ya previamente definida. Para ver la lista de funciones con una pequeña descripción, selecciona Function del menú Insert o selecciona

c t i o n del menú I n s e r t o selecciona del

del botón de la barra de herramientas. La caja de diálogos función insert te permite insertar cualquier función que se encuentra previamente predefinida en tu hoja de trabajo

se encuentra previamente predefinida en tu hoja de trabajo También puedes escribir el nombre de cualquier

También puedes escribir el nombre de cualquier función preconstruida directamente del teclado. Aquí hay algunos ejemplos que usan algunas de las funciones predefinidas.

Ejemplo 18

Ejemplo 19

Trig and Logs

Matrix functions

ln(26) = 3.258

csc(45deg) = 1.414

identity(3) =

1

0

0

0

1

0

0

0

1

cols(identity(6)) = 6

2. Definiendo funciones y variables

El símbolo de (dos puntos igual) := es un símbolo de asignación y se puede colocar también usando los dos puntos en el teclado y sirve para asignar algún valor a la variable que deseas definir:

Ejemplo 20

a := 7

a la variable que deseas definir: Ejemplo 20 a : = 7 a + 3 ⋅

a + 3a

+

b

2

b := 8 ⋅ 4⋅c = 314.217
b := 8
4⋅c = 314.217

c := 5

3 ⋅ a + b 2 b := 8 ⋅ 4⋅c = 314.217 c := 5

Esta variable la usa Mathcad12 para definir la velocidad de la luz.

También puedes definir funciones las cuales son evaluadas para cualquier valor de la variable independiente.

Ejemplo 21

f(x) := f(x)

cos(x)

c
c

x

Observa que a pesar de que la variable x no está definida, no marca ningun error. La variable independiente puede ser cualquier variable.

f(4) = −0.523

Ejemplo 22

g(t) := g(t)

f(3.12) = −0.624 4 a e t ⋅ ⋅cos( 6t) ln(t)
f(3.12) = −0.624
4 a e t
⋅cos( 6t)
ln(t)

Ejemplo 23

Ejemplo 24

h()x

:=

(x 4) 2

 

g(x)

:=

a

b sin

h()x := ( x − 4 ) 2   g(x) := a − b sin ⋅

x +

π

4

f(34.6) = 6.914

f(0.0001)

=

2

×

10 5

g(3.4) = −7.746

g(a) = 898.84

h(3.2) = 0.64

h(4) = 0

 

g(3 + a) = 14.824

g(1 + b) = 9.823

Inclusive puedes cambiar el valor de las constantes previamente definidas e inmediatamente se vuelve a recalcular la expresión. En las constantes previamente definidas, a, b, c. Cambia cualquiera de los valores ya asignados y observa como Mathcad recalcula todas las expresiones que usan esas variables.

Selecciona la variable que deseas editar y observa que aparece un cursor color azul, el cual sirve para cambiar la variable que desees. Lo que aparece dentro del pequeño cursor es lo que se selecciona y puedes mover lo que seleccionaste usando las flechas hacia adelante y hacia atras y con el teclado para cambiar el

dato que quieras. Ahora edita varias variables para entender como funciona.

Ahora edita varias variables para entender como funciona. Lección 8: Construyendo expresiones matemáticas Escribe lo
Ahora edita varias variables para entender como funciona. Lección 8: Construyendo expresiones matemáticas Escribe lo
Ahora edita varias variables para entender como funciona. Lección 8: Construyendo expresiones matemáticas Escribe lo

Lección 8: Construyendo expresiones matemáticas

funciona. Lección 8: Construyendo expresiones matemáticas Escribe lo siguiente en un espacio abajo y observa que

Escribe lo siguiente en un espacio abajo y observa que sucede cuando presionas la barra espaciadora

f()x :=

que sucede cuando presionas la barra espaciadora f()x := ( ( x + 6 ) ⋅

(

(x + 6) x

3

1

)

La primera vez que presionaste la barra espaciadora

− 1 ) La primera vez que presionaste la barra espaciadora La línea azul de edición

La línea azul de edición agrupa el término entre parentesis de tal forma que toda la expresión queda multiplicada por la expresión que sigue. Si no presionas la barra espaciadora, se vera lo siguiente.

Si no presionas la barra espaciadora, se vera lo siguiente. La cual es una expresión completamente

La cual es una expresión completamente diferente. Cuando presionas la barra espaciadora la segunda vez, x 3 fue seleccionada por las líneas de edición por lo tanto cuando escribes el -1 se resta a toda la expresión

entera. Compara que sucede cuando tecleas lo siguiente f(x):x+6*(x 3-1) probablemente obtengas lo siguiente.

f()x

3 - 1 ) probablemente obtengas lo siguiente. f()x x := + 6 ⋅ ( 3

x

:= +

6

(

31

x

)

Aquí es importante observar qué sucede cuando presionamos la barra espaciadora, con la cual me permite editar expresiones matemáticas variadas tales como:

Ejemplo 25

x 2 + 3

x 2

+

3

5 5

2

3

+

5

t

x x

1

2

3

Ejemplo 25 x 2 + 3 x 2 + 3 5 5 2 3 + 5

Lección 9: Editando expresiones

+ 3 5 5 2 3 + 5 t x x 1 2 3 Lección 9:

Entendiendo las estructuras de expresiones en Mathcad ayudan a editarlas eficientemente. Observa la expresión de abajo y realiza lo siguiente con el mouse.

f(x) :=

de abajo y realiza lo siguiente con el mouse. f(x) := x 2 + 5 8
x 2 + 5
x 2 + 5

8

x 3

a) Selecciona el símbolo de la raíz cuadrada. Nota que toda la raíz cuadrada está bajo la selección de la líneas

azules

b) Ahora selecciona a la derecha del 5 bajo el radical y entonces empieza a presionar la barra espaciadora.

Nota como mas y mas de la expresión es seleccionada por las líneas azules.

c) Selecciona inmediatamente a la izquierda del 3 en el exponente de x 3 , entonces presiona la barra

espaciadora. Nota como mas y mas elementos se seleccionan con las líneas azules.

Las líneas de edición azules definen subexpresiones que operaran por los siguientes operadores o expresiones tecleadas. La linea vertical azul define en donde se agregaran los operadores y expresiones para cambiar la posición de la línea utilice la tecla de insert.

Cuando seleccionas una parte de la expresión matemática, la siguiente expresión tecleada reemplaza lo que seleccionaste. Esto es probablemente como funciona la mayoría de los procesadores de palabra. Inténtalo ahora.

x 2 + 6 f(x) := − x 3 8
x 2 + 6
f(x) :=
x 3
8

a) Si quieres reemplazar el 5 con un 6, haga doble click sobre el cinco y teclee el 6.

b) Si deseas reemplazar la división por una multiplicación, selecciona a la izquierda del 8 en el denominador,

presiona la barra espaciadora y teclea el signo de multiplicación.

c) Si quieres sacar la raíz cuadrada del lado derecho de la expresión, selecciona el lado izquierdo del radical

y presiona la barra espaciadora hasta que toda la expresión quede contenida en la líneas azules y entonces teclea un backlash.

d) Si deseas restar

1

2 x en lugar de x 3 en el lado derecho, selecciona el x 3 y entonces teclea 1/2[spacebar]*x

Si te equivocas y cometes algún error, solamente selecciona la opción Undo en el menú de Edit para regresar a la expresión original o si no has grabado recientemente el documento, cierrelo sin guardarlo y vuelve abrirlo.

Nota: Se puede deshacer hasta 100 veces por documento, esto se puede cambiar en el menú de Preferences en Tools, el cual puedes cambiar cuando lo desees, aumentándolo o disminuyéndolo.

Lección 10: Definiendo rangos variables

o disminuyéndolo. Lección 10: Definiendo rangos variables Asignar un rango de valores a una variable es

Asignar un rango de valores a una variable es algo muy fácil en Mathcad. Por ejemplo, para crear que la variable x cambie de 0 a 10, solamente coloca el cursor donde deseas que aparezca la expresión y escribe

x:0;10

x := 0

deseas que aparezca la expresión y escribe x:0;10 x := 0 10 Nota que cuando tecleas

10

Nota que cuando tecleas el punto y coma despliega los dos puntos (

debes colocar el valor final. Así es cómo en Mathcad se define un operador de rango variable. Otra manera de hacer lo mismo es teclear directamente el botón de rango variable que se encuentra en la paleta de matrices.

)

seguido por un cuadro negro donde

la paleta de matrices. ) seguido por un cuadro negro donde Puedes también usar un rango

Puedes también usar un rango variable en cualquier otra variable. Observa que Mathcad crea ahora una tabla

de salida (una serie vertical de cuadros que contienen números).

x := 0 5 (x − 5) f(x) −2 ⋅ :=
x := 0
5
(x − 5)
f(x) −2 ⋅
:=

Teclee:

x =

2

5

+ ⋅x 2

2

f(x)

=

0

-52

1

-31.5

2

-15

3

-2.5

4

6

5

10.5

Si quieres cambiar el rango a que los incrementos sean diferentes de uno (que es el valor predeterminado), teclea el siguiente valor deseado después de definir el primer valor inicial. Por ejemplo para crear una rango variable que vaya de 1 a 10 con incrementos de 0.1 escribe.

variable que vaya de 1 a 10 con incrementos de 0.1 escribe. x:1,1.1 10 Observa que

x:1,1.1 10

Observa que se escribió una coma antes del segundo valor del rango y después el punto y coma. Ahora se muestran varios ejemplos.

x := 1 , 1.1 1.8 data := −10 , −8 0 n := 202
x
:= 1 , 1.1
1.8
data := −10 , −8
0
n := 202 , 192
102

He aquí las variables definidas anteriormente.

x =

data =

n =

1

-10

202

1.1

-8

192

1.2

-6

182

1.3

-4

172

1.4

-2

162

1.5

0

152

1.6

142

1.7

132

1.8

122

 

112

102

3. Evaluar funciones y expresiones en un rango

Este z := −3 z =
Este
z := −3
z
=

-3

-2

-1

0

1

2

3

4

5

operador se encuentra en la paleta de matrices m

desde un valor inicial hasta un valor final, el operador también se puede obtener del teclado escribiendo (punto y coma); si le agregas enmedio una coma (,) que significa que la variable cambiará al segundo valor especificado y terminará hasta alcanzar el extremo marcado.

n

y significa que una variable puedes definirla

5 El valor inicial es de -5 y varia de uno en uno hasta alcanzar el valor de 5.

Si ahora quieres que la variable cambie de 0.5 en 0.5 inserta una coma después del valor inicial para indicarle cuál es el siguiente valor deseado.

Ejemplo 26

x := −2 , −1.5

siguiente valor deseado. Ejemplo 26 x := − 2 , − 1.5 2 x = -2

2

x =

-2

-1.5

-1

-0.5

0

0.5

1

1.5

2

Observa que ahora los cambios se dan de 0.5 en 0.5 hasta alcanzar el valor extremo.

se dan de 0.5 en 0.5 hasta alcanzar el valor extremo. Lección 11: Construyendo gráficas Con

Lección 11: Construyendo gráficas

el valor extremo. Lección 11: Construyendo gráficas Con Mathcad es muy fácil construir una grafica x-y

Con Mathcad es muy fácil construir una grafica x-y solamente, escribe una expresión que dependa de una variable, por ejemplo sin(z) y entonces selecciona el botón de la gráfica x-y de la paleta que se encuentra en el menú de gráficas o selecciona gráfica x-y del menú Insert/Graph.

1 0.5 cos(z) 5 2.5 0 2.5 5 0.5 1
1
0.5
cos(z)
5
2.5
0
2.5
5
0.5
1

Inténtalo.

z

La expresión que quieras graficar no tiene que estar en función de x. Teclea lo siguiente y*2[barra espaciadora]-3*y, seguido por @ (es la forma corta de solicitar una gráfica x-y). Mathcad graficará sobre un rango razonable de la variable independiente de la expresión que acabas de escribir. Inténta graficar de esta manera en los siguientes ejemplos.

 

200

100

y

2 3y

 

0

100

a) z*cos(z)

b)

1

1

+

x 2

10 0 10 y
10
0
10
y

Graficando funciones usando rangos variables

Cuando se graficaron las expresiones anteriores, Mathcad seleccionó un rango por default de la variable independiente. Tú puedes controlar el rango que deseas graficar. Para graficar una simple función usando rango variable haga lo siguiente:

Define una función de una variable que deseas graficar. Por ejemplo, grafica la siguiente función f(x):-x^2[barra espaciadora]+8*x-27

Define una variable independiente para el eje horizontal. Por ejemplo escribe x:0;10

Crea tu gráfica en el lugar que deseas hacerlo y teclea @ para que aparezca la gráfica x-y y escribe x en la parte media baja del eje horizontal y teclea f(X) en la parte media del eje vertical después presiona [enter]

Tu gráfica deberá verse así:

f()x

presiona [enter] Tu gráfica deberá verse así: f()x 2 := − + 8 ⋅ x −

2

:= − + 8x 27

x

x := 0 10
x := 0
10

0

20 f(x) 40 60
20
f(x)
40
60
0 5 10 x
0
5
10
x

Aquellas personas que hayan hecho gráficas notarán que la gráfica luce un poco segmentada. Para suavizarla cambia la definición de la variable independiente como se muestra a continuación x:0,0.1;10 La pequeña cantidad incrementada significa que más puntos serán calculados, lo cual hace que la curva sea más suave porque Mathcad simplemente conecta los puntos calculados.

Para editar la gráfica recientemente hecha, solamente haga doble click sobre la gráfica y aparecerá una caja

de diálogo que te permitirá cambiar diferentes opciones como ejes logarítmicos, líneas de la malla, leyendas, tipos de trazo, marcas, colores, límites de los ejes y más. experimente con una gráfica haciendo doble click sobre cualquier gráfica (de contorno, de superficie, vectores, polares etc) y muestra la caja de diálogo correspondiente para darle el formato adecuado.

x := 0 , 0.1 10 0 20 f(x) 40 60
x := 0 , 0.1
10
0
20
f(x)
40
60

Graficando vectores

0 5 10 x
0
5
10
x

Definiendo un vector de datos de gastos realizados. Creamos el vector usando el comando de matrices en el menú de insert. El vector tiene 8 renglones y 1 columna.

gastos :=

⎜ ⎛ ⎞

⎜ ⎟







12.5


14

⎜ ⎝ ⎠

17

2

3

6

8

11

Grafica esos puntos, el eje horizontal debe ser un índice i y la otra variable son los gastos realizados.

i := 0

7

gastos i

variable son los gastos realizados. i := 0 7 gastos i 15 11.25 7.5 3.75 0

15

11.25

7.5

3.75

0

son los gastos realizados. i := 0 7 gastos i 15 11.25 7.5 3.75 0 02468

02468

i

Ahora realiza este otro ejemplo.

Grafica dos vectores de igual tamaño uno contra el otro, definimos un segundo vector llamado día.

dia :=

1

2

3

5

7

8

10

12

Ahora es fácil crear la gráfica tecleando @

20

15

gastos 10
gastos
10

5

0 3.75 7.5 11.25 15
0
3.75
7.5
11.25
15

dia

Aquí los trazos son puntos y se usó el color magenta con O´s. Observa que la malla de líneas verdes se han apagado en ambos ejes.

Graficando una función de vectores

Se puede graficar una función sobre un dominio que no contiene puntos igualmente espaciados. Por ejemplo el dominio consiste de un vector de valores. Graficando una función con los elementos de un vector que requiere una función definida, definiendo un vector el cuál será el dominio para la función y graficarla. Un ejemplo de esto es:

Define una función de una variable. Tecleando f(x):x^2

f()x

Define una función de una variable. Tecleando f(x):x^2 f()x := x 2 Define un vector de

:=

x 2

Define un vector de números que sera el dominio para la función. Teclee x: seguido por [ctrl]M, y lléne en la caja de diálogos el número apropiado de renglones y columnas ( aquí 5 renglones y 1 columna), seguido por OK. Posteriormente escribe los valores del vector.

x :=

por OK. Posteriormente escribe los valores del vector. x := ⎛ − 2.2 ⎞ ⎜ ⎜

2.2


0

3.56

9.9

13

Define un índice variable. Teclee i:0;4

i := 0

Define un índice variable. Teclee i:0;4 i := 0 4 Teclea @ y llena los espacios

4

Teclea @ y llena los espacios de la variable x y y de la gráfica. El resultado obtenido debe ser similar a esto.

100 75 f x () 50 i 25 5 1.25 2.5 6.25 10
100
75
f x
()
50
i
25
5
1.25
2.5
6.25
10

x i

Aquí la diferencia es que cuando graficamos una función de rango variable, el eje horizontal no tiene que

tener incrementos unitarios (tales como 1,2,3, que quieras graficar.

,10)

sin importar, puede ser cualquier conjunto de números

Graficando dos o más funciones

Graficar múltiples funciones sobre un sólo dominio o en una misma gráfica, ya sea usando su propio sistema de ejes o empalmándolas en una sola. Por ejemplo suponga que quiere graficar ambas funciones en una sola gráfica, es fácil solamente escriba la dos funciones separándolas con comas y después teclea @

Escribe 1/t[barra espaciadora],t^2@[enter]

10 1 5 t 10 5 0 5 10 t 2 5 10
10
1
5
t
10
5
0
5
10
t 2
5
10

t

En este ejemplo ambas expresiones están graficadas sobre el mismo rango de valores, pero se puede utilizar dos rangos separados o inclusive usar una escala diferente para cada eje y. Como se muestra a continuación.

10 4 5 1 0 2 t 5 10 0 2 10 1 2
10
4
5
1
0
2
t
5
10
0
2
10
1
2

t

t 2

El segundo eje secundario se habilita cuando editamos la primera gráfica y ahí nos permite habilitar el eje y secundario, ojo no existe un eje x secundario todavía en ésta versión de Mathcad 12.

Ahora veamos el siguiente ejemplo. escribe f(X):sin(x)

Teclea g(t);t^3

Escribe x:-10,-9.9:10

f (x) := sin (x) g()t := t 3 x := −10 , −9.9
f
(x) := sin (x)
g()t
:=
t 3
x := −10 , −9.9

10

Teclea t:-2,-1.9;2

 

t

:= −2 , −1.9

2

Después

Teclea @ en algún espacio en blanco

En la parte media del eje horizontal escribe x,t

En la parte media del eje vertical escribe f(x),g(t)

Aprieta [enter]

El resultado debe ser algo como esto.

10 5 f(x) g(t) 10 5 0 5 10 5 10
10
5
f(x)
g(t)
10
5
0
5
10
5
10

x,t

Como se puede apreciar, graficar más de una función es muy simple, solamente separa sus argumentos con comas (,) La misma sintásis se mantiene para múltiples trazos usando vectores o funciones de vectores.

4. Grafique funciones rápidamente

En cualquier lugar puedes graficar funciones en 2D y 3D y para hacerlo necesitas usar la paleta de gráficas, la cual te permite dibujar funciones muy fácilmente.

Ejemplo 27

f (x) := (3 + sin (x))⋅cos(x) ⎛ 3 ⎞ 2 g(x) := 3 ⎝
f (x)
:= (3 + sin (x))⋅cos(x)
3
2
g(x)
:=
3
2
⋅ cos(x)
+ sin (x) 2

Ejemplo 28

Ejemplo 29

Ejemplo 30

10

5

0

5

f(x)

g(x)

10 5 0
10
5
0

x

x := 0 , 0.01 4 rango que deseo graficar f ()x := x 2
x := 0 , 0.01
4
rango que deseo graficar
f ()x :=
x
2
f(x)
1
0
024
x
x := −5 , −4.99
5
x − 3
g(x) :=
2⋅x +
1
5
g(x)
0
5
50
5

Zxy( , )

:=

2 x

2

2 y 2

x

Ejemplo 31

Ejemplo 31 Z()x , y := ( x 2 + y 2 ) 2 − Z

Z()x, y

Ejemplo 31 Z()x , y := ( x 2 + y 2 ) 2 − Z

:=

(

x

2

+ y

2

)

2

Z

8

(

x

2

y

2 )

31 Z()x , y := ( x 2 + y 2 ) 2 − Z 8

Z

Ejemplo 32

tiempo :=

0

8

⎝ ⎠

3

1

4

2

5

6

7

9

330 320 temp 310
330
320
temp
310

300

290

0 5 10
0
5
10

tiempo

temp :=

298

299

301

304

306

309

312

316

319

322

temp

400

350

temp2 300
temp2
300

250

temp2 :=

305

307

311

316

322

330

341

354

367

382

0 5 10
0
5
10

tiempo

Apretando dos veces el cursor sobre la gráfica, te permite editar los colores y todos los parámetros que quieras cambiar en tu gráfica, incluyendo la posibilidad de ponerle nombre a la gráfica y a las variables involucradas, así como agregar otro eje y (Este eje secundario se activa ahí mismo).

5. Observa datos en dos y tres dimensiones

La siguiente gráfica muestra como Mathcad puedes automáticamente interpolar una serie de puntos para crear una superficie. El mismo arreglo de puntos es desplegada en ambas gráficas. La primera gráfica fue creada usando Graph/3D Scatter Plot del menú Insert. y la segunda gráfica fue hecha usando Graph/Surface Plot del menú Insert. También puedes usar la paleta correspondiente a las gráficas.

puedes usar la paleta correspondiente a las gráficas. X , Y , Z X , Y
puedes usar la paleta correspondiente a las gráficas. X , Y , Z X , Y
puedes usar la paleta correspondiente a las gráficas. X , Y , Z X , Y

X, Y , Z

X, Y, Z

Miguel Angel Ríos Sánchez

24

31/05/2005

6. Calcula sumas e integrales

Los operadores de sumatorias e integrales están en la paleta de cálculo. Para utilizar estas expresiones selecciona el lugar donde desea colocar la expresión y oprime el botón de la paleta y llene los espacios en blanco.

Ejemplo 33

Ejemplo 34

Ejemplo 35

Ejemplo 36

Ejemplo 37

Ejemplo 38

Ejemplo 39

10 1

n!

n

= 0

1

0

1

1 +

x 2

=

d

2.718

x

= 0.785

3

1

(3x + 2) d x

π

0

sin (θ)

d θ

= 16

= 2

π

3

π

6

0

1

2

t

e

4

d

t

=

4

cot(2⋅θ) 2 d θ

1

2

⎮ ⎮ (x + 3) 3

3 x 2 + 16x + 15

= 0.027

d

x

= −0.154

3 3 x 2 + 16 ⋅ x + 15 ⋅ = 0.027 d x =

Lección 12: Definiendo vectores y matrices

d x = − 0.154 Lección 12: Definiendo vectores y matrices Los ejemplos hasta ahora expuestos

Los ejemplos hasta ahora expuestos involucran un sólo número o escalares. Mathcad tiene herramientas muy poderosas para trabajar con arreglos de números, como los vectores y matrices. Creando un vector o una matriz en Mathcad, involucra la selección de las dimensiones del arreglo a llenar en los espacios adecuados. Por ejemplo, para crear un vector v, de 3 renglores y una columna.

Teclea v:

Selecciona insert del menú de matrix (o selecciona el botón de matrices dentro de la paleta de matrices)

Llena el número de renglones y columnas. Por ejemplo, el vector abajo mostrado tiene 3 renglones y una columna)

Selecciona insert

Llena en los espacios los valores deseados en cada espacio mostrado del vector. Usa el tabulador para moverse dentro del vector definido o seleccionalo con el mouse.

v :=

3.2

14.7

4

Para accesar a un elemento en particular del vector, usa el operador subscript, el cual puede ser creado tecleando el parentesis rectangular del lado izquierdo, o usando.

el parentesis rectangular del lado izquierdo, o usando. En la paleta de matrices. Por default el

En la paleta de matrices. Por default el primer elemento tiene el índice 0.

teclea:

v 1 = 3.2

El siguiente elemento tiene el índice 1

v[1=

teclea: v[1=

v 1 = 3.2

Y el último elemento tiene el índice 2

teclea: v[2=

v 2 = 14.7

Si z es una matriz, entonces el tercer elemento de la primera columna puede accesarse tecleando v[2,0

Por conveniencia, podemos definir el índice como un rango variable para accesar a todos los elementos a la vez:

Teclea i:1;3

Después.

i := 1 Escribe v[i=
i := 1
Escribe v[i=
= v i 3.2 14.7 -4
=
v i
3.2
14.7
-4

3

Cómo ejercicio define un vector y sus índices. Es importante entender que el índice de un vector será siempre un rango consecutivo de números enteros en Mathcad, empezando desde 0. cualquier valor no especificado será igualmente definido como cero por Mathcad. Por ejemplo considere el siguiente ejemplo:

Teclea i:2;5

i := 3 6
i := 3
6

Escribe wrong[i:2

wrong i := 4

Escribe wrong=

wrong =

0

0

4

4

4

4

⎝ ⎠

Podrías esperar que el vector wrong tenga cuatro elementos (del segundo al sexto). Sin embargo, como puedes apreciar tiene seis elementos. Esto es porque internamente, Mathcad mantiene al elemento 1 y al segundo. Y porque no fueron definidos específicamente, Mathcad los hace igual a cero.

Es muy útil usar los elementos del vector como argumentos de funciones. Por ejemplo usaremos las constantes y funciones definidas ahora.

b := 9.7 v + 3 f(v) := 9 b 2 ⋅
b := 9.7
v + 3
f(v) :=
9 b 2

a := 1.1 a :=

v + a

Ahora define un vector y úsa sus elementos como argumentos de funciones.

⎛ 3.3 ⎞ ⎜ v := ⎜ −1.2 ⎟ ⎜ ⎝ 8 ⎠ i :=
⎛ 3.3
v :=
⎜ −1.2
8
i := 1
3
f
()
v
=
i
1.11
1.098
1.131

Define un vector y usa sus elementos en una función. También puedes usar vectores como argumentos de funciones. Por ejemplo:

teclea f(x):[ctrl]4x

f()x

de funciones. Por ejemplo: teclea f(x):[ctrl]4x f()x := ∑ x Aquí usamos el operador sumatoria, el

:=

x

Aquí usamos el operador sumatoria, el cual esta disponible a través del botón en la paleta de vectores y

matrices:

v

=

3.3

1.2


8

f (v) = 10.1

3.3 ⎞ ⎜ − 1.2 ⎟ ⎜ ⎝ 8 ⎠ ⎜ f (v) = 10.1 La

La mayoría de los operadores de vectores y matrices pueden encontrarse en ésta paleta, pero aquí muestro una lista de los más básicos.

Operación

Tecla rápida

Producto punto

[Shift]8

Producto cruz

[Ctrl]8

Determinante

I

Columna

[Ctrl]6

Botón de la paleta

Despliega

v.w (despliega el escalar de la multiplicación)I Columna [Ctrl]6 Botón de la paleta Despliega v x w M M < 2 >

v x w vxw

v.w (despliega el escalar de la multiplicación) v x w M M < 2 > Regresa

M

v.w (despliega el escalar de la multiplicación) v x w M M < 2 > Regresa

M

<2>

el escalar de la multiplicación) v x w M M < 2 > Regresa el tercer

Regresa el tercer elemento de la matriz

Mathcad tiene una amplia variedad de funciones pre definidas para manipular vectores y matrices. He aquí una pequeña muestra de ejemplos que usaremos en la matriz M definida a continuación.

Objetivo

Número de columnas

Número de renglones

M :=

7

6

5

1

8 2

9

7

3

Valor mayor en la matriz

Eigenvalores de la matriz

Ejemplo

cols(M) = 3

rows(M) = 3

max (M) = 9

eigenvals(M) =

11.526

11.463

1.938


Hay dos restricciones en los tamaños de arreglos en Mathcad 12

Si quieres definir arreglos con la paleta de matrices, el arreglo no puede tener más de 100 elementos. Puedes teclear varios arreglos y juntarlos para superar esta limitación. (funciones de Augment y Stack)

El número total de elementos en los arreglos dependen de la cantidad de memoria de su computadora,

pero siempre será menor a 8x10 6

Antes de que un arreglo pueda ser usado, debe ser llenado con valores, o inicializado. Hay varios métodos para inicializar estos arreglos en Mathcad. Puedes:

Meter directamente los valores con el teclado

Leer los valores de un archivo

Usar una tabla para llenar el arreglo

Calcular los valores usando una función o un rango variable o

Copiar y pegar los valores de algún otro programa de windows

Ejemplo 40

Ejemplo 41

G 3,2 := 64 ⎛ 0 ⎜ 0 ⎞ G = ⎜ 0 0 ⎟
G
3,2 := 64
⎛ 0
0 ⎞
G =
0
0
0
64

C := READPRN("C:\Documents and Settings\marios\Escritorio\DATOS.txt" )

and Settings\marios\Escritorio\DATOS.txt" ) C = 1 2 1 0 50 2 10 48.2 3 20 46.5

C =

1

2

1 0

50

2 10

48.2

3 20

46.5

4 30

44.8

5 40

43.2

6 50

41.6

7 60

40.1

8 70

38.7

9 80

37.3

10 90

35.9

Ejemplo 42

Para leer un archivo de Excel.

D :=

90 35.9 Ejemplo 42 Para leer un archivo de Excel. D := \DATOS2.xls D = 1

\DATOS2.xls

D =

1

2

1 0

50

2 10

48.2

3 20

46.5

4 30

44.8

5 40

43.2

6 50

41.6

7 60

40.1

8 70

38.7

9 80

37.3

35.9

10 90

En los dos ejemplos anteriores observe que los índices de las tablas empiezan en cero,cero a pesar de que los archivos fueron creados usando Excel y aquí los índices empiezan en uno,uno.

El origen de las matrices se puede cambiar en Worksheet Options del menú Tools donde seleccione Array Origin (ORIGIN) donde puede seleccionar el valor de 1, si quiere que empiece en (1,1)

También puede hacerlo definiéndolo de una manera global

ORIGIN 1

Ejemplo 43

Con esta instrucción acaba de definir de una manera global el origen de los arreglos

A

:=

 

1

2

1 20

38.6

2 30

35.9

3 40

34.6

4 50

33.2

NOTA: Observe que ahora el índice de inicio empieza en 1,1

Ejemplo 44

Ejemplo 45

Ejemplo 46

r := 1 S := r,c
r := 1
S
:=
r,c

5

2

r +

c 2

c := 1

m p l o 4 6 r := 1 S := r,c 5 2 r +

3

S =

5

8

13

⎜ ⎜ 20

⎜ ⎠

⎛ ⎜ 2

10

5

10

17

26

13

18

25

34

29

mifuncion ()rr , c

:=

2

+

c 2

S := matrix(5 , 3 , mifuncion)

, c := 2 + c 2 S := matrix ( 5 , 3 , mifuncion

S =

0

4

9

1

16

ID := identity(6)

1

2

5

10

17

4

5

8

13

20

Ejemplo 47

ID =

1

0

0

0

0

0

A :=

= ⎛ 1 0 0 0 0 0 ⎝ ⎜ ⎜ ⎜ ⎜ ⎜ ⎜ ⎜

1


3

2

0

1

0

0

0

0

0

0

1

0

0

0

0

0

0

1

0

0

2 3

3

4

5

4

0

0

0

0

1

0

0

0

0

0

0

1

B :=

7



8

8 9

9 10

AUG := augment (A , B)

AUG =

1



3

2

2 3

3 4

4 5

7 8

9

8

9 10

9

10

11

STK := stack (A , B)

STK =

1

2

3

7

8

9

2

3

4

8

9

10

3

4

5

9

10

11

9

10

11

7. Cálculo de matrices

Para definir matrices, selecciona en la paleta de matrices el ícono y aparece un menú que te permite elegir el número de columnas y renglones que deseas tener en la matriz, entonces llena los espacios de la matriz que aparece ( de esta forma solamente puedes definir matrices de hasta 100 elementos como máximo).

Ejemplo 48

B :=

de hasta 100 elementos como máximo). Ejemplo 48 B := ⎛ 5 ⎜ 1 5 ⎝

5

1

5

1

2

3

4

6

2

Calcule la inversa de la matriz B

B 1

0.111

= 0.222

0.056

0.111

0.079

0.159

0.111

0.206

0.087

Encuentre el determinante seleccionando el ícono de valor absoluto de x en la misma paleta de matrices.

B = −126 Ejemplo 49 ⎛ 2 −1 ⎞ A := ⎜ ⎝ −7 4
B
= −126
Ejemplo 49
⎛ 2
−1 ⎞
A
:=
−7 4
⎛ −3 0 ⎞ B := ⎜ ⎝ 7 −4 ⎠
⎛ −3 0 ⎞
B :=
7
−4
C := A + B Ejemplo 50 ⎛ −3 0 A := ⎜ ⎝ 7
C := A + B
Ejemplo 50
⎛ −3
0
A
:=
7
−4
D := A + B − C
Ejemplo 51
1 ⎞
3
6
2
−2
D :=
5
7
3
5
−1 0
3
⎛ −1 −1 ⎞ C = ⎜ ⎝ 0 0 ⎠ ⎞ ⎛ 2 −1
⎛ −1 −1 ⎞
C =
0
0 ⎠
⎛ 2
−1 ⎞
B :=
−7 4
D =
⎛ −2 −1 ⎞
2
4 ⎠
⎛ 1 0 ⎞ C := ⎜ ⎝ −2 −4 ⎠
⎛ 1
0
C :=
−2 −4

J :=

2 4 ⎠ ⎛ 1 0 ⎞ C := ⎜ ⎝ −2 −4 ⎠ J :=
⎛ 4 ⎞ ⎜ ⎜ −11 ⎟ ⎜ F := D⋅J ⎝ 7 ⎠
4
⎜ −11 ⎟
F := D⋅J
7

F =

50.5

⎜ ⎟

⎜ ⎝ ⎠

7.667

76.333

8. Solucione ecuaciones numéricamente

Primero escoge una solución para definir una solución probable.

Ejemplo 52

t := 1

probable. E j e m p l o 5 2 t : = 1 Valor inicial

Valor inicial propuesto.

Mathcad encontrará la raíz que se encuentra más cerca de ese valor inicial dado por el usuario.

(

root t 3 sinh(t) , t

) = 1.102

Observa la gráfica de la función, donde se puede apreciar las tres raíces de la ecuación anterior.

t := 2 , 1.99

anterior. t : = − 2 , − 1 . 9 9 2 Aquí definimos los

2 Aquí definimos los valores de la variable independiente.

1 − 1.102 1.102 0 0 t 3 −sinh(t) 1 2 10 1 2 t
1
− 1.102
1.102
0
0
t 3 −sinh(t)
1
2
10
1
2
t
Ejemplo 53
a := a
Esto sólo sirve para limpiar esta variable que ya fue usada anteriormente en un
rango variable.

Puedo obtener todas las raíces de la siguiente manera.

v

:=

p()a

:=

a

3

3 a

2 + 2a + 6

pa( ) coeffs , a

6



2

3

1

r := polyroots(v)

Usa la tecla de coeffs del menú Symbolics que da el vector de

coeficientes del polinomio empezando con el término constante.

Nota que todos los coeficientes están incluidos, aún si ellos son cero:

r T = (1 2 + 1.414i 2 1.414i )

La transpuesta es para que muestre la respuesta en forma horizontal.

j := 0 , 1 2 a := −2 , −1.99 3 Observa que dos
j := 0 , 1
2
a := −2 , −1.99
3
Observa que dos de la raíces son complejas.
20
p(a)
p
()
0
0
r j
polinomio
raices
20
2
101
23
a ,
r j

Ejemplo 54

Define la siguiente función.

Proporciona un valor inicial

Encuentra la solución

Despliega la solución

f()x := x x := 0
f()x
:=
x
x := 0

3 + 12x 21

Soln := root(f ()x , x)

Soln = 1.48

Nota: Si deseas encontrar las otras raíces, lo que necesitas hacer es cambiar tu valor inicial y si tiene raíces

complejas, tu valor inicial debe ser imaginario.

Ejemplo 55

Define la siguiente función

Define los coeficientes del polinomio

Encontrar las soluciones

Despliega la solución

x 3

+

0

x

v :=
v