P. 1
Entorno Dreanwaver Flash Photoshop

Entorno Dreanwaver Flash Photoshop

|Views: 81|Likes:
Publicado porharold0488

More info:

Published by: harold0488 on Dec 02, 2010
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOC, PDF, TXT or read online from Scribd
See more
See less

12/02/2010

pdf

text

original

INTRODUCCION En esta parte del curso de herramientas del software hablare sobre los entornos de aplicaciones que nos

ayudaran en el desarrollo web, además aprender cual es su funcionalidad para las actividades que pronto se acercan a medida que acaba el curso. ENTORNO DREANWAVER MX 2004 QUE ES. Es una aplicación en forma de estudio (basada en la forma de estudio de Adobe Flash) enfocada a la construcción y edición de sitios y aplicaciones Web basadas en estándares. Creado inicialmente por Macromedia (actualmente producido por Adobe Systems).

PARA QUE SIRVE Sirve para la creación de sitios web y aplicaciones, también se usa para la edición creación de código para la web. Además de diseñar, desarrollar y mantener de forma eficaz sitios y aplicaciones Web basados en normas. Con Dreamweaver, los desarrolladores Web lo abarcan todo, desde la creación y mantenimiento de sitios Web básicos hasta aplicaciones avanzadas compatibles con las mejores prácticas y las tecnologías más recientes. COMO FUNCIONA La barra de la aplicación.

La barra la aplicación es una novedad en Dreamweaver CS4. Si tenemos la ventana maximizada veremos todos los elementos de la barra ocupando una sola línea, si no, ocuparán dos líneas, como en la imagen superior.

Cada archivo que tengamos abierto. o al administrador de sitios.Esta barra contiene los siguientes elementos: los menús (en la imagen. lo que nos permitirá cambiar de uno a otro fácilmente. indica que ese archivo tiene cambios sin guardar. aunque en ocasiones nos envíen a los paneles. veremos las operaciones relacionadas con los diferentes elementos que se pueden insertar en Dreamweaver. acceder a las extensiones que se pueden añadir. que aparecen junto al icono. nos permiten (de derecha a izquierda) cambiar entre la vista de diseño o código. varios botones propios de la aplicación. Los botones propios de la aplicación. Lo veremos más adelante. como un desplegable. Las pestañas de documento. que ya veremos. Los menús. están agrupados en categorías. Todas las opciones de Dreamweaver son accesibles a través de los menús. Si junto al nombre aparece un *. por ejemplo. mostrará una pestaña con su nombre. el conmutador de espacio de trabajo y una caja de búsquedas para obtener ayuda on line. Al hacer clic en Insertar. Más hacia la derecha observamos el conmutador del espacio de trabajo. Un espacio de trabajo es la configuración del entorno (paneles visibles y su disposición) que podemos guardar y cargar. en la parte inferior). Podemos cerrar cada .

. Dreamweaver CS4 añade una novedad. o acceder a otras acciones haciendo clic con el botón derecho. A parte. Siguiendo hacia la derecha encontramos las herramientas de Selección. La barra de estado. existen otras que podemos ver u ocultar desde el menú Ver → Barras de herramientas. Mano (para desplazarse) y Zoom. etc. Y otros datos como el tamaño de la ventana. Pudiendo acceder a ellos con un clic. Esto nos ahorrará bastante tiempo. como la hoja de estilos. Nos sirve para seleccionar etiquetas completas. archivos Java Script. el tamaño de la página o su codificación.. Hasta aquí las barras que siempre veremos en la aplicación. A la izquierda. Esta barra la encontramos debajo de la ventana de documento.. como Cerrar otros archivos.Documento clicando en el aspa. encontramos el selector de etiquetas. Debajo de las pestañas encontramos los archivos a que utiliza nuestra página. y nos da información sobre el mismo.

La barra de herramientas estándar contiene iconos para realizar las acciones más habituales del menú Archivo y Edición. Es actualmente desarrollado y distribuido por Adobe Systems. De izquierda a derecha: Nuevo archivo. Imprimir el código fuente. mucho menos utilizada. sonido.La barra de herramientas estándar. destinado a la producción y entrega de contenido interactivo para las diferentes audiencias alrededor del mundo sin importar la plataforma. acceder cómodamente al título de la página. Pegar. La barra de representación de estilos. Abrir. Cortar. Copiar. y utiliza gráficos vectoriales e imágenes ráster. ENTORNO FLASH QUE ES Es una aplicación en forma de estudio que trabaja sobre "fotogramas". Esta barra. La barra de herramientas de documento. La barra de herramientas de documento contiene iconos que nos permiten cambiar entre las distintas vistas de edición y la vista en vivo. explorar con Adobe Bridge. código de programa. nos permite ver la apariencia de nuestra web en distintos dispositivos. si estamos utilizando hojas distintas que dependan del eso. Deshacer y Rehacer. Guardar. flujo de vídeo y audio bidireccional (el flujo de subida . o realizar las distintas opciones de validación que nos ofrece el programa. Guardar todo.

También incluye la posibilidad de crear una cuadrícula y unas guías. te permite moverte por los fotogramas y por las escenas. así como nuevos fotogramas. Modificar: La opción Transformar permite modificar los gráficos existentes en la película. aunque tiene algunas particularidades. Ver: Además de los típicos Zooms. escenas. Es similar a la de cualquier otro programa de diseño web o gráfico. Edición: Es el clásico menú que te permite Cortar. Esto se puede seleccionar desde los submenús Cuadrícula y Guías desde donde también se pueden configurar sus opciones. Destaca la potencia de la utilidad Importar que inserta en la película actual casi todo tipo de archivos (sonidos.. y la opción Trazar Mapa de Bits convierte los gráficos en mapas vectoriales . imágenes e incluso otras películas Flash). capas. también permite personalizar algunas de las opciones más comunes del programa.sólo está disponible si se usa conjuntamente con Macromedia Flash Communication Server).. La Barra de Menús La Barra de Menús tiene como propósito facilitar el acceso a las distintas utilidades del programa.... abrirlos. Veamos los principales Submenús a los que se puede acceder: Archivo: Permite crear nuevos archivos... vídeo.. Pegar. acciones. Insertar: Permite insertar objetos en la película. guardarlos. En sentido estricto. También permite configurar la impresión de las páginas. imprimirlas. Copiar. tanto objetos o dibujos como fotogramas. o la de Configuración de Publicación desde donde se pueden modificar las características de la publicación. Flash es el entorno y Flash Player es el programa de máquina virtual utilizado para ejecutar los archivos generados con Flash.

entre ellos se encuentran Entrar.. Ventana: Este menú.. Texto: Sus contenidos afectan a la edición de texto. La Línea de Tiempo La Línea de Tiempo representa una forma de ver los fotogramas de modo simplificado. .). lecciones guiadas etc. Probar Película. Salir. Control: Desde aquí se modifican las propiedades de reproducción de la película. hasta el diccionario de Action Script... además de las opciones clásicas acerca de cómo distribuir las ventanas.(este tema se tratará más adelante). Pasar. Comandos: Permite administrar los Comandos (conjunto de sentencias almacenadas que permiten emular lo que un usuario pueda introducir en el entorno de edición) que hayamos almacenado en nuestra animación. Ayuda: Desde aquí podemos acceder a toda la ayuda que nos ofrece Adobe. obtener otros nuevos de la página de Macromedia o ejecutar los que ya tengamos. Optimizar o de la propia película (Capa. Reproducir. Consta de 2 partes. Rebobinar. cargarlos. etc. incluye accesos directos a todos los paneles y también la posibilidad de crear tus propios Espacios de Trabajo. pasando por tutoriales.. desde el manual existente. guardarlos.. Más adelante se tratará en profundidad. El resto de opciones permite modificar características de los elementos de la animación Suavizar. Depurar: Aquí encontraremos las opciones de depuración de la película que te ayudarñan a encontrar errores de progrmación en ActionScrit... Escena .. Continuar.

1) Los Fotogramas (frames) que vienen delimitados por líneas verticales (formando rectángulos) 2) Los Números de Fotograma que permiten saber qué número tiene asignado cada fotograma. El uso de múltiples capas además. Las ventajas y desventajas de usar capas se verá en la unidad referente a Capas. A nivel conceptual. veamos a grandes rasgos qué son las capas. pero otras veces es conveniente separar los objetos de modo que no interfieran entre sí. cuánto dura o cuándo aparecerá en la película. se le dedicará un tema completo. Es decir.0 en la imagen) y el Tiempo de película transcurrido (0. en el orden que establece la misma Línea de tiempo. la Línea de Tiempo representa la sucesión de Fotogramas en el tiempo. Es decir. Una Capa se puede definir como una película independiente de un único nivel. por ejemplo).0s en la imagen). . Esto es interesante a menudo. en la parte inferior hay herramientas para trabajar con Papel cebolla e información sobre el Número de Fotograma actual (1 en la imagen). da lugar a películas bien ordenadas y de fácil manejo (es conveniente colocar los el código ActionScript en una capa independiente llamada "acciones". crearemos tantas capas como sea necesario. Las Capas El concepto de Capa es fundamental para manejar Flash de forma eficiente. Aún así. la película Flash no será nada más que los fotogramas que aparecen en la Línea de tiempo uno detrás de otro. Los objetos que estén en una determinada capa comparten fotograma y por tanto. pueden "mezclarse" entre sí. Para ello. la Velocidad de los Fotogramas (24. una capa contiene su propia Línea de Tiempo (con infinitos fotogramas). Además. Dada la importancia de estas. Para saber más acerca de la Línea de Tiempo y de los distintos tipos de fotogramas que existen visita nuestra Página Avanzada.

ya que coinciden con las Propiedades del documento. Para acceder a ellas. hagamos clic con el botón derecho sobre cualquier parte del escenario en la que no haya ningún objeto y después sobre Propiedades del documento: Añade metadatos a tus archivos para una mejor inclusión de estos en los motores de busqueda rellenando los campos de Título y Descripción.El Escenario A continuación veremos las diferentes partes que conforman el Área de trabajo empezaremos con la más importante: el Escenario. Coincidir: Provocan que el tamaño de la película coincida con el botón seleccionado (tamaño por defecto de la Impresora. Sobre el escenario dibujaremos y colocaremos los diferentes elementos de la película que estemos realizando. . El tamaño mínimo es de 1 x 1 px (píxeles) y el máximo de 2880 x 2880 px. Contenidos existentes o los elegidos como Predeterminados) Color de Fondo: El color aquí seleccionado será el color de fondo de toda la película. El escenario tiene unas propiedades muy importantes. Dimensiones: Determinan el tamaño de la película.

permitiendo abarcar más o menos zona del Entorno de Trabajo. Pudiéndose expandir o minimizar con un clic de ratón. irá en el Panel Acciones). Estas propiedades por supuesto podrán ser alteradas desde este panel cuando se desee. Son muy útiles y ayudan a acelerar el trabajo cuando se emplean correctamente. Transformar en predeterminado: Este botón. Cada vez que hagamos clic en con el Zoom duplicaremos el porcentaje indicado en el desplegable Zooms. . propio de la nueva versión de Flash. Su misión es simplificar y facilitar el uso de los comandos. puedes visualizarlos desplegando el menú Ventana y haciendo clic sobre el nombre del panel que quieras mostrar. Panel Zooms: Son un conjunto de accesos directos a Submenús existentes en el Menú Ver. Fotogramas: O número de fotogramas por segundo que aparecerán en la película. Estos paneles o ventanas se encuentran organizados en el lateral derecho del área de trabajo. todo lo que haga referencia a las acciones. permite almacenar las propiedades del documento actual y aplicarlas a todos los documentos nuevos que se creen desde ese instante en adelante. Los Paneles Los Paneles son conjuntos de comandos agrupados según su función (por ejemplo. Unidades de Regla: Unidad que se empleará para medir las cantidades. Las Vistas o Zooms La Herramienta Zoom se emplea para acercar o alejar la vista de un objeto. Para saber más acerca de los Zooms página Básica. Si no están visibles en el lateral derecho.Veloc.

Ahora sólo bastará darle un nombre a la disposición y será accesible desde el mismo elemento de menú Espacio de trabajo en cualquier momento. (Incluidas nuestras creaciones). Aún así. para que si en algún momento el entorno se vuelve un poco caótico puedas recuperar tu configuración elegida desde el menú Ventana. Panel Información: Muestra el tamaño y las coordenadas de los objetos seleccionados. permitiéndonos modificarlas. vamos a nombrarlos y a resumir las funciones de la mayoría de ellos. Muy útil para alineaciones exactas. Muy útil. Todos los paneles se estudiarán en profundidad a lo largo del curso. Panel Alinear: Coloca los objetos del modo que le indiquemos. Flash permite cargar y guardar tus propias disposiciones de paneles.Para mejorar la experiencia del usuario. . Para ello deberás acceder a la opción Ventana → Espacio de trabajo → Nuevo espacio de trabajo y asignar un nombre a nuestro nuevo espacio. Panel Color: Mediante este panel creamos los colores que más nos gusten. Panel Muestras: Nos permite seleccionar un color de modo rápido y gráfico.

Nos muestra las propiedades del objeto seleccionado en ese instante..te lo explicamos en nuestro tema básico.. Panel Propiedades: Sin duda. así como las marcas registradas Photoshop y Adobe.Panel Escena: Modifica los atributos de las escenas que usemos.. tipo de trazo. color de borde. . encoge.). Panel Comportamientos: Permiten asignar a determinados objetos una serie de características (comportamientos) que después podrán almacenarse para aplicarse a otros objetos de forma rápida y eficaz. tamaño de los caracteres. tamaño etc. Si aún no sabes lo que son las Escenas. los objetos seleccionados. propiedades de los objetos (si hay interpolaciones etc.. Panel Explorador de Películas: Nos permite acceder a todo el contenido de nuestra película de forma fácil y rápida ENTORNO PHOTOSHOP Photoshop. Panel Respuestas: Macromedia pone a nuestra disposición ayuda y consejos accesibles desde este panel. Los componentes son objetos "inteligentes" con propiedades características y muchas utilidades (calendarios.. scrolls etc.. de fondo.) Panel Cadenas: Mediante este panel Flash aporta soporte multi-idioma a nuestras películas. es una de las herramientas software para el tratamiento de imagen más potente y popular de hoy en día Los logotipos de Photoshop son propiedad de Adobe. Panel Acciones: De gran ayuda para emplear Action Script y asociar acciones a nuestra película. aulaClic no tiene ninguna relación con Adobe. creado por Adobe Systems.. Panel Transformar: Ensancha. coordenadas. no debes perderlo de vista nunca. gira . Panel Componentes: Nos permite acceder a los Componentes ya construidos y listos para ser usados que nos proporciona Flash. tipografía. Es fundamental.. el panel más usado y más importante.

Vamos a ver los pasos a seguir para abrir un archivo desde Photoshop: Una vez arrancado el programa. Entonces. transformarla y editarla con un sinfín de posibilidades. . pues Adobe ha sabido crear un programa intuitivo y muy completo que hace que se desmarque de la competencia y sea el software más utilizado por diseñadores e ilustradores. para eso es recomendable que utilices Illustrator. esta es una de las características más interesantes de Photoshop. lo primero que tendremos que hacer será abrirla con Photoshop. haz clic en Archivo en la barra de menú. o bien creadas por otros programas. Abrir una imagen Para comenzar a editar una imagen. también de Adobe.Debemos tener bien claro desde el principio que Photoshop no está pensado para dibujar. Se desplegará una lista como esta: Para abrir una imagen deberás hacer clic en Abrir. De hecho. o digitalizadas por un escáner o máquina fotográfica. una vez introducida la imagen en el programa podrías retocarla. Photoshop está principalmente orientado a tratar y manipular imágenes. y se abrirá un cuadro de diálogo.

. Cuando lo tengas seleccionado. También existe una forma más rápida. haz clic en Abrir y la imagen se abrirá en una ventana dentro del programa. lo que deberás hacer es navegar por las carpetas hasta encontrar el archivo deseado. encontramos la opción Abrir con → Adobe Photoshop CS5 en el menú contextual de la imagen.Llegados a este punto. Incluso desde el Explorador de Windows. que es arrastrar la imagen desde una ventana del Explorador de Windows directamente al área de trabajo de Photoshop.

Puedes abrirlo haciendo clic en Archivo → Buscar en Bridge o desde el icono sobre la barra de menú. Además.Puedes abrir simultáneamente tantas imágenes como tu ordenador soporte. te permite acceder directamente a muchas de las opciones de Photoshop. pero ten en cuenta que cuantos más recursos consumas más lento irá el programa. . Adobe Bridge te permite navegar por tus carpetas y organizar tus imágenes de forma más eficiente. pudiendo añadir información sobre la imagen (llamada metadatos) como su autor. una breve descripción o incluso darle un título. por ejemplo desde el menú contextual de la imagen. Una de las características que se añadió en las versiones CS Photoshop es Adobe Bridge. además de otro tipo de datos técnicos y sobre derechos de autor.

Si quieres saber más sobre Adobe Bridge visita el tema avanzado de Exploración de archivos. .

En la última versión. que nos permite explorar archivos directamente desde un panel. Para abrir Mini Bridge. puedes usar su icono El área de trabajo Una vez abierto el programa observaremos diferentes barras y paneles distribuidos en el entorno de trabajo. Abramos una imagen de prueba para que todas las opciones se encuentren disponibles. Resulta especialmente útil si vamos a ir necesitando imágenes de una misma carpeta. sobre la barra de menús. se ha añadido Mini ridge. . Recuerda que podemos abrir nuestros archivos a través del menú Archivo → Abrir.

Una vez abierta la imagen. todas las barras y paneles se encuentran activos y el área de trabajo toma esta forma: Puedes hacer que la disposición de los paneles y barras vuelvan al estado predeterminado haciendo clic en la opción Ventana → Espacio de trabajo: .

y se ha de comprar una licencia para poder usarlo indefinidamente. Todos estos tipos de espacio mostrarán unas ventanas u otras (normalmente todas tienen las mismas). Color y tono. Análisis. Pintura..O directamente desde la barra superior: Otra de las opciones que se te presentan es seleccionar un espacio de trabajo predefinido. pero por un periodo de 30 días. etc. Adobe permite descargar y probar el programa totalmente gratis.. Photoshop es un software comercial. podrás seleccionar entre 3D avanzado. Automatización. y destacarán las opciones de menú más utilizadas para las diferentes tareas. No obstante. . Estos modos son muy útiles para trabajar con más comodidad pues visualmente te será más rápido acceder a una opción de esta forma.

OBJETIVOS ESPECIFICOS • • • Conocer el entorno dreanwaver mx Conocer el entorno flash Conocer el entorno photoshop • Diferenciar las utilidades en las que se puede llegar a desempeñar cada software.es/flash-cs4/t_2_4.htm. . BIBLIOGRAFIA Sitios web referenciados. http://www.es/photoshop-cs5/t_1_2.aulaclic. Además nos familiarizamos con el entorno de los programas o software que nos ayudaran a la hora de crear nuestro proyecto.aulaclic. CONCLUSIONES Para el desarrollo y diseño de páginas web existen muchas herramientas con las cuales no podemos defender a la hora de implementarlas en la construcción de un sitio web. http://www.htm.OBJETIVOS GENERALES Entender y aprender los diferentes entornos que hay en cada aplicación o herramienta para la creación de páginas y web y diseño de imágenes y graficas.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->