P. 1
pseudocodigo ejemplos

pseudocodigo ejemplos

|Views: 9.690|Likes:
Publicado poralejandrojar

More info:

Published by: alejandrojar on May 07, 2010
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PPTX, PDF, TXT or read online from Scribd
See more
See less

08/06/2013

pdf

text

original

EJERCICIOS VARIOS

€Ejemplo : btener el promedio de las
calificaciones de un grupo de 30 alumnos

INICIO
NUM = 1
CALIF = 0
RESULT = 0
SUMA = 0
SUMA = SUMA +
CALIF
CALIF
NUM < 30
RESULT = SUMA /
NUM
RESULT
FIN
NUM = NUM + 1
NO
SI
Inicio del algoritmo
Num =1 , Result = 0
Suma = 0 , Calif = 0
Etiqueta A:
Lee Calif
Suma = Suma + Calif
Si Num es menor que 30
Num toma Num + 1
Ir a Etiqueta A
Si no
Result = Suma / 30
Fin Si
Escribe Suma / 30
Fin del algoritmo
Ejemplo (Ejemplo anterior):
Inicio del algoritmo
a=0 , b= 1, suma = 0
Lee n
Escribe a,b
Mientras suma < n
suma = a+ b
Escribe suma
a = b
b = suma
Fin Mientras
Fin del algoritmo
introducir una medida expresada en
centímetros para su conversión en pulgadas
(1 pulgada = 2,54 centímetros)
Inicio Algoritmo
CM_PULG = 2.54
Escribir ³INTRODUZCA VALOR EN
CENTIMETROS´
LEER cm
pulgadas = cm / CM_PULG
Escribir ³Pulgadas: ´, pulgadas
Fin Algoritmo
Pseudocodigo para calcular el producto de
números pares enteros del 10 al 20
Inicio algoritmo
suma = 0, conta = 10, producto =1
Mientras conta <= 20
Producto = producto * conta
conta = conta + 2
Fin Mientras
Escribir ´El producto esµ; producto
Fin algoritmo

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->