Está en la página 1de 8

INSTRUCCIONES SELECTIVAS DE BIFURCACION

Se utilizan para evaluar condiciones que pueden ser simples o compuestas.


Los tipos de instrucciones selectivas son:
A.
B.
C.
D.

Simples
Dobles
Anidas
Mltiples

La sintaxis de una instruccin simple a nivel pseudocodigo es:


SI (condicin) ENTONCES
INICIO
Instrucciones varias.
FIN SI
La sintaxis a nivel de diagrama de flujo es:

SI (CONDICION)

La sintaxis de una instruccin doble a nivel de de pseudocodigo es:


SI (condiciones) ENTONCES
INICIO
Instrucciones varias
FIN SI
SINO
INICIO
Instrucciones varias
FIN SI

La sintaxis a nivel de diagrama de flujo es:

SI ( condicin)

Condicion simple: Si solo utiliza operadores de relacin


Compuesta: si utiliza relaciones como (and or not) (< > =)
Ejemplo.
SI ((a<b) y (b<c))

Si(nota >=61) ENTONCES


INICIO
MOSTRAR (APROBADO)
FIN SI
SINO
INICIO
MOSTRAR (NO APROBADO)
FIN SINO

EJERCICIO

Elabore pseudocodigo y diagrama para aplicar el 15% de aumento a un


empleado si tiene ms de 10 aos en la empresa.Muestre el sueldo anterior y
el nuevo sueldo, as como el nombre del empleado

ALGORITMO Aumento
/*El siguiente algoritmo mostrara el aumento de los empleados que tengan
ms de 10 aos en la empresa */
CONSTANTES
P0.15
VARIABLES
REAL: Sueldo_base, nuevo_sueldo
CADENA: nombre [40]
ENTERO: aos
INICIO
MOSTRAR( INGRESE SU NOMBRE, +CDL)
LEER (Nombre )
MOSTRAR (INGRESE SU SUELDO, +CDL)
LEER( sueldo base )
MOSTRAR (INGRESE LA CANTIDAD DE AOS LABORADOS, +CDL)
LEER( aos)

SI (aos>=10) ENTONCES
INICIO
Aumento= sueldo_base + sueldo_base*P
Nuevo sueldo= sueldo_base+ Aumento
MOSTRAR( SEOR/a, nom, Su SUELDO BASE ES EL SIGUIENTE:,
sueldo_base,+CDL)
MOSTRAR(SU SUELDO NUEVO ES:sueldo_nuevo, +CDL)
FIN SI

SINO
INICIO
MOSTRAR( SEOR/a, nom, Su SUELDO BASE ES EL SIGUIENTE:,
sueldo_base,+CDL)

MOSTRAR (SU TIEMPO EN EL TRABAJO NO APLICA AL BONO DE


AUMENTO, +CDL)
FIN SINO

FIN ALGORITMO Aumento

B
1
INICIO
MOSTRAR (INGRESE SU
SUELDO, +CDL)

P0.15
REAL:
Sueldo_base,nuevo_sueldo
CADENA: nombre [40]

LEER (sueldo_base)

ENTERO: aos

MOSTRAR( INGRESE SU
NOMBRE, +CDL)

LEER( aos)

LEER (Nombre )

2
SI(aos
>=10)

MOSTRAR (INGRESE LA
CANTIDAD DE AOS
LABORADOS, +CDL)

A
SI

MOSTRAR( SEOR
/a, nom, Su
SUELDO BASE ES
EL SIGUIENTE:,
sueldo_base,
+CDL)

Aumento=
sueldo_base +
sueldo_base*P

no

Nuevo sueldo=
sueldo_base+
Aumento
MOSTRAR(SU SUELDO
NUEVO
ES:sueldo_nuevo,
+CDL)MOSTRAR(SU
SUELDO NUEVO
ES:sueldo_nuevo,
+CDL)

MOSTRAR( SEOR
/a, nom, Su
SUELDO BASE ES
EL SIGUIENTE:,
sueldo_base,
+CDL)

MOSTRAR (SU
TIEMPO EN EL
TRABAJO NO
APLICA AL BONO
DE AUMENTO,
+CDL)
FIN

TAREA

Genere un nmero aleatorio entre -15 y75, determine si el nmero es positivo o


negativo y si es par o impar.

ALGORTIMO aleatorio
/*El siguiente algoritmo dar un numero aleatorio entre -15 y 75 y clasificara si el
nmero es positivo o negativo o si par o impar*/
CONSTANTES//no hay
VARIABLES
ENTERO: A, par, impar, pos, neg
INICIO
ARAND()%91+(-15)

MOSTRAR(Su numero aleatorio entre -15 a 75 es,A,+CDL)

SI (A>0) ENTONCES
INICIO
MOSTRAR (El numero obtenido es positivo, pos, +CDL)
FIN SI
SINO
INICIO
MOSTRAR (El numero aleatorio es negativo, neg, +CDL)
FIN SINO
SI ((A mod 2)=0) ENTONCES
INICIO
MOSTRAR (El numero aleatorio es par,par, +CDL)
FIN SI
SINO
INICIO
MOSTRAR(el numero aleatorio es impar,impar,+CDL)

FIN SINO
FIN ALGORTIMO aleatorio

DIAGRAMA DE FLUJOS

INICIO

ENTERO: A, par,
impar, pos, neg
ARAND()
%91+(-15)

MOSTRAR(Su
numero aleatorio
entre -15 a 75
es,A,+CDL)

SI

SI
(A>0)

MOSTRAR (El
numero obtenido es
positivo, pos,
+CDL)

no

SI ((A
mod
2)=0)

MOSTRAR (El
numero aleatorio es
negativo, neg,
+CDL)

MOSTRAR(el
numero aleatorio
es
FIN
impar,impar,+CDL)

SI

MOSTRAR (El
numero aleatorio es
par,par, +CDL)

no