Está en la página 1de 7

Republica Bolivariana de Venezuela

Ministerio del poder popular para la Educacin Superior


Universidad Nacional Experimental
Francisco de Miranda
rea: Ciencias de la Educacin
Programa: Educacin Mencin Informtica

Algoritmos:
Introduccin a los Pseudocdigos
y
Diagramas de Flujo
Prof.:
Yosannys Naveda

Bachilleres:
Reyes, Carlos.
C.I: V-25.945.209
Loaiza, Humberto
C.I: V-22.600.939

Algoritmo

Conjunto prescrito
Ordenado y finito
Pasos sucesivos y claros
Estado inicial y entrada

Estado final y solucin

En la vida cotidiana
se emplean
algoritmos
frecuentemente,
como una receta de
cocina o la rutina
diaria.

Pseudocdigo
Utilizado por programadores
Lenguaje humano simplificado
Independiente de los lenguajes
de programacin
Omite detalles no esenciales
en un algoritmo
No tiene sintaxis exacta

Un pseudocdigo es
escrito de la forma
en que el
programador lo
requiera.

Diagramas de flujo

Descripciones grficas de algoritmos


Smbolos conectados con flechas
Los smbolos representan los
pasos de un cdigo o un algoritmo

Inicio/
Final

Entrada
de datos

Proceso

Salida de
datos

Decisin

Representan algoritmos pequeos

Son de fcil lectura

Consideraciones:
Instrucciones
primitivas.
Instrucciones de
proceso.
Instrucciones de
control.
Instrucciones
compuestas.

Ejemplo: Sumar dos nmeros pares y mostrar el


promedio
Pseudocdigo:

Diagrama de Flujo:
Inicio

1 Inicio_Proceso
2 Definir N1, N2 como enteros
3 Definir P como flotante
4 Escribir: Ingrese primer valor
5 Leer N1
6 Si N1%2=0
7 Escribir: El numero debe ser par
8
Volver al paso 4
9 Sino
10 Escribir: Ingrese segundo valor
11 Leer N2
12 Si N2%2=0
13
Escribir: El numero debe ser
par
14
Volver al paso 7
15 Sino
P=(N1+N2)/2
Fin_Si
Fin_Si
Escribir: El promedio es P
Fin_Proceso

Ingrese
valor 1

N1%2=0
N1%2=0

N1
Ingrese
valor 2

N2%2=0
N2%2=0

N2
P=(N1+N2)/2
El
promedio es
P

Fin

GRACIAS
POR SU
ATENCIN
!!!