Está en la página 1de 7

INTRODUCCION A LA PROGRAMACION

Docente Ing. Irma Prado


EJERCICIOS CON LA SENTENCIA WHILE
Grupo A: Control de repeticiones, con una variable de control.
1. Desplegar en pantalla nmeros correlativos desde 1 hasta 100.
i<-1;
Mientras i<=100 Hacer
Escribir i;
i<-i+1
FinMientras
2. Desplegar en pantalla nmeros pares desde 10 hasta 60.
Proceso SinTitulo
i<-10
Mientras i<=60 Hacer
Escribir i;
i<-i+2
FinMientras
FinProceso
3. Desplegar en pantalla nmeros comprendidos desde 1 hasta X, donde X es
positivo.
Proceso SinTitulo
Escribir "X ??";
Leer x
Mientras x<=0 Hacer
Escribir "x??";
Leer x
FinMientras
i<-1
Mientras i<=x Hacer
Escribir i;
i<-i+1
FinMientras
FinProceso
4. Desplegar en pantalla nmeros comprendidos desde -100 hasta 0.
Proceso SinTitulo
i<- -100
Mientras i<=0 Hacer
Escribir i;
i<-i+1
FinMientras
FinProceso
5. Desplegar en pantalla 200 veces la palabra HOLA.
Proceso SinTitulo
i<-1
Mientras i<=200 Hacer
Escribir "Hola";
i<-i+1
FinMientras
FinProceso
6. Dado un nmero N, desplegar N asteriscos.
Proceso SinTitulo
Escribir "ingrese un numero";
Leer n
Mientras n<=0 Hacer
Escribir "positivo porfa";
Leer n
FinMientras
Pg: 1
CHRISTIAN ESPINOZA ROMERO

INTRODUCCION A LA PROGRAMACION
Docente Ing. Irma Prado
i<-1
Mientras i<=n Hacer
Escribir "*";
i<-i+1
FinMientras
FinProceso
7. Dado el nmero P desplegar:
a. Si P>0, desplegar los nmeros correlativos desde 1 hasta P.
b. Si P<0, desplegar los nmeros negativos correlativos, desde -1
hasta P.
c. Si P=0, desplegar la palabra CERO.
Proceso SinTitulo
Escribir "ingrese P";
Leer p
Si p>0 Entonces
i<-1
Mientras i<=p Hacer
Escribir i;
i<-i+1
FinMientras
FinSi
Si p<0 Entonces
i<- -1
Mientras i>=p Hacer
Escribir i;
i<-i-1
FinMientras
FinSi
Si p=0 Entonces
Escribir "CERO";
FinSi
FinProceso
8. Dado el nmero X desplegar la TABLA DE MULTIPLICACION DE X.
Proceso SinTitulo
Escribir "Ingresar x";
Leer x
i<-1
Mientras i<=10 Hacer
r<-x*i;
Escribir r;
i<-i+1
FinMientras
FinProceso
9. Desplegar las 10 tablas de multiplicacin.
Proceso SinTitulo
i<-1;
Mientras i<=10 Hacer
z<-1
Mientras z<=10 Hacer
r<-i*z
Escribir r;
z<-z+1
FinMientras
i<-i+1
Pg: 2
CHRISTIAN ESPINOZA ROMERO

INTRODUCCION A LA PROGRAMACION
Docente Ing. Irma Prado
FinMientras
FinProceso
Grupo B: Validacin de entrada de datos:
10.Realice un programa que pida al usuario ingresar un nmero par, luego
desplegar gracias.
Proceso SinTitulo
Escribir "Ingrese numero par";
Leer a
Mientras trunc(a/2)*2 <>a Hacer
Escribir "PAR";
Leer a
FinMientras
Escribir "GRACIAS";
FinProceso
11.Realice un programa que pida al usuario ingresar un nmero impar, luego
desplegar gracias.
Proceso SinTitulo
Escribir "Ingrese numero impar";
Leer a
Mientras trunc(a/2)*2 =a Hacer
Escribir "IMPAR";
Leer a
FinMientras
Escribir "GRACIAS";
FinProceso
12.Realice un programa que pida al usuario ingresar un nmero X
comprendido en el rango [10,80], luego desplegar gracias.
Proceso SinTitulo
Escribir "ingrese numero entre 10 y 80";
Leer x
Mientras x<10 | x>80 Hacer
Escribir "numero porfavor";
Leer x
FinMientras
Escribir "THANK YOU FOR ALL";
FinProceso
13.Realice un programa que lea dos nmeros X y W, donde X debe ser mayor
que cero y X debe ser menor que W.
Proceso SinTitulo
Escribir "ingrese X y W";
Leer x,w
Mientras x<=0 | x>w Hacer
Escribir "corrija x porfa";
Leer x
FinMientras
Escribir "GRACIAS";
FinProceso
14.Realice un programa que lea tres nmeros X,W,Z. donde X debe estar en el
rango [12,15] y W debe estar en el rango [55,81] y Z en el rango de
[85,90].
Proceso SinTitulo
Escribir "ingrese x,w,z";
Leer x,w,z;
Mientras x<12 | x>15 Hacer
Escribir "corrija x";
Pg: 3
CHRISTIAN ESPINOZA ROMERO

INTRODUCCION A LA PROGRAMACION
Docente Ing. Irma Prado
Leer x
FinMientras
Escribir "gracias";
Mientras w<55 | w>81 Hacer
Escribir "corrija w";
Leer w
FinMientras
Escribir "gracias";
Mientras z<85 | z>90 Hacer
Escribir "corrija z";
Leer z
FinMientras
Escribir "gracias";
FinProceso
Grupo C: Varios
15.Dado un nmero N desplegar sus dgitos de derecha a izquierda.
Proceso SinTitulo
Escribir "ingrese un numero";
Leer n;
d<-0;
Mientras (n>0) Hacer
r<-n-trunc(n/10)*10;
n<-trunc(n/10);
d<- d*10+r
FinMientras
Escribir "resultado: ",d;
FinProceso
16.Dado un nmero X contar sus dgitos.
Proceso SinTitulo
Escribir "ingrese el numero ";
Leer y;
i<-0
Mientras (y<>0) Hacer
y<-trunc(y/10)
i<-i+1
FinMientras
Escribir "los digitos son ",i;
FinProceso
17.Dado un nmero X contar los dgitos 2 que tiene.
Proceso SinTitulo
Escribir "ingrese el numero ";
Leer n;
i<-0
p<-n
t<-n
Mientras (p<>0) Hacer
p<-trunc(p/10)
t<-t-(p*10)
Si t=2 Entonces
i<-i+1
FinSi
t<-p
FinMientras
Escribir "los digitos son ",i;
Pg: 4
CHRISTIAN ESPINOZA ROMERO

INTRODUCCION A LA PROGRAMACION
Docente Ing. Irma Prado
FinProceso
18.Dado un nmero N contar cuntos dgitos D tiene. Asegrese que D est
comprendido entre 0 y 9.
Proceso SinTitulo
Escribir "ingrese el numero ";
Leer n;
Escribir "digito???";
Leer d;
Mientras d<0 | d>9 Hacer
Escribir "numero entre 0 y 9";
Leer d;
FinMientras
i<-0
p<-n
t<-n
Mientras (p<>0) Hacer
p<-trunc(p/10)
t<-t-(p*10)
Si t=d Entonces
i<-i+1
FinSi
t<-p
FinMientras
Escribir "los digitos son ",i;
FinProceso
19.Dado un nmero N cambiar el dgito D por 0.
Proceso SinTitulo
Escribir "ingrese n";
Leer n;
Escribir "digito d???";
Leer d;
i<-0
p<-n
t<-n
y<-n
Mientras (p<>0) Hacer
p<-trunc(p/10)
t<-t-(p*10)
Si t=d Entonces
y<-y-(t*(10^i))
FinSi
t<-p
i<-i+1
FinMientras
Escribir "resutado ",y;
FinProceso
20.Desplegar los dgitos de un nmero de derecha a izquierda.
Proceso SinTitulo
Escribir "ingrese un numero";
Leer n;
d<-0;
Mientras (n>0) Hacer
r<-n-trunc(n/10)*10;
n<-trunc(n/10);
d<- d*10+r
Pg: 5
CHRISTIAN ESPINOZA ROMERO

INTRODUCCION A LA PROGRAMACION
Docente Ing. Irma Prado
FinMientras
Escribir "resultado: ",d;
FinProceso
21.Sumar todos los dgitos de un nmero.
Proceso SinTitulo
Escribir "ingrese n";
Leer n;
g<-0
p<-n
t<-n
y<-n
Mientras (p<>0) Hacer
p<-trunc(p/10)
t<-t-(p*10)
g<-g+t
t<-p
FinMientras
Escribir "resutado ",g;
FinProceso
22.Ingresan N datos por teclado, contar cuntos nmero pares ingresaron,
cuntos impares y cuntos ceros.
Proceso SinTitulo
Escribir "cantidad de datos?";
Leer n;
i<-0
j<-0
c<-0
k<-0
Mientras (k<>n) Hacer
Escribir "ingrese numero";
Leer m
Si m=0 Entonces
i<-i+1
Sino
Si trunc(m/2)*2 <>m Entonces
c<-c+1
Sino
j<-j+1
FinSi
FinSi
k<-k+1
FinMientras
Escribir "pares ",j;
Escribir "impares ",c;
Escribir "ceros ",i;
FinProceso
23.Ingresar varios datos por teclado, obtener la sumatoria de datos positivos
y de datos negativos ingresados. Termina la entrada de datos al ingresar el
dato 0.
Proceso SinTitulo
Escribir "ingrese numero";
Leer n;
c<-0
j<-0
Mientras n<>0 Hacer
Pg: 6
CHRISTIAN ESPINOZA ROMERO

INTRODUCCION A LA PROGRAMACION
Docente Ing. Irma Prado
Si n>0 Entonces
c<-c+n
Sino
j<-j+n
FinSi
Escribir "ingrese numero";
Leer n;
FinMientras
Escribir " sumatorio positivos ",c;
Escribir "sumatoria negativos ",j;
FinProceso
24.Ingresan N notas de estudiantes del curso de INTRODUCCION A LA
PROGRAMACION obtener el promedio de calificaciones.
Proceso SinTitulo
Escribir "catidad de alumnos";
Leer c;
i<-1
r<-0
Mientras i<=c Hacer
Escribir "ingrese notas";
Leer n;
r<-r+n
i<-i+1
FinMientras
p<-r/c
Escribir "promedio es ",p;
FinProceso

Pg: 7
CHRISTIAN ESPINOZA ROMERO