Está en la página 1de 4

Realizado por Hernn Tena

Control de entradas y Salidas


Despus de ver el video Control de entradas y salidas, realizar la siguiente actividad.
1. En un Nuevo libro de Excel crear la siguiente tabla de datos con nombres de productos
reales. Debe incluir una imagen por producto, al final de la actividad aprender cmo.

2. Realizar los siguientes ajustes de diseo a la tabla:

a. Aplicar a los ttulos de las columnas letra Times New Roman 12 (o similar) y color
negra. Centrar cada uno y aplicarle negrilla.
b. Aplicar todos los bordes al rea de trabajo.
c. Aplicar formato de celda moneda a los datos de la columna Precio por unidad, con
separador de miles y 0 posiciones decimales.
d. Aplicar un color de relleno a las celdas que contienen ttulo.
e. Ocultar filas y columnas restantes.
f. Eliminar lneas de cuadrcula.
g. Eliminar hojas adicionales y nombrar la de trabajo como: Control de Entradas y
Salidas

Realizado por Hernn Tena


3. Insertar frmulas as:
a. En la celda de producto (B2) inserte:
=SI(A2<>"";BUSCAR(A2;A5:A19;B5:B19);"")
Si Excel est en Ingls inserte:
=IF(A2<>"";LOOKUP(A2;A5:A19;B5:B19);"")
b. En la celda Precio por unidad (C2) inserte:
=SI(A2<>"";BUSCAR(A2;A5:A19;C5:C19);"")
Si Excel est en Ingls inserte:
=IF(A2<>"";LOOKUP(A2;A5:A19;C5:C19);"")
c. En la celda Stock (F2) inserte:
=SI(A2<>"";BUSCAR(A2;A5:A19;F5:F19);"")
Si Excel est en Ingls inserte:
=IF(A2<>"";LOOKUP(A2;A5:A19;F5:F19);"")
d. En la celda de Stock (F4) inserte:
=SI($A$2<>"";D5-E5;"")
Si Excel est en Ingls inserte:
=IF($A$2<>"";D5-E5;"")
4. Crear dos macros as:
a. Entradas con el siguiente cdigo:
Sub Entrada()
Range("A2").Select
ClaveEntrada = ActiveCell.FormulaR1C1 + 4
CeldaEntrada = "D" & ClaveEntrada

Realizado por Hernn Tena


Range(CeldaEntrada) = Range(CeldaEntrada) + Range("D2")
Range("D2") = ""
End Sub

b. Salidas con el siguiente cdigo:


Sub SALIDAS()
Range("A2").Select
ClaveSalida = ActiveCell.FormulaR1C1 + 4
CeldaSalida = "E" & ClaveSalida
Range(CeldaSalida) = Range(CeldaSalida) + Range("E2")
Range("E2") = ""
End Sub
c. Dar clic en Vista Ver macros Entradas Opciones en la casilla seguida de
CTRL + (insertar la letra q)
Dar clic en Vista Ver macros SALIDA Opciones en la casilla seguida de
CTRL + (insertar la letra w)
5. Habilitar Macro en su Excel, para esto hacer el siguiente procedimiento:
a. Archivo Opciones Centro de confianza Configuracin del centro de confianza
marcamos habilitar todas las macros y clic en aceptar.
6. A cada producto le inserta un comentario con una imagen que lo represente, para
lograrlo hacer el siguiente procedimiento:
a. Clic en la celda que se va a insertar la imagen.
b. Clic en revisar y nuevo comentario

Realizado por Hernn Tena


c. Selecciona el cuadro del comentario, presiona clic derecho y clic izquierdo en
formato de comentario.
d. Clic en colores y lneas.
e. Despliegue los colores y d clic en efectos de relleno.
f. Clic en imagen.
g. Clic en seleccionar imagen, bsquela en su equipo y oprima clic izquierdo dos veces.
h. Finalmente clic en Aceptar
Haga el mismo procedimiento con cada producto
7. Ponerle contrasea a la hoja de la siguiente manera:
a. Seleccione todas las celdas editablas
b. Con las celdas editables seleccionadas, d clic derecho, formato de celda, proteger y
desmarque la casilla Bloqueada. Por ltimo de clic en Aceptar.
c. Luego, clic en revisar proteger hoja Desmarque la primera casilla Seleccionar
celdas bloqueadas e inserte la contrasea que desee dos veces.
8. Finalmente, guarde su libro de Excel seleccionando en tipo de archivo la opcin libro de
Excel habilitado para macros y asgnele como nombre Control de entradas y salidas.

También podría gustarte