Está en la página 1de 3

configuracion basica de un Switch

Switch#delete flash: vlan.dat


Switch#erase startup-config
switch#reload.
Switch#Enable
Switch#Configure terminal
Switch(config)#hostname centro1
Switch(config)#enable secret cisco
Switch(config)#service password-encryption
Switch(config)#banner motd #Este es un sistema seguro#
Switch(config)#line console 0
Switch(config line)#password cisco
Switch(config line)#login
Switch(config line)#exit
Switch(config)#line vty 0 15
Switch(config line)#password cisco
Switch(config line)#login
Switch(config line)#exit
Switch(config)#vlan "numero de vlan"
Switch(config-vlan)#name
Switch(config-vlan)#int range f0/1-5
Switch(config-if)#switchport mode access
Switch(config-if)#switchport access vlan
Switch(config-if)#exit
Switch(config)#int f0/1 (para que se conecte al router)
Switch(config)#switchport mode trunk
Switch(config)#switchport trunk native vlan 100
Switch(config)#duplex full
Switch(config)#speed 100
/* Switch(config)#int f0/23 (para que se conecte al switch y la f0/24)
Switch(config)#switchport mode trunk
Switch(config)#switchport trunk native vlan 100
Switch(config)#duplex full
Switch(config)#speed 100
*/
Switch(config)# ip domain-name uvm.edu
Switch(config)#crypto key generate rsa
Switch(config)#numero de bits (1024)
Switch(config)#username <alumno> privilege 15 password cisco123
Switch(config)#line vty 0 15
switch(config)#transport input ssh
switch(config)#login local
switch(config)#int range f0/1-5, f0/6-8, f0/9-12
switch(config)#switchport mode access
switch(config)#switchport port-security
switch(config)#switchport port-security maximum (numero de pc que se conectaran)
switch(config)#switchport port-security mac-address sticky
switch(config)#switchport port-security violation { protect,restrict,shuwdown}
Para asignarle la ip al switch
switch(config)#interface vlan1
switch(config line)#ip address <<ip>> <<mascara>>
switch(config line)#no shutdown
switch(config line)#exit

Para determinar la puerta de enlace


switch(config)#ip default-gateway <<ip>>
switch(config)#exit
switch#wr
para la lookbap
int l0/0
ip address mascara
no shutdown
****Recuperacion del switch
flash_init
rename flash:config.text flash:config.old
boot
switch#show ip interface brief
switch#show ip run
switch#show vlan brief (para ver los puertos asignados)
********************
*****crear vtp
vtp mode server
vtp doamin redes
vtp password redes
*****jalar vtp
vtp mode client
vtp domain redes
vtp password redes
*********************
para ver las vlan creadas
show vlan brief
le pongo los rango eso van donde se puso vtp
int range f0/1-23
switchport mode access
switchport access vlan <numero de la vlan >
*******etherchannel
int range f0/23 -24
channel-group 1 mode <desirable,auto,active,passive>
exit
int port-channel 1
switchport mode trunk
switchport trunk native vlan 99
exit
do show etherchannel summary
*******Spanning-tree

spanning-tree vlan <numero de vlan> root primary


spanning-tree vlan <numero de vlan> root secondary
spanning-tree mode rapid-pvst
int range f/23 -24
spanning-tree portfast
spanning-tree bpduguard enable
exit
do sh spanning-tree
*********

También podría gustarte