P. 1
Enmascarar un arbol

Enmascarar un arbol

4.0

|Views: 2.163|Likes:
Publicado porPLSEGOVIA
Tutorial
Tutorial

More info:

Published by: PLSEGOVIA on Sep 05, 2007
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as DOC, PDF, TXT or read online from Scribd
See more
See less

06/07/2013

pdf

text

original

Enmascarar un árbol

Este tutorial mostrará cómo extraer una máscara limpia de una foto de un árbol contra un cielo azul, usando canales y niveles y después exporta el resultado final como un fichero png transparente. Los conceptos generales pueden aplicarse de forma intuitiva a otros casos. Primero, descargue la foto del árbol de la izquierda, y ábrala en Adobe Photoshop. 01. 01. Equilibrando los canales Abra la ventana de Canales para examinar los distintos canales de color. Los canales del color indican cuánto de cada color hay en la imagen. Una imagen RGB como esta foto contendrá 3 canales de color separados, uno que indica la cantidad de Rojo, otro para el Verde y otro para el Azul. El blanco en un canal significa que el valor del color está lleno (255), y el negro que está vacío (0). Busque el canal que muestre el borde que contornea el árbol, con el más alto contraste. El árbol debe aparecer, dentro del borde, con un color plano, de contraste muy bajo, y el fondo debe ser blanco o completamente iluminado, también con contraste bajo. De esta forma será fácil definir el árbol con un canal Alfa. Como el cielo es azul, el canal Azul funcionará bien para comenzar la máscara. Presione Ctrl+3 para examinar el canal Azul.

Al observar en detalle, vemos que hay partes del tronco que son considerablemente más luminosas que otras partes del árbol. Son casi tan luminosas como las partes del cielo. Solamente el cielo debe ser blanco, si no, parte del tronco aparecerá transparente una vez que se aplique la máscara. Puesto que el color de la corteza es, 1

por lo general, más rojo que el resto de la escena, utilice el canal Rojo para hacer retroceder la máscara. a) Haga una copia del canal Azul arrastrándolo sobre el botón Nuevo Canal ( ). Doble click sobre el nuevo canal y llámelo Árbol alfa. b) A continuación, haga una copia del canal Rojo, y asegúrese de que está seleccionado. (Ctrl+5) c) Ajuste los niveles en el canal Rojo copia: Imagen > Ajustes > Niveles… (Ctrl+L) Valores: 50/0.85/222 Ahora la idea es aislar las regiones de la corteza que son demasiado brillantes, en el canal Azul. Después, este canal será utilizado como una selección para oscurecer el canal Árbol Alfa. d) Arrastre el canal Rojo copia sobre el botón Cargar canal como selección ( ).

2

e) Click sobre el canal Árbol Alfa, y después presione Ctrl+H para ocultar la selección y así veremos lo que va sucediendo. f) Ahora obscurezca significativamente la región de la corteza. Imagen > Ajustes (Ctrl+L) Valores: 120/1.2/255 > Niveles…

Con este método utilizamos el canal Azul para crear la transparencia, y el canal Rojo para hacerlo más opaco.

3

Cuando compongamos el árbol en otra escena, querremos que el cielo sea totalmente transparente y el árbol, sólido. Para ello, volquemos las sombras al negro, y el cielo al blanco puro. Para hacer esto: g) Presione Ctrl+D para desactivar la selección anterior. h) Ajuste los niveles en el canal Árbol Alfa: Imagen > (Ctrl+L) Ajustes > Niveles…

Ahora arrastre lentamente el nivel de blancos hacia atrás hasta que el cielo entero se vuelva blanco, y arrastre lentamente el nivel de negros hacia adelante hasta que la mayor parte del tronco y los segmentos internos del árbol aparezcan negros. Estos ajustes van bien en este caso: Valores: 30/1/145 Pueden ser necesarios varios intentos hasta encontrar el equilibrio perfecto. Sea consciente de lo que está sucediendo en las distintas partes de la imagen mientras se ajustan los niveles. Si el nivel de blancos se deja demasiado bajo, las partes finas de los ramas desaparecerán en el cielo. Y si el nivel de negros se lleva a demasiado alto, el cielo brillará intensamente en los bordes del árbol. i) Invierta el canal Árbol Alfa (Ctrl+I) de modo que el árbol aparezca blanco, y el cielo negro. 02.

4

02. Aplicando la máscara a) Arrastre el canal Árbol Alfa sobre el botón Cargar canal como selección ( ). b) Vaya a la pestaña capas, y haga una copia de la capa del fondo, arrastrándola sobre el botón Crear una capa nueva ( ). Doble click sobre la nueva capa Fondo copia, y llámela Árbol. c) Click sobre Añadir máscara de capa ( ) en la pestaña de Capas para agregar la selección como una máscara a la capa Árbol. d) Oculte o suprima la capa original Fondo. e) Click sobre la pequeña imagen en blanco y negro que hay en la capa Árbol para pintar en la máscara de la capa. Aísle el tronco de la ladera del fondo. Utilice la herramienta Pincel para hacer la ladera transparente pintando con negro en la máscara de la capa o Utilice la herramienta Lazo poligonal para seleccionar los trozos de ladera, y después llenarlos de negro. Ponga en negro el color del primero plano (Ctrl+D), y después llene (Alt+Backspace) la selección con el color del primer plano. 03.

5

03. Recortando los bordes a) Cree una nueva capa ( ) y arrástrela debajo de la capa Árbol. Después, pegue una imágen (Escena) que constituirá el nuevo fondo. O bien, llene el fondo con un color promediado de la imagen original. O haga un gradiente detrás de la capa Árbol, para probar la máscara sobre una gama de colores. Si el árbol se está moviendo desde un cielo luminoso a otro relativamente más oscuro, puede aparecer un contorno apreciable rodeándolo, como si brillara intensamente. Hay varias formas de corregir esto.

01: Ajustar los niveles de la máscara a) Click sobre la pequeña imagen en blanco y negro que hay en la capa Árbol. Imágen > (Ctrl+L) Ajustes > Niveles…

Arrastre ahora el nivel de sombra hasta que se reduzca al mínimo el borde que brilla intensamente, mientras vigila la integridad de las ramas más pequeñas. Valores: 120/1.2/255 Muchos de los ramas más pequeños desaparecerán con esta técnica. Aunque puede ser eficaz con otras imágenes, no la utilice en este caso.

02: Oscurecer los bordes Una manera mejor de fijar los bordes de este árbol que brillan intensamente es oscurecer los bordes solo dentro de la máscara. 6

a) Mantenga apretado Ctrl y Click sobre la pequeña imagen en blanco y negro que hay en la capa Árbol para seleccionar la transparencia de la máscara. b) Contraiga la selección en 1 pixel. Seleccionar > Modificar > Contraer… 1 pixel c) Invierta Ctrl+Shift+I la selección.

d) Cree una capa de ajuste de Curvas, mediante click sobre en la pes taña de Capas, y seleccionando Curvas… Arrastre la parte inferior de la curva hacia abajo. Presione OK. e) Manteniendo apretado Alt, mueva el cursor del ratón entre las capas Curvas y Árbol, hasta que el cursor cambia a dos círculos solapados, y después click.

Al hacer esto, se crea a grupo recortado, de modo que el ajuste de Curvas afecte solamente a la capa del Árbol. En un grupo recortado, la capa inferior actúa como máscara para las capas superiores. El llevar los bordes a tan oscuros puede crearse una apreciable línea negra alrededor de los bordes muy definidos del árbol. Esto se puede suavizar mediante Desenfoque Gaussiano de 1 ó 2 pixeles en la máscara de la capa Curvas. Sin embargo, desenfocar la máscara de la capa del Árbol puede producir resultados algo indeseables.

04.

7

04.Exportando La siguiente cosa a hacer es, o bien copiar y pegar el árbol en otra imagen de Photoshop, o bien exportarla como un archivo transparente de tipo png para poderlo importar en otros programas tales como Flash o 3D Max. a) Oculte la capa del fondo (llamada Escena en este caso), mediante click en el pequeño icono de ojo a la izquierda de la capa, de modo que desaparezca.

01: Para exportar a png b) Presione C para la herramienta Recortar, y seleccione un área alrededor del árbol, dejando un poco de margen alrededor de los bordes. Doble click dentro de la selección, o la presione Enter para aplicar el recorte.

c) Exporte el archivo con Guardar para Web. Archivo > Guardar para Web… (Alt+Shft+Ctrl+S) Seleccione el ajuste: PNG-24 Permita: Transparencia.

8

02: Para copiar y pegar b) Seleccionar > Todo (Ctrl+A) c) Edición > Copiar combinado (Shft+Ctrl+C) d) Cambiar a otro documento de Photoshop e) Edición > Pegar (Ctrl+V)

9

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->