Está en la página 1de 46

Bo co th vic

TM HIU V IS-IS

MC LC
I.
I.1 M t

Khi nim v IS-IS 1

I.2 So snh vi OSPF

I.2.a Ging nhau:.................................................................1


I.2.b Khc nhau:..................................................................2
I.3 nh a ch trong IS-IS

I.4 Hot ng ca Intergrated IS-IS

I.4.a Duy tr cc k cn trong Intergrated IS-IS...............................................7


I.4.b Hot ng ca Integrated ISIS.....................................................................9
I.5 Cch thc hot ng ca IS-IS
I.6 Cc tiu ch thit k IS-IS

12

13

I.6.a Thit k Area trong ISIS................................................................................13


I.6.b Route Summarization.....................................................................................13
I.7 p dng IS-IS vo mp phng VN-2

II.

14

Cu hnh IS-IS 15

II.1 S khi tin trnh thc hin cu hnh IS-IS 15


II.2 Router ca CISCO

15

II.2.1 Cc cu lnh....................................................................................................15
II.2.2 Cc v d khi cu hnh cho Router CISCO...........................................18
II.3 Trong Router Alcatel 7750 30
II.3.1 Cc cu lnh....................................................................................................30
II.3.2 Cc v d cu hnh trn Alcatel 7750.....................................................33
II.4 Cu hnh trong Juniper T1600

35

III. Kt lun v IS-IS

42

T Chuyn mch i HCM


Thi Quc Khng

Bo co th vic
TM HIU V IS-IS

I. Khi nim v IS-IS


IS-IS l cm t vit tt ca Intermediate System to Intermediate System, l
mt giao thc nh tuyn IGP, c s dng bi cc thit b mng (Router) xc
nh mt ng i tt nht chuyn tip gi tin xuyn qua mng chuyn mch
gi, tin trnh ny c gi l nh tuyn. Giao thc ny c nh ngha nh l
mt chun quc t bn trong m hnh OSI, do Cng ty c phn thit b s DEC
(Digital Equipment Corporation) xy dng v pht trin.

I.1 M t
Vic to ra IS-IS l mt phn trong s n lc to ra mt giao thc chun
quc t c th cnh tranh vi TCP/IP. IS-IS c pht trin p ng:
Mt giao thc khng mang tnh c quyn.
H tr di a ch rng v phn cp.
Mt giao thc hiu qu, cho php hi t nhanh, chun xc v t gy
qu ti mng.
Khi nc M yu cu mi h thng trong chnh ph u phi c kh nng
chy OSI, IS-IS c m rng gip chuyn i cc tuyn ng hc c t
IP vo OSI. Tuy nhin cui cng th Internet (c xy dng trn TCP/IP)
chim u th trong thc tin v c coi nh mt chun quc t. Khi IS-IS c
dng h tr IP, chnh xc n c gi l Integrated IS-IS (IS-IS tch hp)
nhng n gin thng gi tt l IS-IS.
Trong nhng nm gn y, ngi ta li nhc li nhng u im ca IS-IS:
IS-IS l mt giao thc c lp.
Kh nng m rng tt.
C kh nng xc lp nh tuyn theo ToS (Type of Service - Kiu dch
v) tuy nhin ToS khng c IOS h tr.
IS-IS vn ln nh mt giao thc nh tuyn cho IPv6 hay s dng vi
MPLS (Multi-Protocol Label Swiching).
IS-IS l mt giao thc nh tuyn kiu trng thi lin kt Link-state, ngha
l n hot ng trn s hiu bit chnh xc v thng tin topo mng xuyn qua
cc routers. Mi mt router s xy dng ring cho n mt m hnh topo mng.
Gi tin hoc n v d liu s c chuyn tip trn ng vn chuyn tt nht
da trn topo mng m router xy dng, truyn n v tr ch.
IS-IS s dng thut ton Dijkstra cho s tnh ton tuyn ng tt nht.

I.2 So snh vi OSPF


I.2.a Ging nhau:
* IS-IS l giao thc h tr chun ca OSI (Open System Interconnection)
v sau ny c pht trin ln nhm h tr cho c IP (c gi l IS-IS tch
hp).
T Chuyn mch i HCM
Thi Quc Khng

Bo co th vic
TM HIU V IS-IS
* C IS-IS v OSPF u l nhng giao thc nh tuyn kiu trng thi
lin kt Link-state routing protocol.
* V c hai cng s dng thut ton Dijksrta tnh ton tuyn ng
tt nht xuyn qua mng (thut ton SPF).
* C OSPF v IS-IS l giao thc nh tuyn trong min IGP.
* C hai cng h tr VLSM (Variable Length Subnet Masks), c th pht
hin nhng routers hng xm bng cch truyn multicast nhng bn tin Hello
packets, v c h tr chng thc cho qu trnh cp nht nh tuyn.
OSPF c trin khai trong hu ht cc mng cp cng ty, trong khi ISIS
c dng trong cc mng ISP (Internet Service Provider).
I.2.b Khc nhau:
Trc tin, d hiu, ta s map mt s khi nim bn OSPF qua IS-IS.

T Chuyn mch i HCM


Thi Quc Khng

Bo co th vic
TM HIU V IS-IS
OSPF

IS-IS
Area

Stub area

Area ID

Area ID

Backbone area

Backbone area

DIS
(Designated
System)

Intermediate

DR (Designated Router)

Domain

Network

ES (End System)

Host

ES-IS (the address resolution feature


ARP (Address Resolution Protocol)
of ES-IS)
IS (Intermediate System)

Router

ISO Routeing Domain

Autonomous system (AS)

Level 1

Internal nonbackbone stub area

Level 1-2

Area border router (ABR)

Level 2

Backbone router

LSP (Link-state packet)

LSA (Link-state advertisement)

PDU (Protocol Data Unit)

Packet

CSNP & PSNP (Complete and


Link-state acknowledgement packet
Partial Sequence number PDUs)
CLNS address: nhn dng router
v xy dng bng LSDB (Link-state IP address
Database)
NET (Network Entity Title)

IP destination address (subnet and


host, used in a similar way to router
ID)

NSAP (Network Service Access IP destination address + Ip protocol


Point)
number
Subnet = Data link
Subnet = IP network
Bng 1 Khi nim tng ng gia OSPF v IS-IS
IS-IS dng CLNS address xy dng bng LSDB (Link State
Database). Trong khi OSPF th s dng IP address.
Khng nh OSPF, mi interface ca Router s c 1 a ch IP. CLNS
address i din cho mt Router (IS) chy IS-IS ch khng phi mt Interface.
y, LSP l t vit tt ca Link-state Packet, l mt gi thng tin c
T Chuyn mch i HCM
Thi Quc Khng

Bo co th vic
TM HIU V IS-IS
pht ra t cc router trong mng s dng giao thc nh tuyn trng thi lin
kt nhm lit k ra nhng router hng xm (neighbours).
Cc cng trong OSPF mi lin kt s thuc v mt khu vc area (mi
interface thuc v mt khu vc).

Hnh 1 Phn cp Router trong OSPF


Trong khi , IS-IS th mi router ch thuc mt area.

Hnh 2 Phn cp Router trong IS-IS


IS-IS ng gi d liu lp Data link, OSPF ng gi lp Network.
OSPF gn gi hn vi giao thc TCP/IP v ph bin trn cc mng IP;
IS-IS c xy dng h tr ng thi CLNS v IP trn cc mng Back bone
ca ISP.
OSPF v IS-IS cn khc nhau v cch phn cp Router:
Router level 1:
* S dng LSP xy dng topology cho khu vc n thuc v, hay
gi l area local), tng ng router nm trong mt area OSPF nhng khng
phi l backbone.
* Level-1 router ging stub router trong OSPF v database ca n ch
gii hn n area. i ra ngoi mt area khc, dng default-route n router
level-2 gn nht.
Router level 2:
* S dng LSP xy dng topology gia cc khu vc khc nhau
tng ng router backbone trong OSPF.
* route traffic gia cc area, ta cn phi c level 2 router. Routing
gia cc areas c gi l interarea routing. Loi router ny tng t nh router
backbone trong OSPF. Level-2 router s giao tip vi nhau thng qua Hello.
Database ca cc level-2 router phi ging nhau v cha cc network trong
nhng areas khc.
Router level 1-2:
* Lm chc nng ca c 2 con trn.
T Chuyn mch i HCM
Thi Quc Khng

Bo co th vic
TM HIU V IS-IS
* Loi router c y thng tin trong database l level 1-2. c im
ca n l tng t vi ABR trong OSPF. Router ny s c cc router lng ging
nm trong cc area khc nhau bi v n gi c hello loi 1 v hello loi 2. Router
level 1-2 ny s thng bo cho cc level-1 router khc v cc area m n ni v,
hn na n s thng bo cho cc level 2 router thng tin v area ca n. Router
loi ny s tiu tn nhiu b nh v CPU.
Thng tin nh tuyn ch c trao i gia cc routers cng level. Cc
Routers level 1-2 trao i thng tin vi c 2 loi router level khc v n c s
dng kt ni cc router lin ngoi vng v ni vng.

Hnh 3 Minh ho cc cp Router IS-IS


OSPF c mt Area trung tm (Area 0), cn IS-IS c mt Area Back bone
trn cc Area khc.
Trong OSPF, mt Router vng bin ABR (Area Border Router) c th
va x l bn trong vng (intra-area), va c th x l c vng bn ngoi
(inter-area). V mt logic, mng s dng OSPF phi to ra nhng topo mng
li nhn, hoc topo hnh sao rt nhiu vng khc nhau kt ni trc tip vo
vng Area 0, trong khi IS-IS ch cn mng xng sng ca nhng Router Level
2 vi cc nhnh l cc router Level 1-2 v router Level 1 kt ni cc vng c
lp li vi nhau. Trn hnh 3, ng mu hng l backbone, tt c cc router
nm trn ng mu hng c th thy c nhau.
IS-IS gi thng tin qung b di mt dng chun v trong mt dng gi
tin. Ty theo kiu, OSPF qung b v truyn ti cc thng tin mt cch khc
nhau.
Trong OSPF header, cc trng l c nh, khi ta thay i th header phi
thay i theo. Cn i vi IS-IS th khi ta thm thay i n ch gn thm thng
tin vo ch khng cn thay i ton b header. Cc trng thm vo gi l TLV
(Type-Length-Value).
Cc trng TLV cho php lu thng tin ca c level 1 v level 2 v
cho php nh dng gi tin LSP ging nhau gia hai level. TLV l mt im
mnh ca IS-IS: n cung cp tnh mm do v kh nng m rng ca giao thc
T Chuyn mch i HCM
Thi Quc Khng

Bo co th vic
TM HIU V IS-IS
ny.
IS-IS c th thch nghi vi nhng thay i cn thit hoc cc ci tin
trong cng ngh bng cch nh ngha mt TLV mi. Cu trc ca trng TLV:
- Type: Xc nh thng tin qung b v cc c tnh lin quan.
V d: TLV c Type=128 l mt qung b ca IP.
- Length: di ca trng thng tin, y l mt trng quan trng
bi v di ca cc trng thng tin c th khc nhau.
- Value: Thng tin qung b, c th l cc tuyn ng, IS neighbor
hoc chng thc
Cu trc TLV gip vic qung b d dng phn nhm v qung b
cng nhau. Do , IS-IS cn t gi tin hn cho LSP v gip n c kh nng thch
ng so vi OSPF.
Mt iu quan trng na l nm r nhng kiu TLV m thit b ca
bn h tr v n quyt nh ti vic thit k v cu hnh mng, Router nhn s
b qua mi trng TLV m n khng h tr.
Mt s khc nhau kh r l qu trnh ng gi ca hai giao thc.
ISIS l c lp v n chy trc tip t lp datalink: trong IS-IS, PDU
(Protocol Data Unit n v d liu ca giao thc) c ng gi trc tip vo
cc Frame ca lp Datalink). S phn mnh (fragmentation) thuc v trch
nhim ca ISIS.
Ngc li OSPF c ng gi trong IP v v vy b gii hn bi giao
thc .
S khc bit ny gip cho IS-IS c th thch nghi vi hon cnh ch
bng cch thm mt TLV mi. Mt v d cho u im ny l vic ng gi d
liu trong IPv6. Khi mt giao thc Lp 3 mi c pht trin, IS-IS thch nghi
mt cch nhanh chng bng cch to mt trng IPv6 TLV mi. OSPF cn
nhiu thi gian hn thch nghi v dn ti vic hnh thnh mt phin bn mi
ca giao thc ny OSPFv3.
Ngoi ra, c mt im khc bit na, trong IS-IS nh ngha thm mt
kiu a ch: NSAP address (Network Service Access-point) m trong OSPF
khng c.

I.3 nh a ch trong IS-IS


Khi ISIS c dng cho routing IP traffic, cc thng tin routing c
mang trong cc ISIS update, v vy cc router tham gia cn c mt a ch ton
cc (ISO address). a ch ISO address bao gm 2 phn: phn NSAP v phn
gm NET (ty thuc vo thit b ang c dng).

T Chuyn mch i HCM


Thi Quc Khng

Bo co th vic
TM HIU V IS-IS
Hnh 4 a ch ISO NET address n gin

Hnh 5 a ch ISO NSAP


a ch IS-IS c chiu di t 8 n 20 bytes. Chun ISO 10589 nh ngha
ba phn ca mt a ch: Area, ID v SEL.

Hnh 6 a ch ISO address


Area: Vng ny c dng router gia cc area vi level-2 routing.
System ID: ID c dng route n mt host hoc mt router bn
trong mt level-1 routing.
SEL: c dng route mt i tng bn trong mt host hay mt ES.

Hnh 7 a ch NSAP (hay NET)


AFI (Authority & Format Identifier): 49 ~ private address.
System ID: ging nh Router ID bn OSPF, dng nhn din mi router.

T Chuyn mch i HCM


Thi Quc Khng

Bo co th vic
TM HIU V IS-IS

Hnh 8 System ID v NSEL trong NSAP (hay NET)


49.0001. l area ID (cn gi l area address), trong cng area th cn
ging cc router mi thnh neighbor ca nhau.
0000.0c11.1111: l system ID nhn dng tng router trong khu vc.
Cc nguyn tc cho vic dng a ch ISO:
a ch ISO c gn cho ton b h thng, ch khng gn n interface.
Router thng c mt a ch NET. Qui c l ti a ba a ch NET.
Nu nhiu NET c cu hnh trn cng router, n phi c cng SystemID.
a ch area phi ging nhau cho ton b cc router trong cng mt area.
Tt c cc level-2 phi c System-ID ring bit cho ton domain.
Tt c cc level-1 router phi c System-ID ring bit v duy nht cho
ton area.
System-ID phi c cng chiu di cho cc IS v ES trong mt routing
domain.
Cch nh a ch NSAP trong VN-2:
Khi p dng giao thc nh tuyn IS-IS vo trong mng ti mt phng
VN-2, cc a ch NSAP c quy hoch theo quy tc:
* Area ID: c phn theo m ca tnh, thnh ph.
* System ID: nh theo a ch IP (loopback) ca Router.
V d:
BRAS VTU c a ch lo0: 123.12.45.81, m s tnh l 64.
Khi thc hin giao thc ISIS, a ch NSAP s l:
49.0064.1230.1204.5081.00
Area ID
= 49.0064
System ID = 1230.1204.5081
Ghi ch:
IPv4 = 123.12.45.81 c 32 bits, c biu din theo h Deca.
System ID = 1230.1204.5081 c 48 bits (6 bytes), c biu din theo h
Hexa, phn tng nhm (block) 2 bytes.
T Chuyn mch i HCM
Thi Quc Khng

Bo co th vic
TM HIU V IS-IS

I.4 Hot ng ca Intergrated IS-IS


I.4.a Duy tr cc k cn trong Intergrated IS-IS
Cc routers thng thng trao i cc thng tin vi nhau cp nht
cc kin thc ca n v network chung quanh. mc ti thiu, mt router phi
truyn t cho nhng routers ln cn cc thng tin nh nh danh ca router,
cc interfaces.
Trong IS-IS, nu cc hello-packets c trao i v cc iu kin c
tho mn, cc routers s thit lp neighbor. Mc d qu trnh hnh thnh cc
neighbor ph thuc vo h tng mng c dng nhng nhng thng tin bn
trong cc hello-packets lun lun l ging nhau. Mi hello s ch ra ngun gc
ca Hello v nhng c im ca interface. Nu cc interface c chung c
im, cc quan h (adjacency) c to ra. Sau khi mt quan h c to ra,
cc thng tin routing s c trao i nh vo cc LSPs.
mt quan h c hnh thnh v duy tr, c hai interface phi tng
ng vi nhau v cc c im sau:
Kch thc packet MTU phi bng nhau.
Mi routers phi cn phi c cu hnh cng mt mc routing
ngha l hoc l level 1 hoc level 2. Cng mt mc th routers mi
c kh nng gii m nhng hello-packets do nhng routers khc gi
n.
Nu c hai router l level 1, n phi trong cng area.
Nu level 1 router hnh thnh cc quan h vi cc level 1 router v
level 2 hnh thnh cc quan h vi cc level-2 routers. mt
level-1 router hnh thnh mt quan h vi mt level-2 router, router
kia phi c cu hnh nh mt level-1-2 router.
Gi tr System-ID ca mi h thng phi l duy nht.
Nu qu trnh xc thc (authentication) c dng, n phi c
cu hnh ging nhau trn c hai router.
Thi gian gi gi hello phi bng nhau.
IS-IS nh ngha hai kiu network: broadcast v point-to-point. Mt
mng kiu broadcast h tr cho cc c ch broadcast v multicast.
Thit lp cc quan h lin k (adjaency) trn cc kt ni Point-to-Point:
Khi thit lp cc quan h, cc router s gi cc CSNP. Cc CSNP (mt
loi PDU cha ng cc LSPs trong ) l mt danh sch cc kt ni c lu
trong c s d liu. CSNP cng s kch hot qu trnh ng b ha
(synchronization) trong tng router. Cc hello-packets nh k s duy tr cc
quan h lin k ny. Nu mt router khng nghe mt hello-packet trong mt
khong thi gian hold-time, router kia s c xem nh l khng hot
ng. Khong thi gian hold-time bng ba ln thi gian hello.
Thit lp cc quan h lin k (adjaency) trn cc kt ni broadcast:
T Chuyn mch i HCM
Thi Quc Khng

Bo co th vic
TM HIU V IS-IS
Trn cc kt ni broadcast, tt c cc router chy IS-IS s nhn packets
c gi bi mt router duy nht DIS. DIS c trch nhim pht tn (flooding)
tt c cc routers ang chy IS-IS. Mt cch din t khc l DIS s pht tn
cc LSP cho pseudonode.Mt paseudenode s tng trng cho mt mng LAN,
trong mi router ca LAN l mt interface o ca router o kia. Router o
ny gi l pseudonode. Cng ging nh router tht, router o s pht tn cc
LSP khi c mt thay i trong kt ni ca LSP (v d nh khi c mt router ln
cn online).
Cc quan h lin k vi cc routers khc s c duy tr bi DIS. DIS
s gi cc Hello mi 3.3 giy. C ch ny nhm m bo tnh ton vn ca cc
kt ni. Nu c mt vn vi DIS hin ti hoc c mt router khc c u
tin cao hn, router DIS hin hnh s b cho v hu. Qu trnh bu chn da trn
u tin. Nu tt c cc router c gi tr u tin mc nh l 64 th router
no c gi tr SNPA (hay n gin hn l MAC address) cao nht s l DIS.

Hnh 9 Broadcast v Point-to-point


I.4.b Hot ng ca Integrated ISIS
1. Router IS gi Hello ra tt c cc interfaces tm cc router lng
ging v hnh thnh nn cc quan h lin k.
2. Cc router c cng kt ni datalink s tr thnh neighbor.
3. Cc router xy dng cc LSPs da trn cc IS-IS interfaces v cc
prefix c hc t cc neighbor.
4. Routers s pht tn (flood) cc LSP n tt c cc router ln cn
ngoi tr router gi LSPs.
5. Khi mt LSPs mi c nhn, router s xy dng li databse kt hp
cc LSP ny.
6. Router s thc hin gii thut SPF cho tng network, xy dng bng
routing table.
Hot ng ca ISIS c chia thnh 4 qu trnh:
Qu trnh cp nht: (update process)
T Chuyn mch i HCM
Thi Quc Khng

Bo co th vic
TM HIU V IS-IS
LSP c to ra khi c mt thay i trong mng, thng thng do cu
hnh mt router no thay i. Tuy nhin, bt c mt s kin no di y
cng kch hot to ra LSP:
Mt router lng ging up hoc down.
Mt interface trn router thay i trng thi hoc metric.
Mt ng i thay i.
Trong qu trnh pht tn, mt router s truyn v nhn cc LSPs.
* Gi v nhn LSP:
Khi nhn c mt LSP, router s lu trong database v nh du s
pht tn LSP ny. Nu LSP c trong database, router ch cn gi ack v sau
b qua LSP ny. Nu y l LSP mi, router s to ra mt LSP m t kt ni
ca n vi router lng ging. Sau , router s gi LSP mi v LSP do chnh n
to ra n cc neighbor. Cc neighbor kia, n lt n s pht tn n cc
neighbor k tip. Cc LSP level-1 c gi ra ton b area, trong khi cc level-2
LSP c gi ra tt c cc Level 2 routers.
Qu trnh truyn cc LSP trn cc kt ni vt l khc nhau s khc nhau.
* Truyn cc LSP trn cc interface point-to-point:
- Khi mt quan h adjacency c thit lp, c hai u u gi cc
CSNP packet trong c mt phin bn thu nh ca database.
- Nu c bt k mt LSP no khng c trong CSNP, router s gi mt
bng LSP cho router kia.
- Tng t, nu trong c s d liu b mt mt LSP no , router
nhn s yu cu gi li chnh xc LSP .
- Cc LSP c yu cu gi, nhn v cng nhn (ack) nh vo cc
PSNP.
- Khi mt LSP c gi, router s thit lp mt ng h. Nu sau mt
khong thi gian ht hiu lc (expire), LSP s c gi li.
Khong thi gian ny gi l minimumLSPTransmission-interval.
* Truyn cc LSP trn cc kt ni broadcast:
Cc update mc level 1 v level 2 dng cc a ch multicast. DIS c ba
cng vic sau:
To v duy tr cc quan h.
To v cp nht cc LSP.
Pht tn cc LSP trn mng LAN.
* Cc bc chnh trong qu trnh pht tn:
Khi nhn c CSNP, router s so snh LSP vi database.
Nu database c mt bn LSP mi hn hoc nu khng c phin
bn no ca LSP trong CSNP, router s pht tn cc LSP vo mng
LAN dng multicast.
T Chuyn mch i HCM
Thi Quc Khng

Bo co th vic

TM HIU V IS-IS
Nu database khng c LSP c gi trong CSNP, n s gi PSNP
yu cu mt LSP y .

Hnh 10 Cc bn tin CSNP - PSNP


* Xc nh LSP trong database l c hp l hay khng?
LSP c cha 3 field gip xc nh LSP ang c nhn c mi hn
LSP c trong database hay khng. Cc field ny l:
Remaining Lifetime: c dng loi ra cc LSP c. Nu mt
LSP tn ti trong database khong 20 pht, n gi s rng router ban u
ngng hot ng. Thi gian lm mi (refresh time) c gi tr l 15 pht. Nu
khong thi gian b ht hn (expire), LSP s loi b ni dung cha bn trong, ch
li header.
Sequence Number: y l mt gi tr tuyn tnh 32 bit. LSP u
tin c cp ch s l 1. Cc LSP k tip c tng ln 1.
Checksum: Nu mt router nhn mt LSP v checksum khng tnh
ton chnh xc, LSP s flush v lifetime ca LSP c gn v 0. Tt c cc
router cn li s b LSP. Router ban u s truyn li LSP mi.
Qu trnh quyt nh:
Sau khi database c ng b, router cn phi quyt nh ng i
no s dng n mt ch no . D nhin l c th s c nhiu ng i
chn la.
Mc tiu ca qu trnh quyt inh l to ra mt cy phn nh ng i ngn nht
n tt c cc ch. Mi router s xy dng mt cy trong bn thn n l root.
S c vi bng c to ra trong qu trnh ny. Bng PATH l bng cha ng
i ngn nht trong qu trnh xy dng. Bng TENT l bng tm c dng trong
qu trnh tnh ton.
Nu c nhiu hn mt ng i n mt ch, cc tiu chun sau y
c chn la:
Nu c nhiu hn mt ng i n mt ch, Router s dng ti a 6
ng i. Gi tr mc nh l 4.
T Chuyn mch i HCM
Thi Quc Khng

Bo co th vic
TM HIU V IS-IS
Cc metric ty chn c tham kho trc khi default-metric c
chn. Tuy nhin Routers ch h tr default-metric.
Cc ng i bn trong (internal) c chn trc cc ng i
external.
Cc ng i level-1 bn trong mt area th c u tin hn.
a ch vi subnetmask di nht s c dng.
Nu ToS (Type of Service) c cu hnh, ng i c ToS s c
chn trc cc ng i khc.
Nu ToS l bng nhau, s c ti a 6 ng i c t trong bng
routing. Router s thc hin load-balancing trn cc ng i ny.
Nu khng c ng i no, router s chuyn packet n level-2 router
gn nht, l router mc nh.
* Metric or Cost
Metric nh ngha ph tn ca ng i. IS-IS c 4 metric, trong ch c
mt metric l c dng. Cc metric c nh ngha l:
Default: Thng thong cn c gi l cost. Tt c cc IS-IS router phi
h tr loi cost ny. Gi tr mc nh l 10.
Delay.
Expense: phn nh chi ph hin thi ca network.
Error: tin cy ca ng i.
Qu trnh forwarding:
Cc ng i c subnet mask di nht s c chn.
Qu trnh nhn:
Cha c m t chi tit.

I.5 Cch thc hot ng ca IS-IS


IS-IS hot ng nh tuyn da trn 2 trng trong NSAP address sau:
Area address dng nh tuyn gia cc area.
System ID dng nh truyn trong area.
Cch thc hot ng ca IS-IS:
Level 1 router: Nu mt gi n router level 1, so snh area address
n v area address ca n, nu:
Bng nhau: level 1 router ny s nhn vo bng level 1 database
nh tuyn da vo system ID.
Khng bng: Chuyn gi n router level 1-2 gn nht.
Level 2 router: cng so sng area address tng t trn, nu:
Bng nhau: s dng area 1 database route da vo system ID.
Khng bng: s dng level 2 database route da vo system
T Chuyn mch i HCM
Thi Quc Khng

Bo co th vic
TM HIU V IS-IS
V d:

ID.
Cho m hnh mng nh sau:

Hnh 11 Tm ng bng giao thc nh tuyn IS-IS


Theo giao thc nh tuyn IS-IS th tuyn ng no s c thit lp khi
truyn gi tin t: X Y ; v t Y X?
Theo giao thc nh tuyn IS-IS:
- Router X xem xt area address ca Y, thy nm area khc, nn tm
ng ra Router L1-2 gn nht. Router L1-2 bit ng i chi tit, nn chn
ng ngn nht n Y.
- Cn Router Y n c X th ngc li, v Router Y thy khc area
nn chuyn v Router L1-2 gn nht, do Y khng bit ng i chi tit, nn n
phi nh L1-2 nh mt Gateway (Back-bone tng ng trong OSPF). hnh
trn, c 2 router L1-2, Y chn con ng i c cost nh hn (cost=10).
Vy, nh tuyn t X Y s i theo con ng mu xanh, cn t Y X s
theo con ng c t mu vng.
Mt router L1 s mang d liu ca tt c cc router nm trong cng mt khu
vc (local area) v n s ghi nhn nhng Router Level 1-2 nh l mt ng
nh tuyn mc nh (gateway) ra ngoi khu vc (default route). Mt
Router L2 s mang d liu ca tt c cc vng trong cng mt h thng c lp
(cng domain) v mt router L2 hoc L1-2 gn nht cho mi vng. V mt
Router L1-2 mang 2 bng thng tin d liu nh tuyn: mt bng d liu nh
tuyn L1 cho mng trong khu vc (ni vng intra-area), v mt cho ngoi khu
vc (lin vng inter-area). N cng s qung b mt tuyn ng mc nh
vo trong vng ca n.

I.6 Cc tiu ch thit k IS-IS


Trong ISIS, qu trnh thit k tp trung vo areas v a ch.
I.6.a Thit k Area trong ISIS
Khi thit k ISIS, cn xem xt cc dng d liu v ti nguyn c
yu cu bi ISIS. iu chnh qu trnh update c th l cn thit. Nu ta gim
T Chuyn mch i HCM
Thi Quc Khng

Bo co th vic
TM HIU V IS-IS
thi gian update, database s hi t nhanh hn nhng network c th thiu
resource route d liu.
Mt vi thit k tiu biu bao gm:
Mt mng dng flat ch dng level-1 routing. Thit k ny s khng
mang tnh m rng v bt k mt thay i no trong mng cng to
ra mt s pht tn cc LSPs n tt c cc routers. Tuy nhin, thit
k n gin ny c u im l ch c mt c s d liu v khng c
vn v suboptimal routing.
Mt mng flat dng level-2 routing: Khi h thng mng pht trin,
cc level-1 c th thm vo.
Mt h thng mng c cu trc, trong phn core chy level-2
routing cn level-1 kt ni n core. Level 1-2 router c dng
kt ni cc area.
I.6.b Route Summarization
Cc level 1-2 routers c th tm lc cc routes bn trong area ca n.
Route tng (summarize route) c lan truyn n level-2 routers.
Level 1 routes khng th c summarize bn trong areas bi v ISIS khng cho
php iu ny.

I.7 p dng IS-IS vo mp phng VN-2


C mt cu hi t ra l, v sao li p dng giao thc nh tuyn IS-IS vo
trong mng li ca VNPT? Giao thc ny c nhng c im ni bt g? Trn
mt phng VN-2, IS-IS c kh nng h tr qu trnh hot ng, nh tuyn nh
th no.
Trc tin, mt h thng mng c th hot ng c, cn phi
c mt giao thc nh tuyn (routing protocol) h tr, nhm m
bo vic truyn-nhn d liu c thc hin mt cch chnh xc,
nhanh chng.
Mng ng trc ca VNPT rt ln, c th phn thnh nhiu site,
nhiu vng (area) khc nhau. Chnh v vy, cn mt giao thc nh
tuyn ni hay nh tuyn trong min IGP (Interior Gateway
Protocol).
Nh vy, c rt nhiu kiu nh tuyn IGP khc nhau, nh: RIP, EIGRP,
OSPF, IS-ISti sao IS-IS li tr thnh giao thc nh tuyn ng c quan
tm? Cu tr li nm nhng c im ni bt ca IS-IS:
L mt giao thc nh tuyn ng, kiu Link-State, IS-IS hin
nhin tt hn hn mt giao thc nh tuyn kiu Distance Vector:
nh RIP (Routing Information Protocol), IGRP (Interior Gateway
Routing Protocol) v EIGRP (Enhanced IGRP); vi thi gian hi t
nhanh hn, h tr s lng node mng ln hn, v c kh nng
hiu r hon ton trng thi mng.
T Chuyn mch i HCM
Thi Quc Khng

Bo co th vic
TM HIU V IS-IS
Hot ng mt cch tng t OSPF (Open Shortest Path First),
nhng IS-IS ngy cng ng c quan tm, v:
o OSPF ch h tr ti a vi chc Router (khong 50 node
mng), cn IS-IS c th ln n vi trm. Trong khi mng
truyn dn trc ti VTN l rt ln.
o S hiu qu trong cch thc ng gi ca IS-IS so vi OSPF.
Vi nhng dch v khc nhau, OSPF phi ng thnh nhng
kiu gi tin khc nhau (v OSPF ng gi ti lp 3 Network,
nn ph thuc vo giao thc IP). Ngc li, IS-IS lm vic
ti nh ca lp 2 Datalink, vic ng gi cho cc loi dch
v khc nhau ch sai khc nhau phn TLV pha sau Header
chun.
o Cc trng TLV (Type-Length-Value) gip IS-IS d dng h
tr cho IPv6, trong khi OSPF mun h tr cho IPv6 phi m
rng ln thnh 1 giao thc mi OSPFv3.
o Giao thc IS-IS m rng c th h tr trn nn MPLS, v c
th p dng tin hnh vic nh tuyn kt hp vi iu
khin lu lng Traffic Engineering.
* Kt lun: Giao thc nh tuyn IS-IS l mt giao thc ng c quan
tm v ngy cng c p dng rng ri hn trong mi trng mng ng
trc, h tr cho mng ca cc nh cung cp dch v Internet (ISP).

T Chuyn mch i HCM


Thi Quc Khng

II. Cu hnh IS-IS


II.1 S khi tin trnh thc hin cu hnh IS-IS
Cc bc ci t IS-IS c cu hnh tng bc nh s sau:
START
Khi to IS-IS
(Enable IS-IS)
Cu hnh cc thng s tng qut
(Configure Global Parameters)
Tu chnh cc thng s trong
mng IS-IS (Tu chn)

Cu hnh cho tng Interface


(Configure Interface Parameters)

Sa
i

t a ch OSI
(Area Address)
* Ci t cc chng thc.
* nh timer cho cc bn tin xc thc.
t a ch IP address
p cho Interface vo
IS-IS, chn level

Hin th v X l
(Show & Debug)
n
g

Hin th cc thng s, xem


xt ci t IS-IS c chnh xc

* Thit lp cc ng Route.
* Thc hin Redistribute (nu cn)

Thc hin lnh PING kim


tra truyn nhn gi tin
m bo mng thng sut

END
Sau y ta s i tm hiu vo mt vi loi Router ang c s dng:

II.2 Router ca CISCO


II.2.1 Cc cu lnh
a. Khi to IS-IS:
Cu lnh:
Host(config)#router isis

Thc hin:
c thc hin trong mode Config., tc dng enable giao thc
nh tuyn IS-IS cho Router.
Ghi ch:
Nu nh tuyn cho gi CLNS packets, cn thm cu lnh:
Host(config)#clns routing
b. Cu hnh cc tham s tng qut:
t a ch NET:
Cu lnh:
Host(config-router)#net network-entity-title
Thc hin:
Cu hnh 1 a ch NSAP address.
Cu hnh level cho Router:
Cu lnh:
Host(config-router)#is-type {level-1 | level-1-2 | level-2-only}
Thc hin:
Cu hnh cho Router ng vi level ca n trong m hnh mng.
Ghi ch:
Mc nh ca CISCO, n s p cho router vo Level-1-2.
Cu hnh level trong IS-IS l mc Router, ch khng nh
OSPF l mc tng Interface.
c. Cu hnh cho cc Interfaces:
Ci t vic nh tuyn cho gi IP hay CLNS.
Cu lnh:
Host(config-if)#ip router isis
Host(config-if)#clns router isis
Thc hin:
Vo mode interface, ngha l ta phi vo 1 interface, sau ,
dung cu lnh Ip router isis p cho interface ny s dng giao
thc IS-IS nh tuyn gi tin IP; nu vic nh tuyn c thc
hin bng gi tin OSI (CLNS packets), th cu lnh clns router
isis c s dng.
Ghi ch:
Vic thc hin cu lnh ny l cn thit. Nu khng thc hin cu
lnh trn, Interface s khng apply vo giao thc IS-IS, s khng
thc hin c qu trnh nh tuyn.
Trong thc t th vic nh tuyn gi tin IP ph bin hn so vi
CLSN.

Cu hnh level cho Adjacency trn interface:


Cu lnh:
Host(config-if)#isis circuit-type {level-1|level-1-2|level-2-only}
Thc hin:
Cu hnh level cho cc k cn (Adjacencies) trn tng interface.
Ghi ch:
y, ta hiu khi mt Router c cu hnh level-1-2, nhng
c th yu cu giao tip vi nhng k cn level-1 trn interface
ny, v giao tip vi nhng k cn level-2 trn interface khc. Cu
lnh isis circuit-type ny cho php thc hin iu .
Mc nh, khi khng thc hin cu lnh ny, Router s p cc
adjacencies c 2 mc level.
Ci t metric trn interface:
Cu lnh:
Host(config-if)#isis metric default-metric {level-1 | level-2}
Thc hin:
Ci t metric cho interface.
Ghi ch:
Thay i gi tr metric trn interface. Cc gi tr ny c tnh
da vo bng thng, hay tc truyn trn lin kt mi interface.
Mc nh: default = 10.
Ngay trn cng 1 interface, ta cng c th cu hnh tham s
metric khc nhau gia level-1 v level-2.
d. Cc lnh show:
C rt nhiu cu lnh show khc nhau, gip chng ta x l, xem xt
trong tin trnh thc hin giao thc IS-IS, tu mc ch m cu lnh tng ng
c s dng.
Cu lnh:
Host#show isis topology
Host#show isis neighbors {detail}
Host#show isis database
Host#show isis route
Host#show ip route isis
Thc hin:
(1) Hin th bng topology ca IS-IS.
(2) Xem cc hng xm (neighbors) chy cng IS-IS.
(3) Hin th database ca giao thc IS-IS.
(4) Xem bng route ca IS-IS.
(5) Xem bng nh tuyn cho gi IP thc hin bng giao

(1)
(2)
(3)
(4)
(5)

thc

IS-IS.
Ghi ch:
Dng show ? tm kim nhng cu lnh show tng ng vi
mc ch cc tham s m ta ang cn hin th.
II.2.2 Cc v d khi cu hnh cho Router CISCO
II.2.2.a Ci t IS-IS c bn trong cng mt Area
Ta c s mng nh sau:

Cc bc cu hnh s c thc hin nh sau:


1. Enable IS-IS.
2. t a ch NSAP (a ch NET) cho Router.
3. t a ch IP address cho tng Interface.
4. Kim tra Routing table.
5. Ping test th gia cc Local host, show bng IS-IS neighbor.
Trn R1:

Trn R2:

Trn R3:

Kim tra bng Routing trn R1:

y ta thy 2 ng route chy theo giao thc IS-IS chnh l:


i L1 192.168.3.0/24
[115/20]
via 192.168.2.2
Serial1/1
i L1 192.168.4.0/24
[115/30]
via 192.168.2.2
Serial1/1
Cc a ch 192.168.3.0/24 v 192.168.4.0/24 l cc tuyn route hc c nh
giao thc nh tuyn IS-IS thng qua cng serial1/1 ca R1.
Ta c [115/20] = [AD/Metric].
Bng Administrative Distance (AD) ca cc giao thc nh tuyn thng dng:
Connected Interface
|0
Static Route
|1
EIGRP Summary Route
|5
External Bgp
| 20
Internal EIGRP
| 90
IGRP
| 100
OSPF
| 110
IS-IS
| 115
EGP
| 140
External EIGR
| 170
Internal BGP
| 200
Unknown
| 255
V y ta mc nh gi tr metric trn interface l 10, nn:
Metric ca tuyn ng 192.168.3.0/24 l 20: ng vi n c
mng 192.168.3.0/24 ny phi i qua 2 interfaces s1/1 ca R1, R2.
Metric ca tuyn ng 192.168.4.0/24 l 30: v phi i qua s1/1 ca
R1, s1/1 ca R2, v loopback ca R3.
II.2.2.b Ci t IS-IS trong Area, c chng thc
S mng nh sau:

Trong v d ny, chng ta s hng ti nhng mc tiu sau:


1. Khai bo v kim chng hot ng ca giao thc IS-IS trn tng
Router.
2. Cu hnh a ch NET xc nh domain, area, v intermedia system.
3. Cu hnh v kim chng cc k cn (adjacencies) Level 1 v Level 2.
4. Tm hiu v IS-IS topology table.
5. iu chnh thi gian xc nhn gia cc k cn.
6. Cc loi chng thc.
Cc bc cu hnh c thc hin nh sau:
Bc 1: Khi to IS-IS, t a ch NET cho mi Router.
Trn R1:
R1(config)# router isis
R1(config-router)# net 49.0001.1111.1111.1111.00
R1(config-router)# interface fastethernet 0/0
R1(config-if)# ip router isis
R1(config-if)# interface loopback 0
R1(config-if)# ip router isis
Trn R2:
R2(config)# router isis
R2(config-router)# net 49.0001.2222.2222.2222.00
R2(config-router)# interface fastethernet 0/0
R2(config-if)# ip router isis
R2(config-if)# interface loopback 0
R2(config-if)# ip router isis

Trn R3:
R3(config)# router isis
R3(config-router)# net 49.0001.3333.3333.3333.00
R3(config-router)# interface fastethernet 0/0
R3(config-if)# ip router isis
R3(config-if)# interface loopback 0
R3(config-if)# ip router isis
Bc 2: Thc hin vic ci t cc a ch IP addres trn looback, v trn
Interfaces ca cc Router (thc hin n gin b qua); sau dng cc cu
lnh show hin th cc thng tin trong giao thc nh tuyn IS-IS:
R1# show ip protocols
Routing Protocol is "isis"
Invalid after 0 seconds, hold down 0, flushed after 0
Outgoing update filter list for all interfaces is not set
Incoming update filter list for all interfaces is not set
Redistributing: isis
Address Summarization:
None
Maximum path: 4
Routing for Networks:
FastEthernet0/0
Loopback0
Routing Information Sources:
Gateway
Distance
Last Update
192.168.30.1
115
00:00:36
192.168.20.1
115
00:00:36
Distance: (default is 115)
Giao thc ang c chy trn R1 chnh l IS-IS.
R1# show clns protocols
IS-IS Router: <Null Tag>
System Id: 1111.1111.1111.00 IS-Type: level-1-2
Manual area address(es):
49.0001
Routing for area address(es):
49.0001

Interfaces supported by IS-IS:


FastEthernet0/0 - IP
Loopback0 - IP
Redistribute:
static (on by default)
Distance for L2 CLNS routes: 110
RRR level: none
Generate narrow metrics: level-1-2
Accept narrow metrics: level-1-2
Generate wide metrics: none
Accept wide metrics: none
V trn ta cha cu hnh cho R1 l Router Level no, nn n default l
Level-1-2.
Tip theo, ta s dng cu lnh: show clns neighbors xem cc k cn s
dng truyn nhn CLNS (vi gi thuyt cu hnh ISIS cho cc Routers khc):
R1# show clns neighbors
System Id Interface
SNPA
R2
Fa0/0
0004.9ad2.d0c0
R3
Fa0/0
0002.16f4.1ba0

State
Up
Up

Holdtime
9
29

Type Protocol
L1L2 IS-IS
L1L2 IS-IS

Nu chi tit hn ta s dng: show clns neighbors detail thy c c


a ch IP address trn con router k cn ny. iu ny cng cho thy, IS-IS
h tr c c CLNS address ln IP address trong qu trnh nh tuyn.
R1# show clns neighbors detail
System Id Interface
SNPA
R2
Fa0/0
0004.9ad2.d0c0
Area Address(es): 49.0001
IP Address(es): 172.16.0.2*
Uptime: 00:07:30
NSF capable
R3
Fa0/0
0002.16f4.1ba0
Area Address(es): 49.0001
IP Address(es): 172.16.0.3*
Uptime: 00:07:00
NSF capable

State Holdtime Type Protocol


Up
24
L1L2 IS-IS

Up

27

L1L2 IS-IS

Cui cng, ta s dng cc cu lnh: show isis topology, show ip route


xem cc ni dung trong s mng m giao thc IS-IS ang chy, cng nh cc
tuyn ng c th chm n c sau khi chy IS-IS:

R1# show isis topology


IS-IS paths to level-2 routers
System Id Metric Next-Hop
R1
-R2
10
R2
R3
10
R3

Interface

SNPA

Fa0/0
Fa0/0

0004.9ad2.d0c0
0002.16f4.1ba0

R1# show ip route


<output omitted>
Gateway of last resort is not set
i L2 192.168.30.0/24 [115/20] via 172.16.0.3, FastEthernet0/0
C 192.168.10.0/24 is directly connected, Loopback0
172.16.0.0/24 is subnetted, 1 subnets
C 172.16.0.0 is directly connected, FastEthernet0/0
i
L2 192.168.20.0/24 [115/20] via 172.16.0.2, FastEthernet0/0
Bc 3: iu chnh thi gian gi bn tin Hello trong IS-IS.
R1(config)# interface fastethernet 0/0
R1(config-if)# isis hello-interval 5
Ghi ch:
* Phi iu chnh ging nhau trn cc cng ca 2 router cng ni vi nhau
th giao thc IS-IS mi chy c.
* Gia IS-DIS th sau 3.3s s gi mt bn tin Hello, cn gia IS-IS l 10s
nhm thit lp neighbors vi nhau.
* Gp 3 ln thi gian Hello m Router ny khng nhn c bn tin hello do
neighbor ca n gi ti, n hiu rng lin kt gy, v loi b neighbor ny.
Bc 4: Ci t cc chng thc gia cc Router chy IS-IS (thng l Level-2
Router), v t password cho tng min (domain)
R1(config)# interface FastEthernet 0/0
R1(config-if)# isis password cisco level-2
R2(config)# interface FastEthernet 0/0
R2(config-if)# isis password cisco level-2
R3(config)# interface FastEthernet 0/0
R3(config-if)# isis password cisco level-2
Sau khi t pass cho level-2, show bng clns neighbors s thy s khc bit:
R1# show clns neighbors

System Id Interface
SNPA
R2
Fa0/0
0004.9ad2.d0c0
R3
Fa0/0
0002.16f4.1ba0

State Holdtime Type Protocol


Up
23
L2
IS-IS
Up
26
L2
IS-IS

Khi ci t chng thc, cc Router chy IS-IS c set ln Level-2 Router.


R1(config)# router isis
R1(config-router)# domain-password cisco
Tng kt:
Khi cu hnh xong, ta c:
R1# show run
Building configuration...
Current configuration : 1290 bytes
!
version 12.4
!
hostname R1
!
interface Loopback0
ip address 192.168.10.1 255.255.255.0
ip router isis
!
interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.0
ip router isis
duplex auto
speed auto
isis password cisco level-2
isis priority 100
isis hello-interval 5
!
router isis
net 49.0001.1111.1111.1111.00
is-type level-2-only
domain-password cisco
!
End

R2# show run


Building configuration...
Current configuration : 1044 bytes
!
version 12.4
!
hostname R2
!
interface Loopback0
ip address 192.168.20.1 255.255.255.0
ip router isis
!
interface FastEthernet0/0
ip address 172.16.0.2 255.255.255.0
ip router isis
duplex auto
speed auto
isis password cisco level-2
isis priority 100
isis hello-interval 5
!
router isis
net 49.0001.2222.2222.2222.00
is-type level-2-only
domain-password cisco
!
End
R3# show run
Building configuration...
Current configuration : 1182 bytes
!
version 12.4
!
hostname R3
!
interface Loopback0

ip address 192.168.30.1 255.255.255.0


ip router isis
!
interface FastEthernet0/0
ip address 172.16.0.3 255.255.255.0
ip router isis
duplex auto
speed auto
isis password cisco level-2
isis priority 100
isis hello-interval 5
!
router isis
net 49.0001.3333.3333.3333.00
is-type level-2-only
domain-password cisco
!
End
II.2.2.c Ci t IS-IS trong Multi-Area
S mng nh sau:

v d trn, ta thy giao thc nh tuyn IS-IS hot ng tt trong ni


vng (area). Tip theo, ta s thc hin vic nh tuyn gia nhng Area khc
nhau.
Yu cu t ra l s thit lp 1 kt ni Point-to-Point gia R1 v R3. R3 l
router khu vc (49.0002) khc vi khu vc mng li (49.0001).
Trong bi lab ny, ta cu hnh cho:
o R1 l Level-1-2 Router.
o R2 l Level-1 Router.
o R3 l Level-2 Router.
Vic cu hnh c thc hin tng bc nh v d trn, cui cng, ta c c:
R1# show run
Building configuration...
!
version 12.4
!
hostname R1
!
interface Loopback0
ip address 192.168.10.1 255.255.255.0
ip router isis
!
interface FastEthernet0/0
ip address 172.16.0.1 255.255.255.0
ip router isis
isis password cisco
isis priority 100
isis hello-interval 5
no shutdown
!
interface Serial0/0/1
ip address 10.0.0.2 255.255.255.252
ip router isis
no shutdown
!
router isis
net 49.0001.1111.1111.1111.00
domain-password cisco
!

end
R2# show run
Building configuration...
!
hostname R2
!
interface Loopback0
ip address 192.168.20.1 255.255.255.0
ip router isis
!
interface FastEthernet0/0
ip address 172.16.0.2 255.255.255.0
ip router isis
isis password cisco
isis priority 100
isis hello-interval 5
no shutdown
!
router isis
net 49.0001.2222.2222.2222.00
is-type level-1
domain-password cisco
!
end
R3# show run
Building configuration...
!
version 12.4
!
hostname R3
!
interface Loopback0
ip address 192.168.30.1 255.255.255.0
ip router isis
!

interface Serial0/0/0
ip address 10.0.0.1 255.255.255.252
ip router isis
clock rate 128000
no shutdown
!
router isis
net 49.0002.3333.3333.3333.00
is-type level-2-only
domain-password cisco
!
End

II.3 Trong Router Alcatel 7750


Router Alcatel 7750 c nhng cu lnh thc hin IS-IS tng t nh
Router ca CISCO.
II.3.1 Cc cu lnh
a. Khi to IS-IS:
Cu lnh:
Config>router# isis
Thc hin:
Enable giao thc nh tuyn IS-IS cho Router.
b. Xc nh Level cho Router:
Cu lnh:
Config>router# isis
level-capability {level-1|level-2|level-1/2}
level {1|2}
Thc hin:
Xc nh level cho Router.
V d:
config>router# isis
config>router>isis# level-capability 1/2
config>router>isis# level 2
Ghi ch:
* Mc nh, nu ta khng config level cho Router, n
s c p vo Level-Capability l Level-1/2, ngha l c
kh nng hot ng nh tuyn level 1 ln level 2.
* Cu lnh Level {1|2} c dng khi ta cu hnh cho
Router ny ch hot ng nh tuyn hoc level 1 hoc

ch Level 2 m thi.
c. Cu hnh ISO Area Addresses:
Cu lnh:
config>router# isis
area-id area-address
Thc hin:
t a ch NSAP (NET) cho router.
d. Cu hnh cc thng s tng qut cho IS-IS:
Cc cu lnh:
config>router# isis
config>router>isis#
config>router>isis# level-capability level-2
config>router>isis# authentication-check
config>router>isis# authentication-type password
config>router>isis# authentication-key test
config>router>isis# overload timeout 90
config>router>isis# traffic-engineering
Thc hin:
- Chn cp cho Router l Level-n ; n=1, 2 hay 1/2.
- C chng thc bng cu lnh authentication-check.
- t password = do ngi cu hnh t vo,
password ny cn ging nhau gia nhng Router k cn
cng chy IS-IS.
- Thi gian overload = 90s.
- C h tr traffic-engineering.
e. Cu hnh IS-IS trn tng Interface ca Router:
Cu lnh:
PEx>config>router>isis# interface system
PEx>config>router>isis>if# back
PEx>config>router>isis# interface <topex>
PEx>config>router>isis>if# interface-type point-to-point
Thc hin:
Apply cho tng Interface chy IS-IS.
Cu lnh:
PEx>config>router>isis# reference-bandwidth 100000000
Thc hin:
Chn BW(ref)=100.000.000bps = 100Mbps
Ghi ch:

Metric = BW(ref) / BW
f. Cu hnh IPv6 h tr trn IS-IS:
Cu lnh:
config>router# isis
multi-topology
ipv6-unicast
Thc hin:
Thc hin giao thc nh tuyn i vi IPv6.
Ghi ch:
IPv6-unicast-address = l a ch n hng, xc
nh 1 node mng n (router), c th l khi mt gi tin
c gi ti 1 mt a ch n hng unicast s c
chuyn ti ng node mng mang a ch Unicast .
g. Cc cu lnh Show h tr IS-IS trong Alcatel 7750:
Cu lnh:
PEx# show router isis status
(1)
PEx# show router isis interface
(2)
PEx# show router route-table protocol isis(3)
PEx# show router isis adjacency
(4)
PEx# show router isis database
(5)
Thc hin:
(1) Xem trng thi hin ti ca giao thc IS-IS.
(2) Xem thng s ca cc Interfaces chy IS-IS.
(3) Xem bng nh tuyn c thc hin bng IS-IS.
(4) Xem cc Adjacencies cng chy IS-IS.
(5) Xem c s d liu trng thi lin kt ca IS-IS.
Ghi ch:
Cu lnh (1) gip ta thy c area-id ca node mng.
Cu lnh (2) hin th metric trn tng Interface.
h. Cc cu lnh h tr chng thc trong IS-IS trn Alcatel 7750:
Cu lnh:
PEx>config>router>isis>if#
hello-authentication-type password
PEx>config>router>isis>if#
hello-authentication-key <your_password>
Thc hin:
Thc hin vic chng thc bng password trong qu trnh
truyn nhn bn tin Hello xc lp cc neighbors cng chy IS-IS.

i. Routing Policies v Redistribution:


L mt phn kh hay trong giao thc nh tuyn IS-IS. N cho php nh
tuyn theo chnh sch (gn tng t nh Traffic Engineering), v thc hin vic
redistribution gia nhng giao thc nh tuyn (thng l IGP v BGP).
V d:
1. To mt interface mi, t tn l <toce>
PEx# configure router interface toce
PEx>config>router>if# address 192.168.<XX>.1/30
Trong : <XX> = a ch ca nh cung cp dch v PE (Provider Edge).
2. Cu hnh cho pha u cui khch hng CE (Customer Edge), ch
default route n IP ca PE:

3. S dng lnh Ping kim tra CE c kt ni c vi PE. Nu c, hy


c gng chm n cc CEs khc. Khi ny, nu bn ping khng c,
chng t cc giao thc nh tuyn (c bit IGP, BGP) khng c
redistribute vi nhau (v pha CEs khc ni n PE khng dng chung
giao thc nh tuyn ca bn). Tin hnh bc tip theo.
4. Khi ny, ta nh ngha mt bng Policies trn PE:
PEx# configure router
PEx>config>router# policy-options
PEx>config>router>policy-options# begin
PEx>config>router>policy-options#
policy-statement <policy_name>
PEx>config>router>policy-options>policy-statement#
default-action reject
PEx>config>router>policy-options>policy-statement#
entry 10
PEx>config>router>policy-options>policy-statement>entry#
from protocol direct
PEx>config>router>policy-options>policy-statement>entry#
action accept
PEx>config>router>policy-options>policy-statement>entry>action#
back
PEx>config>router>policy-options>policy-statement>entry# back
PEx>config>router>policy-options>policy-statement># back
PEx>config>router>policy-options># commit
5. Xc nhn Policy

PEx>show>router# policy
6. ng thi phi apply giao thc nh tuyn tng ng vo bng Policies
trn:
PEx>config>router>isis># export <policy_name>
II.3.2 Cc v d cu hnh trn Alcatel 7750
II.3.2.a V d cu hnh trong Area Level 1
Cho s mng nh sau, cc Router u Level 1:

Cc bc cu hnh c thc hin nh sau:


Trn ALA-A:
A:ALA-A>config>router# isis
A:ALA-A>config>router>isis# area-id 49.0180.0001
A:ALA-A>config>router>isis# level-capability level-1
A:ALA-A>config>router>isis# interface system
A:ALA-A>config>router>isis>if# exit
A:ALA-A>config>router>isis# interface A-B
A:ALA-A>config>router>isis>if# exit
A:ALA-A>config>router>isis# interface A-C
A:ALA-A>config>router>isis>if# exit
A:ALA-A>config>router>isis#
Trn ALA-B:
A:ALA-B>config>router# isis
A:ALA-B>config>router>isis# area-id 49. 0180.0001
A:ALA-B>config>router>isis# level-capability level-1
A:ALA-B>config>router>isis# interface system
A:ALA-B>config>router>isis>if# exit
A:ALA-B>config>router>isis# interface B-A
A:ALA-B>config>router>isis>if# exit
A:ALA-B>config>router>isis# interface B-C

A:ALA-B>config>router>isis>if# exit
A:ALA-B>config>router>isis#
Trn ALA-C:
A:ALA-C>config>router# isis
A:ALA-C>config>router>isis# area-id 49. 0180.0001
A:ALA-C>config>router>isis# level-capability level-1
A:ALA-C>config>router>isis# interface system
A:ALA-C>config>router>isis>if# exit
A:ALA-C>config>router>isis# interface C-A
A:ALA-C>config>router>isis>if# exit
A:ALA-C>config>router>isis# interface C-B
A:ALA-C>config>router>isis>if# exit
Ghi ch:
Khi cu hnh IS-IS cn xc nh level cho Router, t a ch NET.
Sau , cn apply cho cc Interfaces vo giao thc IS-IS.
II.3.2.b V d cu hnh trong Multi-Area
Lc ny, ta c s mng nh bn di. Router ALA-A tr thnh
Level-1/2. Vic cu hnh hon ton tng t trng hp II.2.3.a, ch cn set
cho ALA-A ln thnh Router L1/2 nh sau:
A:ALA-A>config>router# isis
A:ALA-A>config>router>isis# level-capability level-1/2

II.4 Cu hnh trong Juniper T1600


Cc cu lnh trong Juniper Router h tr cho IS-IS cng kh ging vi
CISCO hay Alcatel Router. Nhng quy nh v enable IS-IS, aplly IS-IS ln mt

cng interface, cch t a ch NET hay cc lnh show c cu trc tng t 2


dng Router trn, ch sai bit nhau v 1 vi tham s.
iu c bit l, Juniper Router (Junose) i u trong vic trin khai hin
th cu hnh dng lnh theo cu trc cy. Mc d cc Router bin ERX-14xx,
ERX-7xx (dng E-series) c cu trc cu lnh ging router ca Cisco hay
Alcatel, nhng khi ta dng lnh show hin th, cc thng tin cu hnh c
trnh by theo mode nh mt cu trc cy (gn ging vi cu trc lp trnh C,
C++, ), iu ny gip ngi cu hnh d dng quan st, chnh sa, v hiu r
cch t chc, lm vic ca Router.
Vi dng Router li T1600 m VTN ang s dng, vic cu hnh c
thc hin trong cc mode [edit protocol] dng cy; lc ny c th chnh sa,
modify li cu hnh mt cch nhanh chng, chnh xc, khng cn phi vo tng
mode configurate terminal router interface mt cch rm r, m c th
trc tip t file cu hnh, nhy n ngay protocol, hoc mode m ta cn chnh
tham s, sa trc tip cu lnh trong protocol, hoc mode ny, m khng lm
nh hng n cc thnh phn khc trong file config.
Sau y, n gin hn nhng ni bn trn, cch cu hnh c bn nht
trong Juniper T1600 Router h tr cho IS-IS s c trnh by, gip thy c
s d dng trong vic configure Router T1600.
a. Nhng cu hnh c bn nht ca IS-IS:
Router c th chy c IS-IS, cn phi Enable IS-IS, cn cu hnh
a ch NET cho n, hoc 1 trong cc cng ca router, thch hp nht l interface
loopback 0 (lo0). Ngoi ra, cn phi cu hnh theo chun ISO trn tt c cc
interface chy IS-IS. y, c mt s khc bit so vi cc dng Router ca
CISCO hay ALCATEL, l ta t NET address trn interface lo0 ch khng
phi nh trong mode config>router#.
Tng t, khi enable IS-IS, router c mc nh Level-1/2.
Cn apply cho cc interface chy IS-IS bng cu lnh:
Interface <interface-name>/all

b. Ci t nhng tham s chung cho mt IS-IS level trc khi p ln


Interface:

c. Ci t cch thc hot ng ca thut ton SPF cho IS-IS:


IS-IS s dng thut ton SPF l Dijkstra tnh ton ng i ngn nht.
Trong IS-IS nh ngha 3 khong thi gian cho cch thc hot ng ca
SPF, l: delay, holddown v rapid-runs.

Delay: khong thi gian t khi c s thay i topology mng n


khi SPF kch hot li. Default=200ms,thuc khong [50-1000ms].
Holddown: thi gian trong cc bc chy SPF thc hin, nu
vt qu thi gian holddown ny th s drop. Default=5s, thuc
khong [2s-10s].
Rapid-runs: s ln chy thut ton SPF, default=3, [1-5] (ln)

d. Cu hnh Routing policy v CLNS cho IS-IS:


Cu hnh Routing Policy:

Vi cu hnh nh trn, nhng gi tin c nh tuyn bng giao thc BGP,


v cc kt ni trc tip (Static), thuc chun ca ISO s c forward vo IS-IS.
Tip n, ta s ci t CLNS cho IS-IS:
Vi cc dng lnh:
no-ipv4-routing;
no-ipv6-routing;
clns-routing;
khng s dng IP, m s dng c CLNS address route.

T bng Policy trn, ta nh ngha dist-static l s accept tt c cc iso


address. C th hiu l t nhng interface fe-0/0/1.0, t1-0/2/1.0 v lo0.0 (ngoi
tr fxp0.0) th cc static route distinguiser kt ni vo n, v cc tuyn ng
c tm thy bi giao thc IS-IS chy trn CLNS c th hiu c nhau.
Mt vi v d v vic p dng cc bng chnh sch nh tuyn IS-IS:
1. Mt bng chnh sch cm tt c cc route level-1:

2. Mt chnh sch nh tuyn export nhng tuyn routes ni vng


Level-1 ra Level-2:

3. Mt chnh sch nh tuyn export nhng tuyn routes ngoi vng


Level-2 vo Level-1:

4. Mt chnh sch nh tuyn cho php nhng tuyn routes ca BGP t EDU
giao tip c, v t chng vo trong IS-IS vi metric=14:
y, "Edu memeber 666:5" = target c to ra trc trong giao
thc nh tuyn BGP.
Vi cu hnh ny, bt k tuyn routes no c qung b nh vo giao thc
nh tuyn BGP vo trong IS-IS th n u t vo bng nh tuyn vi metric
thm l 14.

e. Ci t h tr IPv6 trong IS-IS trn T1600:

f. Disable v Re-enable IS-IS:


Ta thy, khc vi cc dng router khc, T1600 c th h tr n 2 cch
enable hay disable: mt l thay i trc tip trong file cu hnh lnh, cch hai l
nh cu lnh delete isis disable t mode user@host#.

y s dng cu lnh delete isis disable b disable trc , khc vi


Cisco hay Alcatel router ch cn vo mode ca giao thc , v nh ln cu
lnh, v d host#router isis.
Tng kt:
Vi vic cu hnh theo s lp trnh dng cy, vic ci t cho router
Juniper T1600 trc quan, d hiu.
Trong T1600 khng cn s dng cc cu lnh Show nhiu, v khi ta xem
file cu hnh, vi cch hin th nh vy, ta c th bit c nhng tham
s ci t nh th no.
Lnh ping nhm test s giao tip c gia cc node mng cng c
Juniper T1600 h tr nh nhng dng router khc.

III. Kt lun v IS-IS


Vi rt nhiu u im, IS-IS tr thnh mt giao thc nh tuyn ng c
quan tm, c bit l i vi mng li ca VTN, h tr nhiu ISP, ang trin
khai MPLS v sp n l vn n IPv6.
IS-IS l mt giao thc nh tuyn vi tham vng h tr cho tt c cc h
thng, tch hp nhng u im ca cc giao thc nh tuyn khc, nn IS-IS tr
nn kh phc tp. Tm hiu nhng nt c bn nht trong IS-IS gip ngi vn
hnh thit b c ci nhn tng qut, khi cu hnh thc t s d dng hn trong
vic tin hnh ci t, theo nhng quy nh ca tng dng Router ca tng nh
cung cp khc nhau.

Vi bo co th vic ny, ch mong tm hiu nhng nt c bn nht, nm bt


c cch thc hot ng trong giao thc nh tuyn IS-IS. Trong thi gian hn
hp, bo co khng th trnh khi nhng sai st, knh mong cc anh, cc bn
trong i HCM ng gp hon thin hn.
------

Ti liu tham kho:


1. 7750 Services Router Implementation), Alcatel-Lucent, July 2008.
2. 7750 SR OS Routing Protocols Guide, Alcatel-Lucent, Feb. 2009.
3. Routing Protocols Configuration Guide, Juniper Networks JUNOS
software (Release 9.1), 2000.
4. Juniper Networks Reference Guide: JUNOS Routing, Configuration,
and Architecture, Thomas M. Thomas, Oct. 2002.
5. Cc ti liu t ngun Internet.
------