Está en la página 1de 10

INFORME FINAL 1: SIMULACIN SPT / RSPT

LAB. TELE III FIEE-UNI


Choque Chupa Luis Alonso, Navarro Rosemberg Isaac, Espaa Meza Makler, Manrique Eric

1. Realizamos la simulacin de la topologa implementada en clase:


Usamos el programa GNS3 por esta ocasin solo por cuestiones de comodidad.
En los siguientes laboratorios optaremos a usar el simulador de equipos HUAWEI
llamado eNSP

2. A continuacin explicaremos al detalle cmo funciona el STP / RSTP:


Cuando Inicia el protocolo STP, en el inicio necesita datos como las direcciones MAC de
cada interfaz (puertos), para el correcto funcionamiento del algoritmo:

Y de esa forma el protocolo STP genera solo una ruta para evitar los loops (bucles)
que afectaran la estabilidad de mi red.

Comandos de Configuracin SW HUAWEI


VISUALIZAMOS LAS CONFIG. ACTUAL:
<HW-LIM-S3928-4>sys
<HW-LIM-S3928-4>system-view
[HW-LIM-S3928-4]
[HW-LIM-S3928-4]display currentconfiguration
#
sysname HW-LIM-S3928-4
#
radius scheme system
#
domain system
#
local-user huawei
password simple huawei
service-type ssh telnet
level 3
service-type ftp
local-user jimenez
password simple jimenez
service-type telnet
level 3
#
stp mode stp
stp enable
#
vlan 1 to 5
#
vlan 13
description MOLINAVILCA
#
vlan 103
description CAMARENA
#
vlan 113
description MOLINA
#
vlan 119
description hans
#
vlan 203
description QUISPE
#
vlan 213
description VILCA
#
vlan 219
description solier
#
interface Vlan-interface1
ip address 192.168.1.4 255.255.255.0
#
interface Vlan-interface4
ip address 10.10.10.2 255.255.255.0
#
interface Vlan-interface5
ip address 10.10.20.2 255.255.255.0
#

#
interface Vlan-interface103
ip address 192.168.103.4 255.255.255.0
#
interface Vlan-interface113
ip address 192.168.113.4 255.255.255.0
#
interface Vlan-interface119
ip address 192.168.119.4 255.255.255.0
#
interface Vlan-interface203
ip address 192.168.203.4 255.255.255.0
#
interface Vlan-interface213
ip address 192.168.213.4 255.255.255.0
#
interface Vlan-interface219
ip address 192.168.219.4 255.255.255.0
#
interface Aux1/0/0
#
interface Ethernet1/0/1
#
interface Ethernet1/0/2
#
interface Ethernet1/0/3
#
interface Ethernet1/0/4
#
interface Ethernet1/0/5
#
interface Ethernet1/0/6
#
interface Ethernet1/0/7
#
interface Ethernet1/0/8
#
interface Ethernet1/0/9
#
interface Ethernet1/0/10
#
interface Ethernet1/0/11
stp disable
#
interface Ethernet1/0/12
#
interface Ethernet1/0/13
port link-type trunk
port trunk permit vlan all
#
interface Ethernet1/0/14
#
interface Ethernet1/0/15
#
interface Ethernet1/0/16
#
interface Ethernet1/0/17
#
interface Ethernet1/0/18

#
interface Ethernet1/0/19
stp point-to-point force-true
port link-type trunk
port trunk permit vlan 1 113 213
#
interface Ethernet1/0/20
stp point-to-point force-true
port link-type trunk
port trunk permit vlan 1 113 213
#
interface Ethernet1/0/21
#
interface Ethernet1/0/22
port link-type trunk
port trunk permit vlan 1 103 119 203 219
#
interface Ethernet1/0/23
port link-type trunk
port trunk permit vlan 1 103 119 203 219
#
interface Ethernet1/0/24
#
interface GigabitEthernet1/1/1
#
interface GigabitEthernet1/1/2
#
interface GigabitEthernet1/1/3
#
interface GigabitEthernet1/1/4
#
undo irf-fabric authentication-mode
#
interface NULL0
#
interface LoopBack13
ip address 192.168.15.1 255.255.255.0
#
voice vlan mac-address 0001-e300-0000
mask ffff-ff00-0000
#
ip route-static 192.168.14.0
255.255.255.0 192.168.13.2 preference 60
#
user-interface aux 0 7
user-interface vty 0 4
user privilege level 3
set authentication password simple
huawei
#
return

ACTIVANDO STP EN EL SWITCH HUAWEI DEL LABORATORIO:


[HW-LIM-S3928-4]
[HW-LIM-S3928-4]stp enable
[HW-LIM-S3928-4]
[HW-LIM-S3928-4]stp mode
[HW-LIM-S3928-4]stp mode rstp
[HW-LIM-S3928-4]
[HW-LIM-S3928-4]displ
[HW-LIM-S3928-4]display stp
[HW-LIM-S3928-4]dis
[HW-LIM-S3928-4]display stp bri
[HW-LIM-S3928-4]display stp brief
MSTID Port
Role STP State Protection
0 Ethernet1/0/1
DESI FORWARDING NONE
0 Ethernet1/0/2
DESI FORWARDING NONE
(*) means port in aggregation group
[HW-LIM-S3928-4]dis
[HW-LIM-S3928-4]display ip
[HW-LIM-S3928-4]display ip in
[HW-LIM-S3928-4]display ip interface bri
[HW-LIM-S3928-4]display ip interface brief
*down: administratively down
(l): loopback
(s): spoofing
Interface
IP Address Physical Protocol Description
LoopBack13
192.168.15.1 up
up(s)
LoopBack1...
Vlan-interface1
192.168.1.4 up
up
Vlan-inte...
Vlan-interface4
10.10.10.2 down down
Vlan-inte...
Vlan-interface5
10.10.20.2 down down
Vlan-inte...
Vlan-interface13
192.168.13.3 down down
Vlan-inte...
Vlan-interface103
192.168.103.4 down down
Vlan-inte...
Vlan-interface113
192.168.113.4 down down
Vlan-inte...
Vlan-interface119
192.168.119.4 down down
Vlan-inte...
Vlan-interface203
192.168.203.4 down down
Vlan-inte...
Vlan-interface213
192.168.213.4 down down
Vlan-inte...
Vlan-interface219
192.168.219.4 down down
Vlan-inte...
[HW-LIM-S3928-4]dis

3. Finalmente podemos hacer una captura de paquetes con el programa WIRESHARK,


Y analizaremos los campos del BPDU:

Y para terminar, recogemos los datos del BPDU generado por Spanning Tree Protocol:

Segn el estndar IEEE 802.1D Y 802.1W

Y de los Datos recogidos del WIRESHARK:


ENLACE DESDE SW1 A SW2 (BPDU CONF. TC + ROOT)
Byte

Hexade
cimal

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35

00
00
00
00
00
80
00
C4
01
14
E8
00
00
00
00
00
00
80
00
C4
01
14
E8
00
00
80
29
00
00
14
00
02
00
0F
00

INFO

Protocol ID (ID 802.1: 0x0000)


Protocol Type (STP)
BPDU Type (Configuration)
BPDU Flags
Root Bridge Priority
Root Bridge System ID
(MAC)

Root Path Cost

Bridge ID
(32768)

Port ID
Message Age
Max Age
Hello Time
Forward Time

SOURCE:
C4 01 14 E8 F1 00
DESTINATION: 01 80 C2 00 00 00 (multicast STP)

Bridge Priority
8
1000
-- 4 bits --

Bridge System ID Ext.


000
0000 0000 0000
-- 12 bits -Total: 8 bytes

Bridge System ID
C4 01 14 E8 00 00
MAC
-- 48 bits --

CONCLUSIONES.-

Es indispensable el uso del protocolo STP en cualquier topologa de red que


contenga bucles a nivel de capa 2 (Ej, MetroEthernet), ya que me evita la formacin
de los bucles nocivos para el procesamiento y gestionamiento apropiada de mi red.

RSTP es una actualizacin del protocolo STP, cuya importancia consiste en el alto
grado de convergencia (menores tiempos de establecimiento) de las tablas y datos
de red.

También podría gustarte