Está en la página 1de 2

Materia:DFPRUnidad2Actividad2Diseodeunalgoritmoconestructurasselectivas

Disea un algoritmo en pseudocdigo y diagrama de flujo que resuelva el siguiente problema.


Imagina que eres un chef y tienes en tu menu ricos tacos de asada, adoba y lengua el
cual debes preparar 1 solo taco de acuerdo a lo que el comenzal solicite.
Recuerda que se puede poner o no cebolla, cilantro, salsa.
A continuacin presento mi propuesta de resolucin del problema planteado, que la verdad fue algo muy divertido.
Pseudocodigo:
Proceso Taqueria
existencia<-0
Escribir 'Tenemos tacos de asada, adobada y lengua...'
Escribir 'Que le sirvo joven?'
Leer seleccion1
Si seleccion1='asada' Entonces
Escribir 'Entonces uno de ',seleccion1
existencia<-1
Sino
Si seleccion1='adobada' Entonces
Escribir 'Entonces uno de ',seleccion1
existencia<-1
Sino
Si seleccion1='lengua' Entonces
Escribir 'Entonces uno de ',seleccion1
existencia<-1
Sino
Escribir '... de ',seleccion1,' no me queda'
existencia<-0
FinSi
FinSi
FinSi
Si existencia=1 Entonces
Escribir 'le gustaria con cebolla, su taco de ',seleccion1,'?'
Leer seleccion2
Si seleccion2='si' Entonces
Escribir ' con cebollita ...'
FinSi
Escribir "Cilantrito?"
Leer seleccion3
Si seleccion3='si' Entonces
Escribir con "cilantrito..."
FinSi
Escribir "Salsita joven?"
Leer seleccion4
Si seleccion4='si' Entonces
Escribir '..salsita, ahi esta joven'
Sino
FinSi
Escribir 'buen provecho, y gracias por venir..'
Sino
Escribir 'lo siento joven, de veras que de ',seleccion1,' no tengo...'
FinSi
FinProceso

Pgina 1 de 2

Materia:DFPRUnidad2Actividad2Diseodeunalgoritmoconestructurasselectivas
Diagrama de flujo:

Ejecucin del Programa.

Caso: No hay el taco que el cliente solicita.

Caso: Un taco de lengua con cebolla y salsa.

Pgina 2 de 2