Está en la página 1de 1

iniciar-programa

inicia-ejecucion
si orientado-al-norte entonces gira-izquierda;
si orientado-al-este entonces repetir 2 veces gira-izquierda;
si orientado-al-sur entonces repetir 3 veces gira-izquierda;
mientras frente-libre hacer avanza;
si frente-bloqueado y derecha-libre entonces repetir 3 veces gira-izquie
rda;
mientras frente-libre hacer avanza;
repetir 2 veces gira-izquierda;
mientras frente-libre hacer inicio
mientras junto-a-zumbador hacer coge-zumbador;
avanza;
si frente-bloqueado y izquierda-bloqueada entonces inicio
mientras algun-zumbador-en-la-mochila hacer deja-zumbador;
apagate;
fin;
si frente-bloqueado y orientado-al-sur y izquierda-libre entonces inic
io gira-izquierda;
mientras junto-a-zumbador hacer coge-zumbador;
avanza;
fin;
si frente-bloqueado y orientado-al-norte entonces inicio repetir 3 v
eces gira-izquierda;
mientras junto-a-zumbador hacer coge-zumbador;
avanza;
fin;
si frente-libre y derecha-bloqueada y orientado-al-este entonces gira-i
zquierda;
si frente-libre y izquierda-bloqueada y orientado-al-este entonces rep
etir 3 veces gira-izquierda;
si frente-bloqueado y izquierda-bloqueada entonces repetir 3 veces g
ira-izquierda;
fin;
apagate;
termina-ejecucion
finalizar-programa