Está en la página 1de 5

Cc bc cu hnh cho router v to ng hm.

Cn cc k thut kia th mi ngi t tm hiu nha.

Bc 1: t a ch IP cho cng Interface.


R1:conft
interface Looback 0
ip address 1.1.1.1 255.255.255.255
interface s1/0
ip address 192.168.12.0 255.255.255.240
no shut
interface s1/1
ip address 192.168.13.0 255.255.255.240
no shut

interface s1/2
ip address 192.168.14.0 255.255.255.240
no shut
Tng t cho cc router cn li.

Bc 2: Cu hnh OSPF cho tt c Router sao cho mng hi t.


R1:
Router ospf 1
network 1.1.1.1 0.0.0.0 area 0
network 192.168.12.0 0.0.0.0 area 0
network 192.168.13.0 0.0.0.0 area 0
network 192.168.14.0 0.0.0.0 area 0
Tng t cho cc router cn li.

Bc 3: Enable chc nng MPLS trn nhng interface tng ng ca


router.
R1:
ip cef
mpls label protocol ldp
interface s1/0
mpls ip
interface s1/1
mpls ip
interface s1/2
mpls ip
Tng t vi cc router cn li

Bc 4: Cu hnh MPLS_TE trn mi router.


R1 :
router ospf 1
mpls traffic eng router-id Loopback 0
mpls traffic eng area 0
log-adjacency-changes
ex
ip cef
mpls traffic eng tunnels
interface s1/0
mpls traffic eng tunnels
interface s1/1
mpls trafficeng tunnels
interface s1/2
mpls traffic eng tunnels
Tng t cho cc router cn li.

Bc 5 : to ng hm MPLS-TE trn R1.


ng hm t ng
-

Router(config)#interface tunnel 0
Router(config-if)#ip unnumbered loopback0
Router(config-if)#tunnel destination 1.1.1.1
Router(config-if)#tunnel mode mpls traffic-eng
Router(config-if)#tunnel mpls traffic-eng bandwidth 100
Router(config-if)#tunnel mpls traffic-eng affinity 0x1mask0x1
Router(config-if)#tunnel mpls traffic-eng priority 7 7
Router(config-if)#tunnel mpls traffic-eng path-option 1 dynamic
Router(config-if)#tunnel mpls traffic-eng autoroute announce

Kim tra kt qu:

Router#show mpls traffic-eng tunnels tunnel 0

ng hm tng minh (t tay)


-

Router(config)#interface tunnel 1345


Router(config-if)#ip unnumbered loopback0
Router (config-if)#tunnel destination 3.3.3.3
Router (config-if)#tunnel mode mpls traffic-eng
Router(config-if)#tunnel mpls traffic-eng bandwidth 500
Router (config-if)#tunnel mpls traffic-eng affinity 0x1mask0x1
Router (config-if)#tunnel mpls traffic-eng priority 7 7
Router (config-if)#tunnel mpls traffic-eng path-option 1 explicit name r1-r3-r4-r5
Router(config-if)#tunnel mpls traffic-eng autoroute announce
Router(config-if)#ex
ip ca router m ng hm s i qua
Router (config)ip explicit-path name r1-r3-r4-r5 enable
Router (cfg-ip-expl-path)#next-address 1.1.1.1
Router (cfg-ip-expl-path)#next-address 192.168.13.x
Router (cfg-ip-expl-path)#next-address 192.168.34.x
Router (cfg-ip-expl-path)#next-address 192.168.45.x
Router (cfg-ip-expl-path)#next-address 5.5.5.5
Router (cfg-ip-expl-path)#end

Kim tra kt qu:


-

Router#show mpls traffic-eng tunnels tunnel r1-r3-r4-r5

Thc hin chnh bng thng iu chnh ng i: ng no cng c


R1:
-

R1(config)#interface serial 1/1


R1(config-if)#ip rsvp bandwidth 256 256
R1(config-if)#ex

Khi i bng thng ng hm s u tin ng i vi bng thng rng hn

Thc hin chnh metric-TE chnh hng i theo mun.


+Thay i gi tr TE metric:

R1 :
-

R1(config)#interface s1/1
R1(config-if)# mpls traffic-eng adminnistrative-weight 3
R1(config-if)#ex

-Tng t ta thay i TE metric trn lin kt nh hng ng i theo


mun.
Sau khi thay i th R1 th ng hm s theo tuyn c gi tr TE metric nh
nht.

Cn 1 phn nh hng ca affinity bit (Attribute Flag): t tm hiu.


Bo v tuyn, bo v node