Está en la página 1de 6

Prctica de Laboratorio

Basado en la configuracin de muestra Cisco - Configuring InterVLAN Routing and ISL/802.1Q Trunking on a Catalyst 2900XL/3500XL/2950
Switch Using An External Router.
Objetivos:


Introduccin:
En este prctico se describe la creacin de un enlace entre dos VLANs usando un router a modo de ejemplo. Los equipos utilizados
sern: Un switch Cisco Catalyst WS-C2950-12, un router Cisco 2601, con configuraciones iniciales borradas, cables de conexin y
al menos dos estaciones de trabajo.
Los ejemplos de configuracin y comandos utilizados funcionan tambin usando switches Catalyst series 2900XL y 3500XL y routers
Cisco series 3600/4500/4700 con interfaces FastEthernet o mdulos de red FastEthernet, con versiones de IOS 12.1(3) o posteriores.
Como los switches Catalyst serie 2950 utilizados en el prctico no soportan encapsulamiento ISL (InterSwitch Link , propietario de
Cisco) para el trunking entre VLANs, se usar el encapsulamiento IEEE 802.1Q (estndar). Para consultar si un determinado modelo
soporta un determinado protocolo, referirse a http://www.cisco.com/warp/public/473/50.shtml
Importante: Para trunking usando 802.1Q, una de las VLAN que transitan por el canal trunk no se etiqueta. Esa VLAN se llama
VLAN nativa, y se usa para trfico sin etiquetar (trfico usando tramas Ethernet estndar) cuando el puerto est en modo trunking
802.1Q. Es un error comn no hacer coincidir las VLANs nativas cuando se est configurando trunking 802.1Q entre un switch y un
router. Para ms detalles, ver la seccin 802.1Q de Bridging Between IEEE 802.1Q VLANs
(http://www.cisco.com/univercd/cc/td/doc/product/software/ios121/121newft/121t/121t3/dtbridge.htm ). En el ejemplo
propuesto, la VLAN1 es la VLAN nativa, tanto en el router Cisco 2601 como en el switch Catalyst 2650. De acuerdo a las
necesidades, la VLAN nativa puede cambiarse (usando los comandos propuestos) a cualquier otra.
1
Aprender a configurar enlaces InterVLAN usando un router
Lograr habilidad y criterio utilizables en casos reales.
Secuencia de Pasos:
1. Conectar y verificar el cableado de acuerdo a la topologa propuesta. Borrar la configuracin y las
VLANs definidas en los dispositivos antes de empezar. Reinicializarlos
2. En el Switch
a. Configurar las contraseas de Telnet, Consola, y modo privilegiado en el Switch.
b. Configurar una direccin IP y puerta de enlace predeterminada en la VLAN 1 para poder
administrar el switch en forma remota.
c. Configurar el protocolo VLAN Trunking (VTP) y agregar las VLANs
d. Habilitar Trunking en la interfaz fastEthernet 0/1
e. Configurar el encapsulamiento del enlace trunking.
f. Configurar las VLANs permitidas del enlace trunking
g. Configurar los puertos en las VLANs correspondientes y configurarlos como portfast para STP.
h. Verificar y grabar la configuracin.
3. En el router
a. Configurar las contraseas de Telnet, Consola, y modo privilegiado.
b. Configurar la interfaz fastEthernet 0/0 y las subinterfaces para trunking
c. Verificar y grabar la configuracin
4. En las estaciones de trabajo
a. Configurar las direcciones IP y puertas de enlace predeterminadas para adecuarlas a la topologa
de capa 3.
5. Comprobar la conexin usando herramientas en las estaciones de trabajo.
6. Proponer una topologa nueva y realizar la configuracin desde el principio.
Desarrollo:
Las lneas en azul y que comienzan con un signo de admiracin cerrado son comentarios.
2. Configuracin del Switch
2.a Configurar las contraseas de Telnet, Consola, y modo privilegiado en el Switch.
!- Configurar las contraseas de modo privilegiado y
!- de telnet del switch
switch#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
switch(config)#hostname 2950-1
2950-1(config)#enable secret class
2950-1(config)#line vty 0 4
2950-1(config-line)#login
2950-1(config-line)#password cisco
2950-1(config-line)#exit
!- Deshabilita la muestra en consola de estado de interfaces y errores
2950-1(config)#no logging console
2950-1(config)#^Z
2.b Configurar una direccin IP y puerta de enlace predeterminada en la VLAN 1 para
poder administrar el switch en forma remota.
2950-1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
!-- Notar que la VLAN se considera una INTERFACE.
2950-1(config)#int vlan 1
!-- La direccin IP se configura de la manera conocida.
2950-1(config-if)#ip address 192.5.5.251 255.255.255.0
2950-1(config-if)#exit
!-- La puerta de enlace predeterminada se configura en MODO DE CONFIGURACIN GLOBAL
2950-1(config)#ip default-gateway 192.5.5.1
2950-1(config)#end
2
2.c Configurar el protocolo VLAN Trunking (VTP)
2950-1#vlan database
!-- Agregar VLAN2 y VLAN3.
2950-1(vlan)#vlan 2
VLAN 2 added:
Name: VLAN0002
2950-1(vlan)#vlan 3
VLAN 3 added:
Name: VLAN0003
2950-1(vlan)#exit
APPLY completed.
Exiting....
2950-1#
2.d Habilitar Trunking en la interfaz fastEthernet 0/1
2950-1#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
2950-1(config)#int fastEthernet 0/1
2950-1(config-if)#switchport mode trunk
2.e Configurar el encapsulamiento del enlace trunking.
!- Seguimos en la interface fastEthernet 0/1
!-- En otras series de switches podra elegirse encapsulamiento ISL
!-- 3950(config-if)#switchport trunk encapsulation isl
!-- o dot1q (802.1Q):
!-- 3950(config-if)#switchport trunk encapsulation dot1q
!-- En el caso de los switches 2950 switches, no se usan los comandos de arriba.
!-- Los 2950 soportan solamente 802.1q, que se configura automticamente cuando
!-- se habilita una interfaz para trunking, con el comando:
!-- 2950-1(config-if)#switchport mode trunk
!Como usamos dot1q, debemos asegurarnos que la VLAN nativa sea la misma
!-en ambos lados del link. La VLAN nativa predeterminada es la 1,
!-as que si esa es la nativa que pretendemos usar, no hay necesidad de
!-especificar un comando. Es importante tener la misma vlan nativa en el router
!-Para cambiar la vlan nativa se usara el comando:
!-- 2950-1(config-if)#switchport trunk native vlan <vlan ID>
2.f Configurar las VLANs permitidas del enlace trunking
!Permitimos todas las VLANs en el enlace trunk.
2950-1(config-if)#switchport trunk allowed vlan all
2950-1(config-if)#exit
2.g Configurar los puertos en las VLANs correspondientes y configurarlos como
portfast para STP.
2950-1(config)#int fastEthernet 0/2
2950-1(config-if)#switchport access vlan 2
!spanning-tree portfast hace que el puerto pase rpidamente al modo forward,
!sin esperar el tiempo configurado en spanning-tree. Se hace cuando al puerto
!se conecta una estacin de trabajo, un server, un router, etc.; cualquier cosa
!excepto otro switch.
2950-1(config-if)#spanning-tree portfast
2950-1(config-if)#exit
2950-1(config)#int fastEthernet 0/3
2950-1(config-if)#switchport access vlan 3
2950-1(config-if)#spanning-tree portfast
2950-1(config)#int fastEthernet 0/4
2950-1(config-if)#spanning-tree portfast
2950-1(config-if)#^Z
3
2.h Verificar y grabar la configuracin
2950-1# show running
Building configuration...
Current configuration:
!
version 12.0
no service pad
service timestamps debug uptime
service timestamps log uptime
no service password-encryption
!
hostname 2590-1
!
no logging console
enable password class
!
ip subnet-zero
!
interface FastEthernet0/1
switchport mode trunk
!
interface FastEthernet0/2
switchport access vlan 2
spanning-tree portfast
!
interface FastEthernet0/3
switchport access vlan 3
spanning-tree portfast
!
interface FastEthernet0/4
spanning-tree portfast
!
interface FastEthernet0/5
!
interface FastEthernet0/6
!
interface FastEthernet0/7
!
interface FastEthernet0/8
!
interface FastEthernet0/9
!
interface FastEthernet0/10
!
interface FastEthernet0/11
!
interface FastEthernet0/12
!
interface VLAN1
ip address 192.5.5.251 255.255.255.0
no ip directed-broadcast
no ip route-cache
!
ip default-gateway 192.5.5.1
!
line con 0
transport input none
stopbits 1
line vty 0 4
password mysecret
login
4
line vty 5 15
login
!
end
2950-1# copy running-config startup-config
3. En el router
3.a Configurar las contraseas de Telnet, Consola, y modo privilegiado.
Router#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
Router(config)#hostname c2600
c2600(config)#enable password class
c2600(config)#line vty 0 4
c2600(config-line)#login
c2600(config-line)#password cisco
c2600(config-line)#exit
c2600(config)#no logging console
c2600(config)#^Z
3.b Configurar la interfaz fastEthernet 0/0 y las subinterfaces para trunking
c2600#configure terminal
Enter configuration commands, one per line. End with CNTL/Z.
!-- Seleccionar FastEthernet 0/0 para la configuracin trunk
!En versiones anteriores del IOS se configura la VLAN nativa en la interfaz
!-principal del router, ya que las tramas vienen sin etiquetar. Como la versin del IOS
!-de los 2600 que se disponen no soporta vlans nativas, configuramos as:
!-En versiones recientes del IOS (posteriores a la 12.1(3)T) debemos marcar la VLAN
!-nativa en una subinterfaz.(importante!), en lugar de configurarla en la interfaz
!-principal.
!- Formato: encapsulation dot1Q <vlan-id> [native]
c2600(config)#int fastEthernet 0/0
c2600(config-if)#no shut
c2600(config-if)#ip address 192.5.5.1 255.255.255.0
c2600(config-if)#exit
c2600(config)#int fastEthernet 0/0.1
!Habilitar trunking en la subinterface FastEthernet 0/0.1.
!-Encapsulamiento dot1q:
c2600(config-subif)#encapsulation dot1Q 2
!-Configurar capa 3
c2600(config-subif)#ip address 10.10.11.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z
c2600(config)#int fastEthernet 0/0.2
!-Encapsulamiento dot1q:
c2600(config-subif)#encapsulation dot1Q 3
!-Configurar capa 3
c2600(config-subif)#ip address 10.10.10.1 255.255.255.0
c2600(config-subif)#exit
c2600(config)#^Z
3.c Verificar y grabar la configuracin.
c2600#show running-config
Building configuration...
Current configuration:
!
version 12.1
service timestamps debug uptime
5

service timestamps log uptime
no service password-encryption
!
hostname c2600
!
no logging console
enable password class
!
ip subnet-zero
!
interface FastEthernet0/0
ip address 192.5.5.1 255.255.255.0
duplex auto
speed auto
!
interface FastEthernet0/0.1
encapsulation dot1Q 2
ip address 10.10.11.1 255.255.255.0
no ip redirects
!
interface fastEthernet0/0.2
encapsulation dot1Q 3
ip address 10.10.10.1 255.255.255.0
!
ip classless
no ip http server
!
line con 0
transport input none
line aux 0
line vty 0 4
password cisco
login
!
no scheduler allocate
end
4. En las estaciones de trabajo
4.a Configurar las direcciones IP y puertas de enlace predeterminadas para
adecuarlas a la topologa de capa 3.
Cambiar las direcciones IP de las estaciones de trabajo para que concuerden con las VLANs adecuadas, usando
el Gateway adecuado.
5. Comprobar la conexin usando herramientas en las estaciones de trabajo
Usar PING y TRACERT para comprobar la conexin entre las estaciones de trabajo en VLANs distintas.
Fin del Prctico
6