Está en la página 1de 4

Calcular intereses por mes y das en Excel (o como construir

una mega-frmula)
VIERNES, OCTUBRE 17, 2008
Digamos que queremos calcular intereses por la demora en el pago de una cuenta o factura.
Supongamos tambin que la tasa de inters cambia cada mes. Dados estos datos, lo que
buscamos es desglosar los das transcurridos entre la fecha de vencimiento y la del pago
efectivo por mes.
Lo que buscamos es crear una especie de calculadora en una hoja de Excel tal que si
ingresamos el monto adeudado y las fechas, nos haga el clculo del inters a pagar. Nuestra
hoja se vera as (el archivo se puede descargar aqu)



Nuestro enfoque ser resolver el modelo con frmulas. Empecemos por sealar que tanto los
datos en las celdas B2 y B3 como en el rango A6:A17 son fechas y no texto. Es decir,
estamos trabajando con fechas que son nmeros, como ya hemos explicado en el pasado.
Por ejemplo, si seleccionamos la celda A6, donde vemos la palabra "enero", veremos en la
barra de frmulas que en realidad es la fecha 01/01/2008



Para calcular los das por mes de la fecha de iniciacin hasta la fecha de pago usamos una
"mega-frmula". Baste con ver la frmula que usamos para calcular, dinmicamente, los das
del mes de febrero que caen entre las fechas de principio y fin del intervalo para entender
por qu la llamamos "mega"-frmula

=SI(MES(A6)=MES($B$2),MES(A6)<=MES($B$3)),DIA(FIN.MES(A6,0)),0)-
SI(MES($B$2)=MES(A6),$B$2-A6,0),SI(SI(MES($B$3)=MES(A6),$B$3-
A6,0)<>0,SI(MES($B$3)=MES(A6),$B$3-A6,0)+1,0))

Para usar la funcin EOMONTH (o FIN.MES, de acuerdo a las definiciones del sistema) hay
que tener instalado el complemento Analysis Toolpak.

La tcnica que propongo para construir esta mega-frmula consiste en crear las frmulas
parciales en columnas auxiliares y luego unirlas en una nica frmula.


La primer columna auxiliar es C donde calculamos la cantidad de das que caen dentro del
mes de la fecha inicial con esta frmula

=SI(MES($B$2)=MES(A6),$B$2-A6,0)

La funcin MES nos permite ver si el mes de la lnea es el mes de la primer fecha. En caso
afirmativo calculamos la diferencia de das entre la fecha de inicio (B2) y el primer da del
mes (A6). En caso de coincidir el mes el resultado es 0.

En la columna D hacemos lo mismo pero en relacin a la fecha de pago efectivo (B3), con la
frmula

=SI(MES($B$3)=MES(A6),$B$3-A6,0)

En la columna E calculamos los das de los meses que caen entre ambas fechas con la
frmula

=SI(Y(MES(A6)>=MES($B$2),MES(A6)<=MES($B$3)),DIA(EOMONTH(A6,0)),0)

La funcin EOMONTH (FIN.MES) nos permite calcular con exactitud los das de cada mes,
tambin en aos bisiestos.

En la columna F calculamos el total de das de cada mes con una resta sencilla

=E6-C6


A esta altura del partido tenemos calculados los todos los das por mes, excepto para el
ltimo mes del perodo. Para esto u Samos la columna auxiliar G con esta frmula

=SI(D6<>0,D6+1,0)

Ahora podemos combinar todas estas frmulas intermedias en una nica mega-frmula.
Primero nos proponemos la frmula en palabras, lo que nos ayuda a crear la lgica. Nos
fijamos en las columnas auxiliares y decimos:

1 - si el mes de la fila no es el de la fecha de pago, calculamos los das restando la columna
C de E (E-C);
2 - si el mes es el de la fecha de pago tomamos el resultado de la columna D y le sumamos
1.

En la columna H empezamos a crear la mega-frmula

=SI(MES(A6)<MES($B$3),F6,G6)



Necesitamos que toda la frmula est expresada en trminos de celdas en la columna A y B
para lo cual empezaremos reemplazando F6 y G6 por sus equivalentes, las frmulas que
hemos puesto en las columnas auxiliares. Al reemplazar F6 y G6 nos queda

=SI(MES(A6)<MES($B$3),E6-C6,SI(D6<>0,D6+1,0))

Ahora tenemos que ocuparnos de E6, C6 y D6, que al reemplazarlas por las frmulas de las
columnas auxiliares nos dan la mega-frmula que estamos buscando.

Es de notar que esta frmula supone que las fechas de principio y final caen en el mismo
ao.

Para ver cmo construir un modelo real para el clculo de interese por mora, consulten esta
nota.

Quien est interesado en recibir el archivo con el ejemplo y las frmulas, debe dirigir el
pedido a mi mail.