Está en la página 1de 3

Clase #12 Clase #12

OBJETIVOS OBJETIVOS
Matrices Matrices
Operaciones fila y columna Operaciones fila y columna
Matrices Matrices
As como decimos que un vector es un arreglo de una
dimensin (un subndice), una matriz es un arreglo pero
de dos dimensiones (dos subndices)
A
m,n
A
m,2
A
m,1
A
i,j

A
2,n
A
2,2
A
2,1
A
1,n
A
1,2
A
1,1 A =
Para matrices se utilizan dos sub Para matrices se utilizan dos sub ndices (uno para las ndices (uno para las
filas y otro para las columnas). filas y otro para las columnas).
Ejercicio 1 Ejercicio 1
Realizar prueba de escritorio al siguiente algoritmo. Qu
mostrara?
INICIO
i=2
j=2
S=0
Para i=1, <=m, +1
Para j=1, <=n, +1
A
i,j
=i+j
S=S+A
i,j
Fin Para
Fin Para
Mostrar S
FIN
Ejercicio 2 Ejercicio 2
Disear un algoritmo para leer una matriz cuadrada y
mostrar la sumatoria de los elementos de su diagonal
principal
INICIO
Leer m
S=0
Para i=1, <=m, +1
Para j=1, <=m, +1
Leer A
i,j
Si (i=j)
S=S+A
i,j
Fin Si
Fin Para
Fin Para
Mostrar S
FIN
Como sera un algoritmo para
este mismo problema pero
con la diagonal secundaria?
Transponer una matriz Transponer una matriz
Disear un algoritmo para leer una matriz A de orden
PxQ, calcular su transpuesta AT y mostrarla
INICIO
Para i=1, <=m, +1
Para j=1, <=n, +1
Leer A
i,j
AT
j,i
=A
i,j
Fin Para
Fin Para
Para K=1, <=m, +1
Para L=1, <=n, +1
Mostrar AT
K,L
Dejar espacio
Fin Para
Dejar rengln
Fin Para
FIN
Multiplicaci Multiplicaci n: Matriz y Vector n: Matriz y Vector
Disear un algoritmo para calcular la multiplicacin de
una matriz A con un vector X
A
m,n
A
m,2
A
m,1
A
i,j

A
2,n
A
2,2
A
2,1
A
1,n
A
1,2
A
1,1
X
n

X
2
X
1
R
m

R
2
R
1
m i X A R
n
j
j j i i
,..., 1 ;
1
,
= =

=
Am,n Xn,1 Rm,1
=
INICIO
//Se leen m, n, A y X
Para i=1, <=m, +1
R
i
=0
Para j=1, <=n, +1
R
i
=R
i
+A
i,j
*X
j
Fin Para
Mostrar R
i
Dejar rengln
Fin Para
FIN
Multiplicaci Multiplicaci n: Matriz y Vector n: Matriz y Vector
Realizar prueba de escritorio a ese algoritmo con estos
valores
-0.5 4 1
0 -1 3
6
3
2
11
3
A2,3 X3,1 R2,1
=
Multiplicaci Multiplicaci n: Matriz y Vector n: Matriz y Vector
Disear un algoritmo para calcular la multiplicacin de
una matriz A con una matriz B
A
m,p
A
m,1

A
1,p
A
1,1
Am,p Bp,n Cm,n
=
n j m i B A C
p
k
j k k i j i
,..., 1 ; ,..., 1
1
, , ,
= = =

=
B
p,n
B
p,1

B
1,n
B
1,1
C
m,n
C
m,n

C
1,n
C
1,1
Multiplicaci Multiplicaci n: Matriz y Matriz n: Matriz y Matriz
INICIO
//Se leen m, n, p, A y B
Para i=1, <=m, +1
Para j=1, <=n, +1
C
i,j
=0
Para k=1, <=p, +1
C
i,j
=C
i,j
+A
i,k
*B
k,j
Fin Para
Mostrar C
i,j
Dejar espacio
Fin Para
Dejar rengln
Fin Para
FIN
Multiplicaci Multiplicaci n: Matriz y Vector n: Matriz y Vector
Realizar prueba de escritorio a ese algoritmo con estos
valores
Multiplicaci Multiplicaci n: Matriz y Matriz n: Matriz y Matriz
1 -3
2 -1
0 4
A3,2 B2,3 C3,3
=
3 2 6
2 0 5
-3 2 -9
4 4 7
8 0 20
Tareas Tareas
1. Disear un algoritmo a manera de funcin para que,
dada una matriz cuadrada, devuelva si es identidad o
no.
2. Disear un algoritmo para calcular el promedio de
cada fila de una matriz y almacenar los resultados en
un vector.