Está en la página 1de 2

algoritmo volumen var real: rad,alt,vol const PI=3.

14156 INICIO escribe " introduce el radio:" leer rad escribe "introduce la altura:" leer alt si(rad > 0 ) Y (alt>0) entonces volumen <- 4/3 * PI * rad^3*alt fin_si escribir("Volumen de la esfera: ", volumen fin

algoritmo convertir var real:num inicio escribir"ingrese dos numeros enteros positivos" leer num si 10=<num<=99 entonces dec<- num DIV10 uni<-num MOD10 escribir" el valor de posicional en letras del nmero es:",de,"decimal y" ,uni,"unidades" fin_si fin

algoritmos raices var REAL:X1,X2 ENTERO:DISCRIMINATE,coa,cob,coc INICIO Leer coa, cob, coc Discriminante = 0 SI coa<> 0 ENTONCES Discriminante= SQR(cob^2-4*coa*coc) SI Discriminante >= 0 ENTONCES SI Discriminante = 0 ENTONCES X1=X2 X1= -cob /2*coa Escribe El valor de X es: , X1 SINO X1 = (-cob + Discriminante)/2*xoa X2 = (-cob - Discriminante)/2*coa ESCRIBE El valor de X1 es: , X1 ESCRIBE El valor de X2 es: , X2 FIN SI

FIN SI FIN SI FIN