P. 1
Red Hat Linux Getting Started Guide

Red Hat Linux Getting Started Guide

|Views: 69|Likes:
Publicado porrameshkadam2208

More info:

Published by: rameshkadam2208 on Oct 01, 2009
Copyright:Attribution Non-commercial

Availability:

Read on Scribd mobile: iPhone, iPad and Android.
download as PDF, TXT or read online from Scribd
See more
See less

05/24/2012

pdf

text

original

If you want to create graphics for your documents and presentations, you can use OpenOffice.org
Draw
. Using your mouse as a you would a pen or a paintbrush, OpenOffice.org Draw allows you to
make illustrations and save them in several formats that you can add to printed documents, place on
websites, or attach to emails.

To start OpenOffice.org Draw from the desktop panel, click Main Menu => Office => OpenOf-
fice.org Draw
. To start OpenOffice.org Draw from a shell prompt, type oodraw.

Figure 9-7 Shows OpenOffice.org Draw in action.

Figure 9-7. OpenOffice.org Draw

If you are familiar with illustration and graphics applications such as The GIMP (refer to Chapter
11 Working with Images for more information), you will find that OpenOffice.org Draw has some of
the same basic functions. There are toolbars for creating straight and curved lines, basic shapes such
as squares and circles, 3D objects such as cones and cubes, and more. You can create images and fill
them with the color of your choice using the Area Style/Filling drop-down menu on the main toolbar.
You can additionally insert text into your illustrations. OpenOffice.org Draw also allows you to open
and import images and modify them with the tools provided.

When you complete your illustration or image modifications, you can save the file in one of several
native file formats or export your work to several popular formats such as .jpg or .png. Refer to
Table 9-1 for the complete list of compatible image file formats.

For more information on using OpenOffice.org Draw, refer to the documentation located at Help =>
Contents from the file menus.

70

Chapter 9. Working with Documents

9.2. Editing Text Files

Red Hat Linux includes several text editors, applications that allow you to view and modify plain text
files. Plain text files are files that contain text without any font or style formatting applied to it, such
as system logs and configuration files.

gedit is a graphical text editor. It can open, edit, and save plain text files. You can also cut and paste
text to and from other graphical desktop applications, create new text files, and print files. gedit has a
clear and understandable interface that uses tabs so that you can open more than one file at the same
time without opening more than one gedit window.

To start gedit, click Main Menu => Accessories => Text Editor. You can also start gedit by typing
gedit at a shell prompt.

Note

gedit can only be used in a graphical desktop environment.

Figure 9-8. gedit

Once gedit is running, you are presented with a blank editing area. You can begin using gedit imme-
diately or click the Open button to locate the plain text file you want to edit. The file will load into the
main editing area as shown in Figure 9-8. You can navigate the text file by clicking and holding the
scroll bar on the right edge of the window and moving your mouse cursor up and down; or, use the
arrow keys to navigate through the text file line-by-line. Press the [Page Up] and [Page Down] keys to
advance the document a page at a time.

Tip

gedit allows you to open multiple text files in one window using separate tabs for each file. If you
have a file already open and want to copy text from another file, click Open, choose the file you want

Chapter 9. Working with Documents

71

to access, and the file will open in a new tab within the geditwindow. You can navigate between each
file by clicking on the the tab associated with the particular filename.

Once you have modified or written your text file, you can save it by pressing the Save button in the
toolbar, or by choosing File => Save from the file menus. If you are writing a new text file, a pop-up
window will prompt you to name the file and save it in the directory of your choice. If you are editing
an existing file, then any changes you make will automatically appear in the file the next time you
open it. You can also choose File => Save As... to save an existing file under a new name or in a
different location, which is convenient if, for example, you are editing a configuration file and you
want to test your changes without losing your original configuration.

For more information about gedit, choose Help => Contents from the file menus to access the gedit
manual.

You're Reading a Free Preview

Descarga
scribd
/*********** DO NOT ALTER ANYTHING BELOW THIS LINE ! ************/ var s_code=s.t();if(s_code)document.write(s_code)//-->